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About This Manual

You can use this manual to familiarize yourself with the DataFinder Server Edition features and 
how to use them.

The first chapter describes how to create a DataFinder server in a few easy steps and how to 
connect clients to this DataFinder server. The exercises do not take long, and they make it easier 
for you to get started with the DataFinder Server Edition.

The second chapter describes how to define search areas for individual DataFinder servers, to 
plan indexing, to limit access rights, or to optimize custom properties. You will also learn how 
to use the Server Manager to create and manage DataFinder servers, execute upgrades, export 
connection parameters, or specify the start options for DataFinder servers.

The third chapter describes how you can use a DataFinder server as an ASAM ODS server. 
Clients can read the data of the DataFinder server through the ASAM ODS Corba interface. The 
clients use the ASAM data models available on the DataFinder server to display the data. 

The fourth chapter describes the hardware and system requirements, and how you configure 
your firewall in order to connect DataFinder clients outside the firewall with a DataFinder server 
within the firewall. The chapter also outlines how to integrate the DataFinder server into 
archiving systems in order to index and to find archived data.

Related Documentation
For more detailed information on the DataFinder Server Edition, refer to the following 
documentation:

• NI DataFinder Server Edition Help files, which you open by selecting Help»Contents, or 
by pressing <F1>.

• NI DIAdem: Data Mining, Analysis, and Report Generation
DIAdem is the interactive National Instruments software for finding and managing 
technical data, and mathematically and graphically analyzing the data. Chapter 2, Finding 
and Managing Data, describes how to make search entries in DIAdem to find data. 
DIAdem can access DataFinder servers as a client.

• NI LabVIEW DataFinder Toolkit
Use the LabVIEW DataFinder Toolkit to work with the DataFinder in LabVIEW. You can 
use the DataFinder to search for simple text in indexed data, or to execute advanced 
searches for data properties.

LabVIEW can access the DataFinder server with the DataFinder toolkit as client.
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Creating and Connecting 
DataFinder Servers

A DataFinder server is a search engine that you install on a server. The DataFinder server 
searches for files that contain technical data in specified folders on computers in a network. The 
DataFinder server indexes the data files to provide the clients with the data properties. The 
DataPlugins registered in the server manager determine which file types the DataFinder server 
indexes.

You can define several DataFinder servers in the server manager to provide different data for 
different work groups. Clients, such as DIAdem or LabVIEW, communicate with the DataFinder 
servers to query the indexed data and to load search results. 

You can use a DataFinder server as an ASAM ODS server to display, browse, and filter data with 
an ASAM conform data model. All applications which support the ASAM ODS Corba interface 
can access the ASAM ODS server in order to find and load this data.

Note The license specifies how many DataFinder servers you can create and how 
many users can access the DataFinder server simultaneously. For more information 
about licensing, refer to the section on NI License Manager in Chapter 2, Configuring 
DataFinder Servers.

Creating DataFinder Servers
When you start DataFinder Server Edition, the server manager opens. In the server manager you 
create and configure DataFinder servers and test the functionality of the DataFinder servers. To 
create a DataFinder server, complete the following steps:

1. To start DataFinder Server Edition, select Start»All Programs»National Instruments»
DataFinder Server Edition»DataFinder Manager. 

If the server manager does not have a DataFinder server, the New DataFinder Server 
dialog box opens automatically the first time you launch the server manager.

2. Enter, for example, TestRig as the name of the DataFinder server to be created. 

3. Click Add Search Area to specify a search area. 

Search areas are the file system folders where clients can search for data files.

4. Enter My_Data as the alias name for the search area. 
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5. Click Choose a Folder. 

a. Select the folder that you want the DataFinder server to index.

b. Click OK to close the dialog box.

6. Click Share Folder. 

The server manager opens the Windows share dialog box, where you share folders with 
other users on the network. You must share the folders in the search area so the clients can 
read the descriptive information and also load the files found in the search.

7. Click OK to close the Windows share dialog box. 

8. Open the list in the Client path textbox and select the shared network path. The Add 
Search Area dialog box displays the path of the shared folder, as shown in the following 
figure: 

Figure 1-1.  Defining a Search Area

Note Use shared folders (\\Data_Server\..) and not the network drives to 
which you assigned a drive letter (M:\..). You cannot use these mapped network 
drives with a letter together with the start option Run as service. 
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9. Click OK to close the Add Search Area dialog box. 

The New DataFinder Server dialog box displays the newly created search area My_Data 
as shown in the following figure: 

Figure 1-2.  Creating a New DataFinder Server

You can now define more search areas where clients can search for data. Select Exclude 
Subfolder from the context menu of a search area to exclude folders from the search. Click 
Advanced to set the service registration, security settings, and desktop shortcuts for the 
DataFinder server.
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10. Click Finish to close the dialog box. 

The server manager displays the new DataFinder server, as shown in the following figure.

Figure 1-3.  Server Manager with Configured DataFinder Server

Exporting Client Configurations
You must connect the clients to a DataFinder server so that they can execute queries on a server 
and load data. You can export the required connection settings, save the settings in a file, and 
then enable the settings on the client. To export a client configuration, complete the following 
steps.

1. Select the TestRig DataFinder server in the server manager. 

2. Click Export a Client Configuration on the toolbar.

1. Accept the suggested name for the export file TestRig@<Computername>. The name 
consists of the name of the DataFinder server and the name of the server that DataFinder 
Server Edition is installed on.
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2. Enable the Include DataPlugins in client configuration checkbox to save all the 
DataPlugins in the export file, as shown in the following figure. 

When you export the DataPlugins, you provide the client with all the DataPlugins for 
loading the files that the DataFinder server TestRig indexes and finds.

Figure 1-4.  Exporting a Client Configuration

Note You can integrate only VBScript DataPlugins or VBCrypt DataPlugins in a 
URF file. 

3. Click OK to open the Save As dialog box.

4. Click Save to save the client configuration. The server manager saves the connection 
parameters in a file that has the extension .urf. 

Connecting Clients to DataFinder Servers
For a client to connect to the DataFinder server TestRig, you must register the connection 
configuration on the client computer.

1. Copy the TestRig@Computer.urf file to the client computer.

2. Double-click the TestRig@Computer.urf file to register the connection parameters and 
the DataPlugins on the client computer. 

If you import DataPlugins that are already registered on this computer when you register 
the connection parameters, you can specify for each DataPlugin whether the originally 
installed DataPlugin is overwritten or not.

A message indicates that the connection configuration and the new DataPlugins are 
registered.

DIAdem and LabVIEW can use any DataFinder server that is connected to the DIAdem or 
to the LabVIEW computer on a network. You can use security settings to limit the clients’ 
access rights for DataFinder servers.



1-6 | ni.com

Chapter 1 Creating and Connecting DataFinder Servers

DIAdem as a Client of a DataFinder Server
After registering the connection settings on the client computer, you can use DIAdem to navigate 
in the folders, which the TestRig server shares, and search for data.

1. Open DIAdem. 

2. Select DIAdem NAVIGATOR.

3. Select Settings»DataFinder Server. 

The following figure shows the DataFinder Server - Connections dialog box with all the 
DataFinder servers registered in DIAdem.

Figure 1-5.  DataFinder Server Registered in DIAdem

Note To import a URF file, click Import DataFinder Server Connections in the 
DataFinder Server - Connections dialog box. After importing the file, click 
Properties to open the client configuration settings. Click Test to check the 
connection to the DataFinder server. 
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4. Click Open to open the DataFinder server in DIAdem NAVIGATOR. 

The file browser in the following figure shows a tree view of the search areas of the 
DataFinder server. If the associated DataPlugin allows, you can navigate to channel level 
in the files.

Figure 1-6.  Navigating in Search Areas of a DataFinder Server

LabVIEW as a Client of a DataFinder Server
After registering the connection settings on the client computer, you can use LabVIEW to 
connect the TestRig DataFinder server.

1. Open LabVIEW with an empty VI.

2. Right-click the block diagram and select Connectivity»DataFinder Toolkit to open the 
palette.

3. Click Search Text in the DataFinder Toolkit palette and drag and drop the VI into the 
block diagram.
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4. Right-click the DataFinder reference terminal and select Create»Constant from the 
context menu.

5. Open the context menu of the previously created constant and select Manage DataFinders. 

LabVIEW opens the Manage DataFinders dialog box that you can use to create, delete, 
or configure DataFinders. 

Figure 1-7.  DataFinder Server Registered in LabVIEW

6. Select the TestRig DataFinder server from the list of registered DataFinders.

Note The LabVIEW DataFinder Toolkit is not included in the standard LabVIEW 
package. You can use the functions of the LabVIEW DataFinder Toolkit only when 
you have installed and activated the Toolkit.
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Use the server manager to create, configure, duplicate, or delete DataFinder servers. In the server 
manager you also can make general settings, export the settings for connecting clients to a 
DataFinder server, optimize custom properties, and open the search areas of a DataFinder server 
in a browser view.

Configuring DataFinder Servers
To configure a DataFinder server, double-click the DataFinder server in the server manager. In 
the DataFinder server configuration you can define search areas, export or import DataFinder 
server configurations, and see which file types the DataFinder server uses for the search. You 
can define global indexing schedulers for all data files of a DataFinder server, but you also can 
create individual indexing schedulers for search areas.

You can export and import the configuration of a DataFinder server. The configuration files have 
the filename extension .dfc and contain all DataFinder server settings, for example the search 
areas, the index path, and the indexing schedule.

In Settings»Global Options»General you set the base index path for all DataFinder servers on 
the General tab and specify the editor with which you edit the DataPlugin scripts. On the New 
DataFinder Servers tab, you specify the start settings and the security settings for all new 
DataFinder servers.

Defining Search Areas
You select the folders, which the DataFinder server indexes for the search, on the Search Areas 
tab of the configuration dialog box. You can edit and delete search areas and specify the order 
in which the DataFinder server indexes the search areas and displays the search areas in the 
browser. You must define the search areas of the DataFinder server with path names that are 
unique within the network. If you select Edit Client Path from the context menu of the 
DataFinder server, you can see in the Client path entry line which path the client uses to access 
files in the network, for example, \\Testrig4a\NewCar\DATA.

Use the Windows share settings to share the folders in the search areas. Clients can load files 
from the search areas. You define the share mode when you create a search area or edit an 
existing search area. Click Share Folder to open the Windows system dialog box for sharing 
files. In the Windows sharing settings, you specify which users, and how many simultaneous 
users, have read and write access. You can enter individual users and user groups that are defined 
in a network, for example, to provide access rights for an entire department. Refer to the 
Microsoft Windows program Help for more information about sharing folders.
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For each search area, you can define specific security settings which replace the global security 
settings for this search area. Refer to the section on Specifying the Security Settings in this 
chapter for more information.

To block remote access to all the search areas of a DataFinder server, clear the Allow remote 
access to this computer checkbox on the General tab in the configuration dialog box.

Reading File Types with DataPlugins 
DataFinder servers decide on the basis of the filename extension whether to index a file. The File 
Extensions tab has two lists that contain all the filename extensions that the DataFinder server 
recognizes. 

The Indexable extensions list displays all the file types that correspond to the TDM data 
model. In indexable files, the DataFinder server can search for properties of files, groups, and 
channels. Clients can navigate to channel level in indexed files. Click a filename extension to 
see which DataPlugins the DataFinder server uses to index these files.

The Non-indexable extensions list displays all the file types that do not correspond with 
the TDM data model. In non-indexable files, the DataFinder server cannot search for properties 
of groups or channels. The DataFinder server only can search for properties that the file system 
provides, such as the filename and the creation date. 

The registered DataPlugins determine which file types the DataFinder Server can index. A 
DataPlugin analyzes files that are a specific type and makes the results available to the 
DataFinder server. The DataPlugins tab shows you which DataPlugins the DataFinder uses for 
indexing.

To add DataPlugins, select Settings»Global Options»DataPlugins. In this dialog box, you can 
define, import, export, update, and delete DataPlugins. If you change the properties of a 
DataPlugin, these changes apply to all the DataFinder servers. Click Update to open the 
DataPlugin Update Manager. The DataPlugin Update Manager lists the DataPlugins installed on 
your computer for which later versions are available on the internet site ni.com/
dataplugins. You can update all listed DataPlugins or only selected DataPlugins. This 
internet page contains DataPlugins, which have been written and tested by developers and users, 
for various data formats. The site also provides programming help for the creation of 
DataPlugins, including a description of the objects, properties, and methods, and many 
examples. 

Planning Indexing
When indexing, the DataFinder server reads properties from data files and saves this 
information. When clients search for data files, the DataFinder server browses the index for the 
properties. DataFinder Server Edition can create parallel indexes and thus profit from the multi-
core systems when it indexes and manages large bulks of data.
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Click the Indexer tab in the configuration dialog box to specify when and how often the 
DataFinder server indexes all search areas. Click the Start Now button to start indexing the 
DataFinder server immediately. Depending on the amount of data, it can take quite a while to 
index a search area for the first time. Use the Scheduler to start the indexing regularly, for 
example, daily at 00:00 o’clock when no changes in the search areas and no search queries from 
clients are expected. 

You can enable regular indexing and also automatic indexing. Click the button with the three 
dots next to Automatic indexing triggered by to open the settings. The setting Data file 
changes ensures that a changed or new file is indexed immediately within a search area. Use the 
Job file setting for automation systems. In this case the automation system copies a job file, 
which contains a list of files and folders to be indexed, to a specific folder. DataFinder servers 
edit these job files in regular intervals and execute the indexing tasks defined in the job file. After 
completing the tasks, every DataFinder server deletes the respective job file. 

You can specify a schedule for individual search areas in order to index these folders separately 
from the global schedule. This way, the DataFinder server indexes the folders, in which new files 
are constantly being created, more often than folders whose contents change only rarely. Switch 
to the Search Areas tab, select the search area to be changed, and click Search Area Settings. 
Enable the setting Specific schedule and specify the time point for indexing the search area. 
Then start the first indexing.

Select Settings»Schedule Index Optimization to configure and enable a schedule for the 
regular optimization of the index. Because the client cannot use the index during optimization, 
plan the optimization for every Sunday night at 01:00 o’clock, when no search queries are 
expected. 

Specifying the Security Settings
You can use security settings to limit the clients’ access rights to DataFinder servers. If you do 
not enable the security settings, every client can connect to this DataFinder server and browse 
and search in all existing search areas. Assign global security settings to restrict access to the 
entire DataFinder. Assign security settings on the search area to restrict access to specific search 
areas. A client must have access rights to one search area in order to connect to a DataFinder 
server. If the security settings in the DataFinder do not match the security settings of the file 
system, the client receives an error message when he tries to load data from a search area for 
which he has no access rights.

If the DataFinder is operated as an ASAM ODS server, an ASAM ODS client can access all 
visible data depending on the security settings made in the DataFinder server. The access rights 
of the file system are ignored.

You enable the security settings for a DataFinder server either in the New DataFinder Server»
Advanced dialog box when you create a new DataFinder server, or later on the General tab in 
the configuration dialog box. To use the security settings, you require a network with a domain. 
After you have enabled the security settings, you can create and edit the global security settings 
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in this dialog box. To simplify the process, you can import security settings of shared folders. 
Use the global security settings to restrict access to the entire DataFinder server.

You can also specify security settings for individual search areas in order to manage access to 
these search areas, regardless of the security settings for the entire DataFinder server. Switch to 
the Search Areas tab, select the search area to be changed, and click Search Area Settings. In 
this dialog box you can provide a group with access to a search area or restrict access to specific 
users. If specific security settings are assigned to a search area, the global security settings are 
not applied to this search area.

If possible, use the global security settings in order to ensure the best possible search 
performance. Note that a DataFinder server needs read rights for all search areas in order to 
index the search areas. 

Note also that the data between client and server is transferred unencrypted, even if the security 
settings are enabled.

Optimizing Custom Properties
You can optimize the custom properties for a DataFinder server so that the client finds these 
custom properties faster. Custom properties are user-defined properties that you can create for 
files, groups, and channels of the data that is saved in the TDM data model. Custom properties 
give data additional characteristics that are not included in the standard data model. 

To speed up the search for custom properties, select a DataFinder server in the Server Manager 
and select Settings»Optimize Custom Properties. On the tabs File, Group, and Channel, you 
select custom properties that are to be optimized. If you click Optimize All, the Server Manager 
optimizes all custom properties as soon as you close the dialog box. The DataFinder server 
always optimizes custom properties for the data type that the DataFinder server used most 
frequently for indexing the custom property.

If you use DIAdem as the client, you select the custom properties from the properties in the 
Advanced Search. When you select an optimized custom property, you can suggest a value for 
the search. Which operators you can use for a query depends on the data type of the property 
searched for. You only can search for date/time custom properties if the DataFinder server has 
optimized these custom properties.

Specifying the Start Options of DataFinder Servers
You do not need to open the Server Manager to start a DataFinder server. Select a DataFinder 
server in the overview, select Settings»Start Options, and select the Enable autostart 
checkbox. The DataFinder server now launches automatically every time the operating system 
starts. This setting also guarantees that the DataFinder server is automatically available when 
you restart the computer after the server computer was down.

The setting Run as service specifies whether the operating system executes a DataFinder server 
as a Windows service the next time the operating system starts. A service is a Windows 
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application that starts automatically when Windows starts, and runs in the background until you 
shut down Windows. You only can run a DataFinder server as a Windows service if you are 
logged on as an administrator on Windows. In Windows Vista and Windows 7 and Windows 8, 
you must start the application as an administrator, because the operating system generally starts 
applications with default rights. If a DataFinder server is running as a service on a network drive 
to which you have assigned a drive letter, it cannot index search areas. Use an UNC path instead.

Server Manager
The server manager contains an overview of all DataFinder servers and provides access to the 
most important settings of every DataFinder server. If you enable the security settings, a little 
lock is added to the DataFinder symbol. The Version lists the version numbers of the DataFinder 
servers. The Status indicates whether the DataFinder server has started, paused, or stopped. The 
Remote Access shows whether clients can access the DataFinder server. The Index Frequency 
and the Indexer Start Time show when the regular indexing of this DataFinder server starts. If 
you disable regular indexing, the entry Never appears here.

Figure 2-1.  The Server Manager Displays All DataFinder Servers

The properties display at the bottom of the Server Manager shows other properties of the 
DataFinder server selected in the overview. The Autostart property provides information on 
whether the DataFinder starts automatically when the computer launches, and the Observe 
File System property provides information on whether the DataFinder server automatically 
indexes new and changed files.
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If you want to interrupt data file indexing, select a DataFinder server in the server manager and 
click Pause Indexing on the Windows toolbar. If you want to close the selected DataFinder 
server, click Stop. If you close a DataFinder server, the indexing process stops, all clients are 
disconnected from the server, and the server shuts down. Click Start to reactivate a DataFinder 
server. Clients can now browse in the indexed files again. 

You can open the context menu of each activated DataFinder server, independently of the Server 
Manager, in the information area on the Windows task bar. Select About to see when a 
DataFinder server was last completely indexed and how many files, groups, and channels are 
indexed. You also can use the context menu to stop the indexing and to configure, start, and close 
the DataFinder server. The menu DataFinder»Statistics in the server manager also contains 
index information.

If you want to monitor a DataFinder server because of occurring error messages, enable Help»
Diagnosis»Logging to record all messages. Now the DataFinder manager writes every client 
access and every DataFinder server reaction in different logfiles. The menu item Create 
Diagnosis File packs all log files, together with the system information, into a ZIP file which the 
system administrator can use for error analysis. You can delete these files again after the 
diagnosis in the Help menu because the log files can become very large. Because you have to 
stop the DataFinder server first in order to delete the log files, only delete the files when you do 
not expect any more accesses to the DataFinder.

Duplicating and Upgrading DataFinder Servers
Duplicate a DataFinder server to create a new DataFinder server with the same configuration. 
To do so, select a DataFinder server in the server manager and select File»Duplicate. Then you 
specify the name of the new DataFinder server and specify whether the server manager also 
duplicates the index of the DataFinder server. The server manager does not copy the start options 
of this DataFinder server when duplicating. Observe the license conditions for operating several 
DataFinder servers.

If you want to replace the existing installation with the current DataFinder Server Edition, you 
must proceed in two steps. First install the current DataFinder Server Edition. Then you must 
upgrade the individual DataFinder servers separately. To do so, open the View»Display all 
Versions menu in the current version and display all existing DataFinder servers. The 
DataFinder servers which are not the same version as the Server Manager have a red exclamation 
mark. Select Duplicate/Upgrade from the context menu to create a duplicate of this DataFinder 
server in order to upgrade the DataFinder server. You can test the upgraded DataFinder server 
while the client still has access to the earlier DataFinder server. After deleting the earlier version, 
assign the name of the deleted DataFinder server to the new DataFinder server to avoid having 
to make changes to the clients. 
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If you install a new version of DataFinder Server Edition, you can use the new version with the 
existing license for 30 days parallel to the earlier version. In this time you can set up the 
DataFinder server.

Importing the Local DataFinder
If you are already using a local DataFinder on a computer, create a DataFinder server from My 
DataFinder in order to use this DataFinder together with other clients. First export the 
configuration of the local DataFinder to the client. For example, open the configuration in 
DIAdem in Settings»My DataFinder»Configure, click Export, and create a configuration file 
with the filename extension .dfc. Then copy this configuration file to the DataFinder server 
computer. Open the server manager and create a new DataFinder server. Select Settings»
Configure to open the DataFinder server configuration dialog box. Click Import and open the 
DFC file of the local DataFinder. The new DataFinder server indexes the same search areas as 
the local DataFinder where clients can now also search for and access data. 

Exporting a DataFinder Server Configuration
To connect clients with the configured DataFinder server, export the associated connection 
settings. Select a DataFinder server in the Server Manager and select Settings»Export Client 
Configuration. The server manager creates a URF file with the connection settings, such as the 
name of the DataFinder server, the IP address of the computer, and the registered DataPlugins. 
Copy this URF file to the client and double-click the file to transfer the settings. Now the client 
can search for and load data in the search areas of the DataFinder server if you have specified 
the necessary share parameters.

Browsing in Search Areas
The server manager provides a browser view of the search areas of the DataFinder servers on 
separate tabs. To open a tree view, select a DataFinder server in the server manager and click 
Open in Browser in the View menu on the toolbar. If the DataPlugin that is associated with the 
selected file type allows, you can navigate to channel level in the folders of the search areas and 
in the indexed files. 

The properties display below the tree view shows the properties of the selected file, the selected 
channel group, or the selected channel. Click one of the indexed files to view the file properties, 
as shown in the following figure. In the properties display, the server manager displays file 
properties such as the filename, path, creation date, name, and author. Drag up the top edge of 
the properties display to view the entire properties list.
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Figure 2-2.  Browsing in the Search Areas of a DataFinder Server

In the browser view, you can open the context menu to define other folders as search areas, to 
edit and delete existing search areas, and also to exclude subfolders. You also can reindex 
individual files and folders. You can choose whether the DataFinder reindexes all files in the 
specified folder or whether only the files that were changed or added since the last indexing 
process are reindexed. You also can specify whether the DataFinder also includes the subfolders 
of the specified folder in the indexing process.

If you select View»Client View, the server manager displays the selected DataFinder server in 
the view in which the client sees it. In the client view, the Server Manager displays only the 
search areas and hides the My Computer path. Depending on the security settings, the view of 
a specific client can differ from the client view of the Server Manager.

NI License Manager
The NI License Manager helps you manage your NI software product licenses. To work with 
DataFinder Server Edition after your evaluation version has expired, select Start»All 
Programs»National Instruments»NI License Manager and enter your serial number. 

The NI License Manager limits the number of active clients that can access the DataFinder 
server simultaneously. To increase the number of clients, you must purchase a license that allows 
more connections. Then select Help»Activate License in the Server Manager, click Next, and 
enter the new serial number.

The NI License Manager also limits the number of DataFinder servers that you can create in the 
Server Manager. If you need more than one DataFinder server, you must purchase a license that 
allows multiple DataFinder servers.
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DataFinder as ASAM ODS Server

Use a DataFinder server as ASAM ODS server to read the data from a DataFinder server through 
the ASAM ODS Corba interface. You can connect programs as ASAM conform clients with this 
server through the ASAM ODS interface. The client view of the data corresponds with the 
model hierarchy. 

You need a suitable license in order to use a DataFinder server as an ASAM ODS server.

Configuring a DataFinder Server as ASAM ODS 
Server
Open the ASAM configuration dialog box in Settings»ASAM ODS Server to specify an 
existing DataFinder server as ASAM ODS server. Enable the ASAM ODS server and select a 
model hierarchy for the server, as shown in the following figure. The DataFinder server provides 
two default model hierarchies for the display of the data: Year - Month and Author - Year - 
Month. You can also import user-defined model hierarchies.

Figure 3-1.  ASAM ODS Server Configuration
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Exporting a Client Configuration
You must connect the ASAM clients with this DataFinder server so that the clients can execute 
search queries, filter data, and load data on the ASAM ODS server. To do so, you must save the 
required connection settings in a file and then enable these on the client. 

Click Export Client Configuration in the configuration dialog box. Select the setting Include 
ASAM ODS server connection parameters in the export dialog box. This name comprises the 
name of the DataFinder server and the server name. The server manager saves the connection 
parameters in a file with the extension .urf, for example, engine@test_server.urf. 

Connecting Clients with ASAM ODS DataFinder 
Servers
You must register the connection settings on the client computer so that the client can 
connect with the DataFinder server as ASAM ODS server. To do so copy the 
engine@test_server.urf file to the client computer. Double-click the URF file to transfer 
the connection parameters to the client computer. DIAdem can now use the DataFinder server 
as ASAM ODS server over the network.

Use the security settings of the DataFinder server to restrict the access rights of the client. Refer 
to Specifying the Security Settings in chapter 2, Configuring DataFinder Servers for further 
information.

DIAdem as the Client of an ASAM ODS Server
If you have registered the connection settings on a DIAdem computer, DIAdem can either access 
the indexed data of the DataFinder server directly or can open the indexed data as ASAM ODS 
data in the DIAdem NAVIGATOR data browser. Open Settings»Data Stores in DIAdem 
NAVIGATOR in order to use the DataFinder server as ASAM ODS server in DIAdem. Select 
engine_ASAM-ODS@test_server from the list of registered data stores. Double-click the 
data store to view and edit the settings of the ASAM ODS server. If you click Open, DIAdem 
opens the ASAM ODS data store in the data browser. 

The data browser in DIAdem NAVIGATOR uses a model hierarchy configured on the 
DataFinder server to display the data. The following figure shows the model hierarchy Year - 
Month with the hierarchy levels Year - Month - File - Group - Channel. You can 
navigate in the files down to channel level and search for data. You can define search conditions 
for individual levels of the model hierarchy. DIAdem lists the Tests, Measurements, or 
MeasurementQuantities it finds in the search results. You also can use search conditions to filter 
data. The data browser only displays the branches whose data meets the search conditions.



© National Instruments Ireland Resources Limited | 3-3

NI DataFinder Server Edition

Figure 3-2.  Navigating in the ASAM ODS Data Display of a DataFinder Server

Third Party Software as Client
Every program that supports the Corba interface of ASAM ODS can connect to the DataFinder 
server. In order to access the DataFinder Server as ASAM ODS server use the parameters such 
as server name, port address, and URL in the configuration dialog box of the ASAM ODS 
server. 
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Properties of the ASAM ODS Server
A DataFinder server as ASAM ODS server has the following functions.

Structure of the Data Model
The DataFinder server as ASAM ODS server combines the TDM data model with a user-defined 
test hierarchy and a predefined extendable unit model. 

Figure 3-3.  TDM Data Model with Unit Model

Properties and optimized custom properties of the root level of the TDM data model define the 
test hierarchy. The DataFinder server has two predefined test hierarchies for displaying data: 
year month and author year month. You can import further hierarchies for defining the 
test hierarchy. 

Note Elements of the test hierarchy cannot be used in requests. Instead, use the 
properties of the test level in order to get the same search results.

The elements of the TDM data models are below the test hierarchy and are named in the 
ASAM ODS server according to the ASAM ODS data model. The root level corresponds to the 
test of the ASAM model, the channel group corresponds to the measurement, and the channel 
corresponds to the measurement quantity.

1. root → test (AoSubtest)

2. channelgroup → measurement (AoMeasurement)

3. channel → measurementquantity (AoMeasurementQuantity)

AoT est
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Measurement

Measurement Quantity
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Physical Dimension

Test Hierarchy

TDM Data Model

Units Model
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If you enable the DataFinder server as ASAM ODS server, you must optimize the custom 
properties, to make these properties for searching and filtering data available over the 
ASAM ODS Corba interface.

The measurement quantities are assigned to units which are defined in ASAM ODS. A 
DIAdem units catalog with the filename extension *.tuc, which you load, edit, and save in 
DIAdem, is the basis. The name of the units catalog and its path are in the properties of the 
DataFinder server in the server manager.

Further Capabilities of the ASAM ODS Server
In addition to the ASAM ODS standard, the DataFinder server offers a full text search through 
the ASAM ODS Corba interface as well. 

The DataFinder server as ASAM ODS server provides text files in Unicode. Unicode characters 
include special characters and also Chinese, Japanese, and Arabic characters.

The ASAM ODS server can immediately read data from different ATF-XML files over the 
ATFX_TDM DataPlugin installed with the DataFinder server. The ASAM ODS server can also 
read all the data provided by a DataPlugin.

The ASAM ODS server uses the security settings defined in the DataFinder server. Therefore 
user accounts in the Windows Active Directory can also be used. As is ASAM ODS standard, 
the user name and password are transferred unencrypted over the ASAM ODS Corba interface.
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Integrating the DataFinder Server 
in the Work Environment

This chapter describes the hardware and system requirements, and how you configure your 
firewall in order to connect DataFinder clients outside the firewall with a DataFinder server 
within the firewall. The chapter also outlines how to integrate the DataFinder server into 
archiving systems in order to index and to find archived data.

Hardware and System Requirements
Using the DataFinder Server Edition may place special demands on your system. Refer to the 
following notes for information about optimizing your work with DataFinder Server Edition: 

• Save the index to a hard disk with short access times in order to accelerate access to the 
index. Furthermore, National Instruments recommends storing the index and the operating 
system on separate hard disks.

• When accessing the index, DataFinder Server Edition stores parts of the index in the cache. 
Provide sufficient memory to speed up access.

• The DataFinder Server Edition uses parallel threads to index data. In addition, the indexing 
service runs on several independent processes. Because of this considerable parallelization, 
National Instruments recommends the use of a system with several processors. Such a 
system improves data throughput, because DataFinder Server Edition can process several 
search and browse requests simultaneously.

• The DataFinder Server Edition contains 32 bit and 64 bit components so that you can use 
the program on 64 bit operating systems, for example, to utilize more RAM. In this case 
each process can use up to 2 GB RAM.

• The index may be lost as a result of system errors, for example, if you use RAID level 0 
instead of RAID level 5. However, the DataFinder can always create a new index. National 
Instruments recommends the creation of regular backups. Refer to Backing Up the 
Configuration and Indexes in this chapter, for further information about NoValues.

• Minimum system requirements:
– Processor: 2 processor cores, clock frequency 1.4 GHz
– RAM: 2 GB
– Operating system: Windows Server 2003 R2, Windows Server 2008 R2

• Recommended system requirements:
– Processor: 4 to 8 processor cores, clock frequency 2 GHz
– RAM: 8 to 16 GB
– Hard disks for operating system and index: 15.000 rpm SAS drives or SSD drives
– Operating system: Windows Server 2008 R2, Windows Server 2012
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Backing Up the Configuration and Indexes
Generate backup copies of the associated files to save the server manager configuration and the 
indexes of the DataFinders.

The files of DataFinder Server Edition are located below the folder C:\Documents and 
Settings\All Users\Application Data\National Instruments\DataFinder 
Server Edition or C:\ProgramData\National Instruments\DataFinder 
Server Edition. The subfolder Config contains information on the server manager 
configuration and on which DataFinder server is configured, the subfolder Instances contains 
the configurations of the individual DataFinder servers, and the subfolder 
Instances_Data_<Version> contains the indexes of the DataFinder server. 

If you specified a different index path manually, you can find this path in the properties window 
of the server manager on the General tab of the Configure DataFinder dialog box. 

Uninstalling DataFinder Server Edition
When you uninstall DataFinder Server Edition, you can specify whether to also delete an 
existing configuration and its indexes or whether to keep them for a later reinstallation.

The uninstallation process also removes services and autostart entries. In some cases it might 
happen that the uninstallation process cannot remove all autostart entries when installing or 
uninstalling or when DataFinder Server Edition runs with different user accounts. In this case, 
delete the ni_..._<DataFinder name> entries for the respective user account in the 
Windows registry under HKEY_CURRENT_USER\Software\Microsoft\Windows\
CurrentVersion\Run in order to avoid an error message from the operating system when it 
restarts.

Connecting Databases with Adaptors
Use adaptors to connect the DataFinder Sever Edition with a database and to store the index in 
this database. The connected databases can differ in their performance and available functions.

The DataFinder Server Edition provides a standard adaptor, and also an adaptor for the 
connection with the Microsoft SQL server. You can use this adaptor to integrate the DataFinder 
Server Edition into the existing Microsoft SQL database systems. You can only use the 
Microsoft SQL server adaptor if you have a license that allows 25 connections.

During a DataFinder server upgrade, you cannot modify the adaptor. Select the required 
DataFinder server in the server manager and select File»Duplicate to select a different adaptor 
for the existing DataFinder server.
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Configuring Firewalls and Network Address 
Translating Routers
DataFinder servers use the TCP port 2343 and the UDP port 2343 and a range of UDP ports 
beginning at port 6000. The number of UDP ports above 6000, which the DataFinder servers 
use, depends on the number of servers running on the computer. DataFinder clients, such as 
DIAdem, use a range of UDP ports beginning with port 5000. The number of UDP ports above 
5000 that the DataFinder clients use depends on the number of clients running on the computer.

Firewalls
Installing DataFinder Server Edition, adds the permission to the firewall rules to connect 
DIAdem or other DataFinder clients to a DataFinder server. If you suppressed these firewall 
rules during the installation, execute the AddDataFinderFirewalls.vbs script to 
implement these firewall rules now. The script is at ..\<Program Data>\National 
Instruments\DataFinder Server Edition\Config\<Version>\
FirewallRules. 

Note You need administrator rights to execute the script.

If you do not want to execute the script, complete the following steps. The exact steps for 
configuring the firewall depend on which specific firewall you use. Refer to the documentation 
for the firewall for specific instructions about opening ports.

1. Open the TCP port 2343 and the UDP port 2343 for incoming packets.  

a. For LabVIEW DataFinder Toolkit and for DIAdem up to and including 
DIAdem 2012 SP1: 

Open the UDP port range from 6000 to 6010 for incoming packets.

b. From DIAdem 2012 SP2: 

Open one TCP port for each used DataFinder server starting with TCP-Port 59110.

You also can allow clients inside a firewall to connect to a DataFinder server outside the firewall. 
Some firewalls automatically transmit incoming packets without any configuration. If the 
firewall does not open the ports automatically, open the UDP port range from 5000 to 5010 for 
incoming packets.

Note If you use a DataFinder server as an ASAM server, you must add the 
programs ..\National Instruments\DataFinder Server Edition 
<Version>\DataFinderNMS.exe and ....\National Instruments\
Shared\CorbaNamingService\OmniNames.exe to the list of firewall 
exceptions on the server computer. 
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Network Address Translating Routers
Complete the following steps to allow clients outside a NAT router to connect to a DataFinder 
server inside the router. The exact steps for configuring the router depend on the specific NAT 
router you use. Refer to the documentation on the router for specific instructions about 
forwarding ports. Inside the router, only one computer can function as a server.

1. Forward the TCP port 2343 and the UDP port 2343 to the computer with the DataFinder 
server.  

a. For LabVIEW DataFinder Toolkit and for DIAdem up to and including 
DIAdem 2012 SP1: 

Forward the UDP port range from 6000 to 6010 to the computer with the DataFinder 
server.

b. From DIAdem 2012 SP2: 

Transfer one TCP port for each used DataFinder server starting with TCP-Port 59110.

You also can allow clients inside an NAT router to connect to a server outside the router. Some 
routers automatically forward UDP ports without any configuration. If the router does not 
forward the UDP ports automatically, forward the UDP port range from 5000 to 5010 to the 
computer with the client (DIAdem).

Note If DataFinder Server Edition is installed on a Windows computer on which a 
Windows firewall is enabled, you must add the programs..\National 
Instruments\DataFinder Server Edition <Version>\
DataFinderSE.exe and ..\Windows\System32\lkads.exe to the firewall 
exclusion list on the server computer. 

Note If a client (DIAdem) installed on a Windows computer with an enabled 
Windows firewall wants to access a DataFinder server, you must add the
..\Windows\System32\lkads.exe program to the Windows firewall 
exception list on the client computer. 
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Supporting Archiving Systems
Many factors, such as powerful multicore processors, increased memory, fast hard drives, and 
increasing sampling rates, are leading to increasing amounts of data. For easy and economic 
management of these amounts of data, you can use a backup system or an archiving system. 

In a backup system the data that is not needed directly is stored on an inexpensive storage 
medium with a high storage capacity, usually magnetic tapes. Usually the data must be stored 
and recovered manually. 

Archiving systems provide a more effective management of large amounts of data. In archiving 
systems, automated and rule-based background processes move the files into the archive. A file 
with the same name and the same file attributes, but without any contents, remains at the original 
position in the file system. 

The DataFinder Server Edition integrates smoothly into archiving systems. The DataFinder 
server recognizes archived files and saves the archiving flag together with the descriptive TDM 
and TDMS file data, in the DataFinder index. If you navigate in data or search for data, the 
DataFinder server handles archived data the same as all other data. You can also browse and 
search in files that are stored in an archive, not located in the search areas. The related file 
symbol denotes whether the file is in the archive. When you access the file, it is automatically 
restored from the archive.

DataFinder Server Edition supports archiving systems from SER. Archiving systems from other 
providers were not tested, but can function.
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A
Technical Support and 
Professional Services

Log in to your National Instruments ni.com User Profile to get personalized access to your 
services. Visit the following sections of ni.com for technical support and professional services:

• Support—Technical support at ni.com/support includes the following resources:

– Self-Help Technical Resources—For answers and solutions, visit ni.com/
support for software drivers and updates, a searchable KnowledgeBase, product 
manuals, step-by-step troubleshooting wizards, thousands of example programs, 
tutorials, application notes, instrument drivers, and so on. Registered users also 
receive access to the NI Discussion Forums at ni.com/forums. NI Applications 
Engineers make sure every question submitted online receives an answer.

– Standard Service Program Membership—This program entitles members to direct 
access to NI Applications Engineers via phone and email for one-to-one technical 
support, as well as exclusive access to self-paced online training modules at ni.com/
self-paced-training. All customers automatically receive a one-year 
membership in the Standard Service Program (SSP) with the purchase of most 
software products and bundles including NI Developer Suite. NI also offers flexible 
extended contract options that guarantee your SSP benefits are available without 
interruption for as long as you need them. Visit ni.com/ssp for more information.

For information about other technical support options in your area, visit ni.com/
services, or contact your local office at ni.com/contact. 

• Training and Certification—Visit ni.com/training for training and certification 
program information. You can also register for instructor-led, hands-on courses at locations 
around the world.

• System Integration—If you have time constraints, limited in-house technical resources, or 
other project challenges, National Instruments Alliance Partner members can help. To learn 
more, call your local NI office or visit ni.com/alliance.

• Declaration of Conformity (DoC)—A DoC is our claim of compliance with the Council 
of the European Communities using the manufacturer’s declaration of conformity. This 
system affords the user protection for electromagnetic compatibility (EMC) and product 
safety. You can obtain the DoC for your product by visiting ni.com/certification.

• Calibration Certificate—If your product supports calibration, you can obtain the 
calibration certificate for your product at ni.com/calibration.

You also can visit the Worldwide Offices section of ni.com/niglobal to access the branch 
office websites, which provide up-to-date contact information, support phone numbers, email 
addresses, and current events.

http://www.ni.com
http://www.ni.com
http://www.ni.com/support
http://www.ni.com/support
http://www.ni.com/support
http://www.ni.com/forums
http://www.ni.com/self-paced-training
http://www.ni.com/self-paced-training
http://www.ni.com/ssp
http://www.ni.com/services
http://www.ni.com/services
http://www.ni.com/contact
http://www.ni.com/training
http://www.ni.com/alliance
http://www.ni.com/certification
http://www.ni.com/calibration
http://www.ni.com/niglobal
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