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ArtCAM is a unique software program which enables you to create 
impressive, high quality three-dimensional products starting out as 
two-dimensional bitmap or vector based artwork. ArtCAM 
transforms ideas into finished products far more quickly than is 
possible using conventional methods. Even in cases where a 
hand-finished look is desired, ArtCAM accelerates production. Using 
ArtCAM and a machine tool or router to machine most of the job 
leaves you more time to concentrate on the original design and the 
fine details, which together help to differentiate products in today's 
competitive markets. 

 

 

Introduction 
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Exactly what is included in your ArtCAM layout depends on whether 
or not you have a model or project open.  

 If you are working in ArtCAM Insignia, you cannot create or 
open a project. 

The starting layout 
When you start ArtCAM, the layout includes six key areas:  

 
 

The ArtCAM interface 
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Menu Bar - Select a menu item associated with a particular part 
of the ArtCAM's design process to display a drop-down menu of 
sub-menus and commands. Most of these are inactive until you 
create a model or project. 

 Top docking area - The File toolbar is docked horizontally here. 
This enables you to create a new project or independent model, 
or open a previously saved project or independent model. You 
can also set your preferences and display the Reference Help. 

 Start - This docked panel enables you to create a new model or 
project, or open a previously saved model or project. Your 
recent files are listed and can be reopened. You can also start 
the Font Editor and MillWizard standalone tools, or use the Face 
Wizard tool to create a new model from a photographic image 
containing a side profile of a person's head and neck. 

 When a model or project is created or opened, the Start 
panel is hidden. 

 If you are working in ArtCAM Insignia, the Projects area 
and Face Wizard tool are not included.  

 Tutorials - This tab displays a panel that provides information 
on where to download tutorial packs. Tutorial packs included in 
your installation are listed. 

 Live! - This tab displays a panel that provides online videos you 
can watch to learn about working in ArtCAM. 

 Toolbox - This tab displays a panel that contains compatible 
'plug-in' tools. Plug-ins included in your installation are listed. 
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The open model layout 
When you create a new, independent model, the layout includes 
eight key areas: 

 
 

  
Menu Bar - As described previously, although more sub-menus 
and commands are active. 

 Top docking area - Seven toolbars are docked horizontally here: 
File, Model, Bitmap Tools, Vector Creation, Relief Creation, Vector 
Editing and Relief Editing.  
Up to four additional toolbars are hidden by default: Simulation, 
Rotary Relief Tools, Gem Tools and Back Relief Tools. When 
displayed, these are also docked. 

 If you are working in ArtCAM Insignia, the Rotary Relief 
Tools, Gem Tools and Back Relief Tools toolbars are not 
available. If you are working in ArtCAM Pro, the Rotary 
Relief Tools and Gem Tools toolbars are not available.  

 Almost all of the toolbars' tools are also available from the 
Assistant panel, which is hidden by default so to maximise 
the viewing area. When displayed, this panel is docked on 
the left.  
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 Left docking area - The View Manipulation and Design Tools 
toolbars are docked vertically here. The former enables you to 
twiddle and zoom, while the latter contains four tool groups: 
modes, painting, drawing and sculpting. These include many of 
the most frequently used tools in ArtCAM.  

 Viewing area - The viewing area contains two types of tabbed 
windows: the 2D View and 3D View. These display the layers of 
two-dimensional vector and bitmap artwork in your model. The 
3D View window also displays the relief layers containing your 
three-dimensional shapes, calculated toolpaths, and toolpath 
simulations. Each window has a toolbar and colour palette. 

 Project - This docked panel displays the Project Tree and tools 
associated with its items. The Project Tree maps the different 
elements of your model. Its items provide context menus that 
enable you to create models, layers, triangle meshes, 
assemblies and replica meshes, as well as calculate, edit, and 
simulate toolpaths.  

 The most frequently used tools from the Toolpaths panel, 
which is hidden by default, are available from the Project 
panel. When displayed, the Toolpaths panel is docked on 
the left. 

Up to five panels hidden by default: Toolpaths, Relief Layers, 
Bitmap Layers, Vector Layers and Assistant. When displayed, 
each panel is docked and pinned. The layers panels are also 
tabbed. 

 If you are working in ArtCAM Insignia, the Relief Layers 
panel is not included. 

 Toolbox - As described previously. 

 Tutorials - As described previously. 

 Live! - As described previously. 
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The open project layout 
When you create a new project, the layout includes seven key 
areas: 

 

 If you are working in ArtCAM Insignia, you cannot create a 
project. 

  
Menu Bar - As described previously, although fewer sub-menus 
and commands are active compared to when a model is 
opened. 

 Top docking area - The File toolbar is docked horizontally here. 

 Viewing area - The viewing area is filled by a tabbed 3D View 
window. This displays the assemblies and replica meshes 
included in your project. When a model is opened as part of 
your project, in the 3D View window, you can toggle between 
the display of your project's assemblies and replica meshes, as 
well as the model's relief layers, calculated toolpaths and 
toolpath simulations. 

 Project - As described previously, although the Project Tree 
displays only two items: one that enables you to import 
ArtCAM models, triangle models and surface models as 
assemblies and replica meshes, the other to create and import 
ArtCAM models. 
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 Toolbox - As described previously. 

 Tutorials - As described previously.  

 Live! - As described previously.  

 
 

Understanding the framework 
The ArtCAM framework comprises a: 
 Title Bar; 

 docking area on all four sides;  

 a viewing area; and 
 Status Bar. 
The framework:  

 displays information about what you are working on and where; 

 controls how and where docked toolbars are positioned;  

 contains a tab for each auto-hidden panel; and 

 affects the size of the viewing area. 

 

The Title Bar 
The Title Bar enables you to close or resize ArtCAM, and displays 
information about what you are working on and where. 
From left to right, the following is displayed along the Title Bar: 

 a control icon , which displays the control menu; 

 
 the project's name, provided a project is open; 

 the model's name, provided a model is open independently or as 
part of a project; 

 the product's name; 
 the active view's name, provided a cascaded or tiled 2D View or 

3D View window is maximised; 
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 the currently active bitmap layer's name, provided a cascaded or 
tiled 2D View window is maximised; 

 a Minimise  or Maximise  button, depending on whether or 
not fullscreen mode is used;  

 a Restore  button; and  

 a Close  button. 

 

The docking areas 
There are four docking areas, and these are located: 
 between the Title Bar and viewing area; 

 to the left of the viewing area; 

 to the right of the viewing area; and 
 between the Status Bar and the viewing area. 

The following image shows the ArtCAM layout when a new model is 
created. The docking areas are highlighted in red: 

 
When you start ArtCAM or create a project, the top docking area 
contains: 
 the Menu Bar, which is docked horizontally below the Title Bar; 

and 
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 the File toolbar, which is docked horizontally below the Menu Bar. 

 
When you create a model, the top docking area contains: 
 the Menu Bar, which is docked horizontally below the Title Bar; 
 the File, Model, Bitmap Tools, Vector Creation, Vector Editing, 

Relief Creation and Relief Editing toolbars, which are docked 
horizontally below the Menu Bar; 
File toolbar 

 
Model toolbar 

 
Bitmap Tools toolbar 

 
Vector Creation toolbar 

 
Vector Editing toolbar 

 
Relief Creation toolbar 

 
Relief Editing toolbar 

 

 If you are working in ArtCAM Insignia, several tools are not 
included in these toolbars.  
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Many toolbars include toolsets, which are identified by  in a 
button's bottom right corner. For example, the File toolbar 
includes the toolset shown below: 

 
A toolset's most recently selected button is displayed in the 
toolbar. The other buttons are hidden. 

If a complete toolbar cannot fit within a docking area: 

  is displayed at the end, when the toolbar is horizontal; and  

  is displayed at the bottom, when the toolbar is vertical. 

Click this to display the toolbar's other buttons as a list of 
options. 
For example, when the Transfer tool is not displayed in the 
vertical Design Tools toolbar, it is included in the options list: 
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Docking areas, toolbars and auto-hidden panels share a common 
context menu that you can use to control what toolbars (see 
page 301) and panels (see page 294) are displayed: 

 

 If you are working in ArtCAM Insignia, the Rotary Relief 
Tools, Gem Tools, Back Relief Tools and Relief Layers options 
are not included. If you are working in ArtCAM Pro, the 
Rotary Relief Tools and Gem Tools option are not included. 

Pinned toolbars and panels are selected . The top half of the 
context menu comprises toolbar names, and the bottom half 
comprises panel names.  

When you start ArtCAM or create a project, the right docking area 
contains: 
 the Toolbox, Tutorials and Live! panel tabs (see page 292); 
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When you create a model, the left docking area contains: 
 the View Manipulation toolbar, which is docked vertically: 

 
 the Design Tools toolbar, which is docked vertically; 

 

 If you are working in ArtCAM Insignia, the bottom four 
Sculpting tools are not included in the Design Tools toolbar. 

When you create a model, the right docking area contains the 
Toolbox, Tutorials and Live! panel tabs, which are vertical: 
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The viewing area 
When you start ArtCAM, the viewing area is empty.  
When you create a model, the viewing area contains the 2D View 
and 3D View windows, tabbed with the 2D View window active. 

 
The following image shows the ArtCAM layout when a new model is 
created. The viewing area is highlighted in red: 

 
When you create a project, the viewing area contains the 3D View 
window, tabbed and active. 

 
 

The Status Bar 
From left to right, the following are displayed along the Status Bar: 

 a tool description, when the mouse cursor is over a toolbar 
button or menu; 
For example, when the mouse cursor is over the File toolbar's 

New Model  button, Create a new model is displayed in the 
bottom left: 
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 a progress bar, when toolpaths and three-dimensional shapes 
are being calculated; 

 
 the mouse cursor's XYZ coordinates, when the mouse cursor is 

over the 2D View or 3D View window; 

 
 the bounding box's height and width, when vector artwork or 

toolpath previews are selected; and 

 
 a resizing grip. 

 
 

Understanding the Start panel 
On starting ArtCAM, and when no model or project is open, the Start 
panel is docked and pinned on the left. The panel is divided into four 
areas: Projects, Models, Recent Files and Other Features. 

 If you are working in ArtCAM Insignia, the Projects area is not 
included. This means that the Start panel has only three 
areas. 

The Projects area enables you to: 

 create a new ArtCAM Project (see page 89); or 

 open an ArtCAM Project (see page 92). 
The Models area enables you to: 

 create a new ArtCAM model of a specific size (see page 58); or 

 open a compatible file as an ArtCAM model (see page 62). 
The Recent Files area enables you to open one of the last four 
ArtCAM Model files (*.art) or ArtCAM Project files (*.3dp) you have 
been working on. 

 If you are working in ArtCAM Insignia, the last four ArtCAM 
Model files (*.art) are listed. 

The Other Features area enables you to: 

 create new fonts or modify them; 

 create a relief in the shape of a face from a photographic image 
(see page 70); 
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 If you are working in ArtCAM Insignia, this option is not 
included. 

 open MillWizard; or 

 find out about the latest features and enhancements (see page 
55). 

When you create or open a project or model, the Start panel is 
closed (see page 294). The space previously occupied by the Start 
panel is then used by the viewing area. 

 

Understanding the Project panel 
The Project panel is the hub of working in ArtCAM, and this is why it 
is the only docked and pinned panel displayed when you are 
working with a model or project.  
The Project panel: 

 is docked and pinned;  

 is divided into two areas by a splitter bar; 

 contains the Project Tree, which maps the structure of your 
ArtCAM projects and models; and 

 provides access to a collection of context tools and menus. 
The layout of the Project panel is controlled by its splitter bar, which 
separates the Project Tree and its context tools: 

 
The area above the splitter bar contains the Project Tree, while the 
area below displays all context tools and information associated with 
the currently selected item in the Project Tree. The name of the 
currently selected item in the Project Tree is displayed on the 
splitter bar. 
To control what is shown on the Project panel, click: 

 to display the context tools and information associated with 
the currently selected item in the Project Tree; 

 to maximise the area below the splitter bar, and hide the 
Project Tree; 

 to maximise the area above the splitter bar, and hide the 
context tools and information associated with the currently 
selected item in the Project Tree; or 

 to move the splitter bar to its previous position. 

The layout of the Project Tree depends on whether an ArtCAM 
project or an independent ArtCAM model is created. 
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 If you are working in ArtCAM Insignia, you cannot create or 
open a project. 

For example, when working with a new independent model, the 
Project Tree looks as follows: 

 
When working with a new project, the Project Tree looks as follows: 

 
If you are working with a new ArtCAM project, the Project Tree 
includes: 

 , at its root. Provided your project is saved, its name is shown 
here. 

There is no set of context tools or context menu associated with 
this item. 

 Click  beside any item in the Project Tree to show its 
associated items. Click  to hide them. 

  Models, which enables you to add new or saved ArtCAM 
models. 

Right-click  Models to display its context menu: 

 
Use this to create or import a model. 
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  Assembly, which enables you to add triangle and surface 
models. 

When selected, displayed below the splitter bar are tools that 
enable you to nudge, reposition, select, mirror, copy, and render 
all associated assemblies, import components, display properties 
and calculate multi-sided machining toolpaths: 

 

 If you are working in ArtCAM JewelSmith, the Add Gem 

 button is also displayed in the Tools area. 

Right-click  Assembly to display its context menu: 

 
Use this to toggle its visibility, create an empty assembly, import 
a triangle or surface model, export, copy or paste the root 
Assembly, and reverse the direction of triangles. 
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If you are working with an independent ArtCAM model, the Project 
Tree includes: 

 , at its root. Provided your model is saved or imported, its 
name is shown here. 

When selected, the model's dimensions and resolution are 
displayed below the splitter bar, along with the composite relief 
dimensions. 

Right-click  to display its context menu: 

 
Use this to create a triangle mesh, set the model's size, position 
and resolution, mirror, rotate or add a border to the model, 
specify its lights and material settings, or display your notes. 

  Bitmaps, which controls the bitmap layer stack. 

Right-click  Bitmaps to display its context menu: 

 
Use this to create a new bitmap layer, import bitmap artwork, 
and toggle the visibility of bitmap layers. 

  Bitmap Layer, which is the default bitmap layer and displayed 
by clicking  beside  Bitmaps. 
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Right-click  Bitmap Layer to display its context menu: 

 
Use this to create a new bitmap layer, import bitmap artwork, 
export bitmap artwork, duplicate the layer, clear the layer, 
create a relief layer, delete the layer, and rename the layer. 

  Vectors, which controls the vector layer stack. 

Right-click  Vectors to display its context menu: 

 
Use this to create a new vector layer, import vector artwork, 
toggle the visibility of vector layers, and merge them. 

  Default Layer, which is the default vector layer and displayed 
by clicking  beside  Vectors. 
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Right-click  Default Layer to display its context menu: 

 
Use this to create a new vector layer, import vector artwork, 
export, lock or select its vector artwork, set the stacking order, 
set the colour applied to the layer's vector artwork, toggle 
snapping or its visibility, duplicate the layer, delete or rename 
the layer. 

  Front Relief, which controls the relief layer stack that makes 
up the model's front surface. 

 If you are working with a rotary relief,  is displayed in 
place of  . 

 If you are working in ArtCAM Insignia, this item is labelled 
Relief and there are no relief layers. 

When selected, displayed below the splitter bar are tools that 
enable you to create a new relief layer, import triangle models, 
surface models or relief clipart, save the composite relief 
representing the model's front surface or send it to the Relief 
Clipart Library, or merge visible relief layers.  
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Right-click  Front Relief to display its context menu: 

 
Use this to create a new relief layer, import triangle models, 
surface models or relief clipart, toggle the visibility of relief 
layers, and send the composite relief representing the model's 
back surface to the Relief Clipart Library. 

  Back Relief, which controls the relief layer stack that makes 
up the model's back surface.  

 If you are working with a rotary relief,  is displayed in 
place of  . 

 If you are working in ArtCAM Insignia, this item is not 
included in the Project Tree. 

When selected, displayed below the splitter bar are tools that 
enable you to create a new relief layer, import triangle models, 
surface models or relief clipart, save the composite relief 
representing the model's back surface or send it to the Relief 
Clipart Library, or merge visible relief layers.  

 
Right-click  Back Relief to display its context menu: 

 
Use this to create a new relief layer, import triangle models, 
surface models or relief clipart, toggle the visibility of relief 
layers, and send the composite relief representing the model's 
back surface to the Relief Clipart Library. 

  Relief Layer, which is the default relief layer and displayed by 
clicking  beside  Front Relief and  Back Relief. 
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 If you are working with a rotary relief,  is displayed in 
place of  . 

 If you are working in ArtCAM Insignia, this item is not 
included in the Project Tree. 

When selected, displayed below the splitter bar are tools that 
enable you to create a new relief layer, import triangle models, 
surface models or relief clipart onto the layer, export the layer's 
relief, set the layer's position in the stack, duplicate the layer, 
send the layer's relief to the Relief Clipart Library, create a 
greyscale bitmap layer, delete the layer, rename the layer, and 
set the layer's combine mode. 

 

Right-click  Relief Layer to display its context menu:  
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Use this to create a new relief layer, import triangle, surface 
models or relief clipart onto the layer, export the layer's relief, 
set the layer's combine mode and its position in the stack, 
duplicate the layer, move the layer to the opposite stack, toggle 
the layer's visibility, create a greyscale bitmap layer, send the 
layer's relief to the Relief Clipart Library, delete the layer, and 
rename the layer. 

  Sheets , which controls the sheet stack. 

When selected, displayed below the splitter bar are tools that 
enable you to create a new sheet or a sheet report. 

 
Right-click  Sheets to display its context menu: 

 
Use this to create a new sheet or a sheet report.  

  Default Sheet , which is the default vector layer and displayed 
by clicking  beside  Sheets. 

When selected, displayed below the splitter bar are tools that 
enable you to create a new sheet or sheet report, and delete or 
rename the sheet. 

 
Right-click  Default Sheet  to display its context menu: 

 
Use this to create a new sheet or sheet report, and delete or 
rename the sheet. 

  Toolpaths, which enables you to control your calculated and 
created toolpaths, and the tools they use. 
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When selected, displayed below the splitter bar are tools that 
enable you to create 2D and 3D toolpaths, display the Tool 
Database, specify the material block, import toolpaths from an 
ArtCAM model, and import a toolpath template or simulation. 

 
Right-click  Toolpaths to display its context menu:  

 
Use this to specify the material block, import toolpaths from an 
ArtCAM model, import a toolpath template or simulation, and 
control how toolpaths are displayed. 

As you continue working in a model, other items displayed in the 
Project Tree include: 

  for each of the toolpaths you create; beside which is shown 
the toolpath's name. 
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When selected, displayed below the splitter bar are tools that 
enable you to set the toolpath's position in the stack, display the 
Simulation Control toolbar, edit, calculate, simulate, transform or 
delete the toolpath. The toolpath's parameters are also shown. 

 
Right-click  to display its context menu:  

 
Use this to set the toolpath's position in the stack, display the 
Simulation Control toolbar, edit, calculate, simulate, transform, 
delete or rename the toolpath. 

 Double-click  to display the panel of settings used to 
create the toolpath. You can then edit or re-calculate the 
toolpath. 

  for each of the tools used in your calculated toolpaths; beside 
which is shown the tool's name. 
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  is sometimes replaced with another icon to indicate the 
tool's strategy. For example, where a spiral strategy is 
used,  is displayed instead, and where feature machining 
is used,  is displayed instead. 

When selected, displayed below the splitter bar are tools that 
enable you to display the Simulation Control toolbar, edit, 
simulate, transform or delete the toolpath. The tool's parameters 
are also shown. 

 

Right-click  to display its context menu:  

 
Use this to display the Simulation Control toolbar, simulate, 
transform, save or delete the tool passes. 
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 When right-clicking a tool used as part of a Profile toolpath, 
the Profile Options and Profiling Machining Order options are 
also displayed in the context menu. 

  Simulation, when you simulate a toolpath. 

When selected, displayed below the splitter bar are tools that 
enable you  to simulate your calculated toolpaths, import a relief 
file as a simulation, export a simulation as a relief file, create a 
relief layer from a simulation, reset the simulation, delete the 
simulation, and control how the simulation is displayed: 

 

Right-click  to display its context menu:  

 
Use this to simulate your calculated toolpaths, import a relief file 
as a simulation, export a simulation as a relief file, create a relief 
layer from a simulation, reset the simulation, or delete the 
simulation. 

  beside  Vectors, which you can use to toggle the display of 
that artwork on all vector layers in the 2D View and 3D View 
window. 

  beside each vector layer, which you can use to toggle the 
display of the layer's vector artwork in the 2D View and 3D View 
window. 

  beside each vector layer, which you can use to toggle 
snapping (see page 127). 
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  beside each vector layer, which you can use to toggle the 
locking (see page 127) of its vector artwork. 

  beside  Bitmaps, which you can use to toggle the display of 
the currently active bitmap layer in the 2D View and 3D View 
window. 

  beside  Front Relief, which you can use to toggle the 
display of all its associated relief layers in the 3D View window. 

  beside  Back Relief, which you can use to toggle the display 
of all its associated relief layers in the 3D View window. 

  beside each relief layer, which you can use toggle its display 
in the 3D View window. 

  beside  Toolpaths, which you can use to toggle the display 
of the wireframe toolpath preview associated with all calculated 
2D toolpaths in the 2D View window. 

  beside  Toolpaths, which you can use to toggle the display 
of the solid colour simulation associated with all calculated 2D 
toolpaths in the 2D View window. 

  beside  Toolpaths, which you can use to toggle the display 
of all calculated toolpaths in the 3D View window. 

  beside each calculated 2D toolpath, which you can use to 
toggle the display of the wireframe toolpath preview in the 2D 
View window. 

  beside each calculated 2D toolpath, which you can use to 
toggle the display of the solid colour simulation in the 2D View 
window. 

  beside each calculated toolpath, which you can use to toggle 
the display of the toolpath in the 3D View window. 

As you continue working in a project, other items displayed in the 
Project Tree include: 

  for each closed ArtCAM model; beside which is shown the 
model's name.  

Right-click  to display its context menu:  

 
Use this to edit, duplicate, export, delete and rename a model. 
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  for the ArtCAM model currently open; beside which is shown 
the model's name (provided it has already been saved). 

 Although there can be several models in a project, they 
cannot be opened concurrently. 

When selected, displayed below the splitter bar is information 
regarding the model's dimensions and resolution, and the 
composite relief's dimensions. 

Right-click  to display its context menu:  

 
Use this to close, duplicate, export, rename, resize, reposition, 
mirror and rotate the model, adjust its resolution, lights and 
material settings, and toggle the display of its associated notes. 

  for each assembly; beside which is shown the assembly's 
name. 
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When selected, displayed below the splitter bar are tools that 
enable you to nudge, reposition, select, mirror, copy, and render 
all associated assemblies, import components, add gems and 
display properties. 

 

 If you are working in ArtCAM JewelSmith, the Add Gem 

 button is also displayed in the Tools area. 

Right-click  to display its context menu:  

 
Use this to toggle its visibility, create another, import, export, 
cut, copy, paste, smooth, delete, rename or create a relief from 
the assembly. 

  for each of the replica meshes; beside which is shown the 
mesh's name. 



 

ArtCAM 2012 User Guide The ArtCAM interface • 31  

When selected, displayed below the splitter bar are tools that 
enable you to nudge, reposition and select, or create an 
embossed relief: 

 

Right-click  to display its context menu:  

 
Use this to toggle its visibility, edit an associated model, export, 
cut, copy, smooth, delete, rename or create a relief from the 
replica mesh. 

  for each of the gems; beside which is shown the gem's name. 

When selected, displayed below the splitter bar are tools that 
enable you to nudge, reposition and select, or display properties: 

 

 If you are working in ArtCAM Pro, the Tools area is not 
displayed. 
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Right-click  to display its context menu:  

 
Use this to toggle its visibility, export, cut, copy, reverse, delete 
or rename the gem. 

When working in the Project Tree, the name of: 

 the currently selected item is highlighted and displayed on the 
splitter bar. 

 each active item is displayed in bold text. 

 a calculated toolpath is displayed in black text. 

 an uncalculated toolpath is displayed in red text. 

 an unlicensed toolpath is displayed in orange text. 
 

Understanding the Tool Settings panel 
One of the most important panels, particularly when creating 
bitmap and vector artwork, or sculpting a relief, is the Tool Settings 
panel.  
The Tool Settings panel: 

 is hidden by default; 

 is displayed automatically when a selected tool makes use of it;  

 shows the name of your selected tool on it's header and tab; and  

 contains the settings associated with your currently selected tool. 
Tools that require direct interaction with the 2D View or 3D View 
windows typically display settings on the Tool Settings panel. This 
includes the following tools: 
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Tool Category Tools 
Design Tools Select, Node Editing, Transform, Draw Tool, 

Paint Tool, Magic Wand Tool, Measure Tool, 
Create Polyline, Create Rectangles, Create 
Circles, Create Ellipse, Create Polygons, Create 
Stars, Create Arcs, Create Vector Text, Wrap 
text round a curve, Smooth, Smudge, Deposit, 
Carve, Erase and Transfer. 

 If you are working in ArtCAM Insignia, the 
Magic Wand Tool, Smudge, Deposit, Carve, 
and Transfer tools are not available. 

Vector Creation Fillet Vectors, Trim Vectors and Create Cross 
Section. 

Vector Editing Envelope Distortion 

Relief Editing Relief Envelope Distortion. 

 If you are working in ArtCAM Insignia, the 
Relief Envelope Distortion tool is not 
available. 

2D Toolpaths Profile Options and Profile Machining Order. 
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When you select a tool that uses the Tool Settings panel, the panel 
is displayed automatically and the tool's name is displayed on the 
it's header. For example, with the Create Rectangle tool selected, the 
Tool Settings panel looks as follows: 

 
If you select a tool that displays a dialog box or its own floating 
panel of settings, the settings last displayed on the Tool Settings 
panel stay shown. This means that you can choose to work with 
different combinations of tools displayed at the same time. 
To toggle the display of the Tool Settings panel, use one of the 
following methods: 
 Press the F6 key; or 

 From the Menu Bar, click Window > Display Tool Settings. 
 

Understanding the Toolpaths panel 
When a model is created or opened in ArtCAM, the Toolpaths panel 
is hidden by default. This is because: 
 its Toolpath Operations, 2D Toolpaths and 3D Toolpaths tools are 

displayed on the Project panel; 

 its Toolpath Simulation tools are displayed on the Simulation 
toolbar; 
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 its simulation settings are displayed on the 3D Graphics Options 
panel; 

 your created and calculated toolpaths are included in the Project 
Tree. 

When displayed, the Toolpaths panel is: 

 docked and pinned on the left; and 

 divided into four separate areas, each of which is shown by 
default. 

These areas are as follows: 
 Toolpath Operations - This area contains a collection of buttons 

you can use to manage the toolpaths you have created, the block 
or sheet of material in which you want to machine your vector 
artwork or composite relief, manage the content of your Tool 
Database, create toolpath templates, merge separate toolpaths, 
copy or transform them. 

 
 2D Toolpaths - This area contains a collection of buttons you can 

use to create the toolpaths needed to machine the 
two-dimensional vector artwork drawn on the ArtCAM model's 
vector layers. 

 
 3D Toolpaths - This area contains a collection of buttons you can 

use to create the toolpaths needed to machine all or part of the 
ArtCAM model's composite relief: 
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 If you are working in ArtCAM Insignia, the third, fifth and 
sixth buttons are not included. 

 Toolpath Simulation - This area contains a collection of buttons 
that enable you to simulate your calculated toolpaths. You can 
also control the way in which the simulation is shown in the 3D 
View window.  

 
These tools (see page 266) are also available between the 
Simulation toolbar and 3D Graphics Options panel. 

 If you are working in ArtCAM Insignia, the last three 
buttons are not included. 

You can control which of the four areas of the Toolpaths panel are 
displayed. Click: 

 on the area control bar to hide its set of buttons currently 
shown below: 

 
 on the area control bar to display its set of buttons directly 

below: 

 
All toolpaths that you create or calculate are listed above the 
Toolpath Operations area. For each toolpath you create, its name is 
listed and a description of each tool used is shown below. 
When the toolpath list cannot fit in the space above the Toolpaths 
Operation area, a scrollbar is displayed along the Toolpaths panel's 
right edge. 
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Click and drag the scrollbar's slider to scroll through the toolpath 
list: 

 
If you click the scrollbar's  button, you can gradually scroll 
upwards to the top of the list. If you click and hold on the  button 
you can scroll straight to the top of the list: 

If you click the scrollbar's  button, you can gradually scroll 
downwards to the bottom of the list. If you click and hold on the  
button you can scroll straight to the bottom of the list: 

You can control the order in which the toolpaths are listed on the 
Toolpaths panel using the  and  buttons above the Toolpath 
Operations area. 

To the right of each calculated 2D toolpath listed on the Toolpaths 
panel are icons to:  
 control whether or not the toolpath is displayed in the 2D View as 

a wireframe preview  or solid colour simulation ;  

 set the colour of the toolpath when displayed as a solid colour 
simulation ; and  

 toggle its visibility in the 3D View window .   

To the right of each calculated 3D toolpath, there is only an icon to 
control whether or not it is displayed in the 3D View window . 

When the name of a tool associated with a specific toolpath is 
selected from the list, its parameters are shown below the Toolpath 
Simulation area. You can edit the toolpath parameters displayed on 
the panel. 

 

Understanding the Assistant panel 
When a model is created or opened in ArtCAM, the Assistant panel 
is hidden by default. This is because: 

 all of its tools are displayed on their own toolbars; and 
 the model information is displayed on the Project panel. 

When displayed, the Assistant panel is: 

 docked and pinned on the left; and 
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 divided into up to nine separate areas, each of which is shown by 
default. 

These areas are as follows: 
 Model Information - displays your ArtCAM model's dimensions, 

represented by the white area shown in the 2D View window, and 
the dimensions of the composite relief shown in the 3D View 
window. 

 The dimensions shown depend on which relief layers are 
visible, as well as which relief side is currently active. For 
details, see Understanding the Project panel (see page 15) 
and Understanding the Layers panels (see page 42). 

This information is also displayed on the Project panel, when an 
open model  is selected in the Project Tree. 

 File - contains a collection of buttons you can use to manage 
your model files, and edit the content of the vector, bitmap and 
relief layers within them. You can also adjust many of the default 
settings used in ArtCAM from here. 

 
These tools are also displayed on the File toolbar. 

 Model - contains a collection of buttons you can use to manage 
your model layout, its resolution and how it is displayed in the 3D 
View window. 

 

 If you are working in ArtCAM Insignia, the last three of 
these buttons are not available. 

These tools are also displayed on the Model toolbar. 
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 Bitmap Tools - contains a collection of buttons you can use to 
draw and paint artwork on bitmap layers, as well as manage the 
colour palette's content, and a brush's size and shape. You can 
also convert bitmap artwork to vector artwork. 

 

 If you are working in ArtCAM Insignia, the last of these 
buttons is not available. 

These tools are also available from the:  
 Design Tools toolbar displayed vertically in the left docking 

area. 
 Bitmap Tools toolbar displayed horizontally in the top docking 

area. 
 Tool Settings panel, which is hidden by default. 

 Vector Tools - contains a collection of buttons you can use to 
create artwork on vector layers as shapes or text, as well as 
measure and manipulate them. You can also import vector 
clipart, and convert vector artwork to bitmap artwork. 

 
These tools are also available from the Vector Creation and Vector 
Editing toolbars displayed horizontally in the top docking area. 

 Position, Combine, Trim Vectors - contains a collection of buttons 
you can use to align and centre vector artwork, as well as wrap 
vectors around a curve, or nest them within a specified area. You 
can also group, merge, join, trim, clip and slice the vector 
artwork in your model. 
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These tools are also displayed on the Vector Editing toolbar 
displayed horizontally in the top docking area, and the Design 
Tools toolbar displayed vertically in the left docking area. 

 Relief Tools - contains a collection of buttons you can use to 
scale, smooth, invert, offset, sculpt, slice, reset or add texture to 
a relief layer. You can also create an angled plane or a blended 
shape, distort, copy and paste all or a selected area of a relief 
layer. Furthermore, you can load, save and calculate shapes or 
text, create a triangle mesh, cross-section or vector boundary, 
and import relief clipart. 

 

 If you are working in ArtCAM Insignia, only the first, 
second, fifth and last of these buttons are available. 

These tools are also available from the Relief Creation and Relief 
Editing toolbars displayed horizontally in the top docking area. 

 Back Relief Tools - contains a collection of buttons you can use to 
offset or invert the composite relief to the opposite relief layer 
stack, or create a flip machining layer. 

 

 If you are working in ArtCAM Insignia, these tools are not 
available. 

These tools are also available from the Back Relief Tools toolbar, 
which is hidden (see page 301) by default. 

 Gem Tools - contains a collection of buttons you can use to 
create gems, gem vectors and pave settings, convert vectors to 
gem vectors and display gem vector properties:  
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 If you are working in ArtCAM Pro or Insignia, these tools 
are not available. 

These tools are also available from the Gem Tools toolbar, which 
is hidden (see page 301) by default. 

You can control which of the Assistant panel's areas are displayed: 

 Click  on the area control bar to hide the set of buttons 
displayed below: 

 
 Click  on the area control bar to display its set of buttons: 

 
Seven of the Assistant panel's areas include buttons, each of which 
either: 
 display settings on the Tool Settings panel; 

 display settings on a floating panel; or  

 complete a direct action.  

Several of these buttons are combined together in toolsets. Toolsets 
are collapsed by default to minimise the space in the Assistant panel 
occupied by buttons. Several of the buttons across the different 
areas of the Assistant panel are not used frequently, and so it is 
better to keep them hidden. Of course, you may prefer to work with 
all of the buttons displayed at once. 

You can control the extent to which the buttons belonging to a 
particular area are shown or hidden: 

1 Click  on the button's right edge to display its associated 
toolset.  
For example, click  in the Model area of the Assistant panel: 

 
2 To use a specific tool from the toolset: 

 Click the tool's button.  
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For example, if you needed to set the model's resolution, you 
would click the Adjust Model Resolution button as shown 
below: 

 
The toolset collapses and the selected button replaces that 
which was previously displayed.  
In our example, the Adjust Model Resolution button is 
displayed as follows: 

 
The same button is displayed until such time that another 
button from the same toolset is used. 

3 To pin the toolset so that all of it's buttons stay visible: 

 Click  on the far right edge of the expanded toolset, as 
shown below: 

 
In our example, the toolset in the Model area of the Assistant 
is displayed as follows: 

 

 If you are working in ArtCAM Insignia, the last three 
buttons are not available. 

 Click  on the far right edge of the pinned toolset's end button 
to collapse the toolset. 

 

Understanding the Layers panels 
When a model is created or opened in ArtCAM, the Bitmap Layers, 
Vector Layers and Relief Layers panels are hidden by default. This is 
because: 
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 their layer stack is included in the Project panel's Project Tree; 
and 

 their associated tools are available from the Project Tree's 
context menus. 

When displayed, the Bitmap Layers, Vector Layers and Relief Layers 
panels are: 

 docked and pinned on the right; and 

 embedded in a single container, and therefore tabbed. 

 If you are working in ArtCAM Insignia, the Relief Layers panel 
is not available. 

The layers panels are as follows: 
 Bitmap Layers - This panel is used to manage your model's 

bitmap layers (see page 97). When you create a new model, a 
default bitmap layer named Bitmap Layer is displayed here. The 
artwork drawn on the currently active bitmap layer can be 
displayed in the 2D View and 3D View window.  

The panel's toolset enables you to control the stack of bitmap 
layers: 

 
 Vector Layers - This panel is used to manage your model's vector 

layers (see page 118). When you create a new model, a default 
layer named Default Layer is displayed here. The artwork drawn 
on vector layers can be displayed in the 2D View and 3D View 
window.  

The panel's list box enables you to choose which sheet of vector 
artwork is active. Each new model has a default sheet, and this is 
active. Additional sheets are created when you nest vector 
artwork or create plates. 

The panel's toolset enables you to control the stack of vector 
layers: 

 
 Relief Layers - This panel is used to manage your model's relief 

layers (see page 165). When you create a new model, the Front 
Relief option is selected and a default layer named Relief Layer is 
displayed. This layer is part of a stack used to build a composite 
relief representing the model's front surface. 
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The panel's list box enables you to choose which composite relief 
you want to create. With the Back Relief option selected, a 
default layer named Relief Layer is displayed. This layer is part of 
a stack used to build a composite relief representing the model's 
back surface. 

The three-dimensional shapes you create on a relief layer are 
displayed in the 3D View window. 

The panel's toolset enables you to control the stack of relief 
layers: 

 
The changes you make using these panels update the layers in the 
Project panel's Project Tree. Similarly, the changes you make using 
the Project Tree update the Bitmap Layers, Vector Layers or Relief 
Layers panels.  

 

Understanding the design windows 
There are two default design windows in every new ArtCAM model: 
the 2D View and the 3D View . These design windows occupy the 
viewing area. You can create as many 2D View windows as you like, 
but you cannot create any additional 3D View windows. 

 

Using 2D View windows 
You can create multiple 2D View windows in a model. Each of the 2D 
View windows are shown in the viewing area and include a: 

  
tab, which displays the view's name and the currently 
active bitmap layer's name; 

 toolbar; 

 vertical and horizontal ruler; 

 model area; 

 workspace area; and  

 colour palette. 
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When working in an open model, the 2D View window can display: 

 the artwork on the currently active bitmap layer; 

 the artwork on all visible vector layers; 

 sheets; 

 a preview of all calculated 2D toolpaths; 

 a preview of the currently active relief layer; and 

 a greyscale of the composite relief. 

 If you are working in ArtCAM Insignia, you cannot create a 
greyscale of the composite relief. 

For each of the 2D View windows that you create, you can change 
its: 

 name (see page 49); and 

 workspace colour (see page 50). 
 



 

46 • The ArtCAM interface ArtCAM 2012 User Guide  

Understanding the Title Bar 
When a cascaded or tiled 2D View window is minimised, it's Title Bar 
shares almost all of the features of ArtCAM's Title Bar. ArtCAM's 
control icon and standard Windows buttons are displayed at each 
end of the Title Bar.  

When working on a model independently and looking at a tiled or 
cascaded window's Title Bar when maximised, you can see the 
model's name, the product name, and information about the 
window's contents. 

Maximised... 

 
Minimised... 

 
When working on a model as part of a project and looking at the 
window's Title Bar when maximised, you can see the project's name, 
the open model's name, the product name and information about 
the window's contents. 

Maximised... 

 
Minimised... 

 

 If you are working in ArtCAM Insignia, you cannot create a 
project. 

In addition to the control icon  and standard Windows controls, 
the window's Title Bar includes the following information: view name 
and currently active bitmap layer name. 
View Name - The name of the 2D View window is displayed to the 
right of the control icon . Each subsequent view is named 2D 
View and numbered sequentially. The name and number 
information is separated by a ":" (colon). For details on changing 
the name of the view, see Renaming a 2D View window (see page 
49). 
Active Bitmap Layer - The name of the currently active (see page 99) 
bitmap layer is shown along with the view's name in brackets. This 
information is separated by a "-" (dash). 
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 Double-clicking the view's name on the Title Bar mimics 

clicking the standard Windows Maximize  or Restore  
buttons also on the Title Bar. 

 

Using the control menu 
When your windows are cascaded or tiled, you can use the control 
icon  on a window's Title Bar to control their layout in the viewing 
area (see page 7).  

To display the control menu: 

1 From the window's Title Bar, click  on the far left to display the 
control menu: 

 
2 To minimise, maximise or restore the window to it's previous 

size, click: 
 Minimize to minimise the window so that it's Title Bar is 

positioned along the bottom edge of the viewing area. 

 You can also click the Minimize  button on the window's 
Title Bar to minimize the window. 

Before... 

 
After... 

 
 Maximize to maximize the window so that it fills the viewing 

area. 

 You can also click the Maximize  button or double-click 
the name on the window's Title Bar to maximise it. 

 Restore to restore the minimised window to its previous size. 
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 You can also click the Restore  button or double-click 
the name on the window's Title Bar to restore the window to 
its previous size.  

3 To move a resized window: 

 You cannot move a window when it is maximised  (fills the 
viewing area). 

a Click Move, then click and drag anywhere on it's Title Bar.  

 
b Release the mouse button to set the window's position.  

4 To resize the window, click Size, then adjust the window using 
one of the following methods:  

 You cannot resize a window when it is maximised (fills the 
viewing area). 

 To change the width of the window, move the mouse cursor 
over to the left or right window border. When the mouse 
cursor changes into a horizontal double-headed arrow  
click and drag the border to the right or left. 

 To change the height of the window, move the mouse cursor 
over the top or bottom window border. When the mouse 
cursor changes into a vertical double-headed arrow , click 
and drag the border up or down. 

 To change the height and width at the same time, move the 
mouse cursor over any window corner. When the mouse 
cursor changes to a double-headed diagonal arrow , click 
and drag the border in any direction. 

5 To close the window, click Close. 

 You cannot close the 3D View window. 

 You can also click the Close  button on the window's 
Title Bar to close it. 

If you close the only 2D View window before saving the ArtCAM 
model, a message box is displayed asking if you want to save the 
changes. To save the changes, click Yes. To close the model 
without saving your changes, click No. The Start panel is 
displayed. 
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Adjusting the window layout 
In the viewing area, the 2D View and 3D View windows are tabbed 
by default. You can set the layout of the windows. 
From the Menu Bar, click Window, then: 

 Cascade to display the 2D View and 3D View window overlaying 
one another; 

 Tile Vertically to display the 2D View and 3D View window beside 
one another; 

 Tile Horizontally to display the 2D View and 3D View window on 
top of one another; 

 Tabbed Views to display a tabbed 2D View and 3D View window; 

 2D View to display the 2D View window only; or 

 You can also display the 2D View window by pressing the F2 
key when the 3D View window is displayed. 

 3D View to display the 3D View window only. 

 You can also display the 3D View window by pressing the F3 
key when the 2D View window is displayed. 

 
 

Opening a new 2D View window 
To open a new 2D View window, select View > New 2D View from the 
Menu Bar. 
Each new window is named 2D View by default, and numbered 
sequentially. For example, 2D View:1.  

 You can change the 2D View window's name (see page 49). 

The tab associated with each window is given a different colour. 
This makes it easier to distinguish the windows, as shown below: 

 
The same vector and bitmap artwork is displayed in the windows. 
The same colour palette is also displayed below the windows, 
although each window can have its own colour links and shape 
attributes applied to the colours within the palette. 

 

Renaming a 2D View window 
The 2D View window displayed when you create a model is named 
2D View by default. You can change the name of a 2D View window. 

To change a 2D View window's name: 
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1 Make sure that the 2D View window you want to rename is active 
by clicking: 

 it's tab;  

 it's title bar, if tiled or cascaded; or 

 anywhere in the window. 
2 From the Menu Bar, click View > Rename. The Edit View Name 

dialog box is displayed: 

 
3 Click the View Name box, then type the name you want to give to 

the 2D View window. 

4 Click OK to close the Edit View Name dialog box and set the 2D 
View window's name. 

 

Changing the workspace colour 
You can control the colour of the workspace area in the 2D View 
window. Your chosen colour is applied to the workspace area in all 
2D View windows currently open. 

To set the workspace area's colour: 
1 Use one of the following methods to display the Options panel: 

 In the File toolbar, click the Options  button; 

 From the Menu Bar, click Edit > Options; or 

 From the Assistant panel, click the Options  button in 
the File area. 

2 From the Options panel, click the Drawing Colours control bar to 
display its settings. 

3 Select the Custom Workspace Colour check box. The Workspace 
colour swatch is displayed. 

4 Click the Workspace colour swatch: 
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The Color dialog box is displayed: 

 
5 Select the colour you want to use, then click OK. The Color dialog 

box is closed and your chosen colour is shown on the Workspace 
swatch. 

6 Click Apply to close the Options panel and colour the workspace 
area. 

 

Deleting a 2D View window 
You can delete a 2D View window from your ArtCAM model. 

1 Make sure that the 2D View window you want to delete is active 
by clicking: 

 it's tab;  

 it's title bar, if tiled or cascaded; or 

 anywhere in the window. 
2 Use one of the following methods to delete the 2D View window: 

 From the Menu Bar, click Bitmaps > Views > Delete; or 

 On the window's tab, click ; 

 



 

52 • The ArtCAM interface ArtCAM 2012 User Guide  

If you are working with an independent model, are deleting the 
only 2D View window and have not yet saved the model, or the 
changes you have made since it was saved previously, a 
message box is displayed asking if you want to save your 
changes. 

 If you do not want to delete the 2D View window, click 
Cancel to close the message box. 

To save the changes in the model: 
 Click Yes. The Save Model As... dialog box is displayed. For 

details, see Saving a model (see page 85). 

If you do not want to save the changes: 
 Click No. The message box and the model are closed, and the 

Start panel is displayed. 

If you are working with an independent model, are deleting the 
only 2D View window, and have already saved any changes you 
have made to the model, the model closes immediately. 

If you are working with a model that is part of a project, are 
deleting the only 2D View window, and have not yet saved the 
model or the changes you have made since it was saved 
previously, a message box is displayed asking if you want to 
update the project with your changes. 

 If you are working in ArtCAM Insignia, you cannot create or 
open a project. 

To save the changes in the model: 
 Click Yes. The message box and the model are closed. On the 

Project panel, the updated model  in the Project Tree is 
closed. 

 The updated model is not saved as part of the project until 
the project is also saved. For details, see Saving a project 
(see page 93). 

If you do not want to save the changes: 
 Click No. The message box and the model are closed. On the 

Project panel, the model  in the Project Tree is closed. 

If you do not want to delete the 2D View window, click Cancel to 
close the message box. 

If you are working with a model that is part of a project, are 
deleting the only 2D View window, and have already saved the 
changes you have made to the model, the model closes 
immediately. 
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Using the 3D View Window 
The 3D View window is shown in the viewing area and includes a: 

  
tab, which displays the view's name; 

 toolbar; 

 composite relief; 

 background; and 

 colour palette. 

 
When working with an independent model, the 3D View window can 
display: 

 the composite relief resulting from all visible relief layers; 

 If you are working in ArtCAM Insignia, although there is a 
relief, there are no relief layers. 

 calculated toolpaths; 

 the material block; 

 a toolpath simulation; 

 the artwork on the currently active bitmap layer; 
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 the artwork on all visible vector layers; and 

 a triangle mesh. 

 If you are working in ArtCAM Insignia, you cannot create a 
triangle mesh. 

When working in a project, the 3D View can also display: 

 the root  Assembly; 

  assemblies;  

  replica meshes; and 

  gems.  

 If you are working in ArtCAM Insignia, you cannot create a 
project. 

All of the visible items in the Project Tree are shown in the 3D View 
window when a project is first opened. For details, see 
Understanding the Project panel (see page 15). 

 

Understanding the Title Bar 
When a cascaded or tiled 3D View window is minimised, it's Title Bar 
shares almost all of the features of ArtCAM's Title Bar. ArtCAM's 
control icon and standard Windows buttons are displayed at each 
end of the Title Bar. However, by looking at the window's Title Bar 
you cannot see any information other than the name of the view. 

When working on a model independently and looking at a tiled or 
cascaded 3D View window's Title Bar when maximised, you can see 
the model's name, the product name and the name of the view. 

Maximised... 

 
Minimised... 

 
When working on a model as part of a project and looking at the 3D 
View window's Title Bar when maximised, you can see the project's 
name, the open model's name, the product name and the window's 
name. 

Maximised... 
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Minimised... 

 
For details on using the control icon  and the standard Windows 
controls, see Understanding the Title Bar (see page 46) in 
association with 2D View windows. 

 

Information about ArtCAM 
You can find information about the features in ArtCAM from the 
following sources: 

1 Tool panels (in-line help).  

Click  on a panel's header to toggle the display of it's in-line 
help. 

 
2 The ArtCAM Reference Help system.  

From the Menu Bar, click Help > Index. 

 
3 The Live! panel. 

Move the mouse cursor over the Live! tab in the right docking 
area: 
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4 The Tutorials panel. 

Move the mouse cursor over the Tutorials tab in the right docking 
area: 

 
5 The Start panel.  

Click  in the Other Features area to display details of new 
features and enhancements. 

6 The printed ArtCAM User Guide. 

7 The ArtCAM website.  
From the Menu Bar, click Help > ArtCAM on The Web > ArtCAM 
Home Page. 

8 The ArtCAM User Forum.  
From the Menu Bar, click Help > ArtCAM on The Web > ArtCAM 
Forum. You can also access the forum at 
http://forum.artcam.com (http://forum.artcam.com). 

 If you have not yet registered as a forum member, click the 
Register option on the forum's home page to do so. 
Registered users are able to download images, example 
ArtCAM models and relief clipart files attached to posts. 

9 Subscribe to the ArtCAM Newsletter.  
From the Menu Bar, click Help > Subscribe to the ArtCAM 
Newsletter to send an e-mail requesting subscription to the 
quarterly newsletter. 

 

http://forum.artcam.com/
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A model is an ArtCAM proprietary file which hosts the different 
aspects of your design: the vector artwork, bitmap artwork, reliefs 
and toolpaths.  

You can create an ArtCAM model that is independent or part of a 
project. 

 If you are working in ArtCAM Insignia, you can only create an 
independent model. 

When you start ArtCAM, the Start panel is displayed on the left. To 
create a new independent model from the Start panel, click: 

 New Model, then specify your material block's dimensions 
(see page 58); 

 You can also press the Ctrl+N keys on your keyboard to 
create a model in this way. 

  Open Model, then select a compatible file (see page 62); or 

  Face Wizard, then choose a photographic image (see page 
70) containing a side-profile of a person's head and neck. 

 If you are working in ArtCAM Insignia, this option is not 
available. 

To create a new independent model from the Menu Bar, click: 

 File > New > Model, then specify your material block's dimensions 
(see page 58); 

 File > New > Model (Specify Pixel Size), then specify the number of 
pixels (see page 68); or 

 File > New > From Image File, then select a compatible file (see 
page 62). 

Creating models 
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To create a new model that is part of a project, from the Project 
panel: 

 Right-click  Models in the Project Tree, then click: 

a New > Model in the context menu and specify your material 
block's dimensions (see page 58); 

b New > Model (Specify Pixel Size) and specify the number of 
pixels (see page 68); or 

c New > From Image File and select a compatible file (see page 
62). 

 Right-click a closed model  in the Project Tree, then select 
Duplicate in the context menu. This enables you to create a 
duplicate copy of the model, which you can then edit. 

 

Creating a new model 
When creating a model in ArtCAM, you must specify the: 

 units of measurement you want to use; 

 model's dimensions; 

 model's zero origin; and  

 model's resolution. 

The model's dimensions typically represent the sheet or block of 
material you want to use when manufacturing your finished design. 

To create a model using a set of imperial or metric measurements: 

1 If you are working in ArtCAM Pro or JewelSmith and creating a 
model as part of a project: 

 From the Project panel, right-click Models  in the Project 
Tree then click New > Model... from the context menu. The Size 
For New Model dialog box is displayed. 

2 If you are creating an independent model, use one of the 
following methods to display: 
a the Size For New Model dialog box if you are working in 

ArtCAM Pro or JewelSmith; or 
b the Setup Job Dimensions dialog box if you are working in 

ArtCAM Insignia. 

 From the Start panel, click  New Model in the Models area; 

 From the Menu Bar, click File > New Model;  
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 In the File toolbar, click the New Model  button; or 

 Press the Ctrl+N keys. 

3 If you are creating a new model with another already open, use 
one of the following methods to display: 
a the Size For New Model dialog box if you are working in 

ArtCAM Pro or JewelSmith; or  
b the Setup Job Dimensions dialog box if you are working in 

ArtCAM Insignia. 

 In the File toolbar, click the New Model  button; 

 From the Menu Bar, click File > New > Model; or 

 Press the Ctrl+N keys. 
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If you have not saved any changes you have made to the open 
model before creating another, a message box is displayed 
asking if you want to save these changes. For further details, see 
Saving a model (see page 85). If you have not made any 
changes at all or since it was saved previously, the model is 
closed. 

 

 
4 In the Units area, select mm or inches. 

5 In the Height (Y) and Width (X) boxes, specify the height and 
width of the model you want to create. 
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6 Specify the model's origin by clicking one of the numbered 
positions shown below: 

 
The  icon is displayed on the box diagram in your selected 
position. 

7 If you are working in ArtCAM Pro or JewelSmith: 
a In the Resolution area, click and drag the slider to set the 

model resolution: 

 
A resolution of approximately 1500 x 1500 points is suitable 
for most jobs. 

 After a model is created, you can use the Adjust Model 

Resolution  button on the Model toolbar to change the 
resolution. 

8 If you are working in ArtCAM Insignia: 
a In the Thickness (Z) box, specify the thickness of the material 

you are using for machining. 
b In the Material Z Zero area, specify the Z-axis zero level. This 

is the position of the cutting tool relative to the material 
block's surface. Click: 
Top of Block to position the cutting tool on the material 
surface; or 
Machine Bed to position the cutting tool on the machine bed.  

The  icon is displayed in either the top or bottom front left 
corner of the box diagram to mark the job origin. 

c In the Model Position In Material area, set the position of the 
model relative to the material block. Click: 
Top Of Block to align the model's zero plane with the material 
surface; or  
Machine Bed to align the model's zero plane with the machine 
bed. 
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9 Click OK to create your model. 

If you are creating a model that is part of a project, an open 
model  is shown below  Models in the Project panel's 
Project Tree. The model is named (Untitled). 

If you are creating an independent model, the open model  is 
the root of Project panel's Project Tree. The model is named 
(Untitled). 
A tabbed 2D View and 3D View window is created in the viewing 
area. The 2D View window is typically the place in which you 
draw or edit bitmap and vector artwork, although you can do 
much of the same in the 3D View window. The 3D View window is 
the area in which you view a three-dimensional impression of 
your model, known as the composite relief. 

Each new model has a single default vector, bitmap and relief 
layer. For further information, see Understanding the Project 
panel (see page 15) and Understanding the Layers panels (see 
page 42). 

 If you are working in ArtCAM Insignia, there is no relief 
layer. 

 

Creating a new model from a file 
You can create a model using the ArtCAM Open dialog box, which 
contains standard Windows features.  

You can create a new model by opening a file in ArtCAM saved in 
any of the following file formats: 
 ArtCAM Model (*.art) 
 ArtCAM Relief (*.rlf) 
 Windows or OS/2 Bitmap (*.bmp) 

 Windows or OS/2 DIB (*.dib) 

 Windows or CompuServe RLE (*.rle) 

 JPEG Image - JFIF Compliant (*.jpg, *.jpeg, *.jpe and *.jfif) 
 CompuServe Graphics Interchange (*.gif) 
 Windows Enhanced Meta File (*.emf) 
 Windows Meta File (*.wmf) 
 Tagged Image File Format (*.tif and *.tiff) 
 Portable Network Graphics (*.png) 

 Windows Icon (*.ico) 
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 Drawing Interchange Format, including PowerSHAPE and 
AutoCAD (*.dxf) 

 AutoCAD 2D Drawing (*.dwg) 

 Lotus, PC Paint or DUCT picture (*.pic) 

 Delcam DGK (*.dgk) 

 Portable Document Format (*.pdf) 

To create a new model from a compatible file: 

1 If you are creating a model with none currently open, use one of 
the following methods to display the Open dialog box: 

 From the Start panel, click  Open Model in the Models 
area; 

 From the Menu Bar, click the File > Open option; or 

 Press the Ctrl+O keys. 

 
If you are creating a model with another already open, use one 
of the following methods to display the Open dialog box: 
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 In the File toolbar, click the Open File  button; 

 From the Menu Bar, click File > Open; 

 Press the Ctrl+O keys; or 

 From the Assistant panel, click the Open File  button in 
the File area; 

If you have not saved any changes that have been made to the 
open model before attempting to open another, a message box is 
displayed asking if you want to save the changes to the model. 
For further details, see Saving a model (see page 85). If you 
have not made any changes to the current model, either 
whatsoever or since it was saved previously, it is closed 
immediately. 

2 Select the file you want to use to create the model. 
In the Relief Info area, the file's dimensions are displayed in 
actual measurements and pixels where possible. 

 When choosing a bitmap image, the greyscale 
representation shown in the Relief Info area provides an 
indication of the relief that will be created. Consider that 
the brightest areas of the greyscale image reflect the 
highest areas in the relief, while the darkest areas reflect 
the lowest. 

The Model Preview area displays a thumbnail image of the file's 
contents where possible.  If you select an ArtCAM model file 
(*.art), the thumbnail image shown here contains the contents of 
the active 2D View window when the model was last saved. 

3 If you are creating a model from a *.bmp, *.gif, *.jpg, *.jpeg, *.jpe, 
*.jfif, *.tif or *.tiff file, specify the maximum depth of the resulting 
relief in the Max Z box. 

 If you specify a high Z height, the detail in the resulting 
relief is likely to be poor. You should only specify a low Z 
height. 

 If you are using a Drawing Interchange File (*.dxf), Delcam 
DGK (*.dgk) or Portable Document File (*.pdf), a relief 
cannot be created from the artwork within the file. 

4 Click Open.  

If you have selected an ArtCAM model file (*.art), the Open dialog 
box closes, its design windows are displayed in the viewing area, 
and all layer information is shown on the Project panel. 
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If you have selected an ArtCAM Relief file (*.rlf), the Open dialog 
box closes, and a greyscale image of the relief is displayed in the 
2D View window. A single default vector, bitmap and relief layer 
is included in the Project panel's Project Tree. For details, see 
Understanding the Project panel (see page 15). 

 If you are working in ArtCAM Insignia, no relief layer is 
included. 

If you have selected a *.bmp, *.gif, *.jpg, *.jpeg, *.jpe, *.jfif, *.tif or 
*.tiff file, the Open dialog box closes, and the Set Model Size dialog 
box is displayed: 

 
In the Method area, the Image size option is selected by default. 
The image's dimensions are displayed in the Height and Width 
boxes. 

a If you know the resolution at which the image was originally 
scanned, select the Scanned d.p.i. option, then type this in the 
d.p.i. box. 

b In the Units area, select mm or inches. 

c In the Height and Width boxes, specify the height and width of 
the model you want to create. 

d Specify the model's origin by clicking one of the positions on 
the box diagram, as shown below: 
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The  icon is displayed on the box diagram in your selected 
position. 

e Click OK to create your model. A single default vector, bitmap 
and relief layer is included in the Project panel's Project Tree. 
For details, see Understanding the Project panel (see page 15) 
and Understanding the Layers panels (see page 42). 

 If you are working in ArtCAM Insignia, no relief layer is 
included. 

If you select a *.dxf, *.pic, *.dgk or *.pdf file, the Open dialog box 
closes, and the Size For New Model dialog box is displayed: 

 
For details on how to use the Size For New Model dialog box, see 
Creating a new model (see page 58). 
Click OK to close the Size For New Model dialog box.  

 If you are opening a Delcam DGK file (*.dgk) and it does not 
contain any vector artwork, a message box is displayed 
warning that the file is not suitable. Click OK to close the 
message box. 
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If you are opening a *.dxf or *.dwg file, the Imported File dialog 
box is displayed: 

 
If you click Cancel, a model is created equal to the dimensions 
previously displayed in the Size For New Model dialog box, but the 
vector artwork in the original file is not included. 

To include the vector artwork, make sure the settings are 
correct: 

 To position the artwork in the model's centre, select the 
Centre in model check box. 

 In the File Units area, make sure the units of measurement for 
the artwork is the same as those used in your ArtCAM model 
by selecting mm or inches. 

 To identify all self-intersecting spans in the artwork within 
tolerance, make sure the Check for crossings and 
self-intersections check box is selected, and that the correct 
tolerance is specified in the Intersection Tolerance box. 

 When selected, self-intersecting spans are shown in red, 
with white circular shapes marking the positions where 
spans overlap. 

 To rejoin any spans in the artwork that have been exploded 
within tolerance, make sure the Automatically rejoin vectors 
check box is selected, and that the correct tolerance is 
specified in the Rejoining Tolerance box. 

Click OK to close the dialog box, create the model and import the 
vector artwork. 
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 Any layer information within Drawing Interchange (*.dxf) or 
Delcam DGK (*.dgk) files is preserved in ArtCAM. A separate 
vector layer is created for each layer within the original file. 

If you are opening a Portable Document File (*.pdf), ArtCAM 
creates a new model with a separate vector and bitmap layer for 
each of the pages within the PDF document and names each of 
the layers using the file title (page number) convention. For 
example, the layer relating to the first page of the document 
might be labelled Brochure (Page 1). 

 ArtCAM does not currently support layers (or 'Optional 
Content Groups') within Portable Document Format files 
(*.pdf). 

 

Creating a new model using pixels 
 If you are working in ArtCAM Insignia, you cannot create a 

model using an exact number of pixels. 

To create a new model using an exact number of pixels: 

1 If you are creating a model that is part of a project: 

 From the Project panel, right-click  Models in the Project 
Tree, then click New > Model (Specify Pixel Size) in the context 
menu. 

If you are creating an independent model:  
 From the Menu Bar, click the File > New > Model (Specify Pixel 

Size) option. 

The Size For New Model In Pixels dialog box is displayed: 

 
If you are using the Size For New Model In Pixels dialog box for 
the first time, the default value displayed in both the Width and 
Height boxes is 500. Thereafter, ArtCAM uses your previously 
specified pixel values. 
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If there is a compatible image on the Windows clipboard, the 
Open Clipboard option is active. If there is not, the option is 
greyed out. 

 You can create a model from any Windows or OS/2 Bitmap 
(*.bmp), Windows or OS/2 DIB (*.dib), Windows or 
CompuServe RLE (*.rle), JPEG Image - JFIF Compliant 
(*.jpg, *.jpeg, *.jpe and *.jfif), CompuServe Graphics 
Interchange (*.gif), Windows Enhanced Meta File (*.emf), 
Windows Meta File (*.wmf), Tagged Image File Format (*.tif 
and *.tiff), Portable Network Graphics (*.png) or Windows 
Icon (*.ico) file currently on the Windows clipboard. 

2 To set the model size according to the exact number of pixels in 
the image on the Windows clipboard, select the Open Clipboard 
check box. The number of pixels in the clipboard image is shown 
in the Width and Height boxes. 

 If you want a larger or smaller model than that resulting 
from the pixels found in the image on the Windows 
clipboard, specify the new number of pixels in the Width 
and Height boxes. 

If you do not want to use the image on the Windows clipboard to 
set the model size: 
a Deselect the Open Clipboard check box. 

 If there is no compatible image on the Windows clipboard 
to begin with, the Open Clipboard option is already 
greyed-out. 

a In the Width box, specify the model's width (X). 

b In the Height box, specify the model's height (Y). 

3 Click OK to create the model according to the specified number 
of pixels. 

If you are creating a model that is part of a project, an open 
model  is associated with  Models in the Project Tree. Each 
new model is named (Untitled) by default. 

If you are creating an independent model, the open model  is 
the root of the Project Tree. The model is named (Untitled) by 
default. 
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Creating a model using the Face 
Wizard 

The Face Wizard enables you to create a face model, which 
comprises a relief layer generated from a photographic image 
containing a side-profile of a person's head and neck. You can use a 
photographic image saved in any of the following file formats: 
 Windows or OS/2 Bitmap (*.bmp) 

 Tagged Image File Format (*.tif) 
 CompuServe Graphics Interchange (*.gif) 
 JPEG image (*.jpg) 

The process is almost entirely automated. To produce a detailed 
face shape on a relief layer, your image should ideally be captured 
by a digital source using a resolution of at least 1024 x 768 pixels. 
Colour photographic images can be imported, but they are displayed 
as black and white in ArtCAM. 

 You cannot use the Face Wizard as part of an open model. The 
Face Wizard requires that a new model is created each time 
that it is used. If you use the Face Wizard with a model 
already open in ArtCAM, a message box is displayed asking if 
you want to save the model before it is closed. 

To use the Face Wizard to create a model: 

1 If you are creating a face model from the Start panel: 

 In the Other Features area, click Face Wizard. The Toolbox 
panel is docked and pinned on the right of the interface, on 
which is displayed the Face Wizard's first settings page. 

If you are creating a face model with a project or a model 
already open: 

 From the Toolbox panel, click  Face Wizard. The Toolbox 
panel is docked and auto-hidden, on which is displayed the 
Face Wizard's first settings page. 

 To pin the Toolbox panel, click  on the panel's header. 
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2 From the Toolbox panel, click  Open Photo to display the 
Select Image File dialog box: 

 
3 Click the Look in list box, then the folder on your computer in 

which the image file from which you want to create a face shape 
is stored. 

4 When you have found the image file, click its name. Its name is 
displayed in the File name area. 

5 Click OK to import the image. 

 If you are using the Face Wizard with a model already open 
and have not saved any changes that have been made to 
the open model, a message box is displayed asking if you 
want to save the model. For further details, see Saving a 
model (see page 85). If you have not made any changes to 
the current model either whatsoever or since it was saved 
previously, it is closed immediately. 

 If you are using the Face Wizard with both a project and 
model already open, and have not saved any changes that 
have been made to the model, a message box is displayed 
asking if you want to update the project with the changes. 
For further details, see Saving a project (see page 93). If 
you have not made any changes to current model either 
whatsoever or since it was saved previously, it is closed in 
the Project Tree. 
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A new ArtCAM model is created using the image's dimensions. 
On the Toolbox panel, the Face Wizard's second page of settings 
is displayed.  

 If you are working with a project, the new model  is 
associated with  Models in the Project Tree. The model is 
named (Untitled) by default. 

 If you are working with an independent model, the new 
model  is the root of the Project Tree. The model is 
named (Untitled) by default. 

In the 2D View window, the imported image is shown. This is 
hosted on the default bitmap layer, which is associated with  
Bitmaps in the Project Tree displayed on the Project panel. 

 You can change the name (see page 101) of the default 
bitmap layer. 

Also in the Project Tree is a default vector layer associated with 
 Vectors. The colour red is assigned to this layer, on which you 

draw the vector artwork required by the Face Wizard. 

 You can change the name (see page 125) and the colour 
(see page 126) associated with the default vector layer. 

A relief layer named Relief Layer is also created and this is the 
relief layer on which the three-dimensional face shape is created 
using the image and its associated vector artwork. 
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The TIFF image shown below is a good example of what you can 
import: 

 
You are now ready to create a vector to mark the outline of the 
head and neck shown in your imported image. 

6 From the Toolbox panel, click the Create Polyline  button to 
enter Polyline Creation mode. Its settings are displayed on the 
Tool Settings panel. 

7 To join each of the polyline's nodes with a bezier span, select the 
Draw Smooth Polyline check box. 

8 In the 2D View window, click and drag your mouse to create a 
freeform polyline around the head and neck of the person in your 
imported image. 

 You can press the Alt+B keys to toggle the display of the 
imported image. This enables you to view the polyline more 
clearly. 

9 Use one of the following methods to close the polyline: 

 Click the Close Vector With A Line  button to close the 
polyline with a linear span. 

 Click the Close Vector With A Curve  button to close the 
polyline with a bezier curve. 

 Click the Close Vector - Move End Nodes  button to close 
the polyline by joining its start and end nodes. 
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The polyline is shown in magenta and surrounded by a bounding 
box, indicating that it is closed and selected. 

For example, the polyline might look something like this: 
Polyline, image 
displayed… 

 

Polyline, image 
hidden… 

 

10 Press the N key to enter Node Editing mode. You can see the 
nodes, spans and control points that make up the polyline you 
have drawn. 

11 Edit the shape of polyline (see page 142) so that it follows the 
outline of the face area perfectly, or is even a pixel distance 
inside of the face area.  

12 From the Toolbox panel, click Next to display the third settings 
page. You are now ready to specify the positions of facial 
features in the image. 
If you click Next before creating a vector outline of the head and 
neck, a message box is displayed warning that you must have 
one closed vector. Click OK to close the message box. 

13 From the Toolbox panel, click and drag the top target over to the 
position in the image you want to specify as the centre-front of 
the person's eyebrow. This must be on or inside of the polyline 
that you have drawn.  

 
14 Release the mouse to set the position. The position is marked by 

a red square. 
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15 From the Toolbox panel, click and drag the bottom target over to 
the position in the image you want to specify as the nape of the 
neck. This must be on or inside of the polyline that you have 
drawn.  

16 Release the mouse to set the position. The position is marked by 
a red square. 

 You can right-click  Bitmaps in the Project panel's Project 
Tree, then select Toggle All Visibility from the context menu 
to toggle the display of the imported image. This enables 
you to view your selected positions more clearly.  

For example, the specified positions might look something like 
this: 

Positions, image 
displayed… 

 

Positions, image 
hidden… 

 

17 From the Toolbox panel, click Next to display the fourth page of 
settings. 

18 In the Head Dimensions area, specify the height and width of the 
face shape you want to create. 

19 In the Model Dimensions area, specify the height and width of the 
ArtCAM model in which you want to create the face relief. 

20 Click Next to calculate the face relief. 

If you click Next without having specified the centre-front of the 
person's eyebrow and the nape of the neck, a message box is 
displayed warning that you must specify these points. Click OK to 
close the message box. 

During the relief calculation process, a progress bar and cancel 
button are displayed on the Status Bar: 
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The calculated face relief is displayed in the 3D View window, and 
the Smoothing Tool settings are displayed on the Tool Settings 
panel. 

For example, the face shape created on the default relief layer is 
shown in the 3D View window might look something like this: 

 
The area of the imported image shown in the 2D View window 
within the vector outline you have drawn is projected onto the 
surface of the relief layer. 

21 From the Design Tools toolbar, use the sculpting tools to edit the 
shape of the face on the default relief layer shown in the 3D View 
window.  

22 Click Close to exit the Face Wizard. 
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For example, the sculpted face shape on the default relief layer 
might look something like this: 

 
 

Opening a model 
You can open an ArtCAM model as part of a project or 
independently. 

 If you are working in ArtCAM Insignia, you can only open a 
model independently. 

To open an ArtCAM model independently: 

1 If you are opening an ArtCAM model with no other currently 
open, use any of the following methods to display the Open 
dialog box: 

 Click  Open Model in the Models area; 

 From the Menu Bar, click File > Open; or 
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 Press the Ctrl+O keys. 

 

 You cannot open ArtCAM Project Files (*.3dp) or 3D Assembly 
Files (*.3da) as a model. If you select a file in either of these 
file formats, a project is opened instead. For details, see 
Opening a project (see page 92) and Creating a new 
project from a file (see page 90). 

If you are opening an ArtCAM model with a model already open 
in ArtCAM, use one of the following methods to display the Open 
dialog box: 

 From the File toolbar, click the Open File  button; 

 Press the Ctrl+O keys; or 

 From the Menu Bar, click File > Open. 
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If you have not saved any changes that have been made to the 
open model before attempting to open another model, a 
message box is displayed asking if you want to save the changes 
to the model. For further details, see Saving a model (see page 
85). If you have not made any changes to the model at all, or 
since it was saved previously, it is closed immediately. 

2 Use one of the following methods to find the file you want to 
open as a model: 

 You can use the Look in list box and the Up One Level  
button to find the folder on your computer containing the file 
from which you want to create the new bitmap layer. 

 By default, ArtCAM lists All Supported Files. You can limit the 
files to a particular format by clicking the Files of type list box, 
followed by the specific file format you want to use. 

3 When you have located the file that you want to open, click the 
file name to select it. When you select the file, the Relief Info 
area of the dialog displays the file's dimensions in actual 
measurements and pixels. The Model Preview area displays a 
thumbnail image of the file's contents.  
If you select an ArtCAM model file (*.art), the thumbnail image 
shown in the Model Preview area contains the contents of the 
active 2D View window when the model was saved. 

 When choosing a bitmap image, the greyscale 
representation shown in the Relief Info area provides an 
indication of the form that the resulting relief shall take. 
Consider that the brightest areas of the greyscale image 
reflect the highest areas in the resulting relief, while the 
darkest areas reflect the lowest. 

4 Click Open. Depending on which file you have selected, ArtCAM 
either opens the model immediately or begins the process of 
creating a model.   

When opening large files, a progress bar is displayed in the 
Status Bar: 

 
If you select an ArtCAM Model file (*.art), the model is opened.  
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If you select an image file, the Set Model Size dialog box is 
displayed: 

 
If you are opening a Drawing Interchange (*.dxf), AutoCAD 2D 
drawing (*.dwg), DUCT picture (*.pic) or Portable Document 
Format (*.pdf) file, the Size For New Model dialog box is 
displayed: 

 
Click OK to close the Size For New Model dialog box. 

If you are opening a Portable Document File (*.pdf), ArtCAM 
creates a new model with a separate vector and bitmap layer for 
each of the pages within the PDF document and names each of 
the layers using the file title (page number) convention. For 
example, the layer relating to the document's first page might be 
named Brochure (Page 1). 
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 ArtCAM does not currently support layers (or 'Optional 
Content Groups') within Portable Document Format files 
(*.pdf). 

If you are opening a Drawing Interchange (*.dxf) or AutoCAD 2D 
drawing (*.dwg) file, the Imported File dialog box is displayed: 

 
If you click Cancel, a model is created equal to the dimensions 
previously seen in the Size For New Model dialog box, but the 
vector artwork in the original file is not included in the model. 

To include the vector artwork, make sure that the settings are 
correct: 

 To position the artwork in the model's centre, select the 
Centre in model check box. 

 In the File Units area, make sure the units of measurement for 
the artwork is the same as those used in your ArtCAM model 
by selecting mm or inches. 

 To identify all self-intersecting spans in the artwork within 
tolerance, make sure the Check for crossings and 
self-intersections check box is selected, and that the correct 
tolerance is specified in the Intersection Tolerance box. 

 When selected, self-intersecting spans are shown in red, 
with white circular shapes marking the positions where 
spans overlap. 

 To rejoin any spans in the artwork that have been exploded 
within tolerance, make sure the Automatically rejoin vectors 
check box is selected, and that the correct tolerance is 
specified in the Rejoining Tolerance box. 
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Click OK to close the dialog box, create the model and import the 
vector artwork. 

The layers in the imported file are added to the vector layer 
stack above the previously active layer. Each new vector layer 
uses the name of the layer in the imported file, as well as any 
colour. 

If no colour has been applied to a layer in the imported file, the 
new vector layer is coloured red  by default. 

If the name of a layer in the imported file is already used by a 
vector layer in the model, the artwork on the file's layer is added 
to the vector layer with the same name. 

If the imported file does not contain any vector artwork, a 
message box is displayed warning that the file cannot be used. 
Click OK to close the message box. 

To open an ArtCAM model within a project: 

1 From the Project panel, right-click the closed model  in the 
Project Tree that you want to open, then click Edit in the context 
menu.  

 You can also double-click the closed model  in the 
Project Tree to open the model. 

The model's icon in the Project Tree changes from  to , 
indicating that it is now open.  

The open model is always last in the list of models associated 
with  Models in the Project Tree. 

 

Opening recent models 
When working on models independently, you can quickly open any 
of your four most recent models. 

Use one of the following methods to open a recent model: 
 From the Start panel, click the model's name displayed in the 

Recent Files area; or 

 From the Menu Bar, click File followed by the model's name listed 
above the Exit option. 

A combination of up to four models and projects are listed. 

 If you are working in ArtCAM Insignia, projects cannot be 
opened and therefore are not listed. 
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 If you position the mouse cursor over the  icon beside 
any of the four models listed in the Recent Files area of the 
Start panel, its location on your computer is displayed. 

 

Setting the model resolution 
You can adjust the resolution of an open model. This enables you to 
disassociate the bitmap resolution from the model resolution. 

In pictures, the size of the pixels determines the resolution of the 
picture. Resolution is the number of pixels per inch (ppi) or 
centimetre. A picture is created at a specific resolution. You select 
the resolution based on how you will use the image in your model. 
Consider that too low a resolution causes pixelation, or large pixels 
that cause a coarse relief, while too high a resolution add to 
picture's memory requirements without producing a significant 
increase in its overall finish. 

To set the resolution of an open model: 
1 Use one of the following methods to display the Adjust Model 

Resolution dialog box: 

 From the Project panel, right-click the model  in the Project 
Tree, then click Adjust Resolution... in the context menu;  

 From the Model toolbar, click and hold on the Set Model Size 

 button, move the mouse cursor over the Adjust Model 

Resolution  button in the toolset displayed, then release 
the mouse button: 
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 From the Menu Bar, click the Model > Adjust Resolution... 
option; 

 
 

 
The model's resolution is displayed in the Current Resolution 
area. 

2 Click and drag on the slider to set the model's resolution 
according to your job requirements.  

 

 
Drag the slider to the right to increase the resolution of the 
model. Drag the slider to the left to decrease the resolution. The 
new resolution of the model is displayed in the New Resolution 
area. 

3 Click Apply to set the model's resolution. 
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 You cannot use the Undo  button to restore the 
previous resolution of the model. You must be certain that 
you want to adjust the resolution to that shown in the New 
Resolution area before clicking Apply. 

Alternatively, click Cancel to close the dialog box and keep the 
current model resolution. 

 

Saving a model 
You can save a model as an ArtCAM Model file (*.art) only. 

To save a model you are working on as part of the current project: 

 From the Project panel, right-click the open model  in the 
Project Tree, then select Update Project in the context menu. 

 The updated model is not saved as part of the project until 
the project itself is saved. For details, see Saving a project 
(see page 93). 

Use one of the following methods to save an independent model: 

 From the File toolbar, click the Save  button; 

 From the Menu Bar, click File > Save; or 

 Press the Ctrl + S keys. 

If you have previously saved the model, your changes are saved 
immediately; overwriting the previous model file (*.art). 
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If you are saving the model for the first time, the Save Model As... 
dialog box is displayed: 

 

 The ArtCAM Model (*.art) option shown in the Save as type list 
box is the only file format in which you can save the model.  

1 Click the Save in list box or use the Up One Level  button to 
navigate to the folder on your computer in which you want to 
save the model. 

2 In the File name box, type the name you want to give to the 
model.  

3 Click Save to save the model and close the dialog box. 

 If you are working on an independent model, it's name is 
shown to the right of the control icon  in the Title Bar: 

 
If you are working on a model as part of a project, the 
model's name is shown to the right of the project's name in 
the Title Bar: 

 
For further information, see Understanding the Title Bar (see 
page 46). 

 

Closing a model 
To close the model that you are working on as part of a project: 
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1 From the Project panel, right-click the open model  in the 
Project Tree, then select Close in the context menu. 

If you have not made any changes to the model since it was 
opened, it closes immediately. 

The model icon in the Project Tree changes to ; indicating that 
it is now closed. 

If you attempt to close the model before saving any changes that 
you have made since it was opened, a message box is displayed 
asking if you want to update the project with your changes. 

To save the changes to the model before it is closed: 
 Click Yes. The message box closes and the model icon in the 

Project Tree changes to ; indicating that it is now closed. 

To close the model without saving any changes since it was 
either created or saved previously: 
 Click No. The message box closes and the model icon in the 

Project Tree changes to ; indicating that it is now closed. 

To close the independent model that you are working on: 
1 From the Menu Bar, click the File > Close Model option. 

If you click the File > Close Model option before saving a new 
model, or any changes that you may have made to a previously 
saved model, a message box is displayed asking if you want to 
save your changes. 

If you do not want to save the changes to the model before it is 
closed: 
 Click No. The message box and model closes and the Start 

panel is displayed. 

To save the changes to the model before it is closed: 
 Click Yes. 
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If you are saving the model for the first time, the Save Model As... 
dialog box is displayed: 

 
To save the model: 
a Click the Save in list box, followed by the folder on your 

computer in which you want to save the model. 
b In the File name box, specify the name you want to give to the 

model. 
c Click Save to close the dialog box and the model. The Start 

panel is displayed. 

 The ArtCAM Model (*.art) option shown in the Save as type 
list box is the only file format in which you can save the 
model.  

If you are working with a previously saved model, any changes 
made are saved immediately; overwriting the previous model file 
(*.art). 

 The names of the four most recent saved models are listed 

below the  Open Model in the Models area of the Start 
panel, as well as in the File menu on the Menu Bar. 

If a previously saved model has not been changed since it was 
opened, the model closes and the Start panel is displayed. 
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 If you are working in ArtCAM Insignia, you cannot create a 
project. 

An ArtCAM project hosts any number of ArtCAM models, assemblies 
and triangle mesh replicas. Each ArtCAM model within a project 
contains vector and bitmap artwork, reliefs and toolpaths. Each 
assembly hosts replica triangle meshes of ArtCAM models, material 
information or additional assemblies. Provided a replica mesh has 
been created from an ArtCAM model stored as part of the same 
project, it hosts a link to the ArtCAM model file from which it 
originates. 
When you start ArtCAM, the Start panel is displayed on the left. 
There are two ways to create a project from the Start panel. These 
are: 

 In the Projects area, click  New Project. This enables you to 
create a new project (see page 89). 

 In the Projects area, click  Open Project. This enables you to 
choose a compatible file from which you can create a project 
(see page 90). 

You can also create a project from the Menu Bar: 
 Click File > New > Project. This enables you to create a new 

project (see page 89).  

 
 

Creating a new project 
To create a new ArtCAM Project, use one of the following methods: 

Creating projects 
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 From the Start panel, click   New Project in the Projects 
area;  

 From the Menu Bar, click File > New > Project; or 

 In the File toolbar, click and hold on the New Model  button, 

move the mouse cursor over the New Project  button in the 
toolset displayed, then release the mouse button. 

 
The Project panel is docked and pinned on the right, in which is 
displayed the Project Tree. The Project Tree comprises three default 
items: 

  Project, which is named (Untitled) by default. 

 You can give the project a name when it is saved for the first 
time. For details, see Saving a project (see page 93). 

  Models, which hosts any number of ArtCAM models. For 
further details, see Creating models (see page 57). 

  Assembly, which hosts any number of assemblies and their 
associated replica meshes. 

You cannot delete or rename these items. 
 

Creating a new project from a file 
You can create a project using the ArtCAM Open dialog box, which 
contains standard Windows features.  

You can create a new project by opening an ArtCAM Assembly 
(*.3da) file. 

To create a new project from an ArtCAM Assembly (*.3da) file: 

1 Use one of the following methods to display the Open dialog box: 
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 From the Start panel, click  Open Project in the Projects 
area; 

 From the Menu Bar, click the File > Open... option; or 

 Press the Ctrl+O keys. 

 
2 In the Files of Type list box, make sure the ArtCAM File (*.art; 

*.3dp; *.3da; *.rlf) option is selected 

3 Click the Look in list box, then select the folder on your computer 
in which the file that you want to open is stored. 

4 When you have found the file, click its file name. Its name is 
displayed in the File name box. 

5 Click the Open button to open the file and display the Project 
panel.  
The Project panel contains the Project Tree and a selection of 
tools that can be used to manipulate the default items in the 
Project Tree, as well as the items you subsequently create or 
import. 
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Opening a project 
To open an ArtCAM project: 
1 Use one of the following methods to display the Open dialog box: 

 From the Start panel, click  Open Project in the Projects 
area.  

 From the Menu Bar, click File > Open; or 

 Press the Ctrl+O keys. 

 
2 Select an ArtCAM Project File (*.3dp) or ArtCAM Assembly File 

(*.3da) you want to work with, then click Open. 

On the Project panel, the assemblies  and replica meshes  
in your project are displayed in the Project Tree.  

The root  Assembly is selected and its associated tools are 
displayed below the splitter bar. 
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The project's name is displayed: 

 in the Title Bar to the right of the control icon ; and 

 

 on the Project panel, beside  at the root of the Project Tree. 
 

Opening recent projects 
You can open one of the last four projects you have been working 
on. 

 If you are working in ArtCAM Insignia, you cannot open a 
project. 

Use one of the following methods to open a recent project: 
 From the Start panel, click the project's name in the Recent Files 

area. 

 If you position the mouse cursor over the  icon beside 
any of the projects listed in the Recent Files area of the Start 
panel, its location on your computer is shown. 

 From the Menu Bar, click the File option, then the project's name 
listed above the Exit option. A combination of up to four ArtCAM 
projects and models are listed here. 

 

Saving a project 
You can save a project as an ArtCAM Project file (*.3dp) only. 

Use one of the following methods to save the project you are 
currently working on: 

 From the File toolbar, click the Save  button; 

 From the Menu Bar, click File > Save; or 

 Press the Ctrl+S keys. 

If you have previously saved the project, your changes are saved 
immediately; overwriting the previous project file (*.3dp). 
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If you are saving the project for the first time, the Save Project As 
dialog box is displayed: 

 
1 Click the Save in list box, followed by the folder on your computer 

in which you want to save the project. 
2 In the File name box, type the name you want to give to the 

project. 
3 Click Save to save the project and close the Save Project dialog 

box. 

 The project's name is shown to the right of the control icon  
in the Title Bar: 

 
For further information, see Understanding the framework 
(see page 7). 

To save a previously saved project with a different file name: 
1 From the Menu Bar, click the File > Save As... option. The Save 

Project As dialog box is displayed. 

2 Click the Save in list box, followed by the folder on your computer 
in which you want to save the project. 

3 In the File name box, type the new name you want to give to the 
project. 

4 Click Save to save the project and close the Save Project As dialog 
box. 
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The new name given to the project replaces that which was 
originally shown to the right of the control icon  in the Title 
Bar. 

 

Closing a project 
To close the project that you are working on, click File > Close 
Project from the Menu Bar. 
If you click File > Close Project before saving a new project, or any 
changes that you may have made to the currently open project, a 
message box is displayed asking if you want to save the project or 
not. 
To save and close the project, click Yes. The saved project's name is 
listed: 
 on the Start panel, in the Recent Files area; and  

 in the Menu Bar's File menu. 

If you close the project with a model still open, the model is also 
closed.  
If you do not want to save the project before it is closed, click No. 

If a previously saved project has not been changed since it was 
opened, the project closes and the Start panel is displayed. 
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After a new ArtCAM model is created, you must import or create the 
2D artwork that is the foundation of your 2D/2.5D toolpaths or 3D 
reliefs. 

Bitmap artwork in an ArtCAM model can start as an imported image 
comprising a large number of colours. For example, a photograph, 
downloaded graphic, or scanned document. The level of detail in an 
imported image is most often not required, and ArtCAM provides 
several tools that allow you to quickly reduce, replace or remove 
colours, so that only the essential artwork is left. When you are not 
using an imported image as the basis of your design, there are 
many painting and drawing tools that you can use to create your 
own bitmap artwork. 

Vector artwork in an ArtCAM model can be imported or created from 
a model's bitmap artwork. Just as with bitmaps, there are many 
powerful tools that enable you to edit vectors. If you are not using 
imported vector or bitmap artwork as part of your model, there are 
a variety of drawing tools that you can use to create original vector 
designs. 

The process of preparing your artwork can be accelerated by using 
a Portable Document Format (*.pdf) file as the basis of a new 
model; provided that it already contains both vector and bitmap 
images. ArtCAM extracts the vectors and bitmaps from the pages of 
the PDF file and places the artwork on separate layers. 

 

The 2D design process 
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Using bitmap layers 
Bitmap layers are contained in a stack. The stack is displayed on 
the Project panel and the Bitmap Layers panel. 

You can use one of the following methods to display the bitmap 
layer stack: 

 On the Project panel, click   beside  Bitmaps in the Project 
Tree; or 

 Click the Bitmap Layers panel. 

 To display the Bitmap Layers panel, right-click a docking area, 
toolbar or the Status Bar, then select Bitmap Layers from the 
context menu. 

When working from the Project panel, the bitmap layer stack is 
displayed in the Project Tree: 

 
Every ArtCAM model contains an empty default bitmap layer, named 
Bitmap Layer. However, you can create as many bitmap layers as 
you want; either empty, or from imported artwork. 

 

Importing bitmap artwork 
You can import an image saved in one of the following file formats 
as a new bitmap layer: 
 ArtCAM Model (*.art); 
 ArtCAM Relief (*.rlf); 
 Windows or OS/2 Bitmap (*.bmp); 

 Windows or OS/2 DIB (*.dib); 

 Windows or CompuServe RLE (*.rle); 

 JPEG Image - JFIF Compliant (*.jpg, *.jpeg, *.jpe and *.jfif); 
 CompuServe Graphics Interchange (*.gif); 
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 Windows Meta File (*.wmf); 
 Windows Enhanced Meta File (*.emf); 
 Tagged Image File Format (*.tif and *.tiff); 
 Portable Network Graphics (*.png); or 

 Windows Icon (*.ico). 

To import an image file as a new bitmap layer: 
1 Use one of the following methods to display the Load Bitmap 

Layer dialog box: 

 From the Project panel, right-click  Bitmaps in the Project 
Tree, then select Import in the context menu; 

 From the Menu Bar, click the Bitmaps > Load Layer option; or 

 From the Bitmap Layers panel, click the Import Image  
button. 

 
2 Use one of the following methods to find the file that you want to 

import: 

 You can use the Look in list box and the Up One Level  
button to find the folder on your computer containing the file 
from which you want to create the new bitmap layer. 
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 By default, ArtCAM lists All Supported Files. You can limit the 
files to a particular format by clicking the Files of type list box, 
followed by the specific file format you want to use. 

3 When you have found the file, click to select the file listed in the 
main window of the Load Bitmap Layer dialog box. Its name is 
displayed in the File name box. 

In the Model Preview area, you can see a preview of the selected 
file. In the Relief Info area, a greyscale representation of the 
selected file is displayed, along with its dimensions in pixels. 

 The greyscale representation in the Relief Info area provides 
an indication of the form a resulting relief layer might take. 
The brightest areas of the greyscale image are the highest 
areas in the resulting relief layer, while the darkest areas 
are the lowest. 

4 To scale the image, click the Scaling list box and select: 

 None to leave the image unscaled.  

 Fit to maintain the aspect ratio of the image. If the image is 
equal to, or larger than, the model area (the white area in the 
2D View window), the image fills it without being cropped. If 
the image is smaller than the model area, ArtCAM adds 
borders around the image to compensate. The border uses 
the colour found in the top-left pixel of the image. 

 Fill to crop areas of the image outside of the model area. The 
selected image fills the model area and its original aspect ratio 
is maintained. 

 Stretch to fit the image to the model area. The image is 
resized to fill the model area; its original aspect ratio is not 
retained. 

5 Click Open to import the image into the model as a new bitmap 
layer.  

The new bitmap layer is created directly above the previously 
active layer in the stack, and uses the name of the file from 
which it is created. 

A unique colour palette comprising the colours within the 
imported artwork is also created. When the bitmap layer is 
active, its associated colour palette is displayed below the 2D 
View and 3D View windows.  

 

Choosing the active layer 
Only one bitmap layer can be active at a time, and it is the artwork 
on this layer which is displayed. 
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To choose the active bitmap layer: 

1 Use one of the following methods to display the bitmap layer 
stack: 

 From the Project panel, click  beside  Bitmaps in the 
Project Tree; or 

 Click the Bitmap Layers panel. 

 To display the Bitmap Layers panel, right-click a docking 
area, toolbar or the Status Bar, then select Bitmap Layers 
from the context menu. 

2 Click the layer you want to work with. Its name is bold and 
highlighted. 
The bitmap layer's name is displayed on the 2D View tab: 

 
This is useful if you are working with the Project and Bitmap 
Layers panels auto-hidden or closed. 

The colours within the bitmap layer's artwork are displayed in 
their own colour palette, shown below the 2D View and 3D View 
windows. 

 

Creating a new layer 
In an ArtCAM model, you can create as many bitmap layers as you 
like. This enables you to include many different images in a single 
model. 

You can use one of the following methods to create a new bitmap 
layer: 

 From the Project panel, right-click  Bitmaps in the Project 
Tree, then click New in the context menu; 

 From the Menu Bar, click the Bitmaps > Create New Layer option; 
or 

 From the Bitmap Layers panel, click the New Bitmap Layer  
button. 

By default, each new bitmap layer you create is: 

 named Bitmap Layer; 

 numbered sequentially;  

 active; 

 selected; 
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 added to the layer stack directly above the layer which was 
previously active; and 

 visible in the 2D View window. 

 A default colour palette comprising ten basic colours is 
associated with each of the empty bitmap layers that you 
create, and this is displayed below the 2D View and 3D View 
windows: 

 
When a bitmap layer results from an imported image file, a 
new colour palette with a greater range of colours is 
displayed. 

 

Renaming a layer 
In every new ArtCAM model, the default bitmap layer is named 
Bitmap Layer. Each bitmap layer you create uses this name 
together with a unique number. When you import bitmap artwork, 
the new bitmap layer uses the name of the image file from which it 
is created. You can rename any of the bitmap layers in a model. 

To rename a bitmap layer: 

1 Use one of the following methods to display the layer's name 
box: 

 From the Project panel, right-click the  bitmap layer you 
want to rename in the Project Tree, then click Rename in the 
context menu.  

 From the Bitmap Layers panel, double-click the layer you want 
to rename in the stack. 

2 In the name box, type the name you want to give to the layer.  

 To revert to the name previously given to the layer, press 
the Esc key on your keyboard. 

3 Use one of the following methods to set the name of the layer: 
 Press the Enter key; or 

 Click in the empty space below the layer stack. 
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Viewing a layer 
You can control the bitmap artwork shown in the 2D View and 3D 
View windows by choosing a specific bitmap layer and controlling 
whether or not it is visible. When a bitmap layer is created, it is 
active and visible by default. 

To control a bitmap layer's visibility: 
1 If you are working in the 3D View window, select the Colour 

Shade  button in the 3D View toolbar. 

 In the 3D View window, all bitmap artwork is hidden unless 

the Colour Shade  button is selected. 

2 Choose the layer (see page 99) containing the bitmap artwork 
you want to use. 

 The name of the currently active bitmap layer is displayed 
on the 2D View tab: 

 
3 Use one of the following methods to control whether the bitmap 

artwork can or cannot be seen: 
 To hide the layer's artwork when working from the Project 

panel, click the  icon beside  Bitmaps in the Project Tree; 

 To hide the layer's artwork when working from the Bitmap 
Layers panel, click the Toggle All Visibility  button; 

 To display the layer's artwork when working from the Project 
panel, click the  icon beside  Bitmaps in the Project Tree; 
or 

 To display of the layer's artwork when working from the 
Bitmap Layers panel, click the Toggle All Visibility  button. 
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Creating and editing bitmap artwork 
Using the colour palette displayed below the 2D View and 3D View 
windows, and the bitmap tools available in ArtCAM, you can create 
an original design on an empty bitmap layer, or edit the artwork 
currently on a bitmap layer. 

You can choose a bitmap painting or drawing tool from one of these 
places: 
 The 2D View or 3D View window context menu; displayed by 

right-clicking in either window. 
For example, with the 2D View window empty, its context menu 
includes the following options: 

 

 If you are working in ArtCAM Insignia, the Sculpting and 
Magic Wand options are not displayed. 

 The Design Tools toolbar. 

 

 If you are working in ArtCAM Insignia, the Magic Wand 

 button is not included. 

To display all of the buttons within a toolset on a toolbar, click 
and hold the button with  displayed in the bottom-right. Release 
the mouse when its cursor is over the button that you want to 
select. You cannot pin any toolset on a toolbar. 
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 The Bitmap Tools area of the Assistant panel. 

 

 If you are working in ArtCAM Insignia, the Magic Wand 

 button is not included. 
On the Assistant panel, to display all of the buttons within a 
toolset, click the  icon on the right-edge of the button which is 
currently shown. To pin the toolset, click the  icon along the 
right-edge of the last button in the toolset. 

You can manage the colours in the colour palette using: 

 The colour palette context menu; displayed by right-clicking the 
empty space immediately surrounding the colour palette: 
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 The Bitmaps > Colour menu; displayed from the Menu Bar: 

 
 

Reducing colours 
You can reduce the number of colours in the artwork on a selected 
bitmap layer. ArtCAM takes colours of a similar shade in the artwork 
and produces an averaged colour from them. The averaged colour 
replaces the originals. 

Reducing the number of colours helps to: 

 remove unwanted colours; 

 control the number of vectors created when converting bitmap 
artwork; 

 control the shape of vectors created when converting bitmap 
artwork; and 

 control the size of 3D shapes. 

 Colour reduction should be done as an iterative process so 
that the number of colours can be minimised whilst 
preserving the detail in the original bitmap artwork. 

Reducing the number of colours in the bitmap artwork resets all 
colour links and shape attributes. 

To reduce the number of colours in your bitmap artwork: 
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1 Select the bitmap layer (see page 99) in which you want to 
reduce the number of colours. 

2 Use one of the following methods to display the Reduce Number 
Of Colours In Image dialog box: 

 Right-click the empty space surrounding the colour palette, 
and select Reduce Colours from the context menu; 

 From the Menu Bar, click the Bitmaps > Colour > Reduce 
Number option; or 

 Click the Reduce Colours  button from the Colour toolset 
shown in the Bitmap Tools area of the Assistant panel.  

 
The number of colours currently in the bitmap artwork is shown 
in the Current Number Of Colours In Image box. 

3 In the New Maximum Number Of Colours For Image box, enter a 
number of colours between 2 and the current number of colours. 

 If you type 1 in the New Maximum Number Of Colours For 
Image box, a message box is displayed warning that you 
must use a number between 2 and the value equal to the 
total number of colours currently in the bitmap artwork. 
Click OK to close the message box, and then adjust the 
number in the box accordingly. 

4 Click OK to close the dialog box and reduce the number of 
colours in the bitmap artwork. 

 

Colour linking 
Colour linking helps you to: 

 change how different aspects of your bitmap artwork are 
displayed; and 
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 reduce the number of colours in your bitmap artwork, without 
removing them altogether. 

You can link and unlink any of the colours within the colour palette 
shown below the 2D View and 3D View window. 

When a colour is linked to the primary colour, it is: 

 treated as the primary colour for as long as it remains linked; 
 seen in the 2D View and 3D View windows as the primary colour; 

and  

 shown in the colour palette as a smaller swatch, connected to the 
primary colour by a horizontal line. 

For example, colours linked with the primary colour are shown as 
follows: 

 
  Primary colour. 

 Colours linked to primary 
colour. 

You can one of the following methods to toggle the linking of the 
primary and secondary colours: 
 From the Menu Bar, click the Bitmaps > Colour > Link/Unlink 

option; 

 In the colour palette, double right-click the secondary colour's 
swatch; 

 In the colour palette, click the  icon; or 
 Press the Ctrl+L keys. 

You can also use your mouse to link and unlink any of the colours in 
the colour palette. 

Colour links cannot be shared between colour palettes. Any colour 
links in the current colour palette are associated with the currently 
active bitmap layer only. If you choose another bitmap layer, its 
own colour palette is displayed along with its own set of colour 
links. 

To link colours: 

1 In the colour palette, click and drag an unlinked colour swatch 
onto the colour swatch with which you want to link.  
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 When over a colour swatch, the mouse cursor is displayed 

as .  

When outside of a colour swatch, the mouse cursor is 
displayed as . 

2 Release the mouse button to link the colours. In the colour 
palette, the swatch of the linked colour is now smaller, and 
joined to the other colour swatch by a short horizontal line. 

To unlink colours: 

1 In the colour palette, click and drag a linked colour swatch onto 
the colour swatch with which it is already linked.  

2 Release the mouse to unlink the colours. In the colour palette, 
the unlinked colour swatch returns to its original position. 

 

Linking All Colours  
You can use one of the following methods to link all colours in the 
colour palette, with the exception of the secondary colour and 
primary colour: 

 Right-click the empty space surrounding the colour palette, then 
select Link All Colours from the context menu; 

 From the Menu Bar, click the Bitmaps > Colour > Link All Colours 
option; or 

 Press the Ctrl+K keys. 

 

Unlinking All Colours 
You can use one of the following methods to unlink all linked colours 
in the colour palette: 

 Right-click the empty space surrounding the colour palette, then 
select Reset All Links from the context menu; 

 From the Menu Bar, click the Bitmaps > Colour > Reset All Links 
option; or 

 Press the Ctrl+R keys. 
 

Selecting the primary and secondary colours 
There are two colours to consider when working with bitmap 
artwork: the primary colour and the secondary colour.  
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The primary colour influences how the following are created from 
bitmap artwork: 

 vector artwork; and  

 three-dimensional shapes.  

ArtCAM can create vectors around the outline of all areas of bitmap 
artwork in the primary colour; as well as any other areas in colours 
currently linked to the primary colour. 

You can also use the primary and secondary colours to specify 
particular areas of the relief that you do or do not want to edit. 

The primary colour controls the colour of: 
 the Paint tool;  

 the Paint Selective tool; 

 the Draw tool; 

 the Flood Fill tool;  

 the Flood Fill Selective tool; and 

 the Depth Colour, when used in a toolpath simulation. 

The secondary colour is used: 
 as another colour choice for the Paint tool; 

 as another colour choice for the Draw tool; 

 to restrict the Paint Selective tool; and 

 to restrict the Flood Fill Selective tool. 

You can specify the primary and secondary colours: 

 Using your mouse, by clicking the colours from the colour palette 
shown beneath the 2D View and 3D View window: 

 
 

  
Primary colour. 

 Secondary colour. 

 Available colours. 
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 Using the Pick Colour tool, by clicking the colours directly from 

the artwork on the selected bitmap layer. 
 If you are working in the 3D View window, make sure that the 

Colour Shade  button in the 3D View toolbar is toggled on. 

Use one of the following methods to select the primary colour: 

 In the colour palette, click the colour you want to use; 
 In the Design Tools toolbar, click and hold on the Measure Tool 

 button, move the mouse cursor over the Pick Colour  
button in the toolset displayed, then release the mouse button. 

Move the dropper  over a colour in the bitmap artwork, then 
click; or  

 Click the Pick Colour  button in the Bitmap Tools area of the 

Assistant panel, move the dropper  over a colour in the 
bitmap artwork, then click. 

Use one of the following methods to select the secondary colour: 

 In the colour palette, right-click the colour you want to use; 

 In the Design Tools toolbar, click the Pick Colour  button, 

move the dropper  over a colour in the bitmap artwork, hold 
down the Shift key, then click; or 

 Click the Pick Colour  button in the Bitmap Tools area of the 

Assistant panel, move the dropper  over a colour in the 
bitmap artwork, hold down the Shift key, then click. 

 

Using the Paint tools 
The Paint tool enables you to apply the primary or secondary colour 
to the currently active bitmap layer. The Paint Selective tool enables 
you to restrict your painting to the areas using the current 
secondary colour. You can use these tools in the 2D View or 3D View 
window. 
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 When using the Paint and Paint Selective tools in the 3D View 

window, the Colour Shade  button in the 3D View toolbar 
must be toggled on. 

To paint in the primary or secondary colour: 

1 Choose the bitmap layer (see page 99) on which you want to 
paint. 

2 Make sure the bitmap layer is visible (see page 102).  
3 Use one of the following methods to select the Paint tool: 

 In the Design Tools toolbar, click and hold on the Draw  

button, move the mouse cursor over the Paint  button, 
then release the mouse button. 

 Right-click the 2D View or 3D View window, then click Painting 
> Paint in the context menu; 

 From the Assistant panel, click the Paint  button in the 
Drawing toolset shown in the Bitmap Tools area. 

 For information on how to display any of the toolsets in the 
Assistant panel, see Understanding the Assistant panel (see 
page 37). 

4 Change the primary and secondary colours (see page 108) to the 
colours you want to use. 

5 Click the Toggle Brush Shape icon to set the brush shape. You 
can toggle between a round  and a square  tip. 

6 Use one of the following methods to increase or decrease the 
size of the brush: 
 Hold down the Shift key, then roll the middle wheel on your 

mouse; 
 Drag the Brush Diameter slider on the Tool Settings panel; or 

 Drag the Brush Diameter slider in the Bitmap Tools area of the 
Assistant panel. 

7 Position the brush cursor  over the area of the bitmap 
artwork in which you want to paint: 

 To paint in the primary colour, click and drag. 
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 To paint in the secondary colour, hold down the Shift key, 
then click and drag. 

To restrict your changes to those areas currently shown in the 
secondary colour: 

1 Choose the bitmap layer (see page 99) in which you want to 
paint. 

2 Make sure the bitmap layer is visible (see page 102).  
3 Use one of the following methods to select the Paint Selective 

tool: 

 In the Design Tools toolbar, click and hold on the Draw  

button, move the mouse cursor over the Paint Selective  
button, then release the mouse button. 

 Right-click the 2D View or 3D View window, then click Painting 
> Paint Selective in the context menu; or 

 From the Assistant panel, click the Paint Selective  
button in the Drawing toolset shown in the Bitmap Tools area. 

4 Change the primary colour (see page 108) to the colour you 
want to use. 

5 Change the secondary colour (see page 108) to the colour you 
want to replace. 

6 Click the Toggle Brush Shape icon to set the brush shape. You 
can toggle between a round  and a square  tip. 

7 Use one of the following methods to increase or decrease the 
brush diameter: 
 Hold down the Shift key, then roll the middle wheel on your 

mouse; 
 Drag the slider on the Tool Settings panel; or 

 Drag the slider in the Bitmap Tools area of the Assistant panel. 

8 Position the brush cursor  over the area of the bitmap layer 
in which you want to paint, then click and drag. 

All areas of the bitmap layer currently in the secondary colour, 
and beneath the brush cursor, are replaced with the primary 
colour. All other areas of colour remain unchanged. 
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Using the Draw tool 
The Draw tool enables you to apply a line of one pixel wide in the 
primary or secondary colour to the currently active bitmap layer. 
You can use this tool in the 2D View or 3D View window. 

 When using the Draw tool in the 3D View window, the Colour 

Shade  button in the 3D View toolbar must be toggled 
on. 

To use the Draw tool: 

1 Choose (see page 99) or create (see page 100) the bitmap layer 
on which you want to draw. 

2 Make sure the bitmap layer is visible (see page 102). 
3 Use one of the following methods to select the Draw tool: 

 In the Design Tools toolbar, click the Draw  button; or 

 Click the Draw  button in the Drawing toolset shown in 
the Bitmap Tools area of the Assistant panel. 

 For information on how to display any of the toolsets in the 
Assistant panel, see Understanding the Assistant panel (see 
page 37). 

4 Select the colour (see page 108) in which you want to draw as 
the primary or secondary colour. 

5 Position the draw cursor  over the area of the bitmap layer in 
which you want to draw: 

 To use the primary colour, click and drag. 
 To use the secondary colour, hold down the Shift key, then 

click and drag. 
 

Using the Flood Fill tools 
The Flood Fill and Flood Fill Selective tools enable you to replace 
areas of colour on the currently active bitmap layer. You can use 
these tools in the 2D View or 3D View window. 



 

114 • The 2D design process ArtCAM 2012 User Guide  

 When using the Flood Fill and Flood Fill Selective tools in the 

3D View window, the Colour Shade  button in the 3D View 
toolbar must be toggled on. 

To replace a specific colour with the current primary colour: 

1 Choose the bitmap layer (see page 99) containing the artwork 
that you want to edit. 

2 Make sure the bitmap layer is visible (see page 102). 

3 Select the colour (see page 108) you want to use for flood filling 
as the primary colour. 

4 Use one of the following methods to select the Flood Fill tool: 

 In the Design Tools toolbar, click the Flood Fill   button; 

 Right-click the 2D View or 3D View window, and click Painting > 
Flood Fill from the context menu; 

 Click the Flood Fill  button in the Flood Fill toolset shown 
in the Bitmap Tools area of the Assistant panel. 

 For information on how to display any of the toolsets in the 
Assistant panel, see Understanding the Assistant panel (see 
page 37). 

5 Position the roller cursor  over the colour in the bitmap layer 
you want to replace with the current primary colour, then click.  

To replace all colours, except those in or surrounded by the 
secondary colour: 

1 Choose the bitmap layer (see page 99) containing the artwork 
you want to edit. 

2 Make sure the bitmap layer is visible (see page 102). 
3 Use one of the following methods to select the Flood Fill Selective 

tool: 
 In the Design Tools toolbar, click and hold on the Flood Fill  

 button, move the mouse cursor over the Flood Fill 

Selective  button, then release the mouse button. 

 Right-click the 2D View or 3D View window, and click Painting > 
Flood Fill Selective from the context menu; or 
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 Click the Flood Fill Selective  button in the Flood Fill 
toolset shown in the Bitmap Tools area of the Assistant panel. 

 For information on how to display any of the toolsets in the 
Assistant panel, see Understanding the Assistant panel (see 
page 37). 

4 Select the colour (see page 108) you want to use for flood filling 
as the primary colour. 

5 Select the colour (see page 108) you want leave untouched as 
the secondary colour. 

6 Position the roller cursor  over a colour in the bitmap layer 
you want to replace with the primary colour, then click.  

All colours, except those in or surrounded by the secondary 
colour, are replaced with the primary colour. 

 To replace any areas of colour surrounded by the secondary 
colour, you must click each of the colours inside the 
boundary shown in the current secondary colour. 

 

Converting bitmap artwork into vector 
artwork 

The Bitmap To Vector tool enables you to create a vector boundary 
around areas of the currently active bitmap layer shown in the 
current primary colour; as well as any other areas in colours 
currently linked to the primary colour. For further details about 
colour linking, see Colour linking (see page 106). 

When converting bitmap artwork, the resulting vectors follow the 
pixelated outline of the colours. You can smooth these vectors by 
replacing their linear spans with bezier curves. For details, see 
Smoothing nodes (see page 153). 

To create a vector boundary using bitmap artwork: 

1 Choose the bitmap layer (see page 99) containing the artwork 
from which you want to create vectors. 

2 Choose (see page 124) or create (see page 121) the vector layer 
on which you want to create the vectors. 

3 Make sure that the active bitmap (see page 102) and vector (see 
page 129) layers are both visible. 

4 Make sure that the colour around which you want to create 
vectors is selected as the primary colour (see page 108). 
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5 Use one of the following methods to display the Bitmap To Vector 
panel: 

 In the Vector Creation toolbar, click the Bitmap To Vector  
button; 

 From the Menu Bar, click the Vectors > Bitmap To Vector option; 
or 

 Click the Bitmap To Vector  button in the Bitmap Tools 
area of the Assistant panel. 

6 To reduce the number of colours in your bitmap artwork: 
a Click Reduce Colours. The Reduce Number Of Colours In Image 

dialog box is displayed: 

 
b Click and drag the slider, or type a specific number in the box 

displayed to its right. See Reducing colours (see page 105). 
c Click OK. The dialog box closes, and fewer swatches are 

displayed in the colour palette. How significantly your bitmap 
artwork's composition is affected depends on the difference 
between the new and previous number of colours. 

7 In the colour palette, click the swatch of the colour you want set 
as the primary colour. During the conversion process, vector 
boundaries are created around those areas shown in the primary 
colour. 

8 Specify the type of vectors you want to create. Select the: 
 Create Boundary check box to create vector boundaries. 

 Create Centreline check box to create vector centrelines. 

9 If you have selected the Create Centreline check box: 
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a In the Pixel Tolerance box, specify the tolerance you want to 
use. This controls how closely the spans in the resulting 
vectors follow the bitmap artwork's pixelated outline. 

b To create centrelines using open vectors, select Disconnected 
Open Vectors by clicking its radio button. 

c To create centrelines using closed vectors, select Closed 
Vector Loops by clicking its radio button. 

10 In the Speckle Size box, specify the minimum interior pixel area 
around which you want a vector boundary to be created. 

11 In the Smoothness box, specify how sharp or curved the vector 
artwork should be. 

12 Click Create Vectors. The vector artwork is drawn on the active 
vector layer. It is magenta and surrounded by a bounding box; 
indicating that it is selected. 

13 Click  on the Bitmap To Vector panel's header to close it. 

 You can use the Contrast slider on the 2D View toolbar to 
fade the artwork on the currently active bitmap layer and 
view clearly the resulting vector artwork. Alternatively, you 
can toggle the bitmap layer (see page 102)'s visibility so 
that the image is hidden completely. 
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Using vector layers 
Vector layers, like bitmap layers, are contained in a stack. This is 
displayed on the Project panel and the Vector Layers panel. 

You can use one of the following methods to display the vector layer 
stack: 

 From the Project panel, click  beside  Vectors in the Project 
Tree; or 

 The Project panel is docked and pinned on the right of the 
interface. 

 Click the Vector Layers panel. 

 To display the Vector Layers panel, right-click a docking 
area, toolbar or the Status Bar, then select Vector Layers 
from the context menu. 

Every new ArtCAM model contains an empty default vector layer, 
named Default Layer. However, you can create as many vector 
layers as you want; either empty, or from imported artwork. 

 

Importing vector artwork 
You can import vector artwork saved in any of the following formats 
onto a selected vector layer: 
 Adobe Illustrator image (*.ai); 
 Encapsulated PostScript (*.eps); 

 Drawing Interchange Format, including PowerSHAPE and 
AutoCAD (*.dxf); 

 AutoCAD 2D Drawing (*.dwg); 

 Lotus, PC Paint or DUCT picture (*.pic); 

 Delcam DGK (*.dgk); and 

 Windows MetaFile (*.wmf) 
When choosing Drawing Interchange (*.dxf ) or AutoCAD Drawing 
(*.dwg) files, you can:  

 position its vector artwork in the centre of the ArtCAM model; 

 specify the units of measurement; 

 instruct ArtCAM to search for loops within a specified tolerance; 
and 

 rejoin all coincident nodes within a specified tolerance.  
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 ArtCAM also reads all layer information saved within these 
files. 

When choosing Encapsulated PostScript (*.eps) or Adobe Illustrator 
image (*.ai) files with an origin outside of the ArtCAM model, you 
can position their vector artwork: 

 in the centre of your model; or  

 using the X and Y coordinates of the file's origin. 
When choosing Windows Metafiles (*.wmf), Enhanced Metafiles 
(*.emf) and Lotus, PC Paint or DUCT picture files (*.pic), their vector 
artwork is imported directly. 

To import vector artwork: 

1 Choose the vector layer (see page 124) on which you want to 
store the imported vector artwork. 

2 From the Menu Bar, click the Vectors > Import option to display 
the Vector Import dialog box: 

 
3 In the Vector Import dialog box, select the file you want to work 

with, and click Open. 

For *.pic, *.dgk and *.wmf files, or *.eps and *.ai files with an origin 
inside of the model area: 

the artwork is imported onto the currently active vector layer. 
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For *.eps and *.ai files with an origin outside of the model area: 

the Choose location of data dialog box is displayed: 

 
Select the method you want to use to position the artwork, and 
click OK. 

 To position the artwork using the X and Y coordinates stored 
in the file, select the Position the data using the location in the 
EPS file option. 

 To position the artwork in the centre of your model, select the 
Position the data in the centre of the ArtCAM model option. 

For *.dxf and *.dwg files:  

The Imported File dialog box is displayed: 

 
Choose the options that you want to apply to the artwork, and 
click OK. 

 To position the artwork in the centre of your model, select the 
Centre in model check box. 

 In the File Units area, make sure the units of measurement for 
the artwork is the same as those used in your ArtCAM model 
by selecting mm or inches. 
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 To identify all self-intersecting spans in the artwork within 
tolerance, make sure the Check for crossings and 
self-intersections check box is selected, and that the correct 
tolerance is specified in the Intersection Tolerance box. 

 When selected, self-intersecting spans are shown in red, 
with white circular shapes marking the positions where 
spans overlap. 

 To rejoin any spans in the artwork that have been exploded 
within tolerance, make sure the Automatically rejoin vectors 
check box is selected, and that the correct tolerance is 
specified in the Rejoining Tolerance box. 

The layers in the imported file are added to the vector layer stack 
above the previously active layer. Each new vector layer uses the 
name of the layer in the imported file, as well as any colour. 

 If the name of a layer in the imported file is already used by a 
layer in the vector stack, the artwork on the file's layer is 
added to the vector layer with the same name. 

If no colour has been applied to a layer in the imported file, 
the new vector layer is coloured red  by default. 

All imported artwork is selected by default. For further information, 
see Selecting vector artwork (see page 122). 

 

Creating a new layer 
In an ArtCAM model, you can create as many vector layers as you 
like. This enables you to separate your vector artwork and control 
what is displayed and when. 

You can use one of the following methods to create a new vector 
layer: 

 From the Project panel, right-click  Vectors in the Project Tree, 
then click New in the context menu; 

 From the Vector Layers panel, click the New Vector Layer  
button; 

 From the Menu Bar, click Vectors > Create New Layer; or 

 Right-click a selected vector, then click Move Vectors To > New 
Layer in the context menu. 

Each new vector layer that you create is: 

 named Vector Layer; 

 numbered sequentially;  
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 active; 

 selected; 

 added to the layer stack directly above the layer which was 
previously active; 

 given a default colour of black; 

 unlocked; 

 using snapping; and 
 visible in the 2D View window. 

 If you are working in the 3D View window, click the Toggle 

Vector Visibility  button in the 3D View toolbar to 
display the artwork drawn across all visible vector layers. 

 

Selecting vector artwork 
You can select one or more vectors drawn across the vector layers 
in an ArtCAM model. Selected vector artwork can be used to create: 

 bitmap artwork (see page 140); 

 3D shapes (see page 178); and  

 toolpaths (see page 235). 

To select one or more vectors: 

1 Make sure that the vector layers from which you want to select 
vectors are visible (see page 129). 

2 Use one of the following methods to enter Select mode: 

 In the Design Tools toolbar, click the Select  button;  

 If the Select button is shown as  in the Design Tools 
toolbar, then you are already in Select mode. 

 Right-click the 2D View or 3D View window, then click Select in 
the context menu; 

 Press the Esc key; or 

 Click the Select  button in the Vector Editing Mode 
toolset shown in the Vector Tools area of the Assistant panel. 

3 Click the vector you want to select. 
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The number of spans, nodes, bezier curve spans, linear spans 
and arc spans in the selected vector are displayed on the Tool 
Settings panel. 

 Press the F6 key to display the Tool Settings panel.  

4 To add more vectors to your selection, use one of the following 
methods: 
 Hold down the Shift key, then click each of the vectors; or 

Before... 

 
After... 

 
 Click and drag to create a red selection rectangle around the 

vectors, then release the mouse to select them.  
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 To exclude locked vectors from your selection, select the 
Filter Locked check box on the Tool Settings panel. To 
exclude the wireframe previews associated with calculated 
2D toolpaths, select the Filter Previews check box. To use 
your mouse to twiddle the 3D View instead of selecting 
vector artwork, select the Twiddle in 3d check box. 

A bounding box surrounds the selected vectors. 

 To deselect a vector, hold down the Shift key, and click the 
vector. 

 

Understanding the colour-coding of vectors 
Vector artwork is not always shown in the colour assigned (see page 
126) to the vector layer on which it is drawn or imported. 

 One or more ungrouped vectors are magenta  when selected. 
When deselected, they are displayed in the colour assigned (see 
page 126) to the vector layer on which they are hosted. 

 Grouped closed vectors are purple  when selected. When 
deselected, they are displayed in the colour assigned (see page 
126) to the vector layer on which they are hosted. 

 Grouped, closed, self-intersecting vectors are red  when 
deselected. A  marks the position of each intersection, whether 
the vectors are selected or not. 

 Locked vectors are teal  when selected. When deselected, 
they are grey  regardless of the colour assigned (see page 
126) to the vector layer on which they are hosted. 

 Grouped open vectors are blue  when deselected, regardless 
of the colour assigned (see page 126) to the vector layer on 
which they are hosted. 

 Vectors with one or more overlaying copies are red  when 
selected (see page 122) using the click and drag method. When 
deselected, they are displayed in the colour assigned (see page 
126) to the vector layer on which they are hosted. 

 

Choosing the active layer 
Only one vector layer can be active at a time, although the artwork 
drawn across all vector layers which are currently visible is 
displayed. 

Using the active vector layer you can: 
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 control where vector artwork is drawn in your model; 
 export its vector artwork as a *.eps, *.dxf, *.dgk or *.pic file; 

 create a duplicate copy of the layer and its vector artwork; or 

 delete the layer and its vector artwork. 

To choose the active vector layer: 

1 Use one of the following methods to display the vector layer 
stack: 

 From the Project panel, click  beside  Vectors in the 
Project Tree; or 

 Click the Vector Layers panel. 

 To display the Vector Layers panel, right-click a docking 
area, toolbar or the Status Bar, then select Vector Layers 
from the context menu. 

2 Click the layer you want to work with. Its name is bold and 
highlighted. 

 

Renaming a layer 
In every new ArtCAM model, the default vector layer is named 
Default Layer. All vector layers you create are named Vector Layer, 
and given a unique number. When you import vector artwork, the 
new vector layer uses the name of the vector file from which it is 
created. You can rename any of the vector layers in a model. 

To rename a vector layer: 

1 Use one of the following methods to display the layer's name 
box: 
 From the Project panel, right-click the vector layer you want to 

rename in the Project Tree, then click Rename in the context 
menu. 

 From the Vector Layers panel, double-click the layer you want 
to rename in the stack. 

2 In the name box, type the name you want to give to the layer.  

 To revert to the name previously given to the layer, press 
the Esc key on your keyboard. 

3 Press the Enter key, or click in the empty space below the layer 
stack to set the name of the layer. 
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Assigning a colour to a layer 
All new vector layers are shown in black; meaning that all artwork 
on a vector layer is displayed in black. 

You can change the colour associated with a vector layer. Giving a 
unique colour to each layer makes it easier to identify where vectors 
are stored in your model, and what they are used for. 

 Avoid using blue, magenta or red when choosing a vector 
layer's colour. These colours are used when vectors and 
toolpath previews are selected in the 2D View window. 

To change the colour associated with a vector layer: 
1 Use one of the following methods to display the Color dialog box: 

 From the Project panel, click the layer's swatch  in the 
Project Tree; 

 From the Project panel, right-click the vector layer in the 
Project Tree, then select Set Colour... from the context menu; 

 From the Vector Layers panel, click the layer's swatch  in 
the stack.  

 
2 In the Color dialog box, select the colour you want to use for the 

vector layer, then click OK. The colour is applied to the vector 
layer's artwork. 

3 To add a colour to the Custom colors palette: 

a If you know the specific HSL or RGB values of the colour you 
want to add, type them in the Hue, Sat (Saturation) and Lum 
(Luminance) boxes, or the Red, Green and Blue boxes. 
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b If you do not know the HSL or RGB values, in the Colour 
Matrix displayed on the right, click the colour that closest 
resembles what you want to add. In the Hue and Sat 
(Saturation) boxes, the colour values are displayed. 
To change the overall colour balance, use the Red, Green and 
Blue boxes or the vertical slider to increase or decrease the 
red, green and blue colour channels by a percentage of 
themselves. 
To brighten the colour, use a higher value in the Lum box or 
click and drag the slider upwards. To darken the colour, use a 
lower value in the Lum box or click and drag the slider 
downwards. The default value is zero. 

c To add the colour, click the Add to Custom Colors button. 
 

Locking a layer 
Locking enables you to prevent the artwork on a vector layer from 
being moved, deleted or edited. Locking does not prevent you from 
transferring artwork between vector layers. 

Use one of the following methods to lock a layer: 

 From the Project panel, click the  icon beside the vector layer 
in the Project Tree; 

 From the Project panel, right-click the vector layer in the Project 
Tree, then select Lock Vectors in the context menu; or 

 From the Vector Layers panel, click the layer's  icon displayed 
beside the vector layer in the stack. 

Use one of the following methods to unlock a layer: 
 From the Project panel, click the  icon beside the vector layer 

in the Project Tree; 
 From the Project panel, right-click the vector layer in the Project 

Tree, then deselect Lock Vectors in the context menu; or 

 From the Vector Layers panel, click the layer's  icon displayed 
beside the vector layer in the stack. 

 

Snapping on a layer 
Snapping enables you to align a selected vector with: 

 vectors on another, visible layer; or  

 a vertical or horizontal guideline.  



 

128 • The 2D design process ArtCAM 2012 User Guide  

By default, snapping is enabled on all vector layers in a model. You 
can restrict its use to specific vector layers, or choose whether it is 
used at all. 

To toggle snapping on a vector layer: 
1 From the Menu Bar, make sure that the Views > Snap To Objects 

option is selected. 

 If the View > Snap To Objects option is deselected, snapping 
is not used even when snapping for a vector layer is 
toggled on.  

2 Use one of the following methods to toggle snapping off: 

 From the Project panel, click the  icon displayed beside the 
vector layer in the Project Tree; 

 From the Project panel, right-click the vector layer in the 
Project Tree, then click Snap Vectors in the context menu; or 

 From the Vector Layers panel, click the   icon displayed 
beside the vector layer in the stack. 

3 Use one of the following methods to enable snapping: 

 From the Project panel, click the  icon displayed beside the 
vector layer in the Project Tree; 

 From the Project panel, right-click the vector layer in the 
Project Tree, then click Snap Vectors in the context menu; or 

 From the Vector Layers panel, click the  icon displayed 
beside the vector layer in the stack. 

 To temporarily disable snapping, hold down the Shift key. 

The mouse cursor changes in the following ways: 

 
Cursor Displayed when 

 over a node in a vector in the 2D View or 3D 
View window. 

 over the mid of a linear or arc span within a 
vector in the 2D View or 3D View window. 

 over the centre of a vector, as defined by its 
bounding box, in the 2D View or 3D View 
window; and 
over the point at which two vectors intersect 
in the 2D View or 3D View window, provided 
the X key is held down on your keyboard. 
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 over the point at which two guidelines 
intersect in the 2D View window. 

 This cursor is displayed only when  
guidelines are shown, and the View > 
Snap To Guidelines option is selected in 
the Menu Bar. 

 over a horizontal guideline in the 2D View 
window. 

 This cursor is displayed only when  
guidelines are shown, and the View > 
Snap To Guidelines option is selected in 
the Menu Bar. 

 over a vertical guideline in the 2D View or 3D 
View window. 

 This cursor is displayed only when  
guidelines are shown, and the View > 
Snap To Guidelines option is selected in 
the Menu Bar. 

 the cursor position has the same Y value as 
the polyline's start node in the 2D View or 3D 
View window.  

 This cursor is displayed only when 
working in Polyline Creation (see page 
136) mode. 

 the cursor position has the same X value as 
the polyline's start node in the 2D View or 3D 
View window. 

 This cursor is displayed only when 
working in Polyline Creation (see page 
136) mode. 

 
 

Viewing a layer 
You can control what vector artwork is shown in the 2D View and 3D 
View windows by specifying which vector layers are visible. When a 
vector layer is created, it is visible by default. 

To control a vector layer's visibility: 
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1 If you are working in the 3D View window, select the Toggle 

Vector Visibility  button in the 3D View toolbar. 

 In the 3D View window, all vector artwork is hidden unless 

the Toggle Vector Visibility  button is selected. 

2 Use one of the following methods to control what vector artwork 
can or cannot be seen: 

 To hide a layer's artwork, click its  icon; 

 To hide the artwork on all but one layer, right-click the  
icon associated with the layer you want to keep visible; 

 To hide the artwork on all layers when working from the 
Project panel, click the  icon beside  Vectors in the 
Project Tree; 

 To hide the artwork on all layers when working from the 
Vector Layers panel, click the Toggle All Visibility  button;  

 To display a layer's artwork, click its  icon; 

 To display the artwork on all but one layer, right-click the  
icon associated with the layer you want to keep hidden; 

 To display the artwork on all layers when working from the 
Project panel, click the  icon beside  Vectors in the 
Project Tree; 

 To display the artwork on all layers when working from the 
Vector Layers panel, click the Toggle All Visibility  button. 

 

Setting the stacking order 
You can change the stacking order of vector layers by moving a 
layer. This enables you to display the vector layers in your preferred 
order. You can move any vector layer in the stack; even when it is 
locked. 

Use one of the following methods to set a vector layer's position in 
the stack: 
 From the Project panel, right-click the vector layer in the Project 

Tree, then select Move Up or Move Down in the context menu. 

 If the layer is at the bottom of the stack, the Move Down 
option is greyed-out. If the layer is at the top of the stack, 
the Move Up option is greyed-out. 
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 From the Vector Layers panel, click and drag the layer up or 
down in the stack. When the layer is in your required position, 
release the mouse button. 
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Creating artwork on a vector layer 
The artwork drawn on vector layers can be used to create 
two-dimensional toolpaths or three-dimensional shapes on the 
currently active relief layer. For further information, see Creating 
simple shapes using closed vectors (see page 178) and Creating 
complex shapes using vectors (see page 192). 

You can draw simple shapes or more complex free-form shapes on 
a vector layer using the Vector Creation tools located in: 
 the Design Tools toolbar. 

 
The Design Tools toolbar is displayed on the left of the interface. 

To display all of the buttons within a toolset on a toolbar, click 
and hold the button with  displayed in the bottom-right. Release 
the mouse when its cursor is over the button that you want to 
select. You cannot pin any toolset on a toolbar. 

 the Vector Tools area of the Assistant panel. 

 
The Assistant panel is hidden by default. To display the panel, 
right-click a docking area, then select Assistant from the context 
menu. 
To display the buttons within a toolset on the Assistant panel, 
click  on the right-edge of the button which is currently shown. 
To pin the toolset, click  displayed along the right-edge of the 
end button in the toolset. Repeat this step to collapse the 
toolset. 
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The available preset shapes are: rectangles, squares, circles, 
ellipses, polygons, stars and arcs. You can also create free-form 
shapes from polylines, which are one or more linear or bezier curve 
spans joined together by nodes. 

In addition to drawing, you can import artwork into a vector layer, 
and convert bitmap artwork into vector artwork. For details, see 
Converting bitmap artwork into vector artwork (see page 115). 

 

Creating preset vector shapes 
To create a preset shape: 

1 Choose the vector layer (see page 124) on which you want to 
create a vector. 

2 Make sure the vector layer is visible (see page 129). 
3 If you are working in the 3D View window, make sure that the 

Toggle Vector Visibility  button in the 3D View toolbar is 
toggled on. Otherwise, although you can still draw vector 
artwork, it cannot be seen.  

4 To create an exact shape: 

a Click the button for the shape you want to create. 
b On the Tool Settings panel, specify its properties.  

Each of the shapes and its associated properties are as follows: 

 
Shape Button Properties 

 Rectangle 
 Height;  
 Width; 
 Corner radii; 
 Angle; and  
 Centre point's X and Y 

coordinates. 

 Square 
 Height; 
 Corner radii; 
 Angle; and  
 Centre point's X and Y 

coordinates. 

 Circle 
 Radius or Diameter; and  
 Centre point's X and Y 

coordinates. 
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 Ellipse 
 Height; 
 Width;  
 Angle; and  
 Centre point's X and Y 

coordinates. 

 Polygon 
 Number of sides; 

 A polygon must have a minimum 
of three sides. 

 Angle;  
 Radius; and  
 Centre point. 

 Star 
 No. of points;  
 Angle;  
 Radius of first points; 
 Radius of second points; and  
 Centre point. 

 Arc 
 Centre point, start point and end 

point; 
 Start point, end point and mid 

point; or 
 Start point, end point and radius. 

 When creating an arc, you must 
specify the coordinates of 3 
separate points. What these 
points are depends on your 
chosen method for creating the 
arc. 

 

1 To create an approximate shape: 

a Click the button for the shape you want to create. 

b In the 2D View or 3D View window, move the mouse cursor  
to the position at which you want to create your shape. 

c Left-click and drag the mouse. When the shape reaches the 
required size, release the mouse button. The shape's 
properties are displayed in the Tool Settings panel. 

2 If you are creating a Rectangle or Square, drag the corner 
handles to shape the corners. On the Tool Settings panel, the 
radius of each corner is shown in the Corner Radii box. 
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For example, in the 2D View window, a square looks as follows 
before and after its top right corner is dragged inwards: 

Before... 

 

After... 
 

 

 In the 3D View window, corner handles are displayed as a 
red dot . 

3 If you are creating a Rectangle, Square, Polygon, Ellipse or Star, 
click and drag the rotation handle to set its angle. Drag clockwise 
to apply a positive angle, or drag anti-clockwise to apply a 
negative angle. On the Tool Settings panel, the shape's angle is 
displayed in the Angle box. 

For example, in the 2D View window, a polygon looks as follows 
before and after its rotation handle is dragged clockwise: 

Before... 

 

After... 

 

 In the 3D View window, a rotation handle is displayed as a 
green dot . 
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4 If you are creating a preset shape other than an Arc, you can use 
the resizing handles to adjust its size. Click and drag either the 
top or bottom resizing handle to adjust its height. Click and drag 
either the left or right resizing handle to adjust its width. 
For example, in the 2D View window, an ellipse looks as follows 
before and after its top and left resizing handles have been 
adjusted: 

Before... 

 

After... 
 
 
 
 

 

 In the 3D View window, resizing handles are displayed as an 
orange dot . 

5 To create your shape and keep the current tool selected, 
left-click. This enables you to create another instance of the 
same shape. 

To create your shape, leave the current preview displayed and 
keep the current tool selected, press the Enter key. This enables 
you to create multiple copies or variations of the same shape 
using the preview already shown. 

To create your shape and deselect the current tool, right-click. 
The Select tool is reselected, and the properties of the selected 
vector artwork are displayed on the Tool Settings panel. 

 To edit a preset shape, select the vector, then press the E 
key. The Vector Creation tool and your specific settings 
used to create the shape are displayed on the Tool Settings 
panel, so that you can edit them. Other than polylines and 
arcs, any shape created by a Vector Creation tool can be 
edited. 

 

Creating free-form vector shapes 
You can create free-form vector artwork on any vector layer using 
polylines, which are one or more linear or bezier curve spans joined 
together by nodes. 
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When creating a polyline, the following information is displayed on 
the Tool Settings panel: 

 the coordinates of the current mouse cursor position; 

 the angle and length of the span; 

 the coordinates of the last point; and 

 the change in position from the last point in both the X and Y 
direction. 

To create a polyline: 

1 Choose the vector layer (see page 124) on which you want to 
create your polyline. 

2 Make sure the vector layer on which you want to create your 
polyline is visible (see page 129). 

3 Use one of the following methods to display the Poly Line 
Creation settings on the Tool Settings panel: 

 In the Design Tools toolbar, click the Create Polyline  
button; 

 Right-click the 2D View or 3D View window, then select Drawing 
> Polyline in the context menu; or 

 In the Vector Tools area of the Assistant panel, click the Create 

Polyline  button from the Vector Creation toolset. 

 The Assistant panel is hidden by default. To display the 
panel, right-click a docking area and select Assistant from 
the context menu. 

 To display all of the buttons within a toolset on the 
Assistant panel, click  on the right-edge of the button 
which is currently shown. To pin the toolset, click  
displayed along the right-edge of the end button in the 
toolset. Repeat this step to collapse the toolset. 

4 In the 2D View or 3D View window, move the mouse cursor  to 
the position in which you want to create the polyline's start node, 
then left-click. 

 If you are working in the 3D View window, make sure that 

the Toggle Vector Visibility  button in the 3D View 
toolbar is toggled on. Otherwise, although you can draw the 
polyline, it cannot be seen.  
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 If you want to display the coordinates on the mouse cursor, 
click to select the Window > Show Cursor Information option 
from the Menu Bar. 

5 Move the mouse cursor to the position at which you want to 
create the next node, then left-click.  

When moving, a preview of a linear span is displayed as a red 
line: 

 

 To join nodes with a bezier curve span instead, click and 
hold down the left mouse button before dragging. Release 
the mouse button to create the node. 

 To constrain the angle of the linear span drawn between 
points (nodes) to 15 degree increments, hold down the Ctrl 
key when moving the mouse. 

After clicking the mouse, the span connecting the nodes is drawn 
as a black line: 

 
6 Repeat the previous two steps to create more nodes joined by 

spans. 

7 Use one of the following methods to end the polyline: 

 To end the polyline and enter Select mode, right-click; 

 To end the polyline and stay in Polyline Creation mode, press 
the Space Bar; 

 To join the polyline's start and end nodes and stay in Polyline 
Creation mode, press the Tab key; or 

 To end the polyline, create a closed polygon and stay in 
Polyline Creation mode, click the polyline's start node. 
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You can also create a polyline using specific values: 

1 Choose the vector layer (see page 124) on which you want to 
create the polyline. 

2 Make sure the vector layer on which you want to create your 
polyline is visible (see page 129). 

3 Use one of the following methods to display the Poly Line 
Creation settings on the Tool Settings panel: 

 From the Design Tools toolbar, click the Create Polyline  
button;  

 Right-click the 2D View or 3D View window, then select Drawing 
> Polyline in the context menu; or 

 In the Vector Tools area of the Assistant panel, click the Create 

Polyline  button from the Vector Creation toolset. 

4 To create a polyline from bezier curve spans linked by smoothed 
nodes, select Draw Smooth Polylines. 

5 Use one of the following methods to specify the position of the 
polyline's start node: 
 In the X and Y boxes, type the node's  X and Y coordinates; 

 Move the mouse cursor to the position where you want to 
create the node in the polyline. The X and Y coordinates of 
its position are shown in the Cursor Position area and on 
the Status Bar. 

 In the degs box, type the angle of the polyline's span, and 
then, in the L box, type the polyline's length; or 

 In the dx and dy boxes, type the distance of the node along 
the X and Y axes. 

6 Click Add to create the node and its associated span. 

7 Repeat steps 5 to 6 to create more nodes joined by spans. 
8 Position the mouse cursor over the 2D View or 3D View window, 

then use one of the following methods to end the polyline: 

 To end the polyline and enter Select mode, right-click; 

 To end the polyline and stay in Polyline Creation mode, press 
the Space Bar; 

 To join the polyline's start and end nodes and stay in Polyline 
Creation mode, press the Tab key; or 
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 To end the polyline, create a closed polygon and stay in 
Polyline Creation mode, click the polyline's start node. 

 

Converting vector artwork into bitmap artwork 
You can create bitmap artwork on the currently active bitmap layer 
using selected vector artwork. The bitmap artwork is created in the 
current primary colour: 

 around the boundary of the selected vector artwork; or 

 within the boundary of the selected vector artwork. 

You can use the bitmap artwork to: 

 create 3D shapes (see page 174); or 

 restrict the reach of Sculpting tools (see page 227). 

To convert vector artwork into bitmap artwork: 

1 Select the vectors (see page 122) you want to convert into 
bitmap artwork. 

2 Choose the bitmap layer (see page 99) on which you want to 
create the bitmap artwork. 

3 Make sure the bitmap layer is visible (see page 102). 

4 Change the primary colour (see page 108) to the colour in which 
you want to create the bitmap artwork. 

5 To flood fill the selected vectors, use one of the following 
methods: 
 From the Bitmap Tools toolbar, click the Flood Fill Vectors 

 button. 
 From the Menu Bar, click Vectors > Flood Fill Vectors; or 

 In the Vector Tools area of the Assistant panel, click the Flood 

Fill Vectors  button in the Vector Bitmap toolset. 

The colour filled area is created on the currently active bitmap 
layer. 

6 To convert the selected vectors into bitmap artwork, use one of 
the following methods: 
 From the Bitmap Tools toolbar, click the Vector To Bitmap 

 button; 
 From the Menu Bar, click the Vectors > Vector To Bitmap 

option; or 
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 In the Vector Tools area of the Assistant panel, click the Vector 

To Bitmap  button in the Vector Bitmap toolset. 

A one pixel wide outline is created on the currently active bitmap 
layer. 

7 Use one of the following methods to toggle the visibility of all 
vector layers off: 

 From the Project panel, right-click  Vectors in the Project 
Tree, then click Toggle All Visibility in the context menu; or 

 From the Vector Layers panel, click the Toggle All Visibility  
button.  

You can now see clearly the bitmap artwork created from the 
vector artwork. For details, see Viewing a layer (see page 129). 
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Editing vector artwork 
Almost all of the preset vector shapes created using the Vector 
Creation tools can be edited in the same way: square, rectangle, 
circle, ellipse, polygon and star. For further information on these 
shapes, see Creating preset vector shapes (see page 133). 

These vectors can be edited: 
 using specific properties on the Tool Settings panel; or 

 working in Node Editing mode, and using the vector's spans, 
nodes and control points. 

All other vectors can be edited only when working in Node Editing 
mode, and using their spans, nodes and control points. 

To edit a preset vector shape: 

1 Select the vector (see page 122) you want to edit. 

2 Use one of the following methods to display the selected vector's 
properties on the Tool Settings panel, and its manipulation 
handles in the 2D View and 3D View windows: 

 Press the E key; or 

 Right-click the selected vector, then click Edit in the context 
menu. For example, Edit Ellipse. 

 You can only edit vectors drawn using the following tools 
available in the Vector Creation toolset: 

 
3 On the Tool Settings panel, change the selected vector's 

properties as required. For example, specify its new height in the 
Height box. For details, see Creating preset vector shapes (see 
page 133). 

Vectors created using any of the methods listed below cannot be 
edited using specific properties: 

 The Create Polyline  tool. For details, see Creating preset 
vector shapes (see page 133). 

 The Create Arcs  tool. For details, see Creating free-form 
vector shapes (see page 136). 
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 The Create Rectangle, Create Circles, Create Ellipse, Create 
Polygons or Create Stars tool, and where a node or span has been 
moved or edited; 

 the Vector Library or Vector Import tool; or 

 the Bitmap To Vector tool. For details, see Converting bitmap 
artwork into vector artwork (see page 115). 

To edit vector artwork created using any of these methods, you 
must use its spans and nodes. When working in Node Editing mode, 
you can use the options on the selected vector's context menu to 
change its spans and nodes. 

When a vector is selected, use one of the following methods to 
enter Node Editing mode: 

 You cannot work in Node Editing mode in the 3D View window. 

 In the Design Tools toolbar, click the Node Editing  button; 

 If the Node Editing button is shown as  in the Design 
Tools toolbar, then you are already in Node Editing mode. 

 If the Node Editing button is shown as  in the Design 
Tools toolbar, then you are working in the 3D View window. 
Press the F2 key to work in the 2D View window. 

 Right-click the 2D View window, then click Node Editing from its 
context menu; 

 Press the N key; or 

 In the Vector Tools area of the Assistant panel, click the Node 

Editing  button from the Vector Editing Mode toolset. 
 

Selecting nodes and control points 
You can select single or multiple nodes and control points in the 
vector artwork drawn on a vector layer. 
You can select nodes and control points only from the 2D View 
window.  

To select nodes and control points: 

1 Select the vector (see page 122) you want to edit. 

2 Enter Node Editing mode (see page 142). 
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A bounding box surrounds the selected vector, within which you 
can see its spans, nodes and control points. 

3 To select a single node or control point: 

a Move the mouse cursor  over the node or control point you 
want to select.  

b When the cursor changes to , click the node or control 
point beneath the cursor. 

 To deselect a node or control point, position the mouse 
cursor over the node or control point, hold down the Shift 
key, and then click. 

If you select a node that has adjoining control points, these are 
also selected; all of which are red. 

For example, when the node shown below is selected, we can see 
that its adjoining control points are also selected: 

Before... 

 

After... 

 

4 To select more than one node or control point, use one of the 
following methods: 

 Click and drag to create a bounding box around the nodes and 
control points. 

Before... After... 
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 Click to select a node or control point. Hold down the Ctrl key, 
then click the additional nodes and control points. The 
selected nodes and control points are red. 

Before... 

 

After... 

 

 Click to select a node or control point. Hold down the Shift 
key, then click to select a second node or control point. 
ArtCAM calculates the shortest distance between the selected 
nodes, and then selects the other nodes and control points 
between them. The selected nodes and control points are red. 
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Before... 

 

After... 

 

 
 

Converting spans 
Spans within vector artwork can be linear, arcs or bezier curves. A 
span is what joins two nodes in a vector. When working in Node 
Editing mode, you can use the options on the selected vector's 
context menu to change the type of span. 

To convert a span: 

1 Select the vector (see page 122) you want to edit. 

2 Enter Node Editing mode (see page 142). 

A bounding box surrounds the selected vector, within which you 
can see the spans, nodes and control points that make up the 
selected vector. 

 There are no control points associated with a linear span. 
There are two control points associated with a bezier curve 
span, and each of them are attached to the node located at 
either end of the span. There is one control point associated 
with an arc span, and this is located midway between the 
nodes located at either end of the span. 
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For example, the first numbered span shown below is an arc, the 
second a line and the third a bezier curve: 

 
3 Right-click the span you want to change, then click either of the 

Convert span options in the context menu: 

 If you are converting a linear span, click Convert span to bezier 
or Convert span to arc. 

 You can also press the A key to convert a linear or bezier 
span to an arc span. 

 If you are converting a bezier curve span, click Convert span to 
line or Convert span to arc. 

 You can also press the L key to convert a bezier or arc span 
to a linear span. 

 If you are converting an arc span, click Convert span to line or 
Convert span to bezier. 

 You can also press the B key to convert an arc or linear 
span to a bezier span. 
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In our example, if we convert the first numbered span from an 
arc to a line, the second from a line to a bezier and the third 
from a bezier to an arc, we can see how the overall shape of the 
selected vector changes quite considerably: 

 
 

Moving nodes 
You can move one or more nodes in a selected vector to a new 
position. This changes the vector's shape and structure. 

To move a single node or control point: 

1 Select the vector (see page 122) you want to edit. 

2 Enter Node Editing mode (see page 142). 

 If the Node Editing button is shown as  in the Design 
Tools toolbar, then you are already in Node Editing mode. 

A bounding box surrounds the selected vector, within which you 
can see the spans, nodes and control points that make up the 
selected vector. 
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3 Move the mouse cursor  over the node or control point you 
want to move. 

4 When the cursor changes to , click and drag the node or 
control point into its new position. Release the mouse button to 
set its position. 

For example, when the control point in the circle shown below is 
dragged diagonally to the left, we can see that the overall shape 
of the vector changes:  

Before... 

 

After... 

 

To move a selection of nodes simultaneously: 

1 Select the vector (see page 122) you want to edit. 

2 Enter Node Editing mode (see page 142). 

 If the Node Editing button is shown as  in the Design 
Tools toolbar, then you are already in Node Editing mode. 

A bounding box surrounds the selected vector, within which you 
can see the spans, nodes and control points that make up the 
selected vector. 

3 Hold down the Ctrl key, then select the nodes (see page 143) you 
want to move. The selected nodes and any adjoining control 
points are red. 

4 Use one of the following methods to move the selected nodes: 

 Move the mouse cursor over any of the selected nodes, click 
and drag the node to move all of the selected nodes, then 
release the mouse button to set their new position; or 

 Use the four arrow keys on your keyboard to nudge the 
selected nodes into their new position. 

Alternatively, you can move a node to an exact position: 
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1 Select the vector (see page 122) you want to edit. 

2 Enter Node Editing mode (see page 142). 

 If the Node Editing button is shown as  in the Design 
Tools toolbar, then you are already in Node Editing mode. 

A bounding box surrounds the selected vector, within which you 
can see the spans, nodes and control points that make up the 
selected vector. 

3 Right-click any node, then select Properties from the context 
menu. The Node Properties dialog box is displayed: 

 
The node's current X and Y co-ordinates are shown in the X 
coordinate and Y coordinate boxes. 

4 In the X coordinate and Y coordinate boxes, specify the X and Y 
coordinates of the node's new position. 

5 Click OK to move the node and close the dialog box. 

 
 

Inserting nodes 
You can insert a node in any span within open or closed ungrouped 
vectors drawn on a vector layer. Inserting a node divides a span 
into two new spans of the same type as the original. Inserting 
nodes gives you greater freedom to change a vector's overall shape.  

You can also insert a start node in any span within closed vectors 
drawn on a vector layer. This divides a span into two new spans of 
the same type as the original. The start node is shown in green. 

To insert a node in a span: 

1 Select the vector (see page 122) you want to edit. 
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2 Enter Node Editing mode (see page 142). 

 If the Node Editing button is shown as  in the Design 
Tools toolbar, then you are already in Node Editing mode. 

A bounding box surrounds the selected vector, within which you 
can see its spans, nodes and control points. 

3 Move the mouse cursor  over the position in the span in which 
you want to insert a node.  

4 When the mouse cursor changes to : 
 right-click, then select Insert a node from the context menu; or 

 press the I key.   

A new node is created in the span beneath the mouse cursor, 
dividing it into two separate spans. 

For example, when a node is inserted into the bezier curve span 
shown below, you can see that a second bezier curve span with 
two adjoining control points is created: 

Before... 

 

After... 
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 Adding nodes to vector artwork can be a time consuming 
process. Instead, you can use the Create Polyline tool to 
create new, more complicated shapes. With the Create 
Polyline tool settings displayed in the Tool Settings panel, 
each corresponding movement and mouse click creates a 
new node and connects it to the last with a linear or bezier 
curve span. For details, see Creating free-form vector 
shapes (see page 136). 

To insert a start node in a span: 

1 Select the vector (see page 122) you want to edit. 

 You cannot insert a start node into an open vector.  

2 Enter Node Editing mode (see page 142). 

 If the Node Editing button is shown as  in the Design 
Tools toolbar, then you are already in Node Editing mode. 

A bounding box surrounds the selected vector, within which you 
can see the spans, nodes and control points that make up the 
selected vector. 

3 Position the mouse cursor  over the span in which you want to 
insert a start node.  

4 When the mouse cursor changes to : 
 right-click, then select Insert Start Node from the context 

menu; or 
 press the P key. 

A new node is created in the span beneath the mouse cursor, 
dividing it into two separate spans. The previous start node in 
the selected closed vector changes to a node. 

For example, when a start node is inserted into the bezier curve 
span shown below, you can see that a second bezier curve span 
with two adjoining control points is created, and the previous 
start node changes to a node: 
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Before... 

 

After... 

 

 
 

Smoothing nodes 
You can smooth any node in a vector, other than the start or end 
node in an ungrouped open vector. For details, see Selecting nodes 
and control points (see page 143) and Selecting vector artwork (see 
page 122). 

When smoothing, the span on either side of a node is converted to a 
bezier curve span. ArtCAM appends control points to the node which 
enable you to control the curvature of the selected vector. 

To smooth a single node: 

1 Select the vector (see page 122) you want to edit. 

2 Enter Node Editing mode (see page 142). 

 If the Node Editing button is shown as  in the Design 
Tools toolbar, then you are already in Node Editing mode. 

A bounding box surrounds the selected vector, within which you 
can see the spans, nodes and control points that make up the 
selected vector. 

3 Use one of the following methods to smooth a node: 
 Right-click the node you want to smooth, then select Smooth 

node from the context menu; or 

 Select the node (see page 143), then press the S key. 

The spans on either side of the node are converted to bezier 
curves. The node changes from black to blue. 
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For example, a node in a polyline is displayed as shown when 
smoothing is applied: 

Before... 

 
After... 

 
If you move one of the control points joined to the smoothed 
node, the other moves too. This simultaneous movement 
preserves the tangency between the two bezier curve spans. 

To smooth a selection of nodes simultaneously: 

1 Select the vector (see page 122) you want to edit. 

2 Enter Node Editing mode (see page 142). 

 If the Node Editing button is shown as  in the Design 
Tools toolbar, then you are already in Node Editing mode. 

A bounding box surrounds the selected vector, within which you 
can see the spans, nodes and control points that make up the 
selected vector. 

3 Hold down the Ctrl key, then select the nodes (see page 143) you 
want to smooth. The selected nodes are red. 



 

ArtCAM 2012 User Guide The 2D design process • 155  

4 Use one of the following methods to smooth the selected nodes: 
 Right-click any of the selected nodes, then select Smooth 

Nodes from the context menu; or 

 Press the S key. 

The spans on either side of the selected nodes are converted to 
bezier curves. 

For example, a selection of five nodes in a polyline is displayed 
as shown below when smoothing is applied: 

Before... 

 
After... 

 
To remove the smoothing applied to a node: 

1 Select the vector (see page 122) you want to edit. 

2 Enter Node Editing mode (see page 142). 

 If the Node Editing button is shown as  in the Design 
Tools toolbar, then you are already in Node Editing mode. 
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A bounding box surrounds the selected vector, within which you 
can see the spans, nodes and control points that make up the 
selected vector. 

3 Position the mouse cursor  over the node from which you want 
to remove smoothing.  

4 When the mouse cursor changes to :  
 right-click and select Smooth point from the context menu; or 

 press the S key. 

The smoothing is removed, and the node changes from blue to 
black. 

For example, a node in a polyline is displayed as shown below 
when its smoothing is removed: 

Before... 

 
After... 

 
Although the span on either side of the node remains as a bezier 
curve span, removing its smoothing causes the control point on 
either side of the node to affect its adjoining bezier curve span 
only, rather than the whole of the selected vector. 
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For example, when we move the control point on the right of the 
node shown below, we can see that the control point on its left 
remains in the same position: 

Before... 

 
After... 

 
 

Aligning nodes 
You can align a selection of nodes and control points in either the 
horizontal (X) or vertical (Y) axis. All selected nodes and control 
points are replaced with a horizontal or vertical linear span. 

 To keep intermediate nodes and control points when aligning 
nodes, deselect the Align Nodes - replace with a single line 
option on the Options panel (see page 50). 

To align a selection of nodes and control points in a vector: 

1 Select the vector (see page 122) you want to edit. 

2 Enter Node Editing mode (see page 142). 
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 If the Node Editing button is shown as  in the Design 
Tools toolbar, then you are already in Node Editing mode. 

A bounding box surrounds the selected vector, within which you 
can see its spans, nodes and control points. 

3 Hold down the Ctrl key, then select the nodes (see page 143) 
and control points you want to align. The selected nodes and 
control points are red. 

4 To align the selected nodes and control points, right-click any of 
the selected nodes to display the context menu, then select: 
 Align Nodes > in X to align them horizontally 

 Align Nodes > in Y to align them vertically. 

For example, a selection of nodes and control points look as 
shown below when aligned horizontally and vertically: 

Before... 

 
 

Align in X... 
 

 

Align in Y... 
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Importing artwork from PDF files 
Adobe's Portable Document Format (*.pdf) files can contain both 
bitmap and vector artwork. Rather than gradually importing 
separate pieces of vector and bitmap artwork into a model, you can 
use a PDF file to: 

 batch import several pieces into an open model; or  

 create a new model containing several pieces of artwork. 

The artwork from the PDF file can be edited in the same way as if it 
was created using ArtCAM's vector and bitmap tools. 

Every page in a PDF file has a crop box that specifies the region to 
which its contents are clipped when displayed or printed. When 
creating a new model from a PDF file, ArtCAM uses the crop box on 
its first page to set the model dimensions. This ensures that all 
vector and bitmap artwork in the PDF file is included in the model. 

When importing a PDF file into an open model with dimensions 
equal to or greater than those of the crop box, all of its vector and 
bitmap artwork is imported. If the model's dimensions are smaller 
than the crop box, all vector artwork is imported, but any bitmap 
artwork outside of the model area is lost. 

The vector and bitmap artwork extracted from each page in the PDF 
file is placed on separate vector and bitmap layers. Each of these 
vector and bitmap layers is: 

 named with the PDF file's title and the page number from which 
its artwork was extracted;  

 added to the layer stack directly above the layer which was 
previously active;  

 visible; and  

 unlocked. 

 

Creating a model from a PDF file 
To create a new model using a PDF file: 
1 Use one of the following methods to display the Open dialog box: 

 From the Start panel, click Open Model; 
 From the Menu Bar, click File > Open; or 
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 Press the Ctrl+O keys. 

 

 To list only PDF files, click the Files of type list box, then 
select the Portable Document Format (*.pdf) option. 

2 Select the PDF file you want to work with, then click Open. 



 

ArtCAM 2012 User Guide The 2D design process • 161  

If you are working in ArtCAM Pro or JewelSmith, the Size For New 
Model dialog box is displayed: 

 
If you are working in ArtCAM Insignia, the Setup Job Dimensions 
dialog box is displayed:  

 
3 In the Units area, select mm or inches. 

4 In the Height (Y) and Width (X) boxes, specify the height and 
width of the model you want to create. The default values are 
taken from the PDF file's crop box. 

If you adjust the model size so that it is smaller than the PDF 
file's crop box, the bitmap artwork from the PDF file's first page 
outside of the model area is lost. The PDF file cannot be scaled to 
fit inside the model area. 
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5 Specify the model's origin by clicking one of the numbered 
positions shown below: 

 
The  icon is displayed on the box diagram in your selected 
position. 

6 If you are working in ArtCAM Pro or JewelSmith: 
a In the Resolution area, click and drag the slider to set the 

model resolution: 

 
A total resolution of approximately 1,500,000 points is 
suitable for most jobs. When creating vectors or reliefs using 
the bitmap artwork extracted from a PDF file, choosing a 
higher resolution helps to produce cleaner results. 

 After a model is created, you can use the Adjust Model 

Resolution  button on the Model toolbar to change the 
resolution. 

7 If you are working in ArtCAM Insignia: 
a In the Thickness (Z) box, specify the thickness of the material 

you are using for machining. 
b In the Material Z Zero area, specify the Z-axis zero level. This 

is the position of the cutting tool relative to the material 
block's surface. Click: 
Top of Block to position the cutting tool on the material 
surface; or 
Machine Bed to position the cutting tool on the machine bed.  

The  icon is displayed  in either the top or bottom front left 
corner of the box diagram to mark the job origin. 

c In the Model Position In Material area, set the position of the 
model relative to the material block. Click: 
Top Of Block to align the model's zero plane with the material 
surface; or  
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Machine Bed to align the model's zero plane with the machine 
bed. 

8 Click OK to create your model.  

A tabbed 2D View and 3D View window is created in the viewing 
area. The 2D View window is selected by default, in which you 
can see the vector artwork extracted from each of the PDF file's 
pages.  

9 On the Project panel, click  beside : 

   Vectors to display the vector layers created from each of 
the PDF file's pages; or 

  Bitmaps to display the bitmap layers created.  

 

Importing a PDF file into an open model 
To import a PDF file into an open model: 
1 Use one of the following methods to display the Load Vector Layer 

dialog box: 

 From the Project panel, right-click  Vectors in the Project 
Tree, then click Import from the context menu; 

 From the Vector Layers panel, click the Import Vectors  
button; or 

 From the Menu Bar, click the Vectors > Load Layer... option. 

2 In the Load Vector Layer dialog box, select the PDF file you want 
to import, then click Open. 
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After you have created or imported your vector and bitmap artwork, 
and completed any necessary editing, you are ready to create: 

 2D toolpaths (see page 235); or 

 reliefs. 

A relief is essentially one or more three-dimensional shapes in a 
model, although there are two different concepts to consider when 
working with them: the 'relief layer' and the 'composite relief'.  

The content of a relief layer comprises one or more 
three-dimensional shapes typically created: 

 from attributes (see page 174) applied to vector artwork and 
bitmap colours; 

 by importing (see page 222) a triangle model, surface model or 
piece of relief clipart; 

 using the Sculpting tools (see page 227). 

The content on these relief layers combine to form a composite 
relief. Exactly how each of the relief layers interact depends on the 
combine mode (see page 167) assigned to each of them, and 
whether or not they are visible (see page 169). 

A composite relief can be built from two separate layer stacks in the 
model; one representing the front surface of your design, the other 
representing the back. You can view the composite relief resulting 
from these layer stacks separately or concurrently. 

When you have created or imported your composite relief, you are 
ready to create and calculate the 3D toolpaths (see page 235) 
needed to machine it. These toolpaths can then be simulated (see 
page 266) so that you can check for potential issues during the 
machining process, the surface finish, and envision your finished 
piece.  

 

The 3D design process 
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Using relief layers 
Relief layers, like vector and bitmap layers, are contained in a stack. 
Unlike vector and bitmap layers, there are two stacks of relief 
layers; one representing the front surface and another the back 
surface of a three-dimensional model.  

 If you are working in ArtCAM Insignia, there are no relief 
layers. 

When working from the Project panel, both layer stacks are 
displayed simultaneously in the Project Tree. When working from 
the Relief Layers panel, only one of the relief layer stacks can be 
displayed at a time.  

You can use one of the following methods to display either of the 
relief layer stacks: 

 From the Project panel, click  beside  Front Relief or  Back 
Relief in the Project Tree; or 

 The Project panel is docked and pinned on the right of the 
interface. 

 From the Relief Layers panel, click the list box, then Front Relief 
or Back Relief. 

 To display the Relief Layers panel, right-click a docking area 
then select Relief Layers in the context menu. 

Every ArtCAM model contains an empty default relief layer on each 
of the stacks, named Relief Layer. However, you can create as 
many relief layers as you want; either empty, or from imported 
clipart. 

 

Choosing the active layer 
Only one relief layer can be active at a time, although the content 
across all visible relief layers is displayed in the 3D View window. 

Using the active relief layer you can: 

 create a bitmap layer; 
 export its relief as a *.rlf, *.bmp or *.tif file; 

 create a duplicate copy of the layer and its content; or 

 delete the layer and its content. 
To choose the active relief layer from the Project panel: 

1 Click  beside: 
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  Front Relief in the Project Tree to display the layer stack 
that makes up the model's front surface; or 

  Back Relief in the Project Tree to display the layer stack 
that makes up the model's back surface. 

2 In the Project Tree, click the layer you want to work with. Its 
name is bold and highlighted. 

To choose the active relief layer from the Relief Layers panel: 

 To display the Relief Layers panel, right-click a docking area, 
toolbar or the Status Bar, then select Relief Layers from the 
context menu. 

1 Click the list box, then select: 
 Front Relief to display the layer stack that makes up the 

model's front surface; or 
 Back Relief to display the layer stack that makes up the 

model's back surface. 

2 In the layer stack, click the layer you want to work with. Its 
name is highlighted. 

 

Creating a new layer 
In an ArtCAM model, you can create as many relief layers as you 
like. This gives you greater control over changing the appearance of 
the composite relief. 

You can use one of the following methods to create a new relief 
layer: 

 From the Project panel, right-click   Front Relief or  Back 
Relief in the Project Tree, then select New from the context 
menu; 

 From the Relief Layers panel, click the New Relief Layer  
button; or 

 From the Menu Bar, click the Reliefs > Create New Layer option. 

Each new relief layer that you create is: 

 named Relief Layer; 

 numbered sequentially;  

 active; 

 selected; 

 added to the layer stack directly above the layer which was 
previously active; 
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 given the Add  combine mode; and 

 visible. 
 

Setting the combine mode 
In the 3D View window, the relief you see is the composite relief. It 
is made from a stack of one or more visible relief layers. You can 
significantly affect how the composite relief takes shape by 
changing a relief layer's combine mode. ArtCAM starts with the 
layer at the bottom of the stack, then moves upwards, applying the 
combine mode for each visible layer. 

To set a relief layer's combine mode: 

1 Make sure the relief layer is visible (see page 169). 
When working from the Project panel, the combine mode icon in 
the Project Tree is greyed-out when a relief layer is hidden. For 
example, . 

2 Press the F3 key to display the 3D View window so you can see 
how the composite relief changes as a result of setting the 
layer's combine mode. 

3 Use one of the following methods to specify how you want to 
combine the relief layer's content with each of the visible layers 
below in the stack: 
 From the Project panel, right-click the relief layer in the 

Project Tree, then select the combine mode option in the 
context menu. 

 From the Relief Layers panel, click the combine mode button 
currently shown to display the combine mode toolset, then 
click the button you want to use. 

 

 
 From the Relief Layers panel, click the combine mode button 

currently shown to toggle through each of them in the toolset. 

Select: 

Add  to add the relief layer's content to the visible layers 
below in the stack. 

Subtract  to subtract the relief layer's content from the the 
visible layers below in the stack. 
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Merge High  to merge the relief layer's content with the visible 
layers below in the stack, so that only the highest points remain. 

Merge Low  to merge the relief layer's content with the visible 
layers below in the stack, so that only the lowest points remain. 

Multiply  to multiply the height of the relief layer's points by 
the coincident (matching) points on the visible layers below in 
the stack. 

 If you create a new relief layer (see page 166), the Add 
combine mode is selected by default. 

 When you import relief clipart, you can choose the layer's 
combine mode. 

 To create a feasible composite relief, a relief layer with the 
Multiply combine mode applied should have a maximum 
Z height of between 0 and 1. 

 

Renaming a layer 
In every new ArtCAM model, the default relief layer is named Relief 
Layer. All relief layers you create are named Relief Layer, and given 
a unique number. When you import relief clipart, the new relief 
layer uses the name of the file from which it is created. You can 
rename any of the relief layers in a model. 

To rename a relief layer: 

1 Use one of the following methods to display the layer's name 
box: 
 From the Project panel, right-click the layer in the Project 

Tree, then click Rename in the context menu; or 

 From the Relief Layers panel, double-click the layer in the 
stack. 

2 In the name box, type the name you want to give to the layer.  

 To revert to the name previously given to the layer, press 
the Esc key. 

3 Press the Enter key, or click in the empty space below the layer 
stack to set the name of the layer. 

 

Creating a bitmap layer from a relief layer 
You can create a new bitmap layer containing a greyscale image of 
the currently active relief layer's content. 
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The new bitmap layer is: 

 named with the relief layer from which the greyscale image was 
created;  

 active; 

 selected; 

 added to the layer stack directly above the layer which was 
previously active; and  

 visible. 

Use one of the following methods to create the bitmap layer: 
 From the Project panel, right-click the relief layer in the Project 

Tree, then click Create Bitmap in the context menu; or 

 From the Relief Layers panel, click the Create Bitmap Layer  
button. 

 

Viewing a layer 
You can change the appearance of the composite relief by choosing 
a specific relief layer and controlling whether or not it is visible. 
When a relief layer is created, it is visible by default. 

To control a relief layer's visibility: 

1 If you are working with the layer stack associated with the  

Front Relief, select the Toggle Front Relief  button in the 3D 
View toolbar. 

2 If you are working with the layer stack associated with the  

Back Relief, select the Toggle Back Relief  button in the 3D 
View toolbar. 

3 Use one of the following methods to control whether or not a 
layer's content can or cannot be seen: 

 To hide a layer's content, click its  icon; 
When a relief layer is hidden from the Project panel, its 
combine mode icon in the Project Tree is greyed-out. For 
example,  changes to .  

 To hide the content on all but one layer, right-click the  
icon associated with the layer you want to keep visible; 

 To hide the content on all layers in either stack when working 
from the Project panel, click the  icon beside  Relief in 
the Project Tree; 
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 To hide the content on all layers when working from the Relief 
Layers panel, click the Toggle All Visibility  button; 

 To display a layer's content, click its  icon; 

 To display the content on all but one layer, right-click the  
icon associated with the layer you want to keep hidden; 

 To display the content on all layers in either stack when 
working from the Project panel, click the  icon beside  
Relief in the Project Tree; or 

 To display the content on all layers when working from the 
Relief Layers panel, click the Toggle All Visibility  button on 
the Relief Layers panel. 

 

Previewing a relief layer's content 
On the Relief Layers panel, each relief layer has its own thumbnail 
image that enables you to check its content whether it is currently 
visible in the 3D View window or not. This is particularly valuable 
when a composite relief is made up of a large number of relief 
layers. 

 The Relief Layers panel is hidden by default. To display the 
panel, right-click a docking area then select Relief Layers from 
the context menu. 

To preview the content on a relief layer: 
1 On the Relief Layers panel, move the mouse cursor over the relief 

layer's thumbnail image to the left of it's relief combine mode 
toolset. 

 
The thumbnail image is magnified to display the content on the 
relief layer more clearly.  

 The dimensions of the preview thumbnail image associated 
are 17 x 17 pixels. The dimensions of the magnified 
thumbnail image are 100 x 100 pixels. 
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 The thumbnail image, either in its original or magnified 
state, is a scaled-to-fit isometric view of the relief layer as 
if it were shown in isolation in the 3D View window. The 
thumbnail view does not use the view orientation currently 
applied to the 3D View window. 

 If you move the mouse cursor up or down vertically in line 
with the column of thumbnail images in the layer stack, the 
magnified thumbnail image is updated. 

 
 

Transferring relief layers between stacks 
The composite relief can be built from one of two layer stacks in the 
model; one representing the front surface of your piece, the other 
its back.  

Although you can only work with one stack at a time, you can use 
the Toggle Front Relief and Toggle Back Relief tool in the 3D View 
toolbar to concurrently view the composite relief resulting from both 
stacks. 

When you transfer a relief layer from one stack to the other, the 
composite relief resulting from both layer stacks is affected. It is 
prudent to check the composite relief shown in the 3D View window 
whenever you transfer a relief layer. 

In every new model, each of the stacks include an empty relief 
layer. There must always be at least one layer in each of them. 

To transfer a relief layer to the opposite layer stack: 

1 Use one of the following methods to display the layer stack from 
which you want to transfer a layer: 

 From the Project panel, click  Front Relief or  Back Relief 
in the Project Tree; or  

 From the Relief Layers panel, click the list box, then select the 
layer stack: Front Relief or Back Relief. 

2 Choose the layer (see page 165) you want to transfer to the 
opposite stack. Its name is bold and highlighted. 

 Rather than transferring the active relief layer to the 
opposite stack, you might prefer to duplicate the layer and 
transfer this instead. This means that an identical layer is 
included in both stacks. 
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 Where there is only one layer in the current stack, you 
cannot transfer this to the opposite stack. If you try to 
transfer the only relief layer, a message box is displayed 
warning that this cannot be done. Click OK to close the 
message box. 

3 Use one of the following methods to transfer the currently active 
layer to the opposite layer stack: 
 From the Project panel, right-click the relief layer in the 

Project Tree, then click Swap Sides from the context menu; or 

 From the Relief Layers panel, click the Transfer Opposite Side 

 button.  

The relief layer is no longer included in the layer stack currently 
displayed. 

4 Use one of the following methods to confirm that the layer has 
been transferred to the opposite stack,  

 From the Project panel, click  beside the opposite  Relief 
in the Project Tree; or  

 From the Relief Layers panel, click the list box, then select the 
opposite layer stack: Back Relief or Front Relief. 

The opposite layer stack is displayed and you can see the 
transferred relief layer. The composite relief made up from this 
layer stack is displayed in the 3D View window. 

 

Creating a relief layer from bitmap artwork 
You can create a new relief layer from a bitmap layer. Each colour in 
the bitmap layer's artwork produces a three dimensional shape with 
a particular height. The height is calculated using the colour's RGB 
values. In general, bright colours produce high shapes, while dark 
colours produce low shapes. You can restrict the height of these 
shapes. 

The new relief layer is: 

 given the same name as the currently active bitmap layer;  

 active; 

 selected; 

 added to the layer stack directly above the layer which was 
previously active; 

 given the Add combine mode ; and 

 visible. 
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To create a relief layer from a bitmap layer: 

1 Choose the bitmap layer (see page 99) you want to use to create 
a relief layer. Its name is bold and highlighted. 

2 Use one of the following methods to display the Scale Relief 
Height dialog box: 

 From the Project panel, right-click the bitmap layer in the 
Project Tree, then select Create Relief from its context menu; 
or 

 From the Bitmap Layers panel, click the Create Relief Layer  
button. 

 

 The current height value displayed is not the actual Z 
height of the composite relief. This is an arbitrary value 
calculated at 1/4 of either the model's height (Y) or width 
(X); whichever is the smallest at the time of creating the 
relief. 

3 In the New Height box, specify the maximum Z height of the 
relief. 

4 Click the OK button. The dialog box is closed, and the relief layer 
is created.  
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Using the Shape Editor 
You can create simple three-dimensional shapes on relief layers 
using the Shape Editor tool together with:  

 colours drawn on bitmap layers (see page 103); or  

 closed vectors drawn on vector layers (see page 132).  

 If you are working in ArtCAM Insignia, the Shape Editor tool is 
not available. 

Using the Shape Editor tool, you can control: 

 the shape's profile; 

 the shape's angle; 

 the shape's height; and  

 how the shape is combined with any shapes already on the 
currently active relief layer. 

 

Creating simple shapes using bitmap colours 
You can create a simple three dimensional shape using all areas of 
bitmap artwork displayed in the primary colour. The shape is 
created on the currently active relief layer. 

To create a shape using bitmap artwork: 

1 Choose the bitmap layer (see page 99) containing the artwork 
you want to use to create a shape. 

2 Make sure the bitmap layer is visible (see page 102). 

3 Choose the relief layer (see page 165) on which you want to 
create the shape. 

4 If you are working in the 3D View window, click the Colour Shade 

 button in the 3D View toolbar to display the artwork on the 
currently active bitmap layer. 

5 Make sure that you are working in Select mode (see page 122). 

 If the Select button is shown as  in the Design Tools 
toolbar, then you are already in Select mode. 

6 Select the colour you want to use to create the shape as the 
primary colour (see page 108). 

7 Use one of the following methods to display the Shape Editor: 
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 In the Relief Creation toolbar, click the Shape Editor  
button;  

 From the Menu Bar, select Reliefs > Shape Editor;  
 Press the F12 key; or 

 In the colour palette, double-click a colour swatch. 

 You can double-click a colour to select it as the primary 
colour and display the Shape Editor. 

The primary colour is displayed in the Shape Editor's window. The 
default settings enable you to create a flat shape with a start 
height of zero; this is represented by the horizontal line shown. 

For example, with yellow selected as the primary colour, the 
Shape Editor looks as follows: 

 
8 Select the shape's profile by clicking one of the following 

buttons: 

 Click   to select a rounded profile; 

 Click   to select an angled profile; or 
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 Click   to select a flat profile. 

The image shown in the dialog's window changes according to 
your selected profile. 

9 In the Start Height box, specify the Z height at which the shape is 
created. This creates a vertical side wall in the shape. If you are 
creating a flat shape, this also controls the height of the plane. 

10 If you are creating a rounded or angled shape, specify its angle 
using one of the following methods: 
 In the Angle box, type the angle; or 

 Type a positive value to create a convex shape, a negative 
value to create a concave shape, or 0 to create a plane. 

 Click and drag the leftmost slider; or 

 
 Click  or  on the right of the Angle box: 

 
11 If you are creating a rounded or angled shape, choose the 

method you want to use to control the shape's height: 

 To allow the shape to grow to the height that it would 
naturally reach, click the No Limit option. This is selected by 
default. 
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 To apply a scaling factor to the shape in its Z-axis, click 
Scale, then specify the scaling factor either by typing it in 
the Scale box or clicking and dragging the rightmost slider: 

 
Drag the slider upwards to increase the scaling factor, or 
downwards to decrease the scaling factor. The scaling 
factor is shown in the Scale box. 

 To allow the shape to grow to a specific height and then 
plateau, click the Limit To Height option, then specify the 
maximum height in the Height box. 

 If the natural height of the shape exceeds that of the value 
specified in the Height box, a flat top is created. 

 To apply a scaling factor to the shape in its Z-axis, click 
Scale, then set the scaling factor either by typing it in the 
Scale box or clicking and dragging the rightmost slider. 

 To allow the shape to grow to a specific height by applying a 
scaling factor in its Z-axis, click the Scale To Height option, 
then specify the height in the Height box. This does not create 
a flat top in the shape. 

12 To apply the shape attributes to the colour, click Apply.  

 You can revert to the Shape Editor's default settings by 
clicking Reset. 

The shape profile applied to the colour is displayed on it's swatch 
in the colour palette. For example, if an angled profile is applied 
to yellow, it is shown as follows: 

 
13 Select the relief combine mode (see page 183) you want to use 

to combine the shape with the currently active relief layer: 
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 The selected combine mode controls how the shape is 
combined with the active relief layer only. It does not 
control how the shape is combined with the composite 
relief. How the shape is combined with other relief layers to 
make the composite relief is determined by the relief layer's 
combine mode (see page 167). 

 To reset all areas beneath the colour to zero, click Zero. 

 To reset all areas to zero, other than those beneath the 
colour, click Zero Rest. 

14 Click Close to close the Shape Editor. 

 If you click Close before applying your specified shape 
attributes, a message box is displayed confirming they have 
changed and asking if you want to save them. Click Yes to 
apply the shape attributes or No to delete them before 
closing the Shape Editor. 

15 If you are working in the 2D View window, press F3 to display the 
3D View window and see your shape. 

 Click the Colour Shade  button in the 3D View toolbar 
to hide the artwork on the currently active bitmap layer. 

 

Creating simple shapes using closed vectors 
You can create a simple three dimensional shape using closed 
vector artwork. The shape is created on the currently active relief 
layer. 

To create a shape using closed vector artwork: 

1 Make sure the vector layer containing the closed vector you want 
to use is visible (see page 129). 

2 If you are working in the 3D View window, click the Toggle Vector 

Visibility  button in the 3D View toolbar to display the 
artwork on all visible vector layers. 

3 Make sure that you are working in Select mode (see page 122). 

 If the Select button is shown as  in the Design Tools 
toolbar, then you are already in Select mode. 

4 Select the closed vector (see page 122) you want to use to 
create a shape. 
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5 Use one of the following methods to display the Shape Editor 
dialog box: 

 In the Relief Creation toolbar, click the Shape Editor  
button; 

 From the Menu Bar, select Model > Shape Editor; 
 Press the F12 key; or 

 Double-click the selected vector. 

 If you use the last method, be careful not to move the 
vector at the same time. 

 
The default settings enable you to create a flat shape with a start 
height of zero; this is represented by the horizontal line shown. 

6 Select the shape's profile by clicking one of the following 
buttons: 

 Click   to select a rounded profile; 

 Click   to select an angled profile; or 
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 Click   to select a flat profile. 

The image shown in the dialog's window changes according to 
your selected profile. 

7 In the Start Height box, specify the Z height at which the shape is 
created. This creates a vertical side wall in the shape. If you are 
creating a flat shape, this also controls the height of the plane. 

8 If you are creating a rounded or angled shape, specify its angle 
using one of the following methods: 
 In the Angle box, type the angle; or 

  Type a positive value to create a convex shape, a negative 
value to create a concave shape, or 0 to create a plane. 

 Click and drag the leftmost slider; or 

 
 Click   or  on the right of the Angle box: 

 
9 If you are creating a rounded or angled shape, choose the 

method you want to use to control the shape's height: 

 To allow the shape to grow to the height that it would 
naturally reach, click the No Limit option. This is selected by 
default. 

 To apply a scaling factor to the shape in its Z-axis, click 
Scale, then specify the scaling factor either by typing it in 
the Scale box or clicking and dragging the rightmost slider: 
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Drag the slider upwards to increase the scaling factor, or 
downwards to decrease the scaling factor. The scaling 
factor is shown in the Scale box. 

 To allow the shape to grow to a specific height and then 
plateau, click the Limit To Height option, then specify the 
maximum height in the Height box. 

 If the natural height of the shape exceeds that of the value 
specified in the Height box, a flat top is created. 

 To apply a scaling factor to the shape in its Z-axis, click 
Scale, then set the scaling factor either by typing it in the 
Scale box or clicking and dragging the rightmost slider. 

 To allow the shape to grow to a specific height by applying a 
scaling factor in its Z-axis, click the Scale To Height option, 
then specify the height in the Height box. This does not create 
a flat top in the shape. 

 To allow the shape to grow to a specific height, click the 
Constant Height (Vectors Only) option, then specify the height 
in the Height box. This creates a shape where its angle or 
curvature changes in order to maintain a constant height; 
even where its width varies. 

10 To apply the shape attributes to the vector, click Apply.  

 You can revert to the Shape Editor's default settings by 
clicking Reset. 

11 Select the relief combine mode (see page 183) you want to use 
to combine the shape with the currently active relief layer: 

 The selected combine mode controls how the shape is 
combined with the currently active relief layer only. It does 
not control how the shape is combined with the composite 
relief. How the shape is combined with other relief layers to 
make the composite relief is determined by the relief layer's 
combine mode (see page 167). 

 To reset all areas within the vector boundary to zero, click 
Zero. 

 To reset all areas to zero, other than those within the 
vector boundary, click Zero Rest. 

12 Click Close to close the Shape Editor. 
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 If you click Close before applying your specified shape 
attributes, a message box is displayed confirming they have 
changed and asking if you want to save them. Click Yes to 
apply the shape attributes or No to delete them before 
closing the Shape Editor. 

13 If you are working in the 2D View window, press F3 to display the 
3D View window and see your shape. 
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Calculating a relief 
The Relief Calculation tools control how the shape attributes applied 
to a colour in a bitmap layer's artwork calculate a new relief and 
combine it with the currently active relief layer. 

The Relief Calculation tools are available from: 
 the Menu Bar, by clicking Reliefs > Calculate. 

 the Shape Editor; and  

 the Relief Tools area of the Assistant panel, which is hidden by 
default. 

 
Using one of four combination methods, you can: 
 replace (see page 183) the currently active relief layer's content 

with a new relief. 
 add (see page 184) a new relief to the currently active relief 

layer. 
 subtract (see page 186) a new relief from the currently active 

relief layer.  
 merge (see page 188) a new relief with the currently active relief 

layer, so that only their highest or lowest points are kept. 

 
 

Replacing the relief 
You can replace the currently active relief layer's content with a new 
relief. 

To replace one relief with another: 

1 Choose the bitmap layer (see page 99) containing the artwork 
you want to use to create the relief. 

2 Make sure the bitmap layer is visible (see page 102). 
3 If you are working in the 3D View window, make sure the Colour 

Shade  button in the 3D View toolbar is toggled on. 

4 Apply shape attributes (see page 174) to a colour in the bitmap 
layer's artwork. 

5 Choose the relief layer (see page 165) containing the relief you 
want to replace. 
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 You can use the Preview Relief Layer  button in the 2D 
View toolbar to check the contents of the currently active 
relief layer. 

6 Use one of the following methods to replace the currently active 
relief layer's content with a new relief calculated from the 
attributes applied to the colours in your bitmap artwork: 
 From the Menu Bar, click Reliefs > Calculate > Replace; or 

 Click the Replace Relief  button in the Relief Tools area of 
the Assistant panel; 

During the calculation process, a progress bar is displayed in the 
Status Bar:  

 

 You can cancel the relief replacement process by clicking 
. 

7 If you are working in the 2D View window, press the F3 key to 
display the composite relief in the 3D View window. 

 

Adding to the relief 
Using bitmap artwork, you can add a new relief to the currently 
active relief layer's content. 

To add a shape to the currently active relief layer: 

1 Choose the bitmap layer (see page 99) containing the artwork 
you want to use to create the relief. 

2 Make sure the bitmap layer is visible (see page 102). 
3 If you are working in the 3D View window, make sure the Colour 

Shade  button in the 3D View toolbar is toggled on. 

4 Apply shape attributes (see page 174) to the colours in the 
bitmap layer's artwork. 

5 Choose the relief layer (see page 165) on which you want to add 
a new relief. 

 If you are working in the 2D View window, you can use the 

Preview Relief Layer  button in the 2D View toolbar to 
check the contents of the currently active relief layer. 
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6 Use one of the following methods to add the new relief calculated 
from the attributes applied to the colours in your bitmap artwork 
to the currently active relief layer's content: 
 From the Menu Bar, click Reliefs > Calculate > Add; or 

 Click the Add Relief  button in the Relief Tools area of 
the Assistant panel. 

 The combine mode selected here controls how the shape is 
added to the currently active relief layer only. It does not 
control how the shape is combined with the composite 
relief. How the shape is combined with other relief layers to 
form the composite relief is determined by the combine 
mode assigned to the layer itself. For details, see Setting 
the combine mode (see page 167). 

7 If you are working in the 2D View window, press the F3 key to 
display the composite relief in the 3D View window. 

For example, a cyan circle is painted on a bitmap layer: 

 
Using the Shape Editor, a rounded shape is applied to the circle's 
colour, as you can see by looking at the colour palette below the 
2D View and 3D View window: 

 
The rounded shape is added to the currently active relief layer, 
and displayed in the 3D View window as follows: 
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The rectangular vector is then flood-filled in red: 

 
Using the Shape Editor, a plane shape is applied to the 
rectangle's colour, as you can see by looking at the colour 
palette below the 2D View and 3D View window: 

 
The plane is added to the rounded shape on the currently active 
relief layer to create the following new relief: 

 
 

Subtracting from the relief 
You can subtract a shape from the currently active relief layer. 

To subtract a shape from the currently active relief layer: 

1 Choose the bitmap layer (see page 99) containing the artwork 
you want to use to create the relief. 

2 Make sure the bitmap layer is visible (see page 102). 
3 If you are working in the 3D View window, make sure the Colour 

Shade  button in the 3D View toolbar is toggled on. 

4 Apply shape attributes (see page 174) to a colour in the bitmap 
layer's artwork. 
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5 Choose the relief layer (see page 165) from which you want to 
subtract a new relief. 

 You can use the Preview Relief Layer  button in the 2D 
View toolbar to check the contents of the currently active 
relief layer. 

6 Use one of the following methods to subtract the relief from the 
currently active relief layer: 
 From the Menu Bar, click Reliefs > Calculate > Subtract; or 

 Click the Subtract Relief  button in the Relief Tools area 
of the Assistant panel;  

 The combine mode selected here controls how the shape is 
subtracted from the currently active relief layer only. It 
does not control how the shape is combined with the 
composite relief. How the shape is combined with other 
relief layers to form the composite relief is determined by 
the combine mode assigned to the layer itself. For details, 
see Setting the combine mode (see page 167). 

7 Press the F3 key to display the composite relief in the 3D View 
window. 

For example, a cyan circle is painted on a bitmap layer: 

 
Using the Shape Editor, a rounded shape is applied to the circle's 
colour, as you can see by looking at the colour palette below the 
2D View and 3D View window: 

 



 

188 • The 3D design process ArtCAM 2012 User Guide  

The rounded shape is added to the currently active relief layer, 
and displayed in the 3D View window as follows: 

 
The rectangular vector is then flood-filled in red: 

 
Using the Shape Editor, a plane shape is applied to the 
rectangle's colour, as you can see by looking at the colour 
palette below the 2D View and 3D View window: 

 
The plane is subtracted from the rounded shape on the currently 
active relief layer to create the following new relief: 

 
 

Merging with the relief 
You can merge a new relief with the currently active relief layer, so 
that only their: 

 highest points are kept; or 

 lowest points are kept. 
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To merge a new relief with the currently active relief layer: 

1 Choose the bitmap layer (see page 99) containing the artwork 
you want to use to create the relief. 

2 Make sure the bitmap layer is visible (see page 102). 
3 If you are working in the 3D View window, make sure that the 

Toggle Vector Visibility  button in the 3D View toolbar is 
toggled on.  

4 Apply shape attributes (see page 174) to a colour in the bitmap 
layer's artwork. 

5 Choose the relief layer (see page 165) with which you want to 
merge a new relief. 

 You can use the Preview Relief Layer button  in the 2D 
View toolbar to check the contents of the currently active 
relief layer. 

6 Use one of the following methods to merge the new relief 
calculated from the attributes applied to the colour with the 
currently active relief layer's content, so that only the highest 
points show: 
 From the Menu Bar, click Reliefs > Calculate > Merge Highest; or  

 Click the Merge High  button in the Relief Tools area of 
the Assistant panel. 

Use one of the following methods to merge the new relief 
calculated from the attributes applied to the colour with the 
currently active relief layer's content, so that only the lowest 
points show: 
 From the Menu Bar, click Reliefs > Calculate > Merge Lowest; or 

 Click the Merge Low  button in the Relief Tools area of 
the Assistant panel. 

 The combine mode selected here controls how the shape is 
merged with the currently active relief layer only. It does 
not control how the shape is combined with the composite 
relief. How the shape is combined with other relief layers to 
form the composite relief is determined by the combine 
mode assigned to the layer itself. For details, see Setting 
the combine mode (see page 167). 
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7 Press the F3 key to display the composite relief in the 3D View 
window. 

For example, a cyan circle is painted on a bitmap layer: 

 
Using the Shape Editor, a rounded shape is applied to the circle's 
colour as you can see by looking at the colour palette below the 
2D View and 3D View window: 

 
The rounded shape is added to the currently active relief layer, 
and displayed in the 3D View window as follows: 

 
The rectangular vector is then flood-filled in red: 

 
Using the Shape Editor, a plane shape is applied to the 
rectangle's colour, as you can see by looking at the colour 
palette below the 2D View and 3D View window: 
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The plane is merged with the rounded shape on the currently 
active relief layer to create a new relief. The different results 
from using the Merge High and Merge Low options are shown 
below: 

Merge High… 

 

Merge Low… 
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Creating complex shapes using 
vectors 

You can create complex free-form shapes on relief layers using 
vector artwork and the Swept Profiles toolset available: 
 on the Relief Creation toolbar; 

 
 from the Menu Bar, by clicking Reliefs > Swept Profiles; 

 in the Relief Tools area of the Assistant panel. 

The four shapes you can create are: 

 extrude (see page 192) 

 spin (see page 197) 

 turn (see page 202); and 

 two-rail sweep (see page 205). 
 

Creating an extruded shape 
Extruded shapes are created on relief layers using vector artwork. 
An extruded shape uses at least two vectors: 

 one to specify the path along which the shape is extruded, 
known as a drive curve; and 

 another to control the shape's profile at its start, known as the 
start profile.  

Up to two additional vectors can be used: 

 one to control the shape's profile at its end, known as the end 
profile; and 

 another to control the shape's height in the Z direction, known as 
the Z modulation profile. 
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For example, the vector artwork shown below can be used to 
extrude a harp frame shape: 
Before... 

 

After... 

 

To create an extruded shape: 

1 Choose (see page 165) or create (see page 166) the relief layer 
on which you want to extrude the shape. 

2 Use one of the following methods to display the Extrude panel: 

 From the Relief Creation toolbar, click the Extrude  
button; 

 From the Menu Bar, click the Reliefs > Swept Shapes > Extrude 
option; 

 Click the Extrude  button in the Swept Profiles toolset 
shown in the Relief Tools area of the Assistant panel. 

 For information on how to display any of the toolsets in the 
Assistant panel, see Understanding the Assistant panel (see 
page 37). 

3 If you are working in the 3D View window, make sure that the 

Toggle Vector Visibility  button in the 3D View toolbar is 
toggled on. 

4 Select the vector (see page 122) you want to sweep the cross 
section along. This is referred to as the drive curve. 

5 In the Drive Curve area, click the Select button. 
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In the 2D View and 3D View window, direction arrows are 
displayed along the selected vector to show the direction of the 
drive curve and on which side the cross section is to be attached. 

6 To change the drive curve's properties, select the: 
 Reverse curve direction check box to reverse the direction of 

the drive curve. The direction arrows along the selected vector 
now face the opposite direction. 

 Use other side check box to change the side of the drive curve 
along which the cross-section is extruded. The direction 
arrows along the selected vector are now displayed on the 
opposite side. 

 Use as a centreline check box to use the drive curve as the 
centreline for the extrusion. The direction arrows are now 
displayed along both sides of the selected vector. 

 Create square corners check box to create sharp corners in the 
extruded shape. 

7 Select the open, ungrouped vector (see page 122) you want to 
use as the cross section at the start of the extruded shape. This 
is referred to as the start profile. 

8 In the Start Profile area, click the Select button. 

In the 2D View and 3D View window, direction arrows are 
displayed along the selected vector to show the current Z-axis 
direction. The side on which the direction arrows are displayed 
on the selected vector is the side on which the shape is extruded. 
For example, a selected drive curve and start profile in the 2D 
View window might look as shown below: 
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Before... 

  

After... 

 

9 To change the start profile's properties, select the:  
 Move anchor point to other end check box to change the start 

node's position in the selected vector. The start node is green 
and controls which end of the start profile is attached to the 
drive curve. 

 Invert curve in Z check box to invert the profile in the Z-axis 
direction. 

10 To use a different profile at the end of the extruded shape: 
a Select the use separate end profile check box. 

b Select the open, ungrouped vector (see page 122) you want 
to use as the cross-section. This is referred to as the end 
profile. 

c In the End Profile area, click the Select button. 

11 To change the end profile's properties, select the: 
 Move anchor point to other end check box to change the start 

node's position in the selected vector. The start node is green 
and controls which end of the end profile is attached to the 
drive curve. 

 Invert curve in Z check box to invert the profile in the Z-axis 
direction. 

In our example, the vector used for the end profile is the same 
as that which was selected as the start profile. 

12 To scale the extruded shape in the Z-axis along its length: 
a Select the Use a z modulation profile check box. 
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b Select the vector (see page 122) you want to use to scale the 
extruded shape. This is referred to as the z modulation profile. 

c In the Z Modulation area, click the Select button. 

13 To change the z modulation profile's properties, select the: 
 Move anchor point to other end check box to change the 

position of the start node in the selected vector. The start 
node is green and controls which end of the start profile is 
attached to the z modulation vector. 

 Invert curve in Z check box to invert the selected vector in the 
Z-axis direction. 

14 Select the combine mode you want to use. Click: 
 Add to add the extruded shape to the layer's content. 

 Subtract to subtract the extruded shape from the layer's 
content.  

 Highest to merge the extruded shape with the layer's content, 
so that only the highest points show. 

 Lowest to merge the extruded shape with the layer's content, 
so that only the lowest points show. 

 The combine mode (see page 183) selected here controls 
how the extruded shape is combined with the currently 
active relief layer only. It does not control how the 
extruded shape is combined with the composite relief. How 
the extruded shape is combined with other relief layers to 
form the composite relief is affected by the combine mode 
(see page 167) assigned to the layer.  

15 Click Calculate to create the extruded shape. The extruded shape 
is displayed in the 3D View window. 

16 Click Close to close the Extrude panel.  

 If you are working in the 2D View window, click the Preview 

Relief Layer  button in the 2D View toolbar to display a 
greyscale image of the extruded shape. 

 To view only the relief layer on which you have created the 
extruded shape, right-click the currently active layer's  
icon. For details, see Viewing a layer (see page 169). 
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For example, the extruded shape might look something like this 
when the Add combine mode is used: 

 
Prior to calculating the extruded shape, the blocks at the top and 
bottom of the harp frame were created by applying a flat profile 
with a shallow height to the red bitmap colour using the Shape 
Editor. 

 

Creating a spun shape 
Spun shapes are created on relief layers using vector artwork. A 
spun shape uses at least one vector to control the shape's profile, 
known as the start profile.  

Up to two additional vectors can be used: 

 one to control the shape's end cross section, known as the end 
profile; and 

 another to control the shape's height in the Z direction, known as 
the Z modulation profile. 

For example, the vector artwork shown below can be used to create 
a spun shape, and the bitmap artwork to produce leaf shapes: 
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Before... 

 

After... 
 

 

To create a spun shape: 

1 Choose (see page 165) or create (see page 166) the relief layer 
on which you want to create the spun shape. 

2 Use one of the following methods to display the Spin panel: 

 From the Relief Creation toolbar, click the Spin  button; 

 From the Menu Bar, click Reliefs > Swept Shapes > Spin; 

 Click the Spin  button in the Swept Profiles toolset 
shown in the Relief Tools area of the Assistant panel. 

 For information on how to display any of the toolsets on the 
Assistant panel, see Understanding the Assistant panel (see 
page 37). 

3 If you are working in the 3D View window, make sure that the 

Toggle Vector Visibility  button in the 3D View toolbar is 
toggled on. 

4 Select the open, ungrouped vector (see page 122) you want to 
use as the cross section at the start of the spun shape. This is 
referred to as the start profile. 

5 In the Start Profile area, click the Select button.  

In the 2D View and 3D View window, direction arrows are 
displayed along the selected vector to show which side the 
cross-section is to be attached and the direction in which it is 
spun. 

6 To change the start profile's properties, select the:  
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 Move anchor point to other end check box to change the start 
node's position in the selected vector. The start node is green 
and controls the point around which the start profile is spun. 

 Invert curve in Z check box to invert the selected vector in the 
Z-axis direction. 

7 To use a different profile at the end of the spun shape: 
a Select the use separate end profile check box. 

b Select the open, ungrouped vector (see page 122) you want 
to use as the cross-section. This is referred to as the end 
profile. 

c In the End Profile area, click the Select button. 

In the 2D View and 3D View window, direction arrows are 
displayed along the selected vector to show which side the 
cross-section is to be attached and the direction in which it is 
spun. 

In our example, the vector used as the end profile is the same as 
that which was selected as the start profile. 

8 To change the end profile's properties, select the: 
 Move anchor point to other end check box to change the start 

node's position in the selected vector. The start node is green 
and controls the point around which the end profile is spun. 

 Invert curve in Z check box to invert the profile in the Z-axis 
direction. 

In our example, the vector used for the end profile is the same 
as that which was selected as the start profile. 

9 To scale the spun shape in the Z-axis along its length: 
a Select the Use a z modulation profile check box. 

b Select the vector (see page 122) you want to use to scale the 
spun shape. This is referred to as the z modulation profile. 

c In the Z Modulation area, click the Select button. 

In the 2D View and 3D View window, direction arrows are 
displayed along the selected vector to show which side the 
cross-section is to be attached and the direction in which it is 
spun. 
For example, a selected start and Z modulation profile in the 2D 
View window might look something like this: 
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Before... 

 
After... 

 
 

10 To change the z modulation profile's properties, select the: 
 Move anchor point to other end check box to change the start 

node's position in the selected vector. The start node is green 
and the direction of the Z modulation vector is reversed. 

 Invert curve in Z check box to invert the profile in the Z-axis 
direction. 

11 To sweep the selected profiles clockwise through 360 degrees 
starting from a specific angle: 
a Select the Sweep through 360 degrees check box. 

b In the Start Angle box, specify the angle at which to begin 
sweeping.  

12 To sweep the profile through a specific angle and in a specific 
direction: 
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a Deselect the Sweep through 360 degrees check box. 

b In the Start Angle box, specify the angle at which to begin 
sweeping.  

c In the End Angle box, specify the angle at which to stop 
sweeping.  

d Specify the sweep direction by clicking the Clockwise or 
Anticlockwise option. 

13 Select the combine mode you want to use. Click: 
 Add to add the spun shape to the layer's content. 

 Subtract to subtract the spun shape from the layer's content.  

 Highest to merge the spun shape with the layer's content, so 
that only the highest points show. 

 Lowest to merge the spun shape with the layer's content, so 
that only the lowest points show. 

 The combine mode (see page 183) selected here controls 
how the spun shape is combined with the currently active 
relief layer only. It does not control how the spun shape is 
combined with the composite relief. How the spun shape is 
combined with other relief layers to form the composite 
relief is affected by the combine mode (see page 167) 
assigned to the layer.  

14 Click Calculate to create the spun shape. The spun shape is 
displayed in the 3D View window. 

15 Click Close to close the Spin panel.  

For example, a profile swept from 0 through 360 degrees in a 
clockwise direction might look something like this when the Add 
combine mode is used: 

 
The wave effect is achieved by using the Z modulation vector. 
The overall shape of the leaves is achieved by resetting the relief 
outside of the leaf-shaped bitmap artwork to zero. 
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 If you are working in the 2D View window, click the Preview 

Relief Layer  button in the 2D View toolbar to display a 
greyscale image of the spun shape. 

 To view only the relief layer on which you have created the 
spun shape, right-click the currently active layer's  icon. 
For details, see Viewing a layer (see page 169). 

 
 

Creating a turned shape 
You can turn a shape using a vector. An imaginary line between the 
start node and end node in the selected vector acts as an axis about 
which it is turned to create the shape's cross section. 

For example, you can see how a shape can be turned using vectors 
to form castle turrets: 
Before... 

 

After... 
 

 

To create a turned shape: 

1 Choose (see page 165) or create (see page 166) the relief layer 
on which you want to create the turned shape. 

2 Use one of the following methods to display the Turn panel: 

 From the Relief Creation toolbar, click the Turn  button; 

 From the Menu Bar, click Reliefs > Swept Shapes > Turn; 

 Click the Turn  button in the Swept Profiles toolset 
shown in the Relief Tools area of the Assistant panel. 
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 For information on how to display any of the toolsets on the 
Assistant panel, see Understanding the Assistant panel (see 
page 37). 

3 If you are working in the 3D View window, make sure that the 

Toggle Vector Visibility  button in the 3D View toolbar is 
toggled on. 

4 Select the open, ungrouped vector (see page 122) you want to 
use as the turned shape's cross section. This is referred to as the 
profile. 

5 In the Profile area, click the Select button.  

In the 2D View and 3D View window, direction arrows are 
displayed about the selected vector to show the direction from 
the start node to the end node.  
For example, a selected profile in the 2D View window might look 
something like this: 

Before... 

 
After... 
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6 In the Z Scale Factor box, specify the scaling factor that you want 
to apply to the profile in the Z-axis direction. The default value of 
1 produces a semi-circular cross section. 

In our example, a scale factor of 0.5 is applied to the profile. 

7 To change any of the settings before calculating the turned 
shape, click Reset. 

8 Select the combine mode you want to use. Click: 
 Add to add the turned shape to the layer's content. 

 Subtract to subtract the turned shape from the layer's content.  

 Highest to merge the turned shape with the layer's content, so 
that only the highest points show. 

 Lowest to merge the turned shape with the layer's content, so 
that only the lowest points show. 

 The combine mode (see page 183) selected here controls 
how the turned shape is combined with the currently active 
relief layer only. It does not control how the turned shape is 
combined with the composite relief. How the turned shape 
is combined with other relief layers to form the composite 
relief is affected by the combine mode (see page 167) 
assigned to the layer.  

9 Click Calculate to create the turned shape. The turned shape is 
displayed in the 3D View window. 

10 Click Close to close the Turn panel.  

In our example, the Add option is used. 

In our example, the currently active relief layer is displayed in 
the 3D View window as follows: 

 
The crenellations within the castle turrets are created by 
selecting white as the Primary Colour, and then using the Zero 

Relief Under Colour  button in the Relief Tools area of the 
Assistant panel.  
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 If you are working in the 2D View window, click the Preview 

Relief Layer  button in the 2D View toolbar to display a 
greyscale image of the turned shape. 

 To view only the relief layer on which you have created the 
turned shape, right-click the currently active layer's  
icon. For details, see Viewing a layer (see page 169). 

 

Creating a two-rail sweep 
Swept shapes are created on relief layers using vector artwork. A 
two-rail sweep uses at least three open, ungrouped vectors: 

 two to set the boundary of the sweep, known as drive rails; and 

 one or more to control the sweep's height and profile, known as 
cross sections. 

When you create a two-rail sweep, an additional vector to restrict 
the shape's height can also be used. 

For example, the vector artwork shown below can be used to create 
a sweep in the shape of a fish: 
Before… 

 

After… 

 

To create a two-rail sweep: 

1 Choose (see page 165) or create (see page 166) the relief layer 
on which you want to create the sweep. 

2 Use one of the following methods to display the Two Rail Sweep 
panel: 
 From the Relief Creation toolbar, click the Two Rail Sweep 

 button; 
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 From the Menu Bar, click Reliefs > Swept Shapes > Two Rail 
Sweep; 

 Click the Two Rail Sweep  button in the Swept Profiles 
toolset shown in the Relief Tools area of the Assistant panel. 

 For information on how to display any of the toolsets on the 
Assistant panel, see Understanding the Assistant panel (see 
page 37). 

3 Choose the two drive rails: 
a If you are working in the 3D View window, make sure that the 

Toggle Vector Visibility  button in the 3D View toolbar is 
toggled on. 

b Select the first vector (see page 122) you want to sweep cross 
sections along. 

c In the Select Control Vectors area, click the Top Drive Rail's 
Select button. 

In the Status area, the First Drive Rail changes from Not 
Selected to Valid. In the 2D View and 3D View window, 
direction arrows are displayed along the selected vector. In 
the 2D View only, a red letter A is also shown beside it's start 
node. 

For example, the first drive rail might look as shown below: 

 
d Select the second vector (see page 122) you want to sweep 

cross sections along.  
e In the Select Control Vectors area, click the Bottom Drive Rail's 

Select button. 
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In the Status area, the Second Drive Rail changes from Not 
Selected to Valid. In the 2D View and 3D View window, 
direction arrows are displayed along the selected vector. In 
the 2D View only, a red letter B is also shown beside it's start 
node. 

For example, the second drive rail might look as shown below: 

 
4 Make sure that the drive rails share the same direction. To 

reverse the direction of: 
 the first drive rail, click to select the First check box in the 

Reverse Direction of Drive Rails area. 

 the second drive rail, select the Second check box. 

5 Choose the cross-section vectors: 

a Select the open, ungrouped vectors (see page 122) you want 
to use as cross sections. 

When selecting two or more cross sections, each of the 
selected vectors ideally should contain the same number of 
spans. This helps to ensure a smooth transition is made 
between each of the shape's cross sections. The order in 
which you select the cross sections can affect the shape. 

 When using the Select tool , the number of spans in a 
selected vector are displayed on the Tool Settings panel. 

a In the Status area, click the Add Cross Section button. 

In the Cross Section area, a list of cross sections is shown. Each 
of the cross-sections has a: 

 number; 

 Valid status; 
 Smooth Blend  icon; 

 Set Position  icon; 
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 Delete  icon; and 

 displays its number of spans. 
In the 2D View window only, red sequential numbers are 
displayed: 

 on the vectors selected as cross-sections; 

 along the first drive rail to mark the position of the cross 
sections; and 

 blue sequential numbers are displayed along the second drive 
rail to mark the position of the cross sections. 

For example, the cross sections might look as shown below: 

 
Provided the vectors selected as cross sections contain an equal 
number of spans, the Sweep between spans check box is enabled 
and selected. The spans and nodes in each subsequent cross 
section along the drive rails are paired, and the sweep is 
extruded between them. 

When the vectors selected as cross-sections do not contain an 
equal number of spans, or you deselect the Sweep between spans 
check box, although the sweep is extruded between each 
subsequent cross section along the drive rails, their spans and 
nodes are not used. 

6 To insert a cross section: 

a Select the open, ungrouped vector (see page 122) you want 
to insert as a cross section. 

b In the Status area, click the Insert Cross Section button. 

In the 2D View window, a red sequential number is displayed 
on the selected vector.  
In the Cross Sections area, a new cross section is added to 
the list with 1st Rail displayed. 
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c In the 2D View window, move the cursor over the position 
in the first drive rail in which you want to insert the cross 
section, then click. 
The cross section's 1st Rail label is replaced with 2nd Rail. 

d Move the  cursor over the position in the second drive rail, 
then click to complete the cross section. 
The cross section's 2nd Rail label is replaced with Set Position. 

7 To reposition a cross section on the drive rails: 

a Click  to toggle  on. 1st Rail replaces its Position label. 

b On the first drive rail, click the cross section's new position. 
2nd Rail replaces its 1st Rail label. 

c On the second drive rail, click the cross position's new 
position.  is displayed, and Position replaces its 2nd Rail 
label. 

8 Specify how the shape is blended between each cross-section. 
Click: 

  to toggle  on and use a linear blend; or 

  to toggle  on and use a smooth blend.  

9 To remove a cross-section from the list, click  . The cross 
section vector is deselected, and the numbers are updated: 
 in the Cross Sections area; and 

 on the cross sections and drive rails shown in the 2D View 
window. 

10 Choose the scaling options. 

To use a vector to scale the sweep in the Z-axis along its length: 

a Select the open, ungrouped vector (see page 122) you want 
to use to control the Z height; known as a Z control vector. 

b In the Select Control Vectors area, click the Z Control Vector's 
Select button. 

In the Status area, the Z Control Vector changes from Not 
Selected to Valid. In the 2D View only, a red letter Z is shown 
beside it's start node. 

c To match the height of each cross section with the Z control 
vector, select the Vector Controls Exact Height check box.  

 The Scale Height with Width and Scale Final Height check 
boxes are greyed-out. 
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If you are not using a vector to control the sweep's height, you 
can choose one or more of the following scaling options instead: 

 To scale the sweep's height proportionally to the width of each 
cross section across the drive rails, leave the Scale Height with 
Width check box selected. 

With Scale Height with Width selected, narrow cross sections 
produce low heights in the sweep, and wide cross sections 
produce high heights. 

 To keep a constant height throughout the sweep, deselect the 
Scale Height with Width check box. 

 To scale the height of the sweep during the calculation 
process, select the Scale Final Height check box, then specify 
the maximum Z height in the adjacent box. 

11 To create a flat base beneath the sweep, specify its Z height in 
the Start Height box. 

12 Select the combine mode you want to use. Click: 
 Add to add the sweep to the layer's content. 

 Subtract to subtract the sweep from the layer's content.  

 Highest to merge the sweep with the layer's content, so that 
only the highest points show. 

 Lowest to merge the sweep with the layer's content, so that 
only the lowest points show. 

 The combine mode (see page 183) selected here controls 
how the sweep is combined with the currently active relief 
layer only. It does not control how the sweep is combined 
with the composite relief. How the sweep is combined with 
other relief layers to form the composite relief is affected by 
the combine mode (see page 167) assigned to the layer.  

13 Click Calculate to create the sweep. The sweep is displayed in the 
3D View window. 

14 Click Close to close the Two Rail Sweep panel.  

 If you are working in the 2D View window, click the Preview 

Relief Layer  button in the 2D View toolbar to display a 
greyscale image of the sweep. 

 To view only the relief layer on which you have created the 
sweep, right-click the currently active layer's  icon. For 
details, see Viewing a layer (see page 169). 
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Creating a two-rail ring sweep 
Swept ring shapes are created on relief layers using vector artwork, 
and are typically used to create or edit a shank. These can only be 
created in ArtCAM JewelSmith where a model containing a rotary 
relief is currently open. 

A two-rail ring sweep uses at least three open, ungrouped vectors 
and one closed, ungrouped vector: 

 two open, ungrouped vectors to set the boundary of the sweep, 
known as drive rails; 

 one closed, ungrouped vector to control the sweep's height, 
known as the ring silhouette; and  

 one or more open, ungrouped vectors to control the sweep's 
height and profile, known as cross sections. 

For example, the vector artwork shown below can be used to create 
a rotary axis shank: 
Before… 

 

After… 

 

To create a two-rail ring sweep: 

1 Choose (see page 165) or create (see page 166) the relief layer 
on which you want to create the sweep. 

2 Use one of the following methods to display the Two Rail Ring 
Sweep panel: 

 In the Rotary Relief Tools toolbar, click the Two Rail Sweep - 

Ring  button; 

 The Rotary Relief Tools toolbar is hidden by default. To 
display the toolbar, right-click a docking area, then select 
Rotary Relief Tools from the context menu. 
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 Click the Two Rail Sweep - Ring  button in the Rotary 
Relief Tools area of the Assistant panel. 

 The Assistant panel is hidden by default. To display the 
panel, right-click a docking area, then select Assistant from 
the context menu. 

3 Choose the two drive rails: 
a If you are working in the 3D View window, make sure that the 

Toggle Vector Visibility  button in the 3D View toolbar is 
toggled on. 

b Select the first vector (see page 122) you want to sweep cross 
sections along. 

c In the Select Control Vectors area, click the Top Drive Rail's 
Select button. 

In the Status area, the Top Drive Rail changes from Not 
Selected to Valid. In the 2D View and 3D View window, 
direction arrows are displayed along the selected vector. In 
the 2D View only, a red letter A is also shown beside it's start 
node. 

For example, the top drive rail might look as shown below: 

 
d Select the second vector (see page 122) you want to sweep 

cross sections along.  
e In the Select Control Vectors area, click the Bottom Drive Rail's 

Select button. 

In the Status area, the Bottom Drive Rail changes from Not 
Selected to Valid. In the 2D View and 3D View window, 
direction arrows are displayed along the selected vector. In 
the 2D View only, a red letter B is also shown beside it's start 
node. 
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For example, the bottom drive rail might look as shown 
below: 

 
4 Make sure that the drive rails share the same direction. To 

reverse the direction of: 
 the top drive rail, click to select the First check box in the 

Reverse Direction of Drive Rails area. 

 the bottom drive rail, select the Second check box. 

5 Choose the cross section vectors: 

a Select the open, ungrouped vectors (see page 122) you want 
to use as cross sections. 

When selecting two or more cross sections, each of the 
selected vectors ideally should contain the same number of 
spans. This helps to ensure a smooth transition is made 
between each of the sweep's cross sections. The order in 
which you select the cross sections can affect the shape. 

 When using the Select tool , the number of spans in a 
selected vector are displayed on the Tool Settings panel. 

a In the Status area, click the Add Cross Section button. 

In the Cross Section area, a list of cross sections is shown. Each 
of the cross sections has a: 

 number; 

 Valid status; 

 Set Position  icon; 

 Smooth Blend  icon; 

 Delete  icon; and 

 displays its number of spans. 
In the 2D View window only, red sequential numbers are 
displayed: 

 on the vectors selected as cross sections; 

 along the first drive rail to mark the position of the cross 
sections; and 
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 blue sequential numbers are displayed along the second drive 
rail to mark the position of the cross sections. 

For example, the cross section might look as shown below: 

 
Provided the vectors selected as cross sections contain an equal 
number of spans, the Sweep between spans check box is enabled 
and selected. The spans and nodes in each subsequent cross 
section along the drive rails are paired, and the sweep is 
extruded between them. 

When the vectors selected as cross-sections do not contain an 
equal number of spans, or you deselect the Sweep between spans 
check box,  although the sweep is extruded between each 
subsequent cross section along the drive rails, their spans and 
nodes are not used. 
The Ring is symmetrical check box is selected by default. This 
positions the first cross-section across the start nodes in the 
selected drive rails, the last cross section where the drive rails 
intersect the vertical reference guideline vector, with any 
intermediate cross sections in between. This ensures a 
symmetrical sweep is created. 

When deselected, each cross section is positioned along the 
length of the top and bottom drive rails, with the first across the 
start nodes and the last across the end nodes. This can result in 
an asymmetrical sweep being created. 

6 To insert a cross section: 

a Select the open, ungrouped vector (see page 122) you want 
to insert as a cross section. 

b In the Status area, click the Insert Cross Section button. 

In the 2D View window, a red sequential number is displayed 
by the selected vector's start node. In the Cross Section area, 
a new cross section is added to the list with its 1st Rail label 
displayed. 

c In the 2D View window, move the cursor over the position 
in the top drive rail in which you want to insert the cross 
section, then click. The cross section's 1st Rail label is replaced 
with 2nd Rail. 
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d Move the  cursor over the position in the bottom drive rail, 
then click to complete the cross section. The cross section's 
2nd Rail label is replaced with Set Position. 

For example, the cross section could be inserted as follows: 

 
7 To reposition a cross-section on the drive rails: 

a In Cross Section area, click the cross section's Set Position  
icon. The 1st Rail label is displayed. 

b In the 2D View window, click the cross section's new position 
on the top drive rail. The 1st Rail label is replaced with 2nd 
Rail. 

c Click the cross section's new position on the bottom drive rail. 
The 2nd Rail label is replaced with Set Position. 

8 Specify how the shape is blended between each cross-section. 
Click: 

  to toggle  on and use a linear blend; or 

  to toggle  on and use a smooth blend.  

9 To remove a cross section from the list, click  . The cross 
section vector is deselected, and the numbers are updated: 
 in the Cross Sections area; and 

 on the cross sections and drive rails shown in the 2D View 
window. 

10 Choose the scaling options. 

To use the ring silhouette to scale the shape in the Z-axis along 
its length: 

a Select the closed, ungrouped vector (see page 122) you want 
to use to control the Z height; known as a ring silhouette 
vector. 

b In the Select Control Vectors area, click the Ring Silhouette's 
Select button. 
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In the Status area, the Ring Silhouette changes from Not 
Selected to Valid. In the 2D View only, a red letter Z is shown 
beside it's start node. 

For example, the ring silhouette vector might look as shown 
below: 

 
c To match the height of each cross section with the ring 

silhouette, leave the Silhouette Vector Controls Z check box 
selected. 

 The Scale Height with Width and Scale Final Height check 
boxes are greyed-out. 

If you are not using the ring silhouette vector to control the 
sweep's height, deselect the Silhouette Vector Controls Z check 
box, then select one or more of the following scaling options 
instead: 

 To scale the sweep's height proportionally to the width of each 
cross section across the drive rails, leave the Scale Height with 
Width check box selected. 

With Scale Height with Width selected, narrow cross sections 
produce low heights in the sweep, and wide cross sections 
produce high heights. 

 To keep a constant height throughout the sweep, deselect the 
Scale Height with Width check box. 
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 To scale the height of the sweep during the calculation 
process, select the Scale Final Height check box, then specify 
the maximum Z height in the adjacent box. 

11 Select the combine mode you want to use. Click: 
 Add to add the sweep to the layer's content. 

 Subtract to subtract the sweep from the layer's content.  

 Highest to merge the sweep with the layer's content, so that 
only the highest points show. 

 Lowest to merge the sweep with the layer's content, so that 
only the lowest points show. 

 The combine mode (see page 183) selected here controls 
how the sweep is combined with the currently active relief 
layer only. It does not control how the sweep is combined 
with the composite relief. How the sweep is combined with 
other relief layers to form the composite relief is affected by 
the combine mode (see page 167) assigned to the layer.  

12 Click Calculate to create the sweep. The sweep is displayed in the 
3D View window. 

13 Click Close to close the Two Rail Ring Sweep panel. 

 If you are working in the 2D View window, click the Preview 

Relief Layer  button in the 2D View toolbar to display a 
greyscale image of the unwrapped sweep. 

 To view only the relief layer on which you have created the 
sweep, right-click the currently active layer's  icon. For 
details, see Viewing a layer (see page 169). 

 

Creating an Embossed Relief 
To create an embossed relief, you must be working in an open 
project with at least one visible replica mesh included in the Project 
Tree. These replica meshes can be created: 

 from a triangle mesh of the composite relief; 

 by importing compatible triangle or surface models (see page 
222); or 

 by importing components (see page 232) from the Component 
Library.   
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 If you are working in ArtCAM Insignia, you cannot create an 
embossed relief. 

Using the visible replica meshes in the Project Tree, the Emboss 
Relief Wizard produces a bas-relief, or low relief, which, despite 
having a particularly shallow depth, preserves: 

 the detail and illusion of depth that would be lost through 
conventional scaling; and 

 perspective in the direction of embossing. 
Reproducing the results of the Emboss Relief Wizard using relief 
creation, editing and sculpting tools would be extremely difficult and 
time consuming, if not impossible. 

To create an embossed relief: 
1 From the Project panel, select one of the following items in the 

Project Tree: 

 root  Assembly ; 

 assembly ; or 

 replica mesh  . 

The selected item's name is highlighted, and is also displayed on 
the splitter bar. 

2 All of the visible replica meshes  associated with your selected 
item in the Project Tree are included in the embossed relief. 
Make sure that only the items you want to use are visible in the 
3D View window. 

 To toggle the display of an assembly  or replica mesh 
in the Project Tree, right-click either the assembly or 

replica mesh, then click Show or Hide in the context menu, 
depending on whether it is currently visible or not. 
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For example, a replica mesh created from an imported triangle 
model of a triplane is shown in the 3D View window as follows: 

 

3 On the Project panel, click the Emboss Relief Wizard  button 
in the Tools area below the splitter bar. The Select View Direction 
settings are displayed. 

4 Set the viewing angle you want to use for the embossed relief: 
a In the 3D View window, position the mouse cursor over one of 

the replica meshes displayed. 
b Hold down the Space Bar, then click and drag. 

 
c Release the mouse button and Space Bar to set the viewing 

angle. 
5 Click Next. The Apply Perspective settings are displayed. 

If any gems  are associated with the selected item in the 
Project Tree, these are now hidden in the 3D View window. Gems 
cannot be included in the embossed relief. 

6 Click and drag the Apply Perspective slider to set the perspective 
factor you want to apply to the Z-axis of all replica meshes 
shown in the 3D View window. 
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For example, by moving the slider to its middle position, the 
illusion of depth is noticeable in the triplane's tail section: 

 
7 Click Next >. The Select Detail settings are displayed.  

In the Project Tree, a new model   is created beneath  
Models . The model is open, and given the name of the item 
selected in the Project Tree. For example, TriPlane. The 
embossed relief is eventually created in this model. 

8 In the Detail Height box, specify the maximum Z height of the 
detail, edges and features from the visible items in the Project 
Tree you want to include in the embossed relief. 

This setting enables the embossed relief's shape to vary in order 
to create the illusion of depth. 

9 In the Shape Height box, specify how much of the Z height from 
the visible items in the Project Tree you want to use in the 
embossed relief. 

This setting produces the same result as scaling the items in the 
Project Tree; preserving their original shape in the new relief.  

10 Click Finish to create the embossed relief. 

During the calculation process, a:  

 progress bar is displayed in the status bar area; and  

 a relief layer named Temp is created in the relief layer stack.  

When the calculation process is complete, the: 

 Temp relief layer is deleted from the layer stack. 

 embossed relief is created on a new relief layer, which is 
selected and given the name of the selected item in the 
Project Tree. 

 embossed relief is shown in the 3D View window looking down 
the Z-axis. 
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The embossed relief includes the original detail in the replica 
meshes and your chosen viewing angle. 

11 In the 3D View toolbar, click to deselect the Toggle Assembly 

Visibility  button and the Draw Zero Plane  button. 
This leaves only the embossed relief displayed in the 3D View 
window. 

For example, the embossed relief created from the triplane 
replica mesh is shown as follows: 

 
The maximum Z height of this embossed relief is 0.529 mm, and 
is best illustrated displayed in a material block with a thickness 
of only 1 mm: 
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Importing a triangle or surface model 
You can import a triangle or surface model into an open ArtCAM 
model or project. When importing into an open model, the 3D 
model is pasted onto the currently active relief layer. When 
importing into an open project, the 3D model is added to the Project 
Tree as a replica mesh or an assembly; either of which can be used 
to create a new model containing: 

 a relief; 

 a rotary relief; or 

 an embossed relief (see page 217). 

 If you are working in ArtCAM Insignia, you can only import a 
triangle or surface model into an open ArtCAM model. The 3D 
model is combined with the relief. 

The 3D models you can import are as follows: 
Triangle Models 

 ArtCAM Assembly (*.3da); 

 ArtCAM Project (*.3dp); 

 3D Studio (*.3ds); 

 Drawing Interchange File (*.dxf); 
 Binary or ASCII STL (*.stl); 
 Universal 3D File (*.u3d); 

 Wavefront Object File (*.obj); and 

 Delcam Machining Triangles (*.dmt) 
Surface Models 

 3D NURBS Modeller - Rhinoceros (*.3dm); 

 Delcam DGK (*.dgk); 

 SolidWorks Part File (*.sldprt); 
 IGES Format (*.igs, *.ige and *.iges); 

 ACIS File (*.sat); 
 CATIA File (*.fic); 

 CATIA5 (*.catpart and *.catproduct); 
 Cimatron File (*.pfm); 

 Elite File (*.elt); 
 Ideas File (*.mf1 and *.prt); 
 Inventor File (*.ipt); 
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 Parasolid Files (*.x_t, *.xmt_txt, *.x_b and *.xmt_bin); 

 Parts File (*.psmodel); 
 DDX Files (*.ddx and *.ddz); 
 Pro/Engineer Files (*.asm and *.par); 
 SpaceClaim File (*.scdoc); 

 Step Files (*.stp and *.step); 

 Unigraphics File (*.prt); and 

 VDAFS File (*.vda) 

 

Importing into a model 
To import a triangle or surface model into an open model: 

1 Choose the relief layer (see page 165) onto which you want to 
import the triangle or surface model. 

2 From the Menu Bar, click Reliefs > Import 3D Model . The Import 3D 
Model dialog box is displayed: 

 
3 Click the Look in list box, then select the folder on your computer 

containing the triangle or surface model you want to use. 
4 Select the file you want to import, then click Open. During the 

import process: 
 a progress bar is displayed in the Status Bar; 
 the Import 3D Model dialog is closed; 

 the imported model is displayed in the 3D View window; and 
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 the Paste 3D Model dialog box is displayed. 

 
In the Current Size area, the imported model's dimensions are 
shown. Whether these are metric or imperial measurements 
depends on the units you are using in your ArtCAM model. 

5 If you are working in the 2D View window, press the F3 key to 
display the imported model in the 3D View window. Although the 
imported model is displayed, it is not yet part of your ArtCAM 
model. 

6 Set the imported model's position in the ArtCAM model:  

 To align the model's origin with the ArtCAM model's origin, 
click Centre. 

 To position the model in the centre or a corner of the ArtCAM 
model, click one of the box diagram's five preset positions. 

 To position the model in a specific location, type the 
coordinates in the X, Y and Z boxes. 

When using either of the first two methods, the coordinates in 
the Position's X and Y boxes are updated. 

7 To rotate the imported model: 
a In the Rotate model about an axis area, specify the angle of 

rotation for each axis in it's box. You can use positive and 
negative values. 

b Click Apply. The model's size and position are updated, and 
the angle in the X, Y and Z boxes is reset to 0.0. 
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For example, if you rotate the model by 45 degrees in the X-axis 
only, the coordinates in the Position's Y and Z boxes and the 
measurements in the Set model size's Y Size and Z Size boxes 
change. 

8 To mirror the imported model: 
a Select the Mirror check box for each of the axes in which you 

want to mirror. 
b Click Apply. All three check boxes are deselected. 

9 If you are working with metric measurements, the Model was in 
mm check box is shown and selected by default. If you are 
working with imperial measurements, the Model was in inches 
check box is shown and selected by default. 

If the imported model was not created in the units of 
measurement used in your ArtCAM model, deselect the check 
box. The model is resized in the 3D View window, and it's 
dimensions are updated. 

10 To scale the imported model or resize its dimensions: 
a Select the Link check boxes for each of the plane's axes. 

For example, to use the X-Y plane, select the Link X and Link 
Y check boxes and deselect the Link Z check box. 

b For the axis in which you want to resize the model, specify the 
new measurement in its Size box. The percentage in its Scale 
box is updated proportionally. For all other linked axes, the 
measurement in the Size box and percentage in the Scale box 
is updated proportionally. 

For example, to resize along the X-axis, type the new 
measurement in the X Size box. The percentage in the X Scale 
box is updated proportionally. Provided the Link X and Link Y 
check boxes are selected, the measurement in the Y Size box 
and percentage in the Y Scale box is adjusted proportionally. 

c For the axis in which you want to scale the model, specify the 
percentage in its Scale box. The measurement in its Size box 
is updated proportionally. For all other linked axes, the 
measurement in the Size box and percentage in the Scale box 
is updated proportionally. 

For example, to scale the model by 50% in the Z-axis, make 
sure that only the Link Z check box is selected, then type the 
percentage in the Z Scale box. 

d Click Apply. The model's size and position are updated, and 
the percentage in each Scale box is reset to 100.0. 
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11 Click Paste to paste the imported model as it is shown in the 3D 
View window into the currently active relief layer using the merge 
highest (see page 188) combine method. 

12 Click Close to close the dialog box. 

 

Importing into a project 
To import a triangle or surface model into a open project: 

1 From the Project panel, right-click the root  Assembly or the 
assembly  in the Project Tree below which you want to import 
the triangle or surface model, then click Import in the context 
menu. The Import 3D Model dialog box is displayed: 

 
2 Click the Look in list box, then select the folder on your computer 

containing the triangle and surface model you want to use. 
3 Select the file you want to import, then click Open. During the 

import process: 
 a progress bar is displayed in the Status Bar; 

 a replica mesh  is added to the Project Tree, below the 
root  Assembly or the currently active assembly ; and 

 the Import 3D Model dialog is closed. 

The imported model is displayed in the 3D View window. 
 



 

ArtCAM 2012 User Guide The 3D design process • 227  

Sculpting a relief 
You can use the Sculpting tools to: 

 create free-form shapes on a new relief layer; or 

 edit the content on a relief layer. 

 If you are working in ArtCAM Insignia, there are no relief 
layers and only the Smooth and Erase tools are available. 

The settings you choose for the Sculpting tools are stored between 
ArtCAM sessions. 

To sculpt: 

1 Select the relief layer (see page 165) on which you want to 
sculpt. 

2 In the Design Tools toolbar, select the sculpting tool you want to 
use. Click: 

 Smooth for smoothing an area of the relief layer by 
blending one area with the next; 

 Smudge for extending or reducing an area of the relief 
layer by dragging it; 

 Deposit for adding material to the relief layer;  

 Carve for removing material from the relief layer; 

 Erase for gradually restoring or removing material on the 
relief layer to zero; or 

 Transfer for copying one area of the relief layer and pasting 
it to another. 

You can also select any of these tools from the context menu 
displayed by right-clicking in either the 2D View or 3D View 
window. 

 When one of the sculpting tools is currently selected, you 
can toggle through them all using the 1 to 6 number keys. 
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In the Design Tools toolbar, the selected tool's button is 
highlighted. On the Tool Settings panel, the selected tool's name 
and its settings are displayed. 

By default, the selected sculpting tool has: 

 a rounded profile; and 

 no relief layer attached. 

3 To attach a relief layer to your chosen tool, click the list box on 
the Tool Settings panel, followed by its name. All of the layers 
included in the currently selected relief layer stack (see page 
165) are included. 

When using a tool with a relief layer attached, all areas of the 
attached layer above or below the zero plane are used. The zero 
plane is ignored. 

When the sculpting cursor is positioned over the relief shown in 
the 3D View window, a greyscale image of the attached relief 
layer's content when viewed down the Z axis is displayed 
beneath the cursor. 

 If you cannot see the greyscale image, click the Colour 

Shade  button in the 3D View toolbar. 

 If you are working in Software Shading mode, no thumbnail 
image of the relief layer is shown in the list box, and no 
greyscale image of the relief layer is displayed beneath the 
sculpting cursor. An orange outline surrounds the sculpting 
cursor instead. 
If you are working in Complete OpenGL 1 Support mode, the 
thumbnail image of the relief layer shown in the Tool 
Settings list box is lower-quality, and no greyscale image of 
the relief layer is displayed beneath the sculpting cursor. An 
orange outline surrounds the sculpting cursor instead. 

4 Specify the settings you want to apply to the selected sculpting 
tool. 

To set the number of pixels that make up the tool's width: 
 Click and drag the Diameter slider; or 

 Hold down the Shift key, then roll the middle mouse wheel.  

Click and drag to the right to increase the width of the tool. 
Click and drag to the left to reduce its width. As you move the 
slider, the image to the left changes to illustrate the overall 
tool size. 
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 If your mouse has a middle wheel, when the sculpting 
cursor is positioned over the relief, hold down the Shift key, 
then roll it backwards to reduce the diameter of the tool, or 
forwards to increase its diameter. 

The Diameter controls how much material is deposited onto, or 
removed from, the currently selected relief layer when using 
the selected tool. 

If a relief layer is attached to the selected tool, this is scaled 
according to the specified diameter. 

When the sculpting cursor is positioned over the relief in the 
3D View window, the greyscale image of the attached relief 
layer displayed beneath the cursor is scaled according to the 
specified diameter. 

 To set the height of the deposit or the depth of the removal as 
a percentage of the tool width, click and drag the Strength 
slider. 

Click and drag to the right to increase the height of the 
deposit or depth of the removal. Click and drag to the left to 
reduce the height of the deposit or depth of the removal. As 
you move the slider, the image to the left changes to illustrate 
the height of the deposit or the depth of the removal. 

 If your mouse has a wheel, when the sculpting cursor is 
positioned over the relief, roll it backwards to reduce the 
strength of the tool, or forwards to increase its strength. 

 To set the sharpness of the tool, click and drag the 
Smoothness slider. 

Click and drag to the right to smooth the tool. Click and drag 
to the left to sharpen the tool. As you move the slider, the 
image to the left of the Diameter and Strength sliders changes 
to illustrate the softness or sharpness of the tool. 

If a relief layer is attached to the selected tool, this is scaled 
according to the specified diameter. 

When the sculpting cursor is positioned over the relief in the 
3D View window, the greyscale image of the attached relief 
layer displayed beneath the cursor is faded from the 
outside-edge according to the specified smoothness. 

 If your mouse has a middle wheel, when the sculpting 
cursor is positioned over the relief, hold down the Ctrl key, 
then roll it backwards to reduce the sharpness of the tool, 
or forwards to increase its sharpness. 
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5 To sculpt a specific area of the selected relief layer only, you can 
use a combination of options to control your sculpting. 

To sculpt a specific area of the selected relief layer using a 
bitmap colour: 

a Make sure that the bitmap layer containing the artwork you 
want to use is selected (see page 99) and visible (see page 
102). 

b Make sure that the Colour Shade  button in the 3D View 
toolbar is toggled on. The artwork on the selected bitmap 
layer is displayed in the 3D View window. 

c Select the primary colour (see page 108) you want to use to 
control your sculpting. 

d Specify how you want to use your chosen colour: 

To ignore the colour and sculpt anywhere in the selected relief 
layer, select Ignore. 

To sculpt only in those areas of the selected relief layer 
beneath the colour, select Sculpt only under colour. 

To sculpt only in those areas of the selected relief layer 
outside of the colour, select Sculpt excluding colour. 

To prevent material from being removed below a specific height 
in the selected relief layer: 
 Select the Material Safety Plane check box, then, in the 

adjacent box, specify the Z height below which you want to 
prevent all sculpting. 

To sculpt a specific area of the selected relief layer using a mask: 
 Click the Mask Settings list box, followed by the name of the 

relief layer you want to use as the mask. 

All of the layers in the currently selected relief layers stack are 
included in the Mask Settings list box. 

The relief layer selected as the mask overlays the relief layer 
selected for sculpting. A low contrast greyscale image of the 
relief layer selected as the mask is also displayed in the 3D 
View window. 

The selected mask works almost as a stencil, where your use 
of the tool is restricted to those areas of the mask that are 
above or below the zero plane only.  

6 Specify how you want the effects of the selected sculpting tool to 
combine with the selected relief layer. 
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If you have selected the Smooth  tool or Smudge  
tool, select a Relief Combine Mode in the Modelling Settings area: 

 To use the average result to raise and lower the area of the 
selected relief layer beneath the sculpting cursor, select 
Normal. 

 To raise only the lowest points in the selected relief layer 
beneath the sculpting cursor, select Raise Only. 

 To lower only the highest points in the selected relief layer 
beneath the sculpting cursor, select Lower Only. 

If you have selected the Deposit  tool, select a Relief 
Combine Mode in the Modelling Settings area: 

 To deposit material onto the area of the selected relief layer 
beneath the sculpting cursor, select Add. 

 To deposit a single layer of material onto the area of the 
selected relief layer beneath the sculpting cursor, regardless 
of how many times the cursor passes over the area, select 
Merge. 

If you have selected the Carve  tool, select a Relief Combine 
Mode in the Modelling Settings area: 

 To carve material from the area of the selected relief layer 
beneath the sculpting cursor, select Add. 

 To carve a single layer of material onto the area of the 
selected relief layer beneath the sculpting cursor, regardless 
of how many times the cursor passes over the area, select 
Merge. 

If you have selected the Transfer  tool, select a Relief 
Combine Mode in the Modelling Settings area: 

 To deposit the cloned material onto the area of the selected 
relief layer beneath the sculpting cursor, select Add. 

 To replace the material in the area of the selected relief layer 
beneath the sculpting cursor with the cloned material, select 
Merge. 

 If you have selected the Erase  tool, there is no 
Modelling Settings area. 
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7 In the 3D View window, click and drag the sculpting cursor over 
the area of the selected relief layer to sculpt using your chosen 
tool with the settings that you have specified. 

If you are using the Transfer  tool: 

a Hold down the Shift key, then left-click the position in the 
relief layer you want to use as the reference point for cloning.  

b Click and drag from the position in which you want to clone 
the area of the relief layer taken from your reference point. 

8 If you want the sculpting cursor to display a boundary equal to 
the specified diameter of the selected sculpting tool, select the 
Show tool outline check box in the Common Settings area. 

9 If you want the sculpting cursor to display a brush equal to the 
specified strength and smoothness of the selected sculpting tool, 
as well as a greyscale thumbnail of any relief layer attached as a 
mask, select the Show tool check box in the Common Settings 
area. 

10 If you want to hide the sculpting cursor's boundary and brush 
when clicking and dragging, select the Hide tool mid-stroke check 
box in the Common Settings area. 

 

Importing from the Component Library 
A component library is essentially a folder on your computer 
containing a collection of 3D assembly (*.3da) files, each of which 
you can import separately. In this way, it is similar to using a vector 
library or relief clipart library. 

Each component: 

 can only be imported into an open project; 

 has up to three parametric dimensions; 

 can be resized proportionally; 

 creates at least one new assembly in the Project Tree, each with 
its own associated replica mesh. 

To import a component: 

1 From the Project panel, select the root  Assembly  or 
assembly  in the Project Tree below which you want to import 
a component.  
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2 Below the panel's splitter bar, click the Open Mesh Library  
button in the Libraries area. The Component Library settings are 
displayed. 

3 Click the Libraries list box, then the name of the library you want 
to use. The library's components are listed below the Advanced 
Options area.  

4 Click to select the component you want to import. Its name and 
dimensions are displayed. 
For example, with the Primitives library selected, clicking Cone 

 displays the Component Name, Base Diameter and Height. 
5 To control the dimensions and set their parameters: 

a Click the Advanced Options control bar. Its settings are 
displayed below. 

b Click the Dimension list box, then the dimension you want to 
add or modify.  

Each dimension is numbered. If your chosen dimension is 
already used by the component, the Active check box is 
selected and three parameters are displayed: Description, 
Reference Size and Links. 

c If you are using a new dimension, select the Active check box, 
then go to the next step. 

If you are editing parameters, go to the next step. 
If you are removing the dimension, deselect the Active check 
box, then go to step g. 

d In the Description box, type the dimension's name. 

 If you type ShankDiameter or ShankWidth, Standard and 
Size list boxes alongside Diameter and Width boxes are 
included in the component's settings. 

a In the Reference Size box, type its distance. 

b In the Link area, make sure the check box for each of the 
plane's axes is selected. 

For example, the first of the Cone's dimensions is its base 
diameter. Here, the distances along the X-axis and Y-axis on 
the X-Y plane are respectively 10 mm. 

c Click Apply. 

6 In the Component Name box, specify the component's name.  
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7 Specify each of the component's dimensions in the boxes. 
For example, the Cone has two dimensions, Base Diameter and 
Height, and both of these are set to 10mm. 

8 Click Import to add the component to the Project Tree.  

One or more assemblies  are created in the Project Tree, each 
with its own associated replica mesh . Any gems  
associated with the component are also imported. 

9 Click  on the splitter bar to close the Component Library 
settings. 
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ArtCAM provides several 2D/2.5D and 3D  toolpaths that you can 
use to machine the vector artwork or composite relief that you have 
created as part of your ArtCAM model.  

The toolpaths you can use to machine vector artwork are available 
from the: 
 Project panel, displayed in the 2D Toolpaths area below the 

splitter bar when  Toolpaths is selected in the Project Tree; 

 Menu Bar, displayed by clicking Toolpaths > 2D Toolpaths; and 

 Toolpaths panel, displayed in the 2D Toolpaths area. 

The toolpaths that can be used to machine a composite relief are 
available from the: 
 Project panel, displayed in the 3D Toolpaths area below the 

splitter bar when  Toolpaths is selected in the Project Tree; 

 Menu Bar, displayed by clicking Toolpaths > 3D Toolpaths; and 

 Toolpaths panel, displayed in the 3D Toolpaths area. 

Selecting a toolpath 
Select the type of toolpath you want to create: 
1 To create a 2D toolpath, in the 2D Toolpaths area of the Project 

or Toolpaths panel, click the: 

 Create 2D Profiling Toolpath  button to display the 
Profiling panel, which enables you to create a toolpath that 
machines along, inside or outside the boundary of a selection 
of vectors. 

Creating toolpaths 
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 Create Area Clearance Toolpath  button to display the 2D 
Area Clearance panel, which enables if you to create a toolpath 
that clears an area of material within a selected vector or 
between selections of vectors. 

 Create V-Bit Carving Toolpath  button to display the V-Bit 
Carving panel, which enables you to create a toolpath that 
reproduces an engraved or recessed look when machining 
vector text or a selection of vectors. 

 You cannot machine a V-Bit Carving toolpath without using 
a 3-axis machine. For further information, consult a 
member of staff or your machine tool supplier. 

 Create Bevel Carving Toolpath  button to display the 
Bevel Carving panel, which enables you to create a toolpath 
that reproduces a bevelled (angle-edged) look when 
machining vector text or a selection of vectors. 

 You cannot machine a Bevel Carving toolpath without using 
a 3-axis machine. For further information, consult a 
member of staff or your machine tool supplier. 

 Create Engraving Toolpath  button to display the Smart 
Engraving panel, which enables you to create a toolpath that 
engraves within or around the boundary of vector text or a 
selection of vectors. 

 Create Drilling Toolpath   button to display the Drilling 
panel, which enables you to create a toolpath that drills holes 
using a selection of vectors or a 2D toolpath preview. 

 Create Inlay Toolpath  button to display the Inlay Wizard 
panel, which enables you to create a toolpath that machines a 
selection of vectors that represent corresponding inlays 
(female) and inserts (male). 

 Create Raised Round Toolpath  button to display the 
Raised Round panel, which enables you to create a toolpath 
that enables you to create precise recessed letters and shapes 
using vector text or a selection of vectors. 
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 Create Texture Toolpath  button to display the Texture 
Toolpath panel, which enables you to create a toolpath that 
machine a texture across the whole surface, or a specific area, 
of your model using only a tool's geometry and machining 
parameters. 

 Create Drill Bank Toolpath  button to display the Drill 
Banks panel, which enables you to machine a pattern such as 
L, + or T shapes containing any number of drills to match the 
Drill Bank on your machine. ArtCAM considers the selected 
geometry and applies a toolpath for all X and Y axis holes 
containing a 32 mm (1.26") pitch (standard pitch value for 
most machines).   

 Open 2D Machining Wizard  button to display the 2D 
Machining Wizard panel, which provides a fully automated 
nested-based manufacturing solution for makers of custom 
furniture and cabinetry. 

2 To create a 3D toolpath, in the 3D Toolpaths area of the Project 
or Toolpaths panel, click the: 

 Create Machine Relief Toolpath  button to display the 
Machine Relief panel, which enables you to create a toolpath 
that machines the whole of the composite relief or a particular 
area within a vector boundary. 

 Create Feature Machining Toolpath  button to display the 
Feature Machining panel, which enables you to create a 
toolpath that machines Raised, Recessed or Centreline 
Engraved features created from vector artwork. 

 Create Z Level Roughing Toolpath  button to display the Z 
Level Roughing panel, which enables you to create a toolpath 
that removes unwanted material in planar slices when 
machining the composite relief. 

 If you are working in ArtCAM Insignia, the Create Z Level 

Roughing Toolpath  button is not included. 
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 Create Laser Machining Toolpath  button to display the 
Laser Machining panel, which enables you to create a toolpath 
that removes layers of unwanted material when machining the 
composite relief using a laser-engraving machine. 

 Create 3D Cut Out (Profile) Toolpath  button to display the 
3D Cut Out panel, which enables you to create a toolpath that 
machines the area of the composite relief either inside or 
outside the boundary of a selection of vector artwork. 

 If you are working in ArtCAM Insignia, the Create 3D Cut Out 

(Profile) Toolpath  button is not included. 

 Create 3D Rest Machining Toolpath  button to display the 
3D Rest Machining panel, which enables you to identify all 
areas of the composite relief that cannot be machined when 
using a chosen tool, and create a toolpath to machine all 
remaining areas in the composite relief using a second smaller 
tool. 

 If you are working in ArtCAM Insignia, the Create 3D Rest 

Machining Toolpath  button is not included. 

 

Specifying what you are machining 
Almost all of the toolpath panels include a Vector Association or Area 
To Machine area. This contains at least one list box that enables you 
to control what vector artwork or which part of the composite relief 
is machined by the toolpath. 

Specify what part of your model you want to machine: 

1 To machine vector artwork directly or use vectors to control 
which area of the composite relief is machined: 
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a Click the Vector Association or Area To Machine list box, then 
Selected Vectors or the vector layer's name. For example, 
Default Layer. 

 
b If you have selected Selected Vectors, select the vector 

artwork (see page 122) you want to use. 

c If you have chosen a specific vector layer (see page 124), 
make sure it contains all of the vector artwork you want to 
use. 

The Profiling and 3D Cut Out panels also include a Profile Type list 
box that enables you to control how the vector artwork is 
machined. Select: 
 Along to machine along the vector boundary; 

 Inside to machine within the boundary; or  

 Outside to machine outside the vector boundary. 

 
2 To machine the composite relief: 

a Make sure that only the relief layers that make up the 
composite relief you want to machine are visible (see page 
169). 

b Click the Area To Machine list box, then Whole Relief. 
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The Machine Relief panel's Area To Machine list box includes an 
additional option that enables you to machine as closely as 
possible to the composite relief above or below its base height 
using a chosen tool: Automatic Boundary. 

 
A boundary vector is calculated from the tool's geometry and is 
drawn on the currently active vector layer (see page 124). 
The Texture Toolpath panel's Area To Machine list box includes an 
additional option that enables you to machine the model area: 
Whole Model.  

 
 

Specifying the cutting parameters 
Almost all of the toolpath panels include a Cutting Parameters area 
with one or more of the following settings: 
 Start depth or Surface Z sets the surface depth at which a tool 

begins machining. 
 Finish depth or Finish Z sets a tool's final cutting depth. 

 Allowance or Offset Allowance specifies an offset around the 
vector boundary or the composite relief. This leaves additional 
material during intermediate machining passes for a tool to clear 
during the last pass. 

 Tolerance controls how closely and accurately a tool follows the 
curvature of a vector boundary or composite relief. Although a 
tight tolerance produces a quality finish, it can also significantly 
increase toolpath calculation and machining times. 

Some toolpath panels include additional allowances and cutting 
parameters for particular types of tools. 
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Specify your toolpath's cutting parameters: 

 
Panel Cutting Parameters 

Profiling Start Depth, Finish Depth, 
Allowance and Tolerance.  
Provided the Profile Type is set to 
Outside or Inside, you can specify a 
Final Pass Thickness and Final Pass 
Allowance.  

Area Clearance Start Depth, Finish Depth, 
Allowance, Final Tool Allowance, 
Tolerance and Independent Finish 
Depth. 

V-Bit Carving Start Depth and Tolerance. 
Limit Tool Maximum Depth is 
optional. 

Bevel Carving Start Depth, Wall Height, Finish 
Depth, Allowance and Tolerance. 

Smart Engraving Start Depth, Finish Depth, 
Tolerance, Allowance and 
Independent Finish Depth. 

Drilling Start Depth, Finish Depth and 
Plunge Clearance. 

Inlay Start Depth, Finish Depth, 
Allowance and Tolerance. 
Depth and Width if the inlay is 
stepped. 

Raised Round Start Depth, Finish Depth and 
Tolerance. 

Texture Toolpath  Start Depth, Minimum Finish Depth 
and Maximum Finish Depth. 

Drill Banks Start Depth, Finish Depth, Plunge 
Clearance, Circle Tolerance and 
Pitch Tolerance. 

Machine Relief Allowance and Tolerance. 

Feature 
Machining 

Feature Height or Depth, Feature 
Allowance and Allowance. 
Overcut Distance if Area Clear 
strategy is used. 
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Panel Cutting Parameters 

Z Level Roughing Surface Z, Allowance and Last Slice 
Z. 

Laser Machining Surface Z, Slice Thickness, Last 
Slice Z, Stepover and Angle 
Increment. 

Cut Out (Profile) Surface Z, Finish Z, Allowance and 
Tolerance.  

Rest Machining Cusp Tolerance. 

 If you are working in ArtCAM Insignia, the Cut Out (Profile) and 
Rest Machining toolpaths are not available. 

 

Using tools from the Tool Database 
All of the toolpath panels require that you select at least one tool 
from the Tool Database. Some toolpaths enable you to select several 
tools. 

When a toolpath requires only one tool, there is one tool area on 
the panel. When a toolpath requires or enables you to use two tools 
or more, the panel includes: 
 a Tools List; or 

 a separate area for each tool. 
For example, the 2D Area Clearance and Smart Engraving toolpath 
include a Tools List, and the Bevelled Carving toolpath includes a 
Carving Tool and Profiling Tool area. 

Choose the tools you want to use: 
1 If there is a Tool area on the panel: 

a Click the control bar to display the Tool Database. 

 
The area's name often includes the type of tool you need. For 
example, Profiling Tool or Carving Tool. 

On the control bar, Click to select... or Undefined is displayed 
when no tool is selected. 
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b In the Tool Database, double-click the name of the tool you 
want to use:  

 
The Tool Database closes, and your selected tool's description 
is displayed on the control bar. For example, End Mill 10 mm. 
For further details on using the Tool Database, see Using the 
Tool Database (see page 256). 

2 To replace the tool in the Tool area: 

a Click the control bar to display the currently selected tool's 
parameters. 

b Click Select... to display the Tool Database. 

c From the Tool Database, double-click the name of the tool you 
want to use instead. The Tool Database is closed, and your 
selected tool's description replaces what was previously shown 
on the control bar. For example, End Mill 3 mm. 

3 If there is a Tools List on the panel:  

a Below the Tools List, click Add.  

 
The Tool Database is displayed. 
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b From the Tool Database, double-click the name of the tool you 
want to use. The Tool Database is closed, your selected tool's 
description is displayed in the Tools List, and the tool is 
selected. 

 If you are working in ArtCAM Insignia, you can only add 
one tool to the Tools List. 

A control bar is displayed below the Tools List, on which the 
tool's description is shown. Below the control bar, the tool's 
parameters are displayed. For example, Stepover and Stepdown. 
You can change the tool's parameters by specifying them in the 
boxes. Updating the parameters here does not affect those in the 
Tool Database.  

4 To remove a tool from the Tools List: 
a In the Tools List, click the tool's description. For example, End 

Mill 3 mm. It is highlighted. 
b Click Remove. 

 
If there are no other tools included in the Tools List, the control 
bar is no longer displayed. If there is at least one other tool left 
in the Tools List, the tool which was previously below the deleted 
tool is now selected, and its description is shown on the control 
bar instead. The tool is not removed from the Tool Database. 

 

Selecting a strategy 
The strategy controls the way in which your selected vector artwork 
or composite relief is machined. 

When creating a toolpath, you are given a choice between two 
instances of a single strategy. For example, Raster or Raster 
(Classic). The "(Classic)" suffix indicates that a particular strategy: 

 does not make use of multithreaded technology; 

 is less memory-intensive; 

 is better suited where radiused conical tools are used; and 

 creates a surface finish familiar to users of ArtCAM 2011 and 
earlier. 
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To choose a strategy: 
1 If there is a Tools List on the panel, click the tool's description. 

For example, End Mill 3 mm. 
2 Click the Tool Clearance Strategy list box, then: 

 Raster or Raster (Classic) to machine in passes back and forth 
along the X-axis at a specified angle. 

 If you are working in ArtCAM Insignia, these strategies are 
named Raster in X and Raster in X (Classic), and you cannot 
specify the angle. 

 Raster X & Y or Raster X & Y (Classic) to machine in passes 
back and forth along the X and Y axes at a specified angle. 
Machining in two perpendicular directions increases the 
machining time, but typically produces a superior surface 
finish. 

 If you are working in ArtCAM Insignia, you cannot specify 
the angle. 

 Offset (Classic) to machine in repeated passes, each time 
moving inwards or outwards by the tool's Stepover. 

 If you are working in ArtCAM Insignia, this strategy is not 
available. 

 3D Offset to machine using a consistent stepover, regardless 
of direction. This technique is best suited to machining steep 
and near vertical surfaces. 

 If you are working in ArtCAM Insignia, this strategy is not 
available. 

 3D Offset Spiral to machine in a spiral motion, where the 
stepover is consistent regardless of direction. This minimises 
the number of lifts of the tool and maximises cutting time 
while maintaining more constant load conditions and 
deflections on the tool. 

 If you are working in ArtCAM Insignia, this strategy is not 
available. 

 Spiral to machine in a spiral motion. When the tool reaches 
the first edge of the composite relief, it stops. If the 
composite relief is rectangular in shape, this means that only 
part of it is machined. 

 If you are working in ArtCAM Insignia, this strategy is not 
available. 



 

246 • Creating toolpaths ArtCAM 2012 User Guide  

 Spiral in Box to machine in a spiral motion. When the tool 
reaches the first edge of the composite relief it retracts, 
traverses along the edge of the composite relief, and then 
plunges to continue machining the next area of the composite 
relief. This strategy allows you to machine the entire 
composite relief but can also be time consuming. 

 If you are working in ArtCAM Insignia, this strategy is not 
available. 

 

 If you cannot see the tool's Stepover on the panel, click  
on the control bar displaying the tool's description. 

3 If you have selected Raster, Raster (Classic), Raster X & Y or 
Raster X & Y (Classic), specify the angle in the Angle box. 

 If you are working in ArtCAM Insignia, the Angle box is not 
displayed. 

4 If you have selected Offset (Classic): 
a Click the Cutting Direction list box, then: 

Climb to revolve the tool in the same direction as the table 
feed. The tooth meets the material at the top of the cut, 
producing the thickest part of the chip first. Typically, this 
improves the surface finish and increases tool life. 
Conventional to revolve the tool in the opposite direction to 
the table feed. The width of the chip starts at zero, and 
increases to a maximum at the end of the cut. This can lead 
to accelerated tool wear and an inferior surface finish. 
Both to revolve the tool in either direction, as required. 

 

 In ArtCAM Pro and JewelSmith, the option to use both climb 
and conventional milling is limited to the Machine Relief 
toolpath. If you are working in ArtCAM Insignia, the Both 
option is not available. 
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 Some toolpaths use nothing other than an offset strategy, 
therefore only the Cutting Direction list box is displayed on 
its panel. For example, Profiling and Bevel Carving.  

a Click the Start From list box, then: 

Start Outside to machine inwards from the boundary; or 

Start Inside to machine outwards from the centre, towards the 
boundary. 

 

 Although several toolpaths with an Offset option include 
Start From settings, such as 2D Area Clearance and Machine 
Relief, others do not. For example, Smart Engraving. 

 

Setting Z slices 
When calculating a Machine Relief toolpath and using a Roughing 
Tool, you can control the number of Z passes used to machine 
between the top of the material block and the composite relief's 
lowest point. You can do the same with a Laser Machining toolpath. 

 If your Roughing Tool's Allowance is set to zero, dwell marks 
may remain on the material surface after the final machining 
pass. 

To set the number of slices in your toolpath: 
1 Click the Z Slices control bar to display the settings. 

2 To enable ArtCAM to calculate the number of slices using the 
composite relief's Z dimensions, material block dimensions and 
your Roughing Tool's specified Stepdown, Allowance and 
Tolerance, select the Automatic check box. The: 

 Start/Surface Z is equal to the top of the material block or, 
where you have not specified your material block dimensions, 
the composite relief's maximum Z height. 

 Last Slice Z is equal to the composite relief's minimum Z 
height, together with your Roughing Tool's specified Allowance 
and Tolerance. 

 Number of Slices is the result calculated from the Z heights 
and the Roughing Tool's Stepdown, Allowance and Tolerance. 

 Slice Thickness is equal to or less than the selected Roughing 
Tool's Stepdown. 



 

248 • Creating toolpaths ArtCAM 2012 User Guide  

 If you cannot see the tool's Stepdown on the panel, click  
on the control bar displaying the tool's description. For 
example, End Mill 10 mm. 

3 To control the number of slices and their thickness: 
a Deselect the Automatic check box. The Start/Surface Z and Last 

Slice Z boxes are enabled. 

b In the Start/Surface Z box, specify the Z height of the first 
slice.  

c In the Last Slice Z box, specify the Z height of the last slice. 

d Click Apply to calculate the number of slices and their 
thickness. Your Roughing Tool's specified Stepdown, Allowance 
and Tolerance are also used during the calculation process. 

 

Adding lead moves 
Lead moves are a precautionary measure to prevent dwell marks on 
a machined piece at the point where the tool enters and leaves the 
material block when machining a profile pass.  

Instead of plunging into the material block, machining the profile, 
and then retracting, the tool enters and leaves the block at a 
particular position in the profile from a specified distance. The entry 
and exit positions can be the profile's start and end points, or the 
mid of it's longest span. 

You can apply lead moves to a: 
 new or previously calculated Profiling or 3D Cut Out toolpath; or  

 previously calculated Bevel Carving, Female Inlay or Male Insert 
toolpath.  

To add lead moves: 
1 If you are creating a new toolpath, select the Add Lead In / Out 

Moves check box to display its associated settings. 

 
2 If you are adding lead moves to a previously calculated toolpath, 

use one of the following methods to display the Profile Options 
settings on the Tool Settings panel: 
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 From the Project panel, select the tool's name  in the 

Project Tree, then click the Profile Options  button 
displayed below the splitter bar; 

 From the Project panel, right-click the tool's name  in the 
Project Tree, then select Profile Options in the context menu; 
or 

 
 From the Toolpaths panel, select the tool's name from the list 

above the Toolpath Operations area, then click the Profile 

Options  button in the 2D Toolpaths area. 

3 In the Distance (D) box, specify the distance from the profile at 
which the tool cuts into and retracts from the material block. 

4 In the Overcut (O) box, specify the distance you want the tool to 
machine beyond the the profile's start and end point. This further 
helps to create a smooth finish. 

5 Select: 
 the Do not lead out check box if you want to add lead in moves 

only. 
 Linear if you want the tool to lead into and out of the material 

block in a straight-line motion. 

When you calculate the toolpath, ArtCAM checks that the lead 
move's distance is within the profile's boundary. If your 
specified distance causes the lead move to intersect with the 
profile, it is clipped so that it does not. 
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 Circular Arc if you want to instruct the tool to lead into and out 
of the material block in an arc motion. 

When you calculate the toolpath, ArtCAM checks that the lead 
move's radius is within the profile's boundary. If your 
specified radius causes the lead move to intersect with the 
profile, a linear lead with a distance within the profile's 
boundary replaces the arc lead. 

If ArtCAM makes any necessary changes to the lead moves, a 
message box is displayed during the calculation process. 

6 If you are adding linear lead moves: 
a In the Angle In box, specify the lead in move's angle. 

b If you are adding lead out moves, specify their angle in the 
Angle Out box. 

c If you are creating a new toolpath and want the tool to ramp 
from the surface depth to the profile rather than plunge, 
select the Ramp from surface check box. The surface depth is 
equal to your specified Start depth or Surface Z value. The 
ramp length is equal to your specified Distance (D) value. 

d If you are creating a new toolpath and want to position lead 
moves at the profile's start and end points only, deselect the 
Automatic positioning check box. Otherwise, ArtCAM positions 
the lead moves at the mid of profile's longest span; which is 
also the longest span in the vector artwork used to create the 
toolpath.  

e If you are creating a new toolpath and want to apply cutter 
compensation commands (G41 - comp left and G42 - comp 
right) to the NC code associated with the profile's start and 
end point, select the Cutter compensation check box. 

Cutter compensation enables your machine tool's controller to 
calculate the offset toolpath based on the profile that is 
specified in the NC code. The offset value is typically stored in 
the controller's memory. The main advantage of this approach 
is that changes to the offset value are completed on the 
machine without editing the NC code. This is very practical 
when making adjustments to compensate for tool wear or 
changing to a tool with different diameter. 

 The Ramp from surface, Automatic positioning and Cutter 
compensation check boxes are not available on the Tool 
Settings panel. These are only available when creating a 
toolpath. 
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7 If you are adding circular lead moves, specify the arc move's 
radius in the Radius (R) box. This must be equal to or greater 
than the value in the Distance (D) box, otherwise a message box 
is displayed. 

8 If you are adding lead moves to a previously calculated toolpath, 
click Apply. 

If the previously calculated toolpath includes ramping or cutter 
compensation and you have selected Circular Arc, a message box 
is displayed warning that the two are incompatible. To apply 
circular arc lead moves to the profile, you must: 

a edit the toolpath. 

b change your original lead move settings.  

c recalculate the toolpath. 
If you have selected Circular Arc and your specified Radius (R) 
value is greater than the Distance (D) value, a message box is 
displayed warning that the distance must be less than or greater 
than the radius. To apply circular arc lead moves to the profile, 
you must: 

 reduce their radius so that it is equal to or less than their 
distance; or  

 increase their distance so that it is equal to or greater than 
their radius. 

 

Adding ramping moves 
When machining hard stock material, ramping the tool significantly 
reduces the load on the tool and the Z axis of your machine. You 
can add ramping moves to Profiling, 2D Area Clearance, Smart 
Engraving, Inlay, Machine Relief, Z Level Roughing or 3D Cut Out 
toolpaths. 

To add ramping moves to your toolpath: 
1 Select the Add ramping moves or Add ramping check box. 

 
2 If you are creating a Machine Relief toolpath: 

a In the Max Zig Angle box, specify the angle of descent as the 
tool ramps into the material block. 

b In the Plunge Height box, specify the Z height from which the 
ramp descends.   
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c Select the Limit Length check box, then, in the Ramp Length 
(TDU) box, specify the maximum ramp distance relative to the 
tool's diameter. Typically, the ramp length should be greater 
than the tool diameter to allow chips to clear from beneath 
the tool.  

d Select the Independent zag angle check box, then, in the Zag 
Angle box, specify the second angle of descent if your tool 
does not reach the start of the toolpath segment in a single 
pass. 

 If you are working in ArtCAM Pro or JewelSmith and have 
selected Raster (Classic), Raster X & Y (Classic) or Offset 
(Classic) as your tool clearance strategy, the Independent 
zag angle check box is not displayed. If you are working in 
ArtCAM Insignia and have Raster in X (Classic) selected as 
your tool clearance strategy, the Independent zag angle 
check box is not displayed. 

3 If you are creating another toolpath, specify the type of ramp 
you want to use. Click: 
 Spiral to descend in a helical ramp motion around the profile's 

perimeter. 
 ZigZag to descend in linear zig zag moves with a specified Z 

angle and distance.  
 Smooth to add a short linear ramp to each toolpath segment. 

If you have selected ZigZag or Smooth: 

a In the Max Ramp Angle (A) box, specify the maximum usable 
slope for ramping down to depth. Setting this to 0 causes a 
plunge cut.  

 The ideal ramp angle should be between 0 and 20 degrees 
from the table surface. This angle enables the tool to enter 
into the material block at 100% of the feed rate. At any 
angle greater then 20 degrees, the feed rate should be 
reduced accordingly. 

a In the Max Ramp Length (L) box, specify the maximum 
distance for each linear ramping move. 

b In the Min Ramp Length (Lmin) box, specify the minimum 
distance for each linear ramping move.  

If you have selected ZigZag, specify the Z height from which the 
ramp descends in the Zig Start Height (S) box. 
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Setting the machining order 
If your toolpath contains segments, you can control the order in 
which they are machined. These toolpaths include Profiling, V-Bit 
Carving and Drilling. 

You can instruct ArtCAM to calculate the machining order, or use a 
polyline drawn on a vector layer to map the order.  

1 To use a preset machining order: 
a Click the Cut Sequence control bar to display it settings. 

b Click to select the Automatic option. 

c Click the list box, then: 
Optimise to instruct ArtCAM to calculate the most efficient 
machining order. 
Use Text Order if you are machining vector text and want to 
machine in the order in which it was created. 
Left to Right to machine from the left of the model area to the 
right. 
Right to Left to machine from the right of the model area to 
the left. 
Bottom to Top to machine from the bottom of the model area 
to the top. 
Top to Bottom to machine from the top of the model area to 
the bottom. 
Spiral Out to machine from the centre of the model area 
outwards in a spiral motion. 
Spiral In to machine from the outside edge of the model area 
inwards in a spiral motion. 

 
Your selected option is displayed on the control bar. 

2 To set the order using an open, ungrouped vector: 
a Click the Cut Sequence control bar to display it settings. 

b Click to select the Manual option. 
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c Draw (see page 136) and select (see page 122) a polyline on 
a vector layer that follows the order in which you want to 
machine the toolpath segments. The polyline's start node 
should be positioned (see page 148) close to the toolpath 
segment at which you want to begin machining. 

 You must select an open ungrouped vector to represent the 
machining order. 

a Click the Select Vector button. The No Vector Selected 
message in red text changes to Vector Selected in blue text. 

b Make sure all of the vectors you want to machine are selected 
(see page 122). 

 

Specifying the Safe Z height and Home position 
All toolpaths require that you specify the: 

 height at which your selected tool makes rapid moves between 
toolpath segments; and 

 the X, Y and Z coordinates of the tool's start and end position. 

To set these positions: 
1 In the Options area, click the control bar to display the Safe Z box 

and the Home's X, Y and Z boxes. 

2 In the Safe Z box, specify the height at which your selected tool 
makes rapid moves between toolpath segments. 

 This must be sufficient to clear any clamps used to hold 
your material block or sheet in position. 

3 In the Home's X, Y and Z boxes, type the X, Y and Z coordinates 
of the tool's start and end position. 

 This should be at a safe distance away from your material 
block or sheet. 

4 Click the control bar to hide the Safe Z box and the Home's X, Y 
and Z boxes. 

Your settings are displayed on the control bar. 

 

Specifying the material setup 
The material setup enables you to specify:  

 the thickness of your material block or sheet; and 
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 how the model is positioned relative to your material block or 
sheet.  

To specify your material's thickness and set the position of your 
model relative to the material:  
1 In the Material area, click the control bar. The Material Setup 

dialog box is displayed: 

 
2 In the Material Thickness box, make sure the value is equal to 

that of the material block or sheet you are using for your job. 

If you have already created a composite relief, you cannot set 
the Material Thickness to less than the Z height displayed in the 
Model Thickness area.  

 The composite relief's Z height is also displayed on the 
Project panel when the model is selected in the Project 
Tree. 

3 In the Material Z Zero area, make sure the Z zero position is 
correct by clicking the option beside the top or bottom left of the 
block diagram. 

 The  icon marks the position of the origin relative to the 
material block or sheet. 

4 Make sure that the position of the model relative to the material 
block or sheet is set correctly.  

 To specify the amount of stock material above the composite 
relief's surface, click the Top Offset option in the Model 
Position In Material area, then specify the offset in its 
associated box.  
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 You can adjust the position of the composite relief relative 
to the material block or sheet by clicking and dragging the 
slider: 

 
The value shown in both the Top Offset and Bottom Offset 
boxes is adjusted when the slider is moved. 

 To set the amount of stock material below the base of the 
composite relief, click the Bottom Offset option, then specify 
the offset in its associated box. 

 

Calculating the toolpath 
To calculate the toolpath: 
1 In the Name box, type the name you want to give the toolpath. 

2 Choose when you want to calculate the toolpath: 

 To calculate the toolpath at a later time, either by itself or as 
part of a batch of toolpaths, click the Calculate Later button. 

 To calculate the toolpath now, click the Calculate Now button. 

A progress bar is displayed in the Status Bar area during the 
toolpath calculation process: 

 

 You can click  to cancel the toolpath calculation process 
at any time. 

3 Click  on the toolpath panel's header to close it. 

 
 

Using the Tool Database 
When you create a toolpath in ArtCAM, it is necessary to select the 
tool you want to use to machine your selected vector artwork or the 
composite relief. A broad range of pre-defined tools can be selected 
from the Tool Database. You can also specify your own custom tools 
and add them to the Tool Database. 
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To specify and add a custom tool to the Tool Database: 

1 Use one of the following methods to display the Tool Database: 

 From the Project panel, select  Toolpaths in the Project 

Tree, then click the Tool Database  button in the 
Toolpath Operations area displayed below the splitter bar; or 

 From the Toolpaths panel, click the Tool Database  
button in the Tool Operations area. 

 For information on using the Toolpaths panel, see 
Understanding the Toolpaths panel (see page 34). 

 
2 Make sure that the tool group in which you want to add a tool is 

selected by clicking its name. When selected, its name is 
emphasised in blue. 

To add a new tool group: 
a In the Tool/Group Description area, click the Add Group... 

button. The new tool group is named New Group by default 
and is created below whichever item is currently selected in 
the Tools and Groups window. 

 A tool group is identified by the  icon, while a tool is 
identified by the , , , , ,  or  icon. 

a Type the name that you want to give to the new tool group. 
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b Click anywhere in the white area shown in the Tools and 
Groups window to apply the name to the tool group. 

 You can click and drag any of the tools listed in the Tools 
and Groups window into the new tool group you have 
created. 

3 Click the Add Tool... button to display the Edit Tool dialog box: 

 
4 In the Description box, type the name you want to give to your 

tool. 
5 Click the Tool Type list box, then select the type of tool you want 

to add to the Tool Database. An image representing the selected 
tool type is displayed alongside boxes in which you must specify 
the tool's machining parameters. 

6 In the Tool Number box, specify the number of the tool according 
to its current position in your tool changer. 

7 Click the Tool Units list box, followed by the unit of measurement 
associated with your tool. 

8 Click the Rate Units list box, followed by the unit of speed 
associated with your tool. 

9 In the Notes box, type any relevant information concerning the 
practical uses of your tool. 

10 In the column of boxes on the right, specify your tool's 
machining parameters. For example, Diameter, Stepdown and 
Feed Rate. 
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11 Click OK to add your tool to the Tool Database. The tool is listed 
in the Tools and Groups window, and its details are displayed in 
the Tool/Group Description area. 

12 Click OK to close the Tool Database. 
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Saving toolpaths 
You can save a toolpath as a machine-specific toolpath file or as a 
toolpath template file (*.tpl). 

 When you save an ArtCAM model file (*.art), all of the 
toolpaths created or calculated as part of the model are saved 
in the file. For details, see Saving a model (see page 85). 

You can create a machine-specific toolpath file from any of your 
calculated toolpaths. The toolpath file can then be sent directly to 
your CNC machine tool. 
You can create a toolpath template file (*.tpl) from any of your 
created or calculated toolpaths. A template contains all of the 
original settings you have used when creating the toolpaths. The 
toolpath settings saved within a template can be applied to selected 
vector artwork drawn across the vector layers in an ArtCAM model. 
A toolpath template file can be imported into an ArtCAM model. 

To save a toolpath as a machine-specific file: 
1 Use one of the following methods to display the Save Toolpaths 

dialog box: 

 From the Project panel, select  Toolpaths in the Project 

Tree, then click the Save Toolpaths  button in the 
Toolpath Operations area below the splitter bar; 

 From the Project panel, right-click  Toolpaths in the Project 
Tree, then select Save Toolpaths As from the context menu; 

 From the Menu Bar, click Toolpaths > Save Toolpaths As; 

 From the Toolpaths panel, click the Save Toolpaths  
button in the Toolpath Operations area. 
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 For information on using the Toolpaths panel, see 
Understanding the Toolpaths panel (see page 34). 

 
2 In the Calculated toolpaths window, select the toolpath you want 

to save as a single machine-specific toolpath file. The toolpath's 
name is highlighted. 

 To select more than one toolpath, hold down the Ctrl key 
then click each of the toolpaths' names. 

3 Click  to transfer all selected toolpaths to the Toolpaths to 
save to a single file window. 

 The  button is displayed when all toolpaths are listed in 
the Toolpaths to save to a single file window.  

4 Make sure that the toolpaths are listed in the correct machining 
order: 

 Click the  or  button to set the order in which the 
toolpaths are saved. Each click on these buttons moves the 
selected toolpath one position in the list. The name of the 
selected toolpath is highlighted. 

 The  button is displayed if the toolpath at the bottom 
of the list shown in the Toolpaths to save to a single file 
window is selected. 

 The  button is displayed if the toolpath at the top of 
the list shown in the Toolpaths to save to a single file window 
is selected. 
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 Both the  and  button are displayed when all 
toolpaths are listed in the Calculated toolpaths window. 

 Click  to transfer the toolpath selected in the Toolpaths to 
save to a single file window back to the Calculated toolpaths 
window. The name of the selected toolpath is highlighted. 

 Click  to transfer all toolpaths listed in the Toolpaths to 
save to a single file window to the Calculated toolpaths window.  

 The  and  buttons are greyed-out  when all 
toolpaths are listed in the Calculated toolpaths window. 

5 Click the Machine output file is formatted for list box, followed by 
the machine format you require. 

 If you are saving toolpaths that make use of a variety of 
tools in a single output file, you must use a machine that 
has been formatted with a tool changer. 

6 To save the machine-specific toolpath file to a specific spool 
directory on your computer, select the Save files to spool directory 
check box. 

 If you have not selected a spool directory, click the Spool 
Dir... button to display the Browse For Folder dialog box. 
Create or select the folder on your computer where you 
want to save your machine-specific toolpath files, and then 
click  OK to confirm it as the spool directory. 
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7 Click Save to display the Save As dialog box: 

 
You can see that the machine format that you chose from the 
Machine output file is formatted for list box in the Save Toolpaths 
dialog box is shown in the Save as type list box. 

8 Click the Save in list box or use the Up One Level button  to 
navigate to the folder on your computer in which you want to 
save the machine-specific toolpath file. 

 If the Save files to spool directory option is selected in the 
Save Toolpaths dialog box, its location is shown in the Save 
in list box. 

9 In the File name box, type the name that you want to give to the 
machine-specific toolpath file . 

10 Click Save to save the toolpaths listed in the Toolpaths to save to a 
single file window as a machine-specific toolpath file and close 
the Save As dialog box. 

11 Click Close to close the Save Toolpaths dialog box. 

 To close the Save As dialog box without saving the 
machine-specific toolpath file, click Cancel. 

To save a toolpath as a template file: 
1 On the Project panel or Toolpaths panel, make sure that only the 

toolpaths you want to save as a template are listed. The 
toolpaths can be created or calculated.  
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 On the Toolpaths panel, created toolpaths are listed in red 
text (or yellow when selected) and calculated toolpaths are 
listed in black text. For information on using the Toolpaths 
panel, see Understanding the Toolpaths panel (see page 
34). 

2 Use one of the following methods to display the Save Toolpath 
Template dialog box: 

 From the Project panel, select  Toolpaths in the Project 

Tree, then click the Save Toolpaths As Template  button 
in the Toolpath Operations area below the splitter bar; 

 From the Project panel, right-click  Toolpaths in the Project 
Tree, then select Save Toolpaths As Template from the context 
menu; 

 From the Menu Bar, click Toolpaths > Save Toolpaths As 
Template; or  

 From the Toolpaths panel, click the Save Toolpath As Template 

 button in the Toolpath Operations area. 

 



 

ArtCAM 2012 User Guide Creating toolpaths • 265  

3 Click the Save in list box or use the Up One Level  button to 
navigate to the folder on your computer in which you want to 
save the template. 

4 In the File name box, specify the name you want to give to the 
template. 

5 Click Save to close the Save Toolpath Template dialog box and 
save the template. 

 To close the Save Toolpath Template dialog box without 
saving the template, click Cancel. 
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You can simulate calculated toolpaths in the 2D View and 3D View 
window. This enables you to envision the machining passes used to 
create your finished piece. 

 In the Project panel's Project Tree and on the Toolpaths panel, 
the names of calculated toolpaths are listed in black. The 
names of uncalculated toolpaths are listed in red. 

In the 2D View window, you can simulate calculated 2D toolpaths as 
solid colours. These toolpaths include: Profile, Area Clearance, V-Bit 
Carving, Bevel Carving, Smart Engraving, Drilling, Inlay, Raised 
Round, Texture and Drill Banks. 

A solid colour toolpath simulation is a more informative display of a 
2D toolpath than that offered by its default wireframe preview. For 
example, where each of the tools in a calculated toolpath are 
assigned a different colour, a the solid colour simulation might look 
something like this: 

 

Simulating toolpaths 
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In the 3D View window, you can simulate calculated 2D or 3D 
toolpaths in a simulation block. You can control how the toolpath 
simulation is rendered and apply a depth colour to all areas of the 
simulation below the Z zero height. This enables you to clearly 
envision the finished piece. For example, the same simulated 2D 
toolpaths shown above might look something like this: 

 
You can simulate calculated toolpaths: 
 From the Project panel, using the context menu and tools 

associated with the  Toolpaths, toolpath  and tool  items 
in the Project Tree; 

For example, right-clicking a Profile toolpath's End Mill 3 mm tool 
displays the following context menu: 
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 From the Menu Bar, using the Toolpaths > Simulation menu. 

  

 If you are working in ArtCAM Insignia, the Load Simulation, 
Save Simulation As..., and Create Relief From Simulation 
options are not included. 

 From the Simulation toolbar. 

 

 The Simulation toolbar is hidden (see page 301) by default. 
When displayed for the first time, it is floating over the 
viewing area. 

 If you are working in ArtCAM Insignia, the last three 
buttons are not included. 
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 From the Toolpaths panel, using the tools in the Toolpath 
Simulation area. 

 

 If you are working in ArtCAM Insignia, the last three 
buttons are not included. 

 The Toolpaths panel is hidden (see page 301) by default. 
When displayed it is docked and pinned on the left. 

 

Simulating 2D toolpaths in the 2D View window 
Calculated 2D toolpaths can be displayed in the 2D View window as 
a wireframe preview and a solid colour simulation. They are shown 
as a wireframe preview only by default. Displaying toolpaths as a 
solid colour simulation enables you to see the areas of the vector 
artwork machined by your chosen cutting tools, and how effectively 
the toolpath reproduces the integrity of your original design. 

In the example below, the solid colour simulation on the left 
confirms you would need to use a tighter tolerance in your toolpath 
in order to preserve the letter's profile. The image on the right 
shows the simulation of the same toolpath with a tighter tolerance: 
Letter 'a' using a loose 
tolerance… 

 

Letter 'a' using a tighter 
tolerance… 
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Each of the tools used in a calculated 2D toolpath is assigned the 
colour brown by default, but you can change this. When you assign 
a different colour to a tool, it is applied to all subsequent toolpaths 
where the same tool is used. For example, if you assign blue to a 3 
mm End Mill tool, then the simulation for all subsequent toolpaths 
using a 3 mm End Mill tool will be displayed in blue. This does not 
apply retrospectively, so previous toolpaths using the same tool do 
not use the newly assigned colour. 

To control how and what calculated 2D toolpaths are displayed in 
the 2D View window: 

1 Specify which calculated toolpaths you do not want to display as 
a wireframe preview, using one of the following methods: 

 From the Project panel, click  beside the toolpaths  or 
tool names  in the Project Tree; or 

 From the Toolpaths panel, click  beside the tool names 
listed above the Toolpath Operations area. 

2 Specify which calculated toolpaths you want to display as a solid 
colour simulation using one of the following methods: 

 From the Project panel, click  beside the toolpaths  or 
tool names  in the Project Tree; or 

 From the Toolpaths panel, click  beside the tool names 
listed above the Toolpath Operations area. 

3 To associate a colour with a tool, use one of the following 
methods to display the Color box: 

 From the Project panel, select the tool  in the Project Tree, 
then click the Simulation colour swatch  in the Parameters 
area displayed below the splitter bar; or 
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 From the Toolpaths panel, click the swatch  beside the tool's 
name in the list above the Toolpath Operations area. 

 
For details on using this dialog box, see Assigning a colour to a 
vector layer (see page 126). 

 

Simulating toolpaths in the 3D View window 
You can simulate calculated toolpaths in the 3D View window in four 
different ways. You can simulate: 

 a specific toolpath; 

 a particular tool used in a toolpath;  

 a particular region of a toolpath, specified by a selected vector;  

 all toolpaths in succession. 

 In the Project panel's Project Tree and on the Toolpaths panel, 
the names of calculated toolpaths are listed in black, while the 
names of uncalculated toolpaths are listed in red. 

You can choose between three toolpath simulation methods. Use 
the:  
 Simulate All Toolpaths method to display a simulation block and 

quickly simulate all of your toolpaths. 
 Simulate Toolpath method to display a simulation block and 

quickly simulate a specific toolpath or tool used as part of a 
toolpath. 
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 Simulation Control Bar method to display a simulation block and a 
toolbar you can use to simulate your toolpaths in greater detail 
and with far greater control. 

When using the Simulation Control Bar method, a wireframe tool is 
displayed to simulate the tool moves. The simulation block is 
gradually updated to simulate the results of the machining process.  
For example, the image below illustrates the wireframe of a V-Bit 32 
mm 130 degree tool machining bevel carved text into the simulation 
block: 

 
 

To simulate a specific toolpath or particular tool used as part of a 
toolpath: 

1 Use one of the following methods to select the calculated 
toolpath or tool you want to simulate: 

 From the Project panel, click  beside  Toolpaths in the 
Project Tree to display your toolpaths, then click the toolpath 

 or tool's  name.  
 From the Toolpaths panel, click the toolpath or tool's name in 

the list shown above the Toolpath Operations area. 

The selected toolpath or tool's name is highlighted. 

2 To simulate the toolpath quickly, use one of the following 
methods: 

 From the Project panel, right-click the toolpath  or tool's 
name  in the Project Tree, then click Simulate Toolpath 
from the context menu; 
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 From the Project panel, click the Simulate Toolpath  
button in the toolset displayed below the splitter bar; 

 From the Menu Bar, click Toolpaths > Simulation > Simulate 
Toolpath; 

 From the Simulation toolbar, click the Simulate Toolpath  
button; or 

 From the Toolpaths panel, click the Simulate Toolpath  
button in the Toolpath Simulation area. 

3 To simulate the toolpath in more detail and with greater control, 
use one of the following methods: 

 From the Project panel, right-click the toolpath  or tool's 
name  in the Project Tree, then click Simulation Control Bar 
from the context menu; 

 From the Project panel, click the Simulation Control Bar  
button in the toolset displayed below the splitter bar; 

 From the Menu Bar, click Toolpaths > Simulation > Simulation 
Control Bar; 

 From the Simulation toolbar, click the Simulation Control Bar 

 button; or 
 From the Toolpaths panel, click the Simulation Control Bar 

 button in the Toolpath Simulation area. 
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The 3D View window is displayed. If you are simulating for the 
first time, the Toolpath Simulation - Block Definition dialog box is 
also shown. 

 
The Relief Dimensions area displays the composite relief's 
dimensions and resolution. 
The Simulation Block Dimensions area enables you to control how 
much of the toolpath is simulated. By default, the simulation 
block's height (Y) and width (X) is equal to the model (see page 
58) area, while it's thickness and Z zero position are equal to 
specified in your material block settings. 
The Simulation Relief Resolution area enables you to set the 
resolution of the toolpath simulation. 

4 Set the simulation block's height (Y) and width (X). Select: 
 Whole Model to use the model's dimensions. This is selected 

by default. 
 Inside Vector to use a selected vector's dimensions. You can 

select the vector (see page 122) from either the 2D View or 3D 
View window. 

5 Set the simulation block's thickness (Z): 
a In the Top face of block is at height box, specify the Z position 

of the block's top surface. 
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b In the Bottom face of block is at height box, specify the Z 
position of the block's bottom surface. 

6 Set the toolpath simulation's resolution. Click: 
 Fast to prioritise speed and memory consumption over quality 

and detail. 
 Standard to compromise between quality, detail, speed and 

memory consumption. 
 High detail to prioritise detail and quality over speed and 

memory consumption. 
 Custom to use a specific pixel resolution. The default of 1 

pixels per mm equates to a 1.000 mm resolution, which 
makes use of 0.02Mb of memory. If you increase this to 100 
pixels per mm, the resolution increases to 0.010 mm which 
makes use of 200.00Mb of memory. 

 Increasing the resolution can increase the toolpath 
simulation's duration. 

7 Click Simulate Toolpath to close the dialog box and begin the 
toolpath simulation. 

 To change your Simulation Block Dimensions or Simulation 
Relief Resolution settings, you must delete the toolpath 
simulation currently shown in the 3D View window. For 
details, see Deleting a simulation (see page 278). 

If you have chosen the Simulate Toolpath method, the simulation 
block is displayed in the 3D View window, the toolpath simulation 
begins immediately and continues until it is complete. 
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If you have chosen the Simulate Control Bar method, the 
simulation block and wireframe tool is displayed in the 3D View 
window with the Simulation Control toolbar floating over it. 

 

 
 
From the Simulation Control toolbar, click: 

 to pause the simulation. 

 to simulate the selected toolpath's next move, gradually 
updating the simulation block as it does. 

 to simulate the selected toolpath, gradually updating the 
simulation block as it does. 

 to simulate the selected toolpath until its next Z retract 
move, gradually updating the simulation block as it does. 

 to quickly simulate the whole of the selected toolpath. 

 to quickly simulate the selected toolpath up until its next 
retract move. 
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 to stop the simulation and close the Simulation Control 
toolbar. 

 

To simulate all of your calculated toolpaths: 

1 Use one of the following methods to simulate all of your 
calculated toolpaths: 

 From the Project panel, right-click  Toolpaths in the Project 
Tree, then click Simulate All Toolpaths in the context menu; 

 From the Menu Bar, click Toolpaths > Simulation > Simulate All 
Toolpaths; 

 From the Simulation toolbar, click the Simulate All Toolpaths 

 button; or 
 From the Toolpaths panel, click the Simulate All Toolpaths 

 button in the Toolpath Simulation area.  
 

Resetting a simulation 
You can reset a completed toolpath simulation displayed in the 3D 
View window. You cannot reset a simulation when it is being 
calculated. 

When a simulation is reset, the simulation block is kept, but your 
simulated toolpaths are lost. 

Use one of the following methods to reset a simulation: 

 From the Project panel, right-click  Simulation in the Project 
Tree, then click Reset in the context menu; 

 From the Menu Bar, click Toolpaths > Simulation > Reset 
Simulation; 

 From the Simulation toolbar, click the Reset Simulation  
button; or 

 The Simulation toolbar is hidden by default. When displayed 
for the first time, it is floating over the viewing area. 

 From the Toolpaths panel, click the Reset Simulation  
button in the Toolpath Simulation area. 
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 The Toolpaths panel is hidden by default. When displayed 
for the first time, it is docked and pinned on the left. 

 

Deleting a simulation 
You can delete a completed toolpath simulation from the 3D View 
window. You cannot delete a simulation when it is being calculated. 

Use one of the following methods to delete a simulation: 

 From the Project panel, right-click  Simulation in the Project 
Tree, then click Delete in the context menu; 

 From the Menu Bar, click Toolpaths > Simulation > Delete 
Simulation; 

 From the Simulation toolbar, click the Delete Simulation  
button; or 

 The Simulation toolbar is hidden by default. When displayed 
for the first time, it is floating over the viewing area. 

 From the Toolpaths panel, click the Delete Simulation  
button in the Toolpath Simulation area. 

 The Toolpaths panel is hidden by default. When displayed 
for the first time, it is docked and pinned on the left. 

 

Saving a toolpath simulation 
When a toolpath simulation is complete, you can save the 
simulation in one of the following file types: 
 ArtCAM relief (*.rlf); 
 ArtCAM 9 relief (*.rlf); 
 Windows or OS/2 Bitmap (*.bmp); or 

 16-bit Tagged Image File Format (*.tif). 

 If you are working in ArtCAM Insignia, you cannot save a 
toolpath simulation. 

To save a toolpath simulation: 
1 Use one of the following methods to display the Save Simulation 

As... dialog box: 
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 From the Project panel, right-click  Simulation in the Project 
Tree, then click Export in the context menu; 

 From the Menu Bar, click Toolpaths > Simulation > Save 
Simulation As... ; 

 From the Simulation toolbar, click the Save Simulation  
button; or 

 The Simulation toolbar is hidden by default. When displayed 
for the first time, it is floating over the viewing area. 

 From the Toolpaths panel, click the Save Simulation  
button in the Toolpath Simulation area. 

 The Toolpaths panel is hidden by default. When displayed 
for the first time, it is docked and pinned on the left. 

 

2 Click the Save in list box, or use the Up One Level   button, to 
navigate to the folder on your computer in which you want to 
save the toolpath simulation. 

3 In the File name box, specify the name that you want to give to 
the file. 
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4 Click the Save as type list box, followed by the format in which 
you want to save the toolpath simulation. Select: 
 ArtCAM Reliefs (*.rlf) to save the simulation as a relief file 

compatible with your current version of ArtCAM. 
 ArtCAM 9 Relief File (*.rlf) to save the simulation as a relief file 

compatible with ArtCAM 9. 
5 Click Save to save the toolpath simulation and close the dialog 

box. 
 

Loading a toolpath simulation from a 
relief 

You can load a simulation from an ArtCAM relief file (*.rlf). The 
resulting simulation is displayed in the 3D View window. 

 If you are working in ArtCAM Insignia, you cannot load a 
simulation from an ArtCAM relief file. 

If you load a toolpath simulation when another is already displayed 
in the 3D View window, the current simulation is replaced. 

To load a simulation from an ArtCAM relief: 
1 Use one of the following methods to display the Load Simulation 

dialog box: 

 From the Project panel, right-click  Toolpaths in the Project 
Tree, then click Load Simulation... in the context menu; 

 From the Menu Bar, click Toolpaths > Simulation > Load 
Simulation...; 

 From the Simulation toolbar, click the Load Simulation  
button; or 

 The Simulation toolbar is hidden by default. When displayed 
for the first time, it is floating over the viewing area. 

 From the Toolpaths panel, click the Load Simulation  
button in the Toolpath Simulation area. 
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 The Toolpaths panel is hidden by default. When displayed 
for the first time, it is docked and pinned on the left. 

 
2 Click the Look In list box, followed by the folder on your 

computer in which the ArtCAM relief file (*.rlf) that you want to 
simulate is saved. 

3 When you have found the ArtCAM relief file, click the file name 
listed in the main window of the dialog box. Its name is displayed 
in the File name box. 

 You can only select ArtCAM relief files (*.rlf). You can 
confirm this by clicking the Files of Type list box. 
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In the Model Preview area you can see a preview of the selected 
relief file. A greyscale representation of the selected relief file is 
displayed in the Relief Info area along with its dimensions in 
pixels. 

 When choosing a relief, the greyscale representation shown 
in the Relief Information area provides an indication of the 
form that a resulting simulation will take. Consider that the 
brightest areas of the greyscale image reflect the highest 
areas in the resulting simulation, while the darkest areas 
reflect the lowest. 

4 Click Open to load the ArtCAM relief as a simulation and close the 
dialog box. 

 

 

 
 

Creating a relief layer from a simulation 
You can create a new relief layer from a toolpath simulation 
displayed in the 3D View window. The relief's shape is identical to 
the simulation block. 

The new relief layer is: 

 named Simulation;  

 active; 

 selected; 

 added to the layer stack directly above the layer which was 
previously active; 

 given the Add combine mode; and 

 visible. 

To create a relief layer from a toolpath simulation: 

1 Use one of the following methods to display the layer stack on 
which you want to create the relief layer: 

 From the Project panel, click   beside  Front Relief  or  
Back Relief in the Project Tree; or  

 From the Relief Layers panel, click the list box, then select the 
layer stack: Front Relief or Back Relief. 

2 Choose the relief layer (see page 165) above which you want to 
create the relief layer. 
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3 Use one of the following methods to create the relief layer from 
the toolpath simulation: 

 From the Simulation toolbar, click the Create Relief Layer  
button; 

 The Simulation toolbar is hidden by default. When displayed 
for the first time, it is floating over the viewing area. 

 From the Menu Bar, click Toolpaths > Simulation > Create Relief 
From Simulation; or 

 From the Toolpaths panel, click the Create Relief Layer  
button in the Toolpath Simulation area. 

 The Toolpaths panel is hidden by default. When displayed 
for the first time, it is docked and pinned on the left. 

 

Shading a toolpath simulation 
You can control how a toolpath simulation is displayed in the 3D 
View window. You can: 

 render the simulation block with a material; and   

 colour all areas of the toolpath simulation below the simulation 
block's top surface with the primary colour. 

 The simulation block's default material is Simulation 
Default, and the default primary colour is black. 
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For example, in the toolpath simulation shown below, a Light Oak 
(H) material and custom depth colour are selected:  

 
To specify how the simulation block is displayed in the 3D View 
window: 

1 In the 3D View toolbar, click the 3D Graphics Options  
button to display the 3D Graphics Options panel. 

2 Click  on the Simulation Rendering control bar to display its 
settings. 

3 To specify the shading set used to render the simulation block in 
the 3D View window:  

a Click the Material list box, then the name of the shading set 
you want to use. For example, Light Oak (H). 

b Click Apply to render the simulation block with the selected 
shading set. 

4 To colour all areas of the toolpath simulation below the 
simulation block's top surface:  

a Select the primary colour (see page 108).  
b Select the Depth Colour check box. 

c Click Apply to colour the simulation block. 

5 Click Close to close the 3D Graphics Options panel. 
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Toggling the simulation display 
You can control the display of a:  
 solid colour simulation in the 2D View window associated with 

calculated 2D toolpaths and the tools they use. 
 toolpath simulation in the 3D View window associated with 

calculated 2D and 3D toolpaths and the tools they use. 

 

Toggling solid colour simulations in the 2D View window 
When a 2D toolpath is calculated, you can control the display of 
solid colour simulations in the 2D View window: 

1 To toggle the visibility of all solid colour simulations: 

 From the Project panel, click  beside  Toolpaths in the 
Project Tree to hide all solid colour simulations. 

 From the Project panel, click  beside  Toolpaths in the 
Project Tree to display all solid colour simulations 

 From the Toolpaths panel, click the uppermost  above the 
list of toolpaths to hide all solid colour simulations. 

 From the Toolpaths panel, click the uppermost  above the 
list of toolpaths to display all solid colour simulations.  

2 To toggle the visibility of a specific toolpath's solid colour 
simulation: 

 From the Project panel, click  beside the  toolpath's name 
in the Project Tree to hide it's solid colour simulation. 

 From the Project panel, click  beside the  toolpath's name 
in the Project Tree to display it's solid colour simulation. 

When you have two or more calculated toolpaths and one solid 
colour simulation is currently hidden,  is displayed beside  
Toolpaths in the Project Tree and at the top of the Toolpaths 
panel. 

3 To toggle the visibility of a specific tool's solid colour simulation: 

 From the Project panel, click  beside the tool's name  in 
the Project Tree to hide it's solid colour simulation. 

 From the Project panel, click  beside the tool's name  in 
the Project Tree to display it's solid colour simulation. 

 From the Toolpaths panel, click  beside the tool's name to 
display it's solid colour simulation. 
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 From the Toolpaths panel, click  beside the tool's name to 
display it's solid colour simulation. 

When a toolpath uses two or more tools and at least one tool's 
solid colour simulation is currently hidden,  is displayed beside 
the  toolpath's name in the Project Tree and at the top of the 
Toolpaths panel. 

 

Toggling toolpath simulations in the 3D View window 
When a toolpath simulation is complete, you can control the display 
of the simulation block in the 3D View window. 

You cannot control the display of the simulation block: 

 before simulating a toolpath; 

 during the toolpath simulation process; or 

 after deleting the toolpath simulation. 

Use one of the following methods to hide the simulation block: 

 In the 3D View toolbar, click the Toggle Simulation Visibility  
button; 

 Right-click the 3D View window, then deselect Objects To Draw >  
Simulation in the context menu; or 

 In the 3D View toolbar, click the Objects To Draw button , 
deselect Simulation in the list box, then click Apply. 

 

Use one of the following methods to display the simulation block: 

 In the 3D View toolbar, click the Toggle Simulation Visibility  
button; 

 Right-click the 3D View window, then select Objects To Draw > 
Simulation in the context menu; or 

 In the 3D View toolbar, click the Objects To Draw   button, 
select Simulation in the list box, then click Apply. 
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The default user interface layout in ArtCAM 2012 is designed to help 
you work efficiently, find tools easily, and maximise the viewing 
area. However, using only a few mouse clicks you can adjust the 
layout to suit your particular needs and preferences. 

You can: 

 control how and which panels and toolbars are displayed; 

 control the layout of panels and toolbars; 

 create and edit toolbars; 

 specify keyboard shortcuts; and 

 choose a colour scheme. 

 
 

Floating a docked panel 
The following panels, when displayed, are docked by default: 
Toolpaths, Assistant, Project, Start, Toolbox, Training, Live!, Relief 
Layers, Bitmap Layers and Vector Layers. 

 The Toolpaths, Assistant, Relief Layers, Bitmap Layers and 
Vector Layers panel are hidden by default. 

 If you are working in ArtCAM Insignia, the Relief Layers panel 
is not available. 

You can choose whether a panel is either docked or floating. 

To float a docked panel, use one of the following methods: 

Customising the user 
interface 
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 Click the panel's header and drag to the viewing area, then 
release the mouse button; 

 
 Right-click the panel's header, then click Floating from the 

context menu; or 

 
 Double-click the panel's header. 
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Docking a floating panel 
The following tools are also displayed on a floating panel when 
used: 

 
Tool 
Category 

Panel 

Model Lights and Material, Mesh Creator, Options 
and 3D Graphics Options. 

Vector 
Creation 

Vector Library, Block and Rotate Copy, 
Paste Along a Curve, Offset Vectors, 
Vector From Bitmap, Nesting, Multi-Plate 
Tool, Create Border, and Create Vector 
Boundary. 

Vector 
Editing 

Vector Doctor, Wrap Vectors to Relief, 
Vector Clipping, Spline Vectors,  Fit Arcs 
to Vectors, Convert to Shapes, and Mirror 
Vectors. 

Relief 
Creation 

Extrude, Spin, Turn, Two Rail Sweep, 3D 
Blend, Add Draft Angle, Create Angled 
Plane, and 3D Model Unwrapping. 

 In ArtCAM Insignia, only the Two Rail 
Sweep and Add Draft Angle panels can 
be displayed. 

Relief 
Editing 

Scale Relief, Fade Relief, Slice Relief and 
Mirror Merge Relief. 

 In ArtCAM Insignia, only the Scale 
Relief, Fade Relief and Mirror Merge 
Relief panel can be displayed. 
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Toolpaths  Each toolpath uses the same panel 
container. Only one type of toolpath 
can be displayed on the panel at a 
time because toolpaths must be 
calculated sequentially. 

Profiling, 2D Area Clearance, V-Bit 
Carving, Bevel Carving, Smart Engraving, 
Drilling, Inlay Wizard, Raised Round, 
Texture Toolpath, Drill Banks, 2D 
Machining Wizard, Machine Relief, Feature 
Machining, Z Level Roughing, Laser 
Machining, 3D Cut Out and 3D Rest 
Machining. 

 In ArtCAM Insignia, the 3D Cut Out 
and 3D Rest Machining panels are not 
included. 

Rotary 
Relief 

Two Rail Sweep - Ring, Create Flat Plane 
and Correct Vector For Height. 

 In ArtCAM Pro and Insignia, none of 
these panels are included. 

Gem Create Gem Vector, Vectors To Gem 
Vectors, Gem Vector Properties, Create 
Gems and Pave Wizard. 

 In ArtCAM Pro and Insignia, none of 
these panels are included. 

 

If a panel is floating, you can: 

 move it to a new floating position; or 

 return it to a previously docked position. 

To dock a floating panel: 

1 Click the panel's header and drag. 

You can use the drop-targets displayed on all four sides of the 
interface: 

    
In addition, if the panel is floating over:  
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 the viewing area, you can use the Docking Assistant displayed 
in the centre: 

 
 a docked pinned panel, you can use the Docking Assistant 

displayed over the panel: 

 
Release the mouse button when the cursor is over the 
drop-target you want to use. 

To return a floating panel to its last docked position, use one of the 
following methods: 
 Right-click the panel's header, then click Docking from the 

context menu; or 

 
 Double-click the panel's header. 
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Auto-hiding docked panels 
You can control whether or not docked panels are displayed or 
hidden. 

The following panels are auto-hidden by default: 
 Tutorials; 

 Live!; and 

 Toolbox. 

To collapse a docked panel, use one of the following methods: 

 Click  on the panel's header; or  

 

 If the docked panel contains tabbed pages, each of its tabs 
are now displayed as a group of tabs in the docking area. 
The tab used most recently is emphasised in orange. 

 Right-click the panel's header, then select Auto Hide from its 
context menu. 

 
The panel collapses against its adjacent docking area, and a tab 
is displayed. 
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To pin a sliding panel: 

1 In the docking area, move the mouse cursor over the tab 
displaying the name of the panel you want to pin.  

 
The panel slides out, and is visible for as long as the mouse 
cursor is over the tab or its associated panel. 

 If you move the mouse cursor outside of the panel or its 
associated tab, the panel collapses against its adjacent 
docking area. 

2 Use one of the following methods to pin the panel: 

 Click  on the panel's header; or 

 
 Right-click the panel's header, then click Auto Hide in the 

context menu.  
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The panel is docked. If your chosen tab belongs to a group of 
tabs, the other tabs within the group are also pinned and 
displayed within the panel as separate tabs. The page associated 
with your chosen tab is shown in the panel, and its name is 
displayed on its header. 
For example, with the Bitmap Layers panel sharing the same 
container as the Relief Layers and Vector Layers panels, it looks 
as follows: 

 
 

Hiding and displaying panels 
You can control which of the panels are displayed or hidden. You 
can hide a panel, whether it is pinned or auto-hidden. 

The following panels are displayed by default: 
 Start; 

 The Start panel (see page 14) is only displayed before a 
model or project is created or opened. 

 Project; 
 Tutorials; 

 Live!; and 

 Toolbox. 

The following panels are hidden by default: 
 Tool Settings; 

 Assistant; 
 Relief Layers; 

 The Relief Layers panel (see page 42) is not included in 
ArtCAM Insignia. 

 Vector Layers; 

 Bitmap Layers; and  

 Toolpaths. 
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To hide a panel, use one of the following methods: 

 Click  on the panel's header; 

 If the panel is auto-hidden, move the mouse cursor over 
the tab displaying the panel's name. For details, see 
Auto-hiding docked panels (see page 292). 

 
 Right-click the panel's header, then click Hide in the context 

menu; 
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 Right-click a docking area, then click to deselect the panel's 
name in the context menu; or 

 

 If a panel is auto-hidden, it is not selected in the context 
menu. Only floating or docked panels can be hidden or 
displayed in this way.  

 From the Menu Bar, click Window > Toolbars and Docking 
Windows, then the selected panel's name in the sub menu. 

To display a hidden panel: 

 Right-click a docking area, then click to select the panel's name 
in the context menu; or 

 From the Menu Bar, click Window > Toolbars and Docking 
Windows, then the deselected panel's name in the sub-menu. 

If the panel has not been displayed before, it is shown in its default 
layout position.  
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If the panel has been displayed before, it is shown in its last 
position; docked or floating. 

 

Embedding panels 
Each panel, whether docked or floating, is a container that allows 
other panels to share the same space. This enables you to use the 
available workspace efficiently. 

The following panels are embedded by default: 
 Bitmap Layers; 

 Vector Layers; and 

 Relief Layers. 

 The Relief Layers panel is not included in ArtCAM Insignia. 

To embed one panel within another: 

1 Click the panel's header, and drag over to the destination panel. 
The destination panel's Docking Assistant is displayed: 

 
2 Release the mouse button when the cursor is over: 

 to embed the panel below those already displayed; 

 to embed the panel above those already displayed; 

 to embed the panel to the left of those already displayed; 

 to embed the panel to the right of those already displayed; 

  to embed the panel as a tab.  

 If the destination panel is already tabbed, the panel you are 
relocating is added as a new tab. If not, two new tabs are 
created. The tab associated with the relocated panel is 
selected. 

When the mouse cursor is over a drop target in the Docking 
Assistant, its corresponding space is shaded blue. This provides a 
preview of the new layout. 
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For example, positioning the Bitmap Layers panel over  in the 
Vector Layers panel's Docking Assistant creates the following 
result: 

 
 

Resizing panels 
You can resize a floating, docked or embedded panel. 

When a panel is too short and narrow to display all of its content, a 
scrollbar is displayed along its right and bottom edge. You can use 
the scrollbar to control what of the panel's content is visible. 

Floating panels 
To resize a floating panel: 

1 Move the mouse cursor over a panel's edge or corner. When the 
cursor changes to: 

 , click and drag left or right to adjust its width; 

 , click and drag up or down  to adjust its height; 

  or , click and drag the corner inwards or outwards 
diagonally to adjust its height and width simultaneously. 

Docked panels 
To resize a docked panel: 

1 Move the mouse cursor over the panel's edge adjacent to the 
viewing area. When the cursor changes to: 
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 , click and drag left or right to adjust its width; 

 , click and drag up or down to adjust its height. 

Embedded panels 
To resize an embedded panel: 

1 Move the mouse cursor over the solid splitter bar between two 
adjacent embedded panels. 

The splitter bar is horizontal or vertical, depending on how the 
panels are arranged. For example, a horizontal splitter bar looks 
as follows: 

 

 The Project panel has its own splitter bar which is always 
displayed, separating the Project Tree from the tools 
associated with the currently selected item: 

 
2 When the cursor changes to: 

  , click and drag up or down to adjust the height of the 
panels above and below the splitter bar; 

 , click and drag left or right to adjust the width of the 
panels on the left and right of the splitter bar. 

When moved, the splitter bar is no longer solid. For example, a 
horizontal splitter bar looks as follows: 

 

 The Project panel's splitter bar includes tools you can use to 
adjust its layout. Click:  

 to align the splitter bar with the panel's bottom edge; 

 to align the splitter bar with the panel's top edge; or 

 to return the splitter bar to its previous position. 

3 Release the mouse button to set the splitter bar's position. The 
panels on either side of the splitter bar are resized. 

 

Floating a docked toolbar 
All of the toolbars displayed by default are docked, but can be 
floated. When floating, a toolbar has:  

 a header displaying its name and an  icon to hide it; and 

 sharpened corners. 
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For example, the Vector Creation toolbar looks as shown below when 
floating: 

 
To float a docked toolbar, use one of the following methods: 

 Click the toolbar's grip,  or , and drag to the viewing area, 
then release the mouse button; 

 
 Double-click the toolbar's grip: 

 
If the toolbar has not been floated before, it is displayed in the 
top left corner of the interface. 

If the toolbar has been floated before, it is displayed in its last 
floating position. 

 

Docking a floating toolbar 
You can dock toolbars, default or customised, in the docking area: 
 between the Title Bar and viewing area; 

 between the Status Bar and colour palette; 

 to the left of the viewing area; or 

 to the right of the viewing area. 

Depending on where a toolbar is docked, it is vertical or horizontal. 
When docked, the toolbar's name is hidden. All of the toolbars 
displayed by default are docked.  

When docked, a toolbar has:  

 a grip on its left  or top  edge, depending on whether it is 
horizontal or vertical respectively; and  

 rounded corners. 
For example, the Vector Creation toolbar looks as shown below when 
docked: 
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To dock a floating toolbar, click the toolbar's header and drag, then 
release the mouse button when the toolbar is over the empty 
docking area. 

 
To return a floating toolbar to its last docked position, double-click 
the toolbar's header. 

 
 

Hiding and displaying toolbars 
You can control which of the toolbars are displayed or hidden. You 
can hide a toolbar, whether it is currently docked or floating.  

To hide a toolbar, use one of the following methods: 
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 Right-click a docking area, then click to deselect the toolbar's 
name in the context menu; 

 
 From the Menu Bar, click Window > Toolbars and Docking 

Windows, then the selected toolbar's name in the sub-menu; or 

 Click  on the toolbar's header. 

 A toolbar's header is displayed only when the toolbar is 
floating (see page 299). 

To display a hidden toolbar: 

 Right-click a docking area, then click to select the toolbar's name 
in the context menu.  

 From the Menu Bar, click Window > Toolbars and Docking 
Windows, then the deselected toolbar's name in the sub menu. 

If the toolbar has not been displayed before, it is shown in its 
default layout position.  



 

ArtCAM 2012 User Guide Customising the user interface • 303  

If the toolbar has been displayed before, it is shown in its last 
position; docked or floating. 

 

Creating a custom toolbar 
You can create your own toolbars, and add your choice of tools as 
buttons. 

To create a custom toolbar: 
1 From the Menu Bar, click Window > Toolbars and Docking Windows 

> Customise... to display the Customize dialog box: 

 
2 Click the Toolbars tab to display its settings. 

3 Click New... to display the Toolbar Name dialog box: 

 
4 In the Toolbar Name box, type the name that you want to give to 

the toolbar. For example, Favourites. 

 The toolbar's name is only displayed when it is floating (see 
page 299). 
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5 Click OK to close the Toolbar Name dialog box and create the new 
toolbar. The toolbar is floating and empty. On the Toolbars tab of 
the Customize dialog box, the name of the toolbar is selected in 
the Toolbars list. 

6 Click the Commands tab to display its settings. 

7 In the Categories list, click to select the category of commands 
that you want to browse. Its associated commands are displayed 
in the Commands list.  

For example, selecting the Design Tools category displays all of 
the commands you would associate with the buttons on the 
Design Tools toolbar. 

8 From the Commands list, click and drag the command to the 
toolbar.  

 When clicking and dragging a command, the mouse cursor 

changes to . 

 When positioned over a toolbar, the mouse cursor changes 

to . 
For example, click and drag Select from the Commands list to a 
custom Favourites toolbar. 

 
9 When the mouse cursor is over the toolbar, release the mouse 

button to add the command as a new button. 



 

ArtCAM 2012 User Guide Customising the user interface • 305  

 The  icon in the toolbar indicates the position in which the 
command is added as a button. 

Where there is an icon corresponding with the command, this is 
used as the button. Where there is no icon, only a text label is 
displayed. 

 

Deleting a custom toolbar 
To delete a custom toolbar: 
1 From the Menu Bar, click Window > Toolbars and Docking Windows 

> Customise... to display the Customize dialog box: 

 
2 Click the Toolbars tab to display its settings. 

3 In the Toolbars list, click to select the toolbar you want to delete. 
Its name is emphasised in blue. 

 The toolbar you want to delete does not have to be visible. 
4 Click Delete. 

 If you have selected any of the default toolbars, Delete is 
greyed-out. 
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Renaming a custom toolbar 
You can rename any of your custom toolbars. You cannot rename 
any of the default toolbars, which are: 
 2D View; 

 3D View; 

 Back Relief Tools; 

 This toolbar is not included in ArtCAM Insignia. 
 Bitmap Tools; 

 Design Tools; 

 File; 

 Gem Tools; 

 This toolbar is not included in ArtCAM Insignia or Pro. 
 Model; 
 Relief Creation; 

 This toolbar is not included in ArtCAM Insignia. 
 Relief Editing; 

 This toolbar is not included in ArtCAM Insignia. 
 Rotary Relief Tools; 

 This toolbar is not included in ArtCAM Insignia or Pro. 
 Simulation; 

 Vector Creation; 

 Vector Editing; and 

 View Manipulation. 

To rename a custom toolbar: 
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1 From the Menu Bar, click Window > Toolbars and Docking Windows 
> Customise... to display the Customize dialog box: 

 
2 Click the Toolbars tab to display its settings. 

3 In the Toolbars list, click to select the toolbar that you want to 
rename. Its name is emphasised in blue. 

4 Click the Rename... button to display the Toolbar Name dialog 
box: 

 
In the Toolbar Name box, the toolbar's name is emphasised in 
blue, which indicates that it is selected. 

5 In the Toolbar Name box, type the new name that you want to 
give to the toolbar. 

6 Click OK to apply the new name and close the Toolbar Name 
dialog box. The new name given to the toolbar is displayed in the 
Toolbars list. Provided that the toolbar is visible and floating, the 
new name is also displayed on its header.  

7 Click Close to close the Customize dialog box. 
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Adding buttons to a toolbar 
You can add buttons to any toolbar: default or custom. These 
buttons can be: 

 copied from another toolbar; or 

 created from a list of commands. 

To create a copy of a button from one toolbar to another: 
1 From the Menu Bar, click Window > Toolbars and Docking Windows 

> Customise... to display the Customize dialog box: 

 
2 Hold down the Ctrl key, then click and drag a copy of the button 

from one toolbar to another. 
For example, copying the File toolbar's New Model button looks 
as follows: 

 
3 When the mouse cursor is over the toolbar position in which you 

want the copied button, release the mouse button. 

 

To add a button using a command:  
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1 From the Menu Bar, click Window > Toolbars and Docking Windows 
> Customise... to display the Customize dialog box. 

2 From the Commands tab, in the Categories window, click the 
category that includes the command you want to add as a 
button. 

3 In the Commands window, click and drag the command to the 
toolbar. 

 When clicking and dragging a command, the mouse cursor 

changes to . 

4 When the mouse cursor is over the toolbar position in which you 
want the command as a button, release the mouse button. 

 The  icon in the toolbar indicates the position in which the 
button is added. 

Where there is an icon associated with the command, this is used 
by the button. Where there is no icon, only a text label is shown. 

 
 

Setting toolbar button properties 
As well as controlling which buttons are included (see page 308) in 
a toolbar, you can also set their size and toggle the display of their: 

 screen tips; 

 shortcut keys; and 

 text labels. 

To set the toolbar button properties: 
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1 From the Menu Bar, click Window > Toolbars and Docking Windows 
> Customise... to display the Customize dialog box: 

 
2 Click the Options tab, then the: 

 Large Icons check box to set the size of all toolbar buttons; 

For example, the File toolbar looks as follows: 

Large... 

 
Small... 

 
 Show Screen Tips on toolbars check box to toggle the display 

of screen tips when the mouse cursor is positioned over a 
toolbar button; 
For example, the File toolbar's New Model button looks as 
follows: 

Screen tip with shortcut.... 
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Screen tip only... 

 
 Show shortcut keys in Screen Tips check box to toggle the 

display of shortcut keys in a toolbar button's screen tip. 

 If the Show Screen Tips on toolbars check box is deselected, 
the Show shortcut keys in Screen Tips check box is 
greyed-out. 

3 To toggle the display of text labels on each of the buttons in a 
specific toolbar: 
a Click the Toolbars tab, then the name of the toolbar in the 

Toolbars window. It is emphasised in blue. 

b Click the Show text labels check box. 

For example, the File toolbar looks as follows with text labels 
displayed:  

 
4 Click Close to close the Customize dialog box.  

 

Adding a custom menu to a toolbar or 
menu 

To add a custom menu to a toolbar or menu: 
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1 From the Menu Bar, click Window > Toolbars and Docking Windows 
> Customise... to display the Customize dialog box: 

 
2 In the Categories list, click New Menu. The New Menu command is 

displayed in the Commands list. 

3 From the Commands list, click and drag the New Menu command 
to the toolbar or menu. 

4 When the mouse cursor is over the toolbar or menu, release the 
mouse button. The command is added as a menu button. 

5 On the toolbar or menu, right-click the New Menu button, then 
click Button Appearance... from the context menu. The Button 
Appearance dialog box is displayed: 
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6 In the Button text box, type the name that you want to give to 
the menu button. For example, Favourites. 

7 Click OK to apply the new name to the menu button, and close 
the Button Appearance dialog box.  

8 In the Categories list, click to select the category containing the 
command you want to add to the menu. 

9 From the Commands list, click and drag the command to the 
menu button. An empty menu is displayed. 

10 Move the mouse cursor to the empty menu, and release the 
mouse button to add the command. 

If the command has an associated icon, this is added to the 
menu. If there is no icon, the menu command is displayed as 
text only.  

 When clicking and dragging a command, the mouse cursor 

changes to . 

 When positioned over a menu, the mouse cursor changes 

to . 

11 Repeat the last three steps until you have added all of the 
commands that you want to include in the menu. 

 The  icon in the menu indicates the position in which 
the command is added to the menu. 

 The  icon in the menu indicates that the command is 
added to the top of the menu. 

 The  icon in the menu indicates that the command is 
added to the bottom of the menu. 

12 Click Close to close the Customize dialog box. 
 

Assigning or changing keyboard 
shortcuts 

Using keyboard shortcuts accelerates your workflow. You can assign 
new keyboard shortcuts, or change the key combinations already 
used in shortcuts. Unless you choose a function key, F1 through 
F12, your key combination must start with a modifier key and end 
with a regular key. 

The modifier keys you can use are: 
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 Alt; 
 Ctrl;  
 Alt Gr, which is equivalent to using Ctrl+Alt; and 

 Shift, provided it is also used with Ctrl or Alt. 
You can use one or more modifier keys in a shortcut. 

To assign or change a keyboard shortcut: 
1 From the Menu Bar, click Window > Toolbars and Docking Windows 

> Customise... to display the Customize dialog box: 

 
2 Click the Keyboard tab to display its settings. 

3 Click the Category list box, followed by the menu that contains 
the command you want to assign or change the keyboard 
shortcut to. 

4 Click the Commands list box, followed by the command you want 
to assign the shortcut to. 

A description of the selected command is shown below. The 
Current Keys area displays keyboard shortcuts already assigned 
to the selected command.  

5 To delete a shortcut already assigned to the selected command:  
a Click the key combination shown in the Current Keys area. It is 

emphasised in blue. 
b Click Remove. 
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6 Click the empty Press new shortcut key box, then, using your 
keyboard, press the key combination you want assigned to the 
shortcut.  

If you choose a shortcut used elsewhere, its associated 
command is displayed below. In this instance you can: 
 press the Delete key, followed by a different key combination; 

or 

 select the command already using the shortcut, delete the 
shortcut, then repeat this step. 

7 Click Assign to assign the shortcut keys to the command. 

8 To restore the default shortcuts, click Reset All. 
9 Click Close to close the Customize dialog box. 
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Using the keyboard 
There are many different shortcuts available to help you complete 
your tasks in ArtCAM as efficiently as possible.  

View Control 
The following keyboard shortcuts can be used to adjust the ArtCAM 
layout, the content of the 2D View window: 
ArtCAM Function Keyboard Shortcut 
Display Reference Help F1 

Display 2D View F2 

Display 3D View F3 

Toggle Project panel visibility F4 

Toggle Tool Settings panel 
visibility 

F6 

Preview currently active relief 
layer in 2D View 

 If you are working in ArtCAM 
Insignia, a preview of the 
relief is displayed. 

F10 

Display cursor information Alt+C 

Toggle visibility of all vector 
layers 

Alt+V 

Toggle visibility of currently 
active bitmap layer 

Alt+B 

Create greyscale from composite 
relief 

 If you are working in ArtCAM 
Insignia, you cannot create a 
greyscale from the relief. 

Alt+G 

Toggle Notes visibility Alt+N 

 

Models 
The following keyboard shortcuts can be used when working with 
ArtCAM models: 

 



 

ArtCAM 2012 User Guide Customising the user interface • 317  

ArtCAM Function Keyboard Shortcut 
Create new model Ctrl+N 

Open model Ctrl+O 

Save model Ctrl+S 

Create new sheet in model Ctrl+Alt+Shift+S 

 

Editing 

The following keyboard shortcuts can be used when editing: 

 
ArtCAM Function Keyboard Shortcut 
Copy to ArtCAM clipboard Ctrl+C 

Paste from ArtCAM clipboard Ctrl+V 

Cut to ArtCAM clipboard Ctrl+X  

Undo last action Ctrl+Z 

Redo last action Ctrl+Y 

Delete Delete 

 

Vector Drawing 
The following keyboard shortcuts can be used when drawing vector 
artwork: 

 
ArtCAM Function Keyboard Shortcut 
Create vector and continue 
drawing 

Return or Space Bar 

Select tool Esc 

Constrain angle of linear span 
between nodes to 15 degree 
increments (Create Polyline only) 

Ctrl 

Keep aspect ratio (Create 
Rectangle only) 

Shift 

Close polyline to create polygon 
and continue drawing 

Tab 
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Vector Editing 
The following keyboard shortcuts can be used when editing vector 
artwork: 

 
ArtCAM Function Keyboard Shortcut 
Select tool Esc 

Select all vectors Ctrl+A 

Edit selected vector E 

Node Editing tool N 

Convert span (linear or bezier) 
to arc 

A 

Convert span (linear or arc) to  
bezier 

B 

Convert span (bezier or arc) to 
line 

L 

Cut span C 

Remove span R 

Insert node I 

Insert start node or change node 
to start node 

P 

Toggle smoothing on node S 

Delete node D 

Align selected nodes in X-axis X 

Align selected nodes in Y-axis Y 

Nudge selected vector up  
Nudge selected vector down  
Nudge selected vector right  
Nudge selected vector left  
Transform tool (on Tool Settings 
panel) 

T 

Measure tool (on Tool Settings 
panel) 

M 

Display Vector Clipping panel Ctrl+Alt+Shift+C 

Display Vector Slice panel Ctrl+Alt+Shift+V 
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Vector Alignment 
The following keyboard shortcuts can be used when aligning 
vectors: 

 
ArtCAM Function Keyboard Shortcut 
Centre in model F9 

Align left Ctrl+  

Align horizontal centre Shift+  

Align right Ctrl+  

Align top Ctrl+  

Align vertical centre Shift+  

Align bottom Ctrl+  

 

Vector Grouping 

The following keyboard shortcuts can be used when grouping 
vectors: 

 
ArtCAM Function Keyboard Shortcut 
Group selected vectors Ctrl+G 

Ungroup vectors Ctrl+U 

 

Bitmap Colours 
The following keyboard shortcuts can be used when working with 
bitmap artwork: 

 
ArtCAM Function Keyboard Shortcut 
Toggle linking between primary 
and secondary colours 

Ctrl+L 

Link all colours Ctrl+K 

Reset all colour links Ctrl+R 

 

Reliefs 

 If you are working in ArtCAM Insignia, these shortcuts are not 
available. 
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The following keyboard shortcuts can be used when working with 
reliefs: 

 
ArtCAM Function Keyboard Shortcut 
Display Shape Editor 

 If you are working in ArtCAM 
Insignia, the Shape Editor is 
not available. 

F12 

Reset currently active relief layer 

 If you are working in ArtCAM 
Insignia, you can reset the 
relief. 

Shift+Delete 

Copy relief 

 If you are working in ArtCAM 
Insignia, you cannot copy a 
relief. 

Ctrl+Shift+C 

Display Offset Relief dialog box 

 If you are working in ArtCAM 
Insignia, you cannot offset 
the relief. 

Ctrl+Alt+Shift+O 

Select Relief Envelope Distortion 
tool 

 If you are working in ArtCAM 
Insignia, the Relief Envelope 
Distortion tool is not 
available. 

Ctrl+Alt+Shift+R 

 
 

Changing the theme 
You can choose between two themes. This controls the user 
interface's colour scheme, but does not change its layout (see page 
322). 
From the Menu Bar, click Window > Theme, then: 

 Charcoal to apply the obsidian black colour scheme. This is 
selected by default. 

 Classic to apply the beige colour scheme. This is familiar to users 
of ArtCAM 2011 and earlier.  
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For example, a model open in ArtCAM Pro with the 2010 theme and 
layout looks as follows: 
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While a model open in ArtCAM Pro with the Classic theme and 2010 
layout looks as follows: 

 
 

Resetting and changing the layout 
You can choose between three layouts, each of which includes a 
different arrangement of panels and toolbars. 
From the Menu Bar, click Window > Reset Layout, then: 

 Standard to enable access the most frequently used tools, 
without compromising the viewing area. This is selected by 
default. 

 Advanced to maximise the viewing area. 

 Classic to keep the familiarity of ArtCAM 2011 and earlier.  

When selecting a new layout, your: 

 custom toolbars and menus are kept; 

 toolbar changes are kept; and  

 previous panel and toolbar arrangement is lost. 
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Although your chosen layout affects how toolbars and panels are 
arranged, whether you are working with a project or model also 
does. 
When working with a model in the Standard layout: 

 the Project panel is docked and pinned on the right; 

 the Tutorials, Live! and Toolbox panels are docked and 
auto-hidden on the right; 

 the File, Model, Vector Creation, Vector Editing, Relief Creation and 
Relief Editing toolbars are docked horizontally below the Title Bar;  

 The Relief Editing toolbar is not included in ArtCAM Insignia. 

 the Design Tools and View Manipulation toolbars are docked 
vertically on the left;  

 the design windows are tabbed; and 

 large buttons are displayed. 
For example, a model open in ArtCAM Pro with the Standard layout 
and Charcoal theme selected looks as follows: 

 
What distinguishes the Advanced layout from the 2010 layout is: 

 the Project panel is auto-hidden on the right;  
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 all toolbars other than those above the 2D View and 3D View 
windows are hidden; and  

 small buttons are displayed. 
For example, a model open in ArtCAM Pro with the Advanced layout 
and Charcoal theme selected looks as follows: 

 
What distinguishes the Classic layout from the Standard layout is: 

 the Vector Layers, Bitmap Layers, and Relief Layers panels are 
docked and pinned on the right;  

 The Relief Layers panel is not included in ArtCAM Insignia. 

 the Project and Tool Settings panels are docked, pinned and 
tabbed on the left;  

 the Assistant and Toolpaths panels are docked, pinned and 
tabbed on the left; and 

 all toolbars, other than those above the 2D View and 3D View 
windows, are hidden. 
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For example, a model open in ArtCAM Pro with the Classic layout 
and Charcoal theme selected looks as follows: 

 
When working with a project in the Standard layout: 

 the Project panel is docked and pinned on the right; 

 the Tutorials, Live! and Toolbox panels are docked and 
auto-hidden on the right; 

 the File toolbar is docked horizontally below the Title Bar;  
 the 3D View window is tabbed; and 

 large buttons are displayed. 
What distinguishes the Advanced layout from the Standard layout is: 

 the Project panel is auto-hidden on the right;  

 the File toolbar is hidden; and  

 small buttons are displayed. 
What distinguishes the Classic layout from the Standard layout is: 

 the Project panel is docked and pinned on the left; 

 the File toolbar is hidden; and  

 small buttons are displayed. 
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Choosing favourites 
There is a Favourites toolbar at the top of the Assistant panel, which 
you can use to control which of the buttons, toolsets and areas on 
the Assistant panel are shown. This allows you to hide the tools that 
you confidently do not require during your workflow. You can also 
display labels for each of the buttons. 

 Although you can choose which of a toolset's buttons are 
displayed or not, you cannot move a button from one toolset 
to another, or elsewhere on the Assistant panel.  

Using the Favourites Toolbar 
By default, all of the buttons, toolsets and areas that make up the 
Assistant panel are available, and Favourites mode is toggled off. 
The  icon is displayed. 

To choose your favourites: 
1 Click  on the Favourites toolbar, then  Edit Favourites from 

the context menu: 
All of the buttons included in the Assistant panel are displayed, 
and the toolset layout is temporarily ignored. All buttons are 
active when selecting your favourites, although they cannot be 
used. 

2 On the Assistant panel, click each of the buttons that you want to 
add or remove: 

 If a button is currently greyed-out, click to add the button to 
your favourites. 

 If a button is currently visible, click to remove the button from 
your favourites. 

3 Click  Edit Favourites to set your favourites.  

Either  Favourites On or  Favourites Off is displayed in the 
toolbar, depending on whether or not you were working in 
Favourites mode prior to choosing your favourites.   

Only the buttons included in your favourites are displayed on the 
Assistant panel. The toolsets are restored, although which of 
their original buttons are available now depends on whether or 
not they are included in your favourites. If none of the buttons 
within a particular toolset are included in your favourites, the 
toolset is removed altogether. If none of the buttons in a 
particular area of the Assistant  panel are included in your 
favourites, the area is removed altogether. 

To toggle your favourites on, click: 



 

ArtCAM 2012 User Guide Customising the user interface • 327  

 ; or 
  , then  Favourites Off from the context menu. 

When only your favourites are shown on the Assistant panel, the 
 icon is displayed in the toolbar. 

To toggle your favourites off, you can either: 

 ; or 
  , then   Favourites On from the context menu. 

When the default layout is shown on the Assistant panel,  is 
displayed. 

Using Labels 

When you use ArtCAM for the first time, labels are displayed beside 
each of the buttons on the Assistant panel. The buttons are also 
arranged in such a way that their labels can be easily read. 
Thereafter, you can control whether to work with or without labels 
displayed. 

To toggle labels on: 

1 In the Assistant panel's header, click . 

 When labels are hidden, the same description can be 
displayed as a tooltip whenever the mouse cursor is 
positioned over a button. 

When a toolset is pinned and labels are displayed, all of the buttons 
belonging to the toolset are stacked vertically within a shaded 
backdrop. The  icon used to pin the contents of a toolset is 
positioned along the bottom of the shaded area. For example, the 
Vector Editing toolset is displayed as shown below: 

 

 To unpin the toolset, click  along the bottom of the shaded 
area. 

When a toolset is unpinned and labels are displayed, only the most 
recently used button within the toolset is shown along with its 
corresponding label. For example, the Vector Editing toolset is 
displayed as shown below: 
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The  icon beside the button displays all of the other buttons in its 
toolset, and these are stacked vertically within a shaded backdrop. 
The  icon used to pin the contents of a toolset is positioned along 
the bottom of the shaded area. For example, the Vector Editing 
toolset is displayed as shown below: 

 

 To pin the toolset, click  along the bottom of the shaded 
area. 

If a button is not currently available when labels are toggled on, 
both the button and its label are greyed-out. 

To toggle labels off: 

1 In the Assistant panel's header, click . 

When a toolset is unpinned and labels are hidden, only the most 
recently used button within the toolset is shown. The other buttons 
in the toolset are hidden by default. Clicking the  icon displays all 
of the buttons in a toolset, and these are adjacent horizontally. The 
 icon used to pin the contents of a toolset is positioned along the 

right-edge of the button currently shown. 

For example, the Vector Editing toolset is displayed as shown 
below: 
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The way in which your mouse can be used in ArtCAM often changes 
according to which design window is displayed and the particular 
aspect of the model on which you are working. Furthermore, if you 
own a mouse with a wheel this also increases the range of options 
available to you. 

2D View 
You can use the mouse to manipulate the 2D View in the following 
ways: 

 
ArtCAM Function Mouse Action 
Magnify view by 50% 

 
Reduce view by 50% 

 
Zoom in 

 
Zoom out 

 

 

3D View 
You can use the mouse to manipulate the 3D View in the following 
ways: 

 

Using the mouse 
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ArtCAM Function Mouse Action 
Rotate view 

 
Zoom  

 
Pan view 

 
Zoom in 

 
Zoom out 

 

 

Vectors 
You can use the mouse relative to vector artwork in the following 
ways: 

 
ArtCAM Function Mouse Action 
Select vector (also 
select node in Node 
Editing mode)  

Select multiple 
vectors 

 
Copy vector 

...on selected vector. 

Display context 
menu 

...on selected vector. 

Display Shape Editor 

 ...on selected vector. 

 

Bitmaps 
You can use the mouse relative to bitmap images shown in the 2D 
View in the following ways: 
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ArtCAM Function Mouse Action 
Select primary colour 

 ...on colour swatch in colour palette. 

Select secondary 
colour 

 ...on colour swatch in colour palette. 

Link colour to 
primary colour 

 ...on colour swatch in colour palette. 

Display Shape Editor 

 ...on colour swatch in colour palette, 
2D View or 3D View. 

 

Toolpaths 

You can use the mouse relative to toolpaths in the following ways: 

 
ArtCAM Function Mouse Action 
Edit toolpath 

 ...on 2D toolpath preview or toolpath 
name. 
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Floating a docked panel • 287 
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