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Maxwell®  is a comprehensive electromagnetic field simulation software package for engineers tasked with designing and analyzing 3D/2D 
structures, such as motors, actuators, transformers and other electric and electromechanical devices common to automotive, military/
aerospace and industrial systems. Based on the Finite Element Method (FEM), Maxwell can solve static, frequency-domain and time-varying 
electromagnetic and electric fields.  In addition, the software can be  dynamically linked with Simplorer® to create a powerful, system-level 
electromagnetic-based design flow. This flow enables users to combine complex circuits with accurate component models to design high-
performance electromechanical and power electronic systems. Additionally, Maxwell’s 3D solvers have dynamic links to ePhysics™. This allows 
engineers to perform complex 3D multi-physics studies by linking Maxwell to ePhysics’ thermal and structural solvers.

Key Benefits
Electromagnetic field simulation
Maxwell includes 3D/2D Transient, AC electromagnetic, Magneto-
static, Electrostatic and Electrotransient solvers that accurately solve 
for force, torque, capacitance, inductance, resistance, and imped-
ance, as well as generate state-space models. 

Automatic adaptive meshing
Maxwell uses the Ansoft-pioneered automatic adaptive meshing 
techniques. This robust meshing algorithm automatically creates and 
refines the finite element mesh as the solution converges, streamlin-
ing the solution process and making the software very easy to use.

Dynamic link - ePhysics
The Maxwell 3D solvers can be dynamically linked with ePhysics’ 
thermal and stress analysis and are the ideal solution for every elec-
tromechanical device requiring cross-disciplinary design analysis. 

Dynamic link - Simplorer
Dynamic links with Simplorer multi-domain system simulation allow 
accurate high-fidelity component models to be combined with cir-
cuits and system architecture to create a powerful, electromagnetic- 
based design flow.

Import
CAD files can be imported in Maxwell streamlining the design pro-
cess.

Multi-processing and distributed analysis
Maxwell can leverage available computing power with multi-pro-
cessing and distributed analysis options for fast turnaround of your 
largest designs.

Optimization
Optimetrics™ provides parametric, optimization, sensitivity, and 
statistical analysis capabilities to Maxwell. Optimetrics automates the 
design-optimization process by quickly identifying optimal values for 
design parameters that satisfy user-specified constraints. 

Customized pre-processors
RMxprt (electric machine design) and PExprt™ (magnetic component 
design) are used to design devices based on a traditional analytical 
approach. They also can be directly linked to Maxwell and provide 
fully automated design creation and analytical analysis. Users can 
perform preliminary studies of design concepts prior to performing 
rigorous electromagnetic analysis with Maxwell.

applications
Electromechanical 
	 •	 Motors and generators
	 •	 Linear or rotational actuators
	 •	 Relays
	 •	 MEMS
	 •	 Magnetic recording heads
Electromagnetic 
	 •	 Coils
	 •	 Permanent magnets
	 •	 Sensors
Power electronic
	 •	 Transformers
	 •	 Converters
	 •	 Bus bars
	 •	 IGBTs and similar devices
EM behavior
	 •	 Insulation studies 
	 •	 Electrostatic discharge
	 •	 Electromagnetic shielding
	 •	 EMI/EMC
	 •	 Semiconductor
	 •	 Biomedical

The new 2D interface provides strong coupling with
3D and many new usability features.

3D/2D Electromagnetic Field Simulation
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Key features

Low-frequency electromagnetic field simulation and analysis using 
FEM for 3D/2D structures
	 •	 Transient - nonlinear analysis with:
			   Motion—rotation, translational, non-cylindrical rotation
			   External circuit coupling
			   Permanent magnet demagnetization analysis
			   Core loss computation
	 	 	 Lamination modeling for 3D
	 •	 AC Electromagnetic—Analysis of devices influenced by skin/	 	
		  proximity effects, eddy/displacement currents
	 •	 Magnetostatic—Nonlinear analysis with automated equivalent 	
		  circuit model generation 
	 •	 Electric Field—Transient, Electrostatic/Current flow analysis with 	
		  automated equivalent circuit model generation 

Display of data/visualization of results 
	 •	 Field visualization and animations (shaded, contour and vector 	
		  plots)
	 •	 Mesh visualization (full, partial)
	 •	 Current, induced voltage, flux linkage
	 •	 Power loss, stored energy
	 •	 Core loss, eddy, excess, hysteresis loss (including the minor loop 	
		  effects) 
	 •	 Impedance, inductance, capacitance
	 •	 Force, torque
	 •	 Custom reports of user-defined solution data

Performance and integration
	 •	 Distributed Analysis* for parallel computing of parameterized 	
		  models
	 •	 64-bit operating system support
	 •	 Links to Simplorer®*, ePhysics™*, HFSS™*, RMxprt™*, PExprt™*

Integrated 3D modeler featuring ACIS v16 and MFC technology
	 •	 Standard primitives and multi-sweep functions
	 •	 Boolean operations: union, subtraction, intersection
	 •	 Direct import of SAT and DXF files
	 •	 AnsoftLinks™* for import of STEP, IGES and Pro/E files 

Automatic, adaptive mesh technology
	 •	 Fault-tolerant meshing algorithms
	 •	 Mesh-generation feedback 
	 	 •	 GUI performs validation and integrity checks 
	 	 •	 Software identifies artifacts within the imported geometry
	 •	 Mesh-based model resolution

Versatile material manager and material types
	 •	 User, group and system libraries 
	 •	 Linear, nonlinear anisotropic materials
	 •	 Material assignment by coordinate type: cartesian, cylindrical or 	
		  spherical

Integrated Optimetrics™*
	 •	 Geometry and material parameterization 
	 •	 Optimization, sensitivity and statistical analysis

*Option available at additional charge.

AnsoftLinks™

RMxprt™

Maxwell®

ePhysics™

Op
tim

et
ric

s™

CAD Files
IGES, STEP, DXF, SAT, ProE

Simplorer®

Electric Machine

PExprt™

Converters & Transformers

Current density in a busbar system as calculated by Maxwell 3D.



OVERVIEW

FEATURED CAPABILITIES

Optimetrics™ is an optional software module that adds parametric 
capabilities, optimization algorithms, sensitivity and statistical analyses to 
Ansoft’s best-in-class electromagnetic-field simulation products—HFSS™, 
Maxwell® 3D and Q3D Extractor®. Optimetrics automates the design-
optimization process for high-performance electronics, such as microwave/
RF devices, printed circuit boards, on-chip passives, IC packages and 
electromechanical components, by quickly identifying optimal values for 
design parameters that satisfy user-specified constraints and goals.     

Optimetrics™ enables users to study the effects of geometry and materials 
on a design by creating parameters for the dimensions and material 
constants of the model to be analyzed. Optimetrics then varies these 
parameters and adjusts the geometry and materials to achieve the 
desired, user specified, performance goal. 

Leveraging previously computed parametric simulation results within 
its optimizer, Optimetrics enables engineers to understand device 

characteristics over a large design space and quickly identify the best 
performing design that is least sensitive to manufacturing tolerances.
 
Optimetrics, when used in conjunction with HFSS™, Maxwell® 3D and 
Q3D Extractor®, delivers an innovative and robust design platform from 
which users gain a greater understanding of the design space and the 
ability to make insightful design choices.

•	 Parametric Analysis 
	 •	 User-specified range and number of steps for parameters
	 •	 Automatic analysis of parameter permutations
	 •	 Distributed Analysis (cost option)
		  o	 Automated parser management across multiple hardware 	
			   platforms and reassembly of data for parametric tables and 	
			   studies
•	 Sensitivity Analysis 
	 •	 Design variations to determine sensitivities
		  o	 Manufacturing tolerances 
		  o	 Material properties

This example is a connector designed with HFSS 
and Optimetrics. The control panel displays design 
variables (i.e., cost functions, parameters), launches 
design perturbations and converges to the optimal 
performance criterion.

Ansoft Corporation • 225 West Station Square Drive • Pittsburgh, PA 15219-1119 USA
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•	 Optimization 
	 •	 User-selectable cost functions and goal objective
		  o	 Quasi-Newton method
		  o	 Sequential Nonlinear Programming (SNLP)
		  o	 Integer-only Sequential Nonlinear Programming
	 •	 Automatic analysis of parameter variants until optimum goal obtained
•	 Tuning 
	 •	 User-controllable slide bar for real-time tuning display and results
•	 Statistical Analysis
	 •	 Design performance distribution versus parameter values

Current sensor optimization 
results using Maxwell 3D 
and Optimetrics
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Multi-domain simulation software

Overview

SIMPLORER® is the premier software program for the design and 
analysis of complex, multi-domain systems commonly found in 
automotive, aerospace/defense and industrial systems. 

Multi-domain system design is challenging and complex. It 
consists of many interdisciplinary and nonlinear components from 
multiple domains: electrical, mechanical, thermal and control. The 
close interaction across domains renders single-domain system 
simulation tools ineffective.
 
SIMPLORER is the only system engineering tool to offer multiple 
standard modeling techniques (VHDL-AMS, circuits, block 
diagrams, state machines, C/C++) that can be used concurrently. 
It also utilizes the concept of “natures,” allowing components of 
different engineering domains to interact.

SIMPLORER is the ideal tool for system designs such as:

 • Power Systems
 • Electric Motors and Drives
 • Powertrains

Modeling Techniques

SIMPLORER v7 offers VHDL-AMS wizard technology, 
making it easy to leverage the IEEE multi-domain 
modeling standard. 

 • Hybrid-electric Propulsion
 • Other Multi-domain 
  Systems

SIMPLORER allows components to be described as behavioral or 
physical models using one or any combination of SIMPLORER’s 
modeling techniques. This eliminates error-prone mathematical 

transformations and model analogies often employed by single-
domain simulation tools. 

VHDL-AMS
IEEE-endorsed modeling language (standard 
1076.1) created to provide a general-
purpose, easily exchangeable and open 
language for multi-domain analog 
mixed-signal designs. 

CIRCUITS
Numerically stable and fast circuit 
simulator with support for multi-level 
semiconductor modeling that is optimized 
to the needs of demanding power-electronic 
and high-switching-frequency circuit design. 

BLOCK DIAGRAMS
Enables the description of signal-flow-based 

linear, nonlinear, continuous, time-discrete 
and hybrid systems, making it ideal for 

dynamic system simulation and closed-
loop-control applications.

STATE MACHINES
Highly efficient modeling technique for 

event-driven systems, such as logical 
control found in embedded control systems, 

space vector controls or PWM for power-
electronic circuits.

v7.0



Models          

SIMPLORER Model Libraries
SIMPLORER offers optional application-specific model libraries to 
enhance productivity and reduce design time:

 • Alternative Power 
 • Automotive 
 • Hydraulic 
 • Machine 

 

Integration

FEA-Based Models
For models requiring the highest level of fidelity, SIMPLORER 
provides a direct link to Ansoft’s industry-leading electromagnetic 
field simulation and design programs: Maxwell®, RMxprt™, and 
PExprt™.  Users can easily create equivalent circuit models from the 
finite-element analysis (FEA) results and import them directly to 
SIMPLORER.  

Alternatively, users can employ the Transient Simulation coupling 
link to couple transient FEA directly to SIMPLORER. This powerful 
feature provides the ultimate in accuracy and flexibility and is ideal 
for detailed analysis of electromechanical components operating 
within a system.

Manufacturers’ Models
SIMPLORER users can access up-to-date manufacturer-specific 
components online at www.model.simplorer.com. MOSFET, IGBT, 
ultra capacitors and other components are available to customers 
as a free download.

Statistical Analysis and Optimization

SIMPLORER includes many advanced analysis capabilities such as 
parametric sweeps and optimization routines to provide insight into 
design variations and “trade-offs.”
  
 • Parameter Sweep/Table
 • Monte Carlo
 • 3D Graphic
 • Genetic Algorithm
 • Successive Approximation

 • Mechanical
 • Power 
 • SMPS
 • Sensor

 • SIMPLEX
 • Frequency Sweep
 • Worst Case
 • Sensitivity

Please consult your local sales representative for pricing and information on this and other Ansoft products.
SIMPLORER, PExprt and RMxprt are trademarks of Ansoft Corporation. All other trademarks are the property of their respective owners.  
PL37-0407   © 2004 Ansoft Corporation

SIMPLORER v7 includes many new statistical design 
and optimization routines.

SIMPLORER v7 now includes a transient simulation coupling link. 
Users can simultaneously solve a transient FEA project with a 
transient system simulation.

Scripting
This powerful feature opens APIs in the SIMPLORER environment, 
allowing SIMPLORER to be embedded into existing design flows. 
The scripting capability is language independent so users can work 
with popular scripting languages, such as Visual Basic®, Java® or 
Tcl/Tk and interact easily with other tools supporting the Microsoft 
Com interface, such as MS Office and LabView®

Co-Simulation
SIMPLORER allows the integration of proprietary C/C++ programs, 
MATLAB®/Simulink®, Mathcad® and other specialized programs, 
allowing SIMPLORER to utilize customized code and existing 
design control. The direct integration of models in their native 
environment avoids model translation, saves design time and 
allows communication and model exchange across departments 
and between suppliers and OEMs.



RMxprt™ is a versatile software program that speeds the design and optimization process of rotating electric machines. With RMxprt, users 
can calculate machine performance, make initial sizing decisions, and perform hundreds of “what if” analyses in a matter of seconds. As 
the entry point for the Ansoft motor and drive design methodology, RMxprt automatically produces both system-level models and geometric 
data, allowing the preliminary design to be refined and integrated with power electronic and control circuitry. 

Key Benefits
Fast design
RMxprt offers numerous machine-specific, template-based interfaces 
for induction, synchronous, and electronically and brush-commutat-
ed machines that allow users to easily enter design parameters and 
to evaluate design tradeoffs early in the design process.

Performance metrics
Critical performance data, such as torque versus speed, power 
loss, flux in the air gap, power factor and efficiency can be quickly 
calculated.

Robust calculation methods
RMxprt uses classical analytical motor theory and equivalent mag-
netic circuit methods to compute performance metrics for a specific 
machine design and accounts for nonlinear magnetic characteristics 
and 3D effects, such as skew and end-turn.

Model pre-processor
RMxprt is a key part of Ansoft’s motor design methodology. In addi-
tion to providing classical motor performance calculations, RMxprt 
can automatically create 3D and 2D geometry and assign material 
properties and other necessary problem definition data necessary 
to perform rigorous finite element analysis on the design using 
Maxwell®. 

Wire library
RMxprt includes a comprehensive database of ANSI and IEC wires. 

High-fidelity system models
RMxprt creates high-fidelity, state-space system models incorporat-
ing machines’ physical dimensions, winding characteristics and non-
linear material properties. Engineers can use the resulting behavioral 
model to explore electronic control topologies, loads, and interac-
tions with drive-system components in Simplorer®.

Convenient design sheet output
Design sheets list all the relevant input parameters and calculated 
parameters and graphically display waveforms including current, 
voltage, torque and back EMF as well as a detailed winding layout. 
RMxprt also can output Excel-format design sheets based on the 
user-defined template.   

Design optimization
RMxprt can perform hundreds of “what if” analyses in a matter of 
minutes, making it a valuable tool for designers needing to make 
initial sizing and material decisions quickly.

Powerful scripting
RMxprt can be integrated with third party development programs 
through scripting languages such as VB script, Tcl/TK, JavaScript®, 
Perl, Excel and MATLAB®.  This allows users to customize the design 
flow and leverage internally developed programs and historical data.

design templates
Machine types 
	 •	 Induction machines 
		  o	 Single-phase motors
		  o	 Three-phase motors
	 •	 Synchronous machines 
		  o	 Line-start PM motors
		  o	 Salient-pole motors and generators 
		  o	 Non-salient pole motors and generators 
	 •	 Brush commutated machines
		  o	 DC motors and generators
		  o	 Permanent magnet DC motors
		  o	 Universal motors
	 •	 Electronically commutated machines
		  o	 Brushless DC motors
		  o	 Adjustable-speed PM motors and generators 
		  o	 Switched reluctance motors
		  o	 Claw-pole generators

RMxprt delivers the reports you need to quickly
analyze and tune your design.

Design Software for Electric Machines

RMxprt ™   
v12
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Key features

•	 Machine-specific template editor 
	 o Rotor 
	 o Stator 
	 o Running strategies 
	 o Drive circuits
•	 Auto-design feature 
	 o Slot size 
	 o Coil turns and wire diameter 
	 o Starting capacitance 
	 o Winding arrangement
•	 Performance curves 
	 o Torque 
	 o Power 
	 o Efficiency

•	 Output waveforms 
	 o Current 
	 o Cogging torque 
	 o Flux in the air gap
•	 Graphical winding editor
•	 Cross section Editor
•	 Customizable design sheet
•	 Cost evaluation
•	 Integrated parametrics and optimization
•	 State-space model export to Simplorer®

•	 Automated project setup for Maxwell® 2D
•	 Automated geometry and material setup for Maxwell 3D

DESIGN FLOW
RMxprt is the ideal starting point for a comprehensive electric machine design flow. RMxprt with Maxwell and Simplorer provides an efficient 
and accurate methodology to design and optimize an electric machine and related electric drive and control system.

RMXPRT™ SIMPLORER®

MAXWELL®

RMxprt™ creates 3D and 2D geometry, assigns materials and sets up 
boundary conditions for Maxwell. Additionally, any parameter changed in 

RMxprt is automatically updated in the finite element project.
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Maxwell 2D is a high-performance interactive software 
package that uses finite element analysis (FEA) to solve 
electric field and magnetic field problems.
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Maxwell 2D solves the electromagnetic field problems for a given
model with appropriate materials, boundaries and source conditions 
applying Maxwell's equations over a finite region of space.
There are two geometry modes available in Maxwell 2D:

Cartesian (XY) model 
Axisymmetric (RZ) model

There are six solvers available in Maxwell 2D:
Electrostatic
AC Conduction Electric Fields
DC Conduction 
Magnetostatic
Eddy Current Magnetic Fields
Transient Magnetic
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Different Methods of Electromagnetic Analysis

Electromagnetic 
Analysis

Analytical 
Techniques

Numerical 
Techniques

Integral 
Equations

Differential 
Equations

Boundary 
Elements

Finite        
Difference

Finite   
Elements

Scalar  
Potentials

Vector  
Potentials

Components of 
H-Field

Closed 
Form

BEM

FDM

FEM

Iterative

3D Magnetostatic

3D Eddy

3D Transient

2D Magnetostatic

2D Eddy

2D Transient

2D Electrostatic

3D Thermal

3D Electrostatic
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Differential Form of Maxwell’s Equations
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FEM and adaptive meshing
In order to obtain the set of algebraic 
equations to be solved, the geometry 
of the problem is discretized
automatically into small elements 
(e.g., triangles  in 2D). 
All the model solids are meshed 
automatically by the mesher.
The assembly of all triangles is 
referred to as the finite element 
mesh of the model or simply the 
mesh. 
Approximate aspect ratio limit in 2D: 

X = 10,000Y

Start              
Field Solution

Generate     
Initial Mesh

Compute    
Fields

Perform       
Error Analysis

Stop              
Field Solution

Has        
Stopping 

Criteria been 
met?

Refine          
Mesh

Yes

No

Y
X
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FEM Approximation Functions

The desired field in each element is approximated with a 2nd order 
quadratic polynomial

Az(x,y) = ao + a1x +  a2y + a3x2 + a4xy + a5 y2

Field quantities are calculated for 6 points (3 corners and 3 
midpoints) in 2D
Field quantities inside of the triangle are calculated using a 2nd

order quadratic interpolation scheme
1

6 2

35
4



Ansoft Maxwell Field Simulator v12 – Training Seminar P1-7

Overview
Presentation

1

FEM Variational Principle

Poisson’s equation:

is replaced with energy functional:

This functional is minimized with respect to value of  A at each
node in every triangle 

JA µ−=∇2

( ) dVJAAAAF ∫ 

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∇•∇
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FEM Matrix Equation

Now, over all the triangles, the result is a large, sparse matrix equation

This can be solved using standard matrix solution techniques such as:

Sparse Gaussian Elimination (direct solver)

Incomplete Choleski Conjugate Gradient Method (ICCG iterative 
solver)

[ ][ ] [ ]JAS =
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FEM Error Evaluation

Put the approximate solution back into Poisson’s equation

Since  A  is a quadratic function, R is a constant in each triangle. 

The local error in each triangle is proportional to R. 

RJAapprox =+∇ µ2
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FEM Percent Error Energy

Summation of local error in each triangle divided by total energy

Local errors can exceed Percent Error Energy 
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Transient Solver 
Fully Coupled Dynamic Physics Solution

AvHV
t
AJA cs ×∇×+×∇+∇−
∂
∂

−=×∇×∇ σσσυ

Current Source 
Density

Permanent MagnetMagnetic Vector Potential

Electric Scalar 
Potential

Velocity 

Time-varying Electric and Magnetic Fields
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Transient Solver - Magnetic Field Diffusion 

Magnetic fields “diffuse” into materials at different rates depending 
on:

Material properties of the component
Physical size of the component

For a cylindrical conductor, diffusion time is:

Induced eddy currents always occur in conducting objects due to 
time-varying fields; however, they may not always be significant

metersinradiusatyconductivipermuwhere

au

===

=

,,:

(sec)
4048.2 2
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GUI - Desktop
The complex functionality built into the Maxwell solvers is accessed through 
the main user interface (called the desktop). 
Problem can be setup in a fairly arbitrary order.
A new “validation check” has been added to insure that all required steps are 
completed.
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ACIS solid modeling kernel

The underlying solid modeling technology used by Ansoft products is 
provided by ACIS geometric modeler. ACIS version 16 is presently
used.
Users can create directly models using primitives and operations on 
primitives.
In addition, users can import models saved in a variety of formats (sm2 
.gds .sm3 .sat .step .iges .dxf .dwg .sld .geo .stl .prt .asm) 
When users import models into Ansoft products, translators are 
invoked that convert the models to an ACIS native format (sat format). 
Exports directly .sat, .dxf, .sm3, .sm2, .step, .iges
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Supported platforms

Windows XP Pro
Windows XP Pro x64 Edition
Windows Server 2003
Windows Server 2003 x64 Edition
Red Hat Enterprise Linux 3, 4
SuSE Linux Enterprise Server 9.3
Solaris 8 -10
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Starting Maxwell
Click the Microsoft Start button, select Programs, and select the Ansoft > 
Maxwell 12 > Maxwell 12
Or Double click on the Maxwell 12 icon  on the Windows Desktop

Adding a Design
When you first start Maxwell a new project will be automatically added to the 
Project Tree.
To insert a Maxwell Design to the project, select the menu item Project > Insert 
Maxwell 2D Design

Toolbar:
Insert Maxwell 2D Design

Insert Maxwell 3D Design

Insert RMxprt Design
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Maxwell Desktop

Status 
bar

History 
Tree

Menu 
bar

Toolbars

Project
Manager
with project
tree

2D Modeler
Window

Property 
Window

Progress 
WindowMessage 

Manager

Coordinate Entry Fields
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Maxwell Desktop – Project Manager
Multiple Designs per Project

Multiple Projects per Desktop

Integrated Optimetrics Setup (requires license for analysis)

Project Manager Window

DesignProject

Design Setup

Design Automation
•Parametric
•Optimization
•Sensitivity
•Statistical

Design Results
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Maxwell Desktop – 2D Modeler

Graphics
area

Model

2D Modeler 
design tree
(history)

2D Modeler Window

Edge

Vertex
Context menu
(right mouse click 
on 2D modeler 
window)

Origin
XY 

Coordinate 
System
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Geometry Mode
To set the geometry mode:

1. Select the menu item Maxwell  2D > Solution Type
2. Solution Type Window:

Choose Geometry Mode: Cartesian XY

Maxwell – Geometry Modes
A Cartesian (XY) model represents a cross-section of a 
device that extends in the z-direction.  Visualize the 
geometric model as extending perpendicular to the plane 
being modeled.
An Axisymmetric (RZ) model represents a cross-section of a 
device that is revolved 360° around an axis of symmetry (the 
z-axis).  Visualize the geometric model as being revolved 
around the z-axis.

Geometric Model

Cartesian (XY Plane) Axisymmetric (RZ Plane)

X
Y

Z

Z

R

Φ
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Set Solution Type
To set the solution type: select the menu item Maxwell  2D > Solution Type

Magnetic Solution Types
Magnetostatic
Computes the static magnetic field that exists in a structure given a distribution of DC currents and permanent 
magnets. The magnetic field may be computed in structures with both nonlinear and linear materials. An inductance 
matrix, force, torque, and flux linkage may also be computed from the energy stored in the magnetic field.
Eddy Current
Computes the oscillating magnetic field that exists in a structure given a distribution of AC currents. Also computes 
current densities, taking into account all eddy current effects (including skin effects). An impedance matrix, force, 
torque, core loss, and current flow may also be computed from the computed field solution.
Transient
Computes transient (Time Domain) magnetic fields caused by permanent magnets, conductors, and windings 
supplied by voltage and/or current sources with arbitrary variation as functions of time, position and speed. It can 
also be coupled with external circuits. Rotational or translational motion effects can be included in the simulation. 
Uses a time-stepping solver. Considers source induced and motion inducted eddy effects.

Electric Solution Types
Electrostatic 
Computes the static electric field that exists in a structure given a distribution of DC voltages and static charges. A 
capacitance matrix, force, torque, and flux linkage may also be computed from the electric field.
AC Conduction
Computes the AC voltages and current density distribution in a material having both conductive and dielectric 
properties given a distribution of AC voltages. An admittance matrix and current flow may also be computed from 
the calculated fields.
DC Conduction
Computes the DC currents that flow in a lossy dielectric given a distribution of DC voltages. A conductance matrix 
and current flow may also be computed from the computed electric field solution.
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Set Model Units
To set the units:

1. Select the menu item 
Modeler > Units

2. Set Model Units:

1. Select Units: mm

2. Click the OK button

Set Default Material
To set the default material:

1. Using the Modeler 
Materials toolbar, choose 
Select

2. Select Definition Window:

1. Type steel_1008 in 
the Search by Name
field

2. Click the OK button
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Modeler – Draw a Rectangle

Point 1

Point 2

Point 1

Point 2

Coordinate Entry Fields

The Coordinate Entry fields allow equations to be entered for position values.  

Examples: 2*5, 2+6+8, 2*cos(10*(pi/180)).

Variables are not allowed in the Coordinate Entry Field

Note: Trig functions are in radians
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Modeler – Importing .dxf and .dwg CAD files

Check “Import as 2D sheet bodies” so objects come in as sheets and not solids

To change the number of segments on an imported curve:
Change to face select mode: Edit > Select > Faces and click on face 

Modeler > Surface > Uncover Faces 

Change to object select mode: Edit > Select > Objects and click on open polyline

Modeler > Purge History 

Modeler > Generate History 

Expand the history tree for that polyline and change number of segments as desired 

Select the polyline and: Modeler > Surface > Cover Lines 
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Modeler – Object Properties
In History Tree:

Commands

(dimensions 
and history)

Attributes

Commands

Attributes

(properties 
of the object)
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Solve Inside – if unchecked 
meshes but no solution inside 
(like the old exclude feature in 
material manager)

Model – if unchecked, the object is 
totally ignored outside of modeler with 
no mesh and no solution 

Modeler – Attributes



Ansoft Maxwell Field Simulator v12 – Training Seminar P1-27

Overview
Presentation

1

Modeler - Views
View > Modify Attributes >

Orientation – Predefined/Custom View Angles 

Lighting – Control angle, intensity, and color of light

Projection – Control camera and perspective

Background Color – Control color of 3D Modeler 
background

View > Visualization Settings – displayed resolution of curves

View > Active View Visibility - Controls the display of: 3D 
Modeler Objects, Color Keys, Boundaries, Excitations, Field 
Plots

View > Options – Stereo Mode, Drag Optimization, Color Key 
Defaults, Default Rotation

View > Render > Wire Frame or Smooth Shaded (Default)

View > Coordinate System > Hide or Small (Large)

View > Grid Setting – Controls the grid display

Toolbar: Toggle Grid Visibility
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Changing the View
Toolbar

Context Menu

Shortcuts

Since changing the view is a frequently used operation, some useful shortcut keys exist.  Press the 
appropriate keys and drag the mouse with the left button pressed:

ALT + Drag – Rotate

In addition, there are 9 pre-defined view angles that can be selected by holding the ALT key and 
double clicking on the locations shown on the next page.

Shift + Drag - Pan

ALT + Shift + Drag – Dynamic Zoom

Pan

Rotate Around
Model Center

Dynamic Zoom

Zoom In/Out

Top

Bottom

Right

Predefined View Angles

Left

Rotate Around
Current Axis

Rotate Around
Screen Center

Fit All

Fit Selected
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Maxwell V12 Keyboard Shortcuts

General Shortcuts
F1: Help
Shift + F1: Context help
CTRL + F4: Close program
CTRL + C: Copy
CTRL + N: New project
CTRL + O: Open...
CTRL + S: Save
CTRL + P: Print...
CTRL + V: Paste
CTRL + X: Cut
CTRL + Y: Redo
CTRL + Z: Undo
CTRL + 0: Cascade windows
CTRL + 1: Tile windows horizontally
CTRL + 2: Tile windows vertically

Modeller Shortcuts

B: Select face/object behind current selection

F: Face select mode

O: Object select mode

CTRL + A: Select all visible objects

CTRL + SHIFT + A: Deselect all objects

CTRL + D: Fit view

CTRL + E: Zoom in, screen center

CTRL + F: Zoom out, screen center

CTRL + Enter: Shifts the local coordinate system 
temporarily

SHIFT + Left Mouse Button: Drag

Alt + Left Mouse Button: Rotate model

Alt + SHIFT + Left Mouse Button: Zoom in / out

F3: Switch to point entry mode (i.e. draw objects 
by mouse)

F4: Switch to dialogue entry mode (i.e. draw 
object solely by entry in command and attributes 
box.)

F6: Render model wire frame

F7: Render model smooth shaded 

Alt + Double Click Left Mouse Button at points on screen: Sets model 
projection to standard isometric projections (see diagram below).

ALT + Right Mouse Button + Double Click Left Mouse Button at points 
on screen:  give the nine opposite projections.

Top

Bottom

Right

Predefined View Angles

Left
Alt + double left Click 
here to restore view in 
an RZ model

Alt + double left Click 
here to restore view in 
an XY model
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Simple Example
Magnetic core with coil

Use 2D RZ Magnetostatic Solver

Coil (120 Conductors, Copper)

Core (Steel_1008)
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Setup the geometry mode and solver
Choose Cylindrical about Z under Maxwell  2D > Solution Type
Choose Magnetostatic

Click the OK button

Create Core
To create the core:

1. Select the menu item Draw >  Rectangle
2. Using the coordinate entry fields, enter the center position

X: 0.0, Y: 0.0, Z: -3.0, Press the Enter key

3. Using the coordinate entry fields, enter the opposite corner of the rectangle

dX: 2.0, dY: 0.0, dZ: 10.0, Press the Enter key

Continued on Next Page
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Create Core (Continued)
To Parameterize the Height

1. Select the Command tab from the Properties window

2. ZSize: H

3. Press the Tab key

4. Add Variable Window

1. Value: 10mm

2. Click the OK button

To set the name:

1. Select the Attribute tab from the Properties window.

2. For the Value of Name type: Core

To set the material:

1. Select the Attribute tab from the Properties window

2. Click on the button in Material value: set to steel_1008

To set the color:

1. Select the Attribute tab from the Properties window.

2. Click the Edit button

To set the transparency:

1. Select the Attribute tab from the Properties window.

2. Click the OK button

To finish editing the object properties

1. Click the OK button

To fit the view:

1. Select the menu item View > Fit All > Active View
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Set Default Material
To set the default material:

1. Using the 3D Modeler Materials toolbar, choose Select

2. Select Definition Window:

1. Type copper in the Search by Name field

2. Click the OK button

Create Coil 
To create the coil for the current to flow:

1. Select the menu item Draw >  Rectangle
2. Using the coordinate entry fields, enter the center position

X: 2.0, Y: 0.0, Z: 0.0, Press the Enter key

3. Using the coordinate entry fields, enter the opposite corner of the rectangle

dX: 2.0, dY: 0.0, dZ: 4.0, Press the Enter key

To set the name:

1. Select the Attribute tab from the Properties window.

2. For the Value of Name type: Coil

3. Click the OK button

To fit the view:

1. Select the menu item View > Fit All > Active View
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Create Excitation
Assign Excitation

1. Click on the coil.

2. Select the menu item Maxwell  2D > Excitations > Assign > Current
3. Current Excitation : General

1. Name: Current1

2. Value: 120 A  (Note: this is 120 Amp-turns)

3. Ref. Direction: Positive

4. Click the OK button

5. Note that for RZ models, positive current flows into the screen,
however for XY models, positive current flows out of the screen.



Ansoft Maxwell Field Simulator v12 – Training Seminar P1-35

Overview
Presentation

1

Define a Region 
Before solving a project a region has to be defined. A region is basically an outermost object that contains all other 
objects. The region can be defined by a special object in Draw > Region. This special region object will be resized 
automatically if your model changes size.

A ratio in percents has to be entered that specifies how much distance should be left from the model.

To define a Region:

1. Select the menu item Draw > Region
1. Padding Data: One

2. Padding Percentage: 200

3. Click the OK button

Note: Since there will be considerable fringing 
in this device, a padding percentage of at least 
2 times, or 200% is recommended
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Setup Boundary
Assign Boundary

1. Change to edge selection mode by choosing: Edit > Select > Edges
2. Using the mouse, click on the top, right and bottom edges while holding down the CTRL key.

3. Select the menu item Maxwell  2D > Boundary > Assign > Balloon
4. Click the OK button
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Add Solution Setup

Solution Setup - Creating an Analysis Setup
To create an analysis setup:

1. Select the menu item Maxwell  2D> Analysis Setup > Add Solution 
Setup

2. Solution Setup Window:

1. Click the General tab:

Maximum Number of Passes: 10

Percent Error: 1

2. Click the OK button
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Save Project
To save the project:

1. In an  Ansoft Maxwell window, select the menu item File > Save As.

2. From the Save As window, type the Filename: 2D_simple_example

3. Click the Save button

Model Validation
To validate the model:

1. Select the menu item Maxwell  3D> Validation Check
2. Click the Close button

Note: To view any errors or warning messages,                     
use the Message Manager.

Analyze
To start the solution process:

1. Select the menu item Maxwell  2D>  Analyze All

Validate Analyze All
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View detailed information about the progress 

In the Project Tree click on Analysis > Setup1 with the right mouse button und select Profile
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Mesh Overlay
Create a plot of the mesh

1. Select the menu item Edit > SelectAll
To create a mesh plot:

1. Select the menu item Maxwell  2D > Fields > Plot 
Mesh

2. Create Mesh Window:

1. Click the Done button
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Field Overlays
To create a field plot:

1. In the object tree, select the plane for plotting:

1. Using the Model Tree, expand Planes

2. Select Global:XZ

2. Select the menu item Maxwell  2D> Fields > Fields >  B > Mag_B
3. Create Field Plot Window

1. Solution: Setup1 :  LastAdaptive

2. Quantity: Mag_B

3. In Volume: Allobjects

4. Click the Done button

4. When done, turn off the plot using:
View > Active View Visibility > Filed Reporter 
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Field Overlays (cont)
Create another field plot:

1. In the object tree, select the plane for plotting:

1. Using the Model Tree, expand Planes

2. Select Global:XZ

2. Select the menu item Maxwell  2D> Fields > Fields >  B > B_Vector
3. Create Field Plot Window

1. Solution: Setup1 :  LastAdaptive

2. Quantity: B_Vector

3. In Volume: Allobjects

4. Click the Done button

4. When done, turn off the plot using:
View > Active View Visibility > Filed Reporter 



Ansoft Maxwell Field Simulator v12 – Training Seminar P1-43

Overview
Presentation

1

Field Overlays (cont)
Create another  field plot:

1. In the object tree, select the plane for plotting:

1. Using the Model Tree, expand Planes

2. Select Global:XZ

2. Select the menu item Maxwell  2D> Fields > Fields >  A > Flux_Lines
3. Create Field Plot Window

1. Solution: Setup1 :  LastAdaptive

2. Quantity: Flux_Lines
3. In Volume: Allobjects

4. Click the Done button

4. When done, turn off the plot using:
View > Active View Visibility > Filed Reporter 

This completes the simple example.
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Screen Capturing
To save the drawing Window or a plot to the clipboard select the menu item: Edit > Copy  Image
In any Windows application, select: Edit > Paste to paste the image
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File Structure
Everything regarding the project is stored in an ascii file

File: <project_name>.mxwl

Double click from Windows Explorer will open and 
launch Maxwell v12

Results and Mesh are stored in a folder named 
<project_name>.mxwlresults

Lock file: <project_name>.lock.mxwl

Created when a project is opened

Auto Save File: <project_name>.mxwl.auto

When recovering, software only checks date

If an error occurred when saving the auto file, the 
date will be newer then the original  

Look at file size (provided in recover dialog)
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Scripts
Default Script recorded in v12

Visual Basic Script

Remote Solve (Windows Only)
Tools > Options > General Options > Analysis Options
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Overall Setup Process
Design

Solution Type

2. Boundaries

2. Excitations
3.  Mesh 

Operations
2.  Analysis Setup

Solution Setup
Frequency Sweep

1. Parametric Model
Geometry/Materials

4.  Results
2D Reports

Fields

Mesh
Refinement

Solve

Update

Converged

Analyze

Finished

2. Solve Loop

NO

YES
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Menu Structure
Draw – Primitives

Modeler – Settings and Boolean Operations

Edit – Copy/Paste, Arrange, Duplicate

Maxwell 2D – Boundaries, Excitations, Mesh Operations, Analysis Setup, Results
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Modeler – Model Tree
Select menu item Modeler > Group by Material

Grouped by Material

Material

Object

Object Command History

Object View
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Modeler – Commands
Parametric Technology

Dynamic Edits - Change Dimensions

Add Variables

Project Variables (Global) or Design Variables (Local)

Animate Geometry

Include Units – Default Unit is meters

Supports mixed Units
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Modeler – Primitives

2D Draw Objects

The following 2D Draw objects are available:

Line, Spline, Arc, Equation Based Curve,

Rectangle, Ellipse, Circle, Regular Polygon, 
Equation Based Surface

3D Draw Objects

Note that 3D objects can be pasted into the 2D 
model window, but they are ignored by the solution

The following 3D Draw objects are available (in 
Maxwell 3D):

Box, Cylinder, Regular Polyhedron 

Cone, Sphere, Torus, Helix, Spiral, Bond Wire

True Surfaces

Circles, Cylinders, Spheres, etc are represented as 
true surfaces. In versions prior to release 11 these 
primitives would be represented as faceted objects. 
If you wish to use the faceted primitives, select the 
Regular Polyhedron or Regular Polygon.

Toolbar: 2D Objects
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Modeler – Boolean Operations/Transformations
Modeler > Boolean >

Unite – combine multiple primitives

Unite disjoint objects (Separate Bodies to separate)

Subtract – remove part of a primitive from another

Intersect– keep only the parts of primitives that overlap

Split – break primitives into multiple parts along a plane (XY, YZ, XZ)

Split Crossing Objects – splits objects along a plane (XY, YZ, XZ) only where they intersect

Separate Bodies – separates objects which are united but not physically connected into individual 
objects

Edit > Arrange >
Move – Translates the structure along a vector

Rotate – Rotates the shape around a coordinate axis by an angle

Mirror – Mirrors the shape around a specified plane

Offset – Performs a uniform scale in x, y, and z.

Edit > Duplicate >
Along Line – Create multiple copies of an object along a vector

Around Axis – Create multiple copies of an object rotated by a fixed angle around the x, y, or z axis

Mirror - Mirrors the shape around a specified plane and creates a duplicate

Edit > Scale – Allows non-uniform scaling in the x, y, or z direction

Toolbar: Boolean

Toolbar: Arrange

Toolbar: Duplicate
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Modeler - Selection
Selection Types

Object (Default)

Face

Edge

Vertex

Selection Modes
All Objects

All Visible Object

By Name

Highlight Selection Dynamically – By default, moving the mouse pointer over an object will dynamically 
highlight the object for selection.  To select the object simply click the left mouse button.

Multiple Object Selection – Hold the CTRL key down to graphically select multiple objects

Next Behind – To select an object located behind another object, select the front object, press the b key to get 
the next behind.  Note:  The mouse pointer must be located such that the next behind object is under the 
mouse pointer.

To Disable:  Select the menu item Tools > Options > Modeler Options
From the Display Tab, uncheck Highlight selection dynamically

Selected

Dynamically Highlighted
(Only frame of object)
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Modeler – Moving Around
Modeler > Snap Mode to set the snaps

Tools > Customize…
Snap Mode to view Snap Mode toolbar

Toolbar: Snap Mode
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Modeler – Coordinate Systems
Can be Parameterized

Working Coordinate System

Currently selected CS.  This can be a local or global CS

Global CS

The default fixed coordinate system

Relative CS

User defined local coordinate system.

Offset

Rotated

Both

Face CS (setting available to automatically switch to face coordinate system in the Modeler Options)

Toolbar: Coordinate System

Step 1: Select Face Step 2: Select Origin

Step 3: Set X-Axis New Working CS

Change Box Size and Cone is 
automatically positioned with 

the top face of the box

Cone created with Face CS
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2D Measure 
Modeler > Measure >

Position – Location, Distance, and Area

Edge – Edge Length

Face – Surface Area

Object – Surface Area, Object Volume

Position Points



Ansoft Maxwell Field Simulator v12 – Training Seminar P1-57

Overview
Presentation

1

Options – General
Tools > Options > General Options > Project Options

Temp Directory – Location used during solution process
Make sure it has at least 512MB free disk.

Options - Maxwell
Tools > Options >  Maxwell Options > Solver

Set Number of Processors = 2 for 1 dual-core processor 
or two single-core processors.  Requires additional 
license
Default Process Priority – set the simulation priority from 
Critical
(highest) to Idle (lowest)
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Options – Modeler Options
Tools > Options >  Modeler Options > Drawing for Point and Dialog Entry Modes

Can enter in new dimensions using either Point (mouse) or Dialog entry mode

Alternatively use F3 and F4 to switch between Point and Dialog entry modes

Tools > Options > Modeler Options > Display tab to enable playback
Must close and re-open Maxwell after making change for this setting, to activate
Visualization is seen by clicking on primatives in the history tree (under subtract command, for instance)

Typical “Dialog”
entry mode 

window
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Converting Older Maxwell Projects (pre-Maxwell v12) to Maxwell v12
From Maxwell v 11 and older, 

1. Select the menu item File > Open
2. Open dialog

1. Files of Type:  Ansoft Legacy EM Projects (.cls)

2. Browse to the existing project and select the .cls file

3. Click the Open button

What is Converted?

Converts Entire Model: Geometry, Materials, Boundaries,

Sources and Setup

Solutions, Optimetrics projects and Macros are not converted
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Material Setup - Libraries 
3-Tier library structure

System (global) level – predefined from Ansoft and ships with new upgrades, users cannot 
modify this
User Library – to be shared among several users at a company (can be encrypted)
Personal libraries - to be used only by single user (can be encrypted)

Add a new material: Tools > Edit Configured Libraries > Materials
New Interface for Materials Setting shared with RMxprt
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Click “Add Material …”. The Material is only available in Project

To add a material in the user or personal library: click on “Export Library” and save it in the desire 
library.

In the main project window, click on Tools > Configured Libraries. Locate the library to have the 
material available for all the projects.

Click on Save as default to automatically load library for any new project.
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Materials Setup - Editing
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Material Setup – BH curve
Robust BH curve entry – can delete points if you make a mistake

Can import data from a file

To export BH curve for use in future, right-mouse-click on curve and select Export to File…
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Material Setup - Permanent Magnets
Direction of magnetization determined by 
material’s object’s Orientation and Magnetic 
Coercivity Unit Vectors.

To modify the Orientation, open the Attribute for 
the object and change the coordinate system. The 
default Orientation for permanent magnets is 
Global CS.

To modify the Magnetic Coercivity Unit Vectors for 
a permanent magnet material, enter the Materials 
Library and edit the material.
The material coordinate system type can be 
described in Cartesian, Cylindrical, Spherical  
The magnetic coercivity has unit vectors 
corresponding to the chosen coordinate system: for 
instance X,Y,Z for cartesian.

To rotate a magnet in a parametric simulation and 
the magnetization direction, you must first rotate 
the object and second assign the FaceCS, as 
shown below in the history tree

1. Rotate                                  
2. Create FaceCS
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Material Setup - Anisotropic Material Properties

ε1, µ1, and σ1 are tensors in the X direction. 
ε2, µ2, and σ2 are tensors in the Y direction. 
ε3, µ3, and σ3 are tensors in the Z direction. 

Note: Nonlinear anisotropic permeability not allowed in Maxwell 2D.
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Planes of symmetry in 
periodic structures where E is 
oblique to the boundary.

The E-field on the slave boundary is forced to match the magnitude 
and direction (or the negative of the direction) of the E-field on the 
master boundary.

Matching 
(Master and 
Slave)

Use this boundary condition 
when the resistive layer’s 
thickness is much smaller 
than the other dimensions of 
the model.

A resistance boundary models a very thin layer of resistive material 
(such as that caused by deposits, coatings or oxidation on a 
metallic surface) on a conductor at a known potential.

Resistance

(DC conduction 
solver only)

Ground at infinityField behaves so that voltage can fringeBalloon

Boundary Type E-Field Behavior Used to model…

Default 
Boundary 
Conditions 
(Natural and 
Neumann)

Field behaves as follows: 

Natural boundaries — The normal component of D changes by 
the amount of surface charge density. No special conditions are 
imposed.

Neumann boundaries — E is tangential to the boundary. Flux 
cannot cross a Neumann boundary.

Ordinary E-field behavior on 
boundaries. Object interfaces 
are initially set to natural 
boundaries; outer boundaries 
are initially set to Neumann 
boundaries.

Symmetry Field behaves as follows: 

Even Symmetry (Flux Tangential) — E is tangential to the 
boundary; its normal components are zero.

Odd Symmetry (Flux Normal) — E is normal to the boundary; its 
tangential components are zero.

Planes of geometric and 
electrical symmetry. 

Electric Field Boundary Conditions (Electrostatic, DC Conduction, AC Conduction)
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No fringing at infinityField behaves so that magnetic flux can fringeBalloon

Boundary Type H-Field Behavior Used to model…

Default Boundary 
Conditions (Natural
and Neumann)

Field behaves as follows: 

Natural boundaries — H is continuous across the boundary.

Neumann boundaries — H is tangential to the boundary 
and flux cannot cross it.

Ordinary field behavior. Initially, 
object interfaces are natural 
boundaries; outer boundaries and 
excluded objects are Neumann 
boundaries.

Magnetic Vector 
Potential

Sets the magnetic vector potential on the boundary. 

Note: In the Magnetostatic solver, A is RMS while in the Eddy 
Current solver, A is peak.

Magnetically isolated structures.

Symmetry Field behaves as follows: 

Odd Symmetry (Flux Tangential) — H is tangential to the 
boundary; its normal components are zero.

Even Symmetry (Flux Normal) — H is normal to the 
boundary; its tangential components are zero.

Planes of geometric and magnetic 
symmetry.

Impedance

(Eddy Current only)

Includes the effect of induced currents beyond the boundary 
surface.

Conductors with very small skin 
depths. 

Matching (Master
and Slave)

The H-field on the slave boundary is forced to match the 
magnitude and direction (or the negative of the direction) of 
the H-field on the master boundary.

Planes of symmetry in periodic 
structures where H is oblique to the 
boundary.

Magnetic Field Boundary Conditions (Magnetostatic, Eddy Current, Transient)
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The charge density in an object.Charge Density

Notes: 

In the Electrostatic solver, any conductor without a source condition will be 
assumed to be floating.

Source Type of Excitation

Floating 
Conductor

Used to model conductors at unknown potentials.

Voltage The DC voltage on a surface or object.

Charge The total charge on a surface or object (either a conductor or 
dielectric).

Electric Field Sources (Electrostatic, DC Conduction, AC Conduction)
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The current density in a conductor.Current Density

Source Type of Excitation

Current The total current in a conductor.

Notes: 

In the Magnetostatic solver, current is RMS ampturns.

Permanent magnets will also act as a source in the Magnetostatic solver.

Magnetic Field Sources (Magnetostatic)

Magnetic Field Sources (Eddy Current)

The current density in a conductor.Current Density

Source Type of Excitation

Current The total current in a conductor.

Parallel Current The total current in a a group of parallel conductors.

Notes: 

In the Eddy Current solver, current is peak amp-turns.

Sources can be solid (with eddy effects) or stranded (without eddy effects).
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Current or voltage on a winding 
representing 1 or more turns

Coil

Source Type of Excitation

Current The total current in a conductor.

Current Density The current density in a conductor.

Permanent magnets will also act as a source in the 
Transient solver.

Magnetic Field Sources (Transient)

Current and voltage sources (solid or stranded) can be constant or functions of intrinsic 
variables: speed (rpm or deg/sec), position (degrees), or time (seconds)
Dataset function can be used for piecewise linear functions: Pwl_periodic (ds1, Time)
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Magnetic Field Sources (Transient)

Maxwell 2D > Excitation > Current
Value: applies current in amps

Type:
Solid

for windings having a single 
conductor/turn
eddy effects are considered

Stranded
for windings having many 
conductors/turns
eddy effects are not considered

Ref Direction:
Positive or Negative
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Magnetic Field Sources (Transient)

Maxwell 2D > Excitation > Add Winding
Current – applies current in amps

Solid or Stranded

Input current and number of parallel branches as 
seen from terminal

Voltage – applies voltage (total voltage drop over the 
length of a solid conductor or the entire winding)

Solid or Stranded

Input initial current, winding resistance, extra 
series inductance not considered in FEA model, 
voltage, and number of parallel branches as seen 
from terminal

External – couples to Maxwell Circuit Editor

Solid or Stranded

Input initial current and number of parallel 
branches

Maxwell 2D > Excitation > Assign > Coil
Pick a conductor on the screen and then specify:

Name

Number of Conductors

Polarity: positive, negative, or functional winding 
direction

Note: Windings in the XY solver will usually have 2 coils: one 
positive and one negative polarity.  Both coils will be 
added to the appropriate winding by right-mouse clicking 
on Coil in the project tree and choosing Add to Winding
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To Create an External Circuit
1. Select: Maxwell2D > Excitations > External Circuit > Edit External Circuit > Import Circuit
2. After circuit editor opens, add elements to construct the circuit. Note that the name of the 

Winding in the circuit (Winding1) must match the name of the Winding in Maxwell (Winding1)

3. Save circuit as *.amcp file and then Maxwell Circuit > Export Netlist > *.sph file. 

0

LWinding15.3ohm
LabelID=R3
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Model
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switch2
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S_sw2
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Model
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switch1
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lID
=V

I1

Note: 
The dot on the winding 
symbol is used as the 
positive reference for 
the current (positive 
current is oriented 
from the "dotted" 
terminal towards to 
"un-dotted" terminal 
of the winding as it 
passes through the 
winding).
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Maxwell 2D > Excitation > Set Eddy Effects
Need to enable the calculation of eddy effects in objects

Maxwell 2D > Excitation > Set Core Loss
For objects with zero conductivity (such as a laminated core), 
you can calculate the core loss
Note that the core loss coefficients must be defined in the 
material setup
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Core Loss Calculation Method

The core loss for electrical steel is based on:

where:
Kh is the hysteresis coefficient. 
Kc is the classical eddy coefficient. 
Ke is the excess or anomalous eddy current coefficient due to magnetic domains. 
Bmax the maximum amplitude of the flux density. 
f is the frequency. 

The power ferrite core loss is based on: 

where:
Cm is constant value determined by experiment. 
fx is the frequency. 
Bymax is the maximum amplitude of the flux density

( ) ( ) 5.1
max

2
max

2
max fBKfBKfBKp ech ++=
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Maxwell 2D > Design Settings
The Design Settings window allows you to specify how the simulator will deal with some 
aspects of the design. Tabs vary by solver used (the panel below is for the transient 
solver)
Set the Symmetry Multiplier (For Transient XY Solutions only).

Set the Material Threshold for treating materials as conductors vs. insulators.
Set Preserve Transient Solution options (For Transient Solutions Only).
Set transient coupling with Simplorer on the Advanced Product Coupling tab (For 
Transient Solutions Only)
Set the Model Depth (Maxwell2D XY Transient Designs Only).
Set the default Background material (Maxwell2D Designs Only).



Ansoft Maxwell Field Simulator v12 – Training Seminar P1-77

Overview
Presentation

1

Maxwell 2D > Parameters
Allows the automatic calculation of parameters following the field solution

Includes: Force, Torque, Flux linkage, Core loss, and Matrix
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Maxwell 2D > Model > Motion Setup > Assign Band

1. Defines the direction and type of motion (translation or rotation)

2. Defines the mechanical parameters such as mass, damping, and load force

3. Defines limits of motion 
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Magnetostatic and Electric Solution Setup
Start the menu of solution setup by: Maxwell > Analysis Setup > Add Solution Setup …
For Magnetostatic solver on Solver tab, suggest setting nonlinear residual = 0.001.  On default tab choose Save 
Defaults to set this value for all future projects.
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Eddy Current Solution Setup
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Transient Solution Setup
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Mesh Operations
To assign Mesh operations to Objects, select the Menu item: Maxwell 2D > Assign Mesh Operations 

1. On Selection is applied on the surface of the object

2. Inside Selection is applied through the volume of the object

3. Surface approximation  is applied to set faceting guidelines for true surface objects
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1. Mesh Operations “On selection”
applied on the perimeter of the object

Element length based refinement: Length Based
Skin Depth based refinement: Skin Depth Based

On selection – length based

On selection – skin 
depth based (2 layers)
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2. Mesh Operations “Inside selection” - applied throughout the volume of the object
Element length based refinement: Length Based

Inside selection – length based
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3. Mesh Operations “Surface Approximation”
For true surfaces, perform faceting control on a 
face-by-face basis 

Select Mesh operation > Assign > Surface 
approximation and specify one or more settings:

Maximum surface deviation (length) 

Maximum Surface Normal Deviation 
(degrees) 

Maximum Aspect Ratio

ro

ri ri
rooAspectRati
*2

=

D

Θ
r

D = Maximum Surface 
Deviation

Θ = Maximum Surface 
Normal Deviation

))2/cos(1( Θ−= rD
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Manual mesh creation
To create the initial mesh: Click Maxwell > Analysis Setup > Apply Mesh Operations
To refine the mesh without solving

1. Define mesh operations as previously discussed

2. Click Maxwell > Analysis Setup > Apply Mesh Operations
3. Click Maxwell > Analysis Setup > Revert to Initial Mesh  to restart to the initial mesh

To view mesh information: Click Maxwell > Results > Solution Data and click on the tab Mesh Statistics
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Mesh Display
1. Select an object

2. Select the menu item Maxwell 2D > Fields > Plot Mesh
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2D transient meshing for rotational models

“Moving Surface” method used

Band

Air gap

Rotor

Stator

1234567
1'2'3'4'5'6'7'

master moving surface

slave moving surface

stationary part

moving part(s)
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2D transient meshing for translational models

“Moving Band” method used
Adaptive meshing not used, so user must manually create the mesh or link to a solved MS or Eddy 
design 

The band area is re-meshed at each time step

The stationary region and moving part(s) are not re-meshed

If you link the mesh to a solved MS or Eddy design:

The entire mesh from the linked design is transferred to the transient design.

The mesh in objects inside and outside of the band never changes as motion occurs.

If the starting transient position is the same as the linked MS or Eddy design, then the linked 
mesh in the band object is reused. 

If the starting transient position is the different than the linked MS or Eddy design, then the 
linked mesh in the band object is completely deleted.  The band is then re-meshed based only 
on mesh operations in the transient solver. Any mesh or mesh operation on the band in the 
linked MS or Eddy Design is ignored. The key point is that mesh operations are always required 
on the band object (use inside selection) for Maxwell 2D transient designs. 

For subsequent positions as the object(s) move in the band, the mesh operations on the band in 
the transient design are re-applied at every timestep and a new mesh is created. 

Stationary 
region

Moving part(s)

band
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Post Processing

Two Methods of Post Processing Solutions:

Viewing Plots

Manipulating Field Quantities in Calculator

Five Types of Plots:

1. Contour plots (scalars): equipotential lines, ...

2. Shade plots (scalars): Bmag, Hmag, Jmag, …

3. Arrow plots (vectors): B vector, H vector, …

4. Line plots (scalars): magnitude vs. distance along a predefined line 

5. Animation Plots
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Contour plot
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Shade plot (tone)



Ansoft Maxwell Field Simulator v12 – Training Seminar P1-93

Overview
Presentation

1

Shade plot (fringe with outline)
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Arrow plot
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Line plot
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Multiple windows and multiple plots
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