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1Getting Started with CosmosScope

Explains how to invoke CosmosScope, set user preferences, connect to 
third-party tools and open a plot file.

This section covers the following topics:
■ Invoking CosmosScope
■ Setting Preferences for Multiple Users
■ Connecting Third-Party Tools to CosmosScope
■ Opening a Plot File

Invoking CosmosScope

Choose one of the following platforms for instructions on how to invoke 
CosmosScope:
■ Windows Platforms
■ UNIX Platforms

Windows Platforms
On a Windows system, use the UNIX Platforms command-line invocation or 
choose: 

Programs > {install_location} > Scope 

or

Programs > {install_location} > CosmosScope
CosmosScope™ User Guide 1
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Invoking CosmosScope
UNIX Platforms
CosmosScope can be executed from the UNIX command prompt or from the 
Command Prompt window. The full form of the scope and cscope commands 
for CosmosScope is shown below:

cscope [-h][-display host[:server.display]] 
[-pfiles pfilename][pfile...]][-noconfig][-geom geom]
[-script aimfile] or [-script < aimfile] [-app application 
name] [-nosplash]

The following table describes the scope and cscope command options.

Option Description

-h Displays the scope (or cscope) command syntax and a 
list of the invocation options.

-display host:0.0 Displays screen graphics on the specified host. On some 
systems, you can replace host:0.0 with unix:0.0 or:0.0, 
when the display host is the one running the simulator (or 
the Scope Waveform Analyzer).

-pfiles pfile Specifies the plotfile to be opened at start-up.

-noconfig Requests that the saved configuration not be loaded on 
start-up.

-geom geom Defines the geometry for the CosmosScope window.

-script aimfile
or
-script < aimfile

Executes the specified AIM script on start-up.

-nosplash Disables the splash screen on startup.

-app application name Specifies the application that CosmosScope is integrated 
with. The value can be saber, cosmos, saberhdl, or 
custom.
2 CosmosScope™ User Guide
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Setting Preferences for Multiple Users
Setting Preferences for Multiple Users

You can set the CosmosScope preferences for multiple users at a single site 
using the AI_SITE_PATH variable. See the AIM Reference for more 
information.

Connecting Third-Party Tools to CosmosScope

CosmosScope provides a communication protocol using AIM (an extension of 
TCL/TK), which allows another application to invoke CosmosScope, send 
commands, get results back from CosmosScope, and monitor job status. 
CosmosScope uses a package called AimAppCom for communications.

This section covers the following topics:
■ Setting Up a Connection
■ Testing the Connection

Setting Up a Connection

Note:   Examples in this section refer to setting up a connection between 
CosmosScope and a Cosmos installation.

To set up a connection from a third-party tool to CosmosScope:

1. Ensure your TCL environment is set up properly. 

2. Invoke the following applications:

• CosmosScope

For example:

> cscope

• TCL shell (version 8.4 or later)

For example:

> tclsh

3. In the TCL shell, load a shared library.
CosmosScope™ User Guide 3
F-2011.09



Chapter 1: Getting Started with CosmosScope
Connecting Third-Party Tools to CosmosScope
For example:

% load <cosmos_install>/lib/IA.32/libdp.so

4. In the TCL shell, source the following interfaces:

• distributed process utility

For example:

% source <cosmos install>/etc/tcl/dp.tcl

• AimAppCom communications package

For example:

% source <cosmos install>/etc/tcl/AimAppCom.tcl

• AIM shell interface

For example:

% source <cosmos install>/etc/tcl/AimAppComExt.tcl

The connection between your third-party tool and CosmosScope is 
complete. Continue to Testing the Connection to see examples of how you 
can use this connection.

Testing the Connection
From within graphic TCL, try entering one or more of the following command 
lines to ensure the connection is complete:
■ Search for a running CosmosScope server and return its handle:

% lindex [AimAppCom:FindServer waveformGrapher] 0

The result is % s0 (or similar).
■ Place a graph in CosmosScope:

% AimAppCom:SendServer s0 Scope:NewGraph

A new graph window opens in CosmosScope.
■ Open a plotfile in CosmosScope:

% AimAppCom:SendServer s0 ScopeSigMgr:loadpffile "path /
inv.tr0"0

A plotfile opens in CosmosScope.
4 CosmosScope™ User Guide
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Opening a Plot File
Opening a Plot File

To open a plot file:

1. Choose the File > Open > Plotfiles... menu. This choice displays the Open 
Plot Files dialog box.

2. In the Directory field, navigate to the directory that contains the plot file you 
wish to analyze.

3. Set the Files of type field as appropriate for the kind of plot file you wish to 
open.

4. Highlight the desired file and click the Open button. Refer to the 
CosmosScope Tools Reference for information on the Signal Manager tool 
and how to begin your analysis.
CosmosScope™ User Guide 5
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Opening a Plot File
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2Tutorials

Provides various tutorials on how to take measurements, perform pareto 
analysis, and view Saber and HSPICE simulation results using CosmosScope. 

This section covers the following topics:
■ Taking Measurements in CosmosScope
■ Performing a Pareto Analysis
■ Viewing Saber Simulator Results
■ Viewing HSPICE Results

Taking Measurements in CosmosScope

This tutorial explains how to use CosmosScope to take measurements. 

To take a measurement in CosmosScope:

1. Choose File > Open > Plotfiles... to open a plotfile that contains the 
signal(s) you want to measure. The Signal Manager opens, which lists all 
the signal data that it contains.

2. Plot the signal.

You can double-click a signal, or select a signal name and click the Plot 
button located at the bottom of the Signal Manager.

3. Click the Measurement Tool icon at the bottom of the main CosmosScope 
window to open the Measurement Tool.

4. In the Measurement Tool dialog box, click the Measurement button, and 
choose one of the available measurements. Some measurements might not 
be available based on the kind of signal you are measuring.
CosmosScope™ User Guide 7
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Performing a Pareto Analysis
5. In the Active graph text box, specify the graph that contains the signal you 
want to measure. Specify the signal you want to measure in the Signal text 
boxes.

6. Change any needed parameters in the Measurement Tool dialog box to 
produce the desired measurement result.

See the CosmosScope Tools Reference for information on the parameters 
used for each measurement.

7. Click Apply to make the measurement.

Performing a Pareto Analysis

This tutorial explains how to run a Pareto analysis on a Monte Carlo simulation 
using an OpAmp and consists of the following sections:

Before You Begin

The following items are required for this tutorial:
■ CosmosScope version 2007.03 or later
■ HSPICE version 2007.03 or later
■ The opampmc.sp file, which is located in the following HSPICE demo 

directory:

<installation>/hspice/demo/hspice/variability

This section covers the following topics:
■ Simulating in HSPICE
■ Analyzing in CosmosScope

Simulating in HSPICE
Before peforming a Pareto measurement and analysis in CosmosScope, you 
first need to produce the plotfile and parameter file.

To produce the plotfile and parameter file:

1. Start HSPICE.

2. Enter the following line at the command-line prompt:

hspice -i opampmc.sp
8 CosmosScope™ User Guide
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Chapter 2: Tutorials
Performing a Pareto Analysis
The opampmc.ms0 (plotfile) and Opampmc.mcs0 (parameter file) are 
produced.

3. Continue to the next section, Analyzing in CosmosScope.

Analyzing in CosmosScope
To perform a Pareto analysis in CosmosScope:

1. Start CosmosScope.

2. Choose File > Open > Plotfiles... to open the opampmc.ms0 file, which is 
an HSPICE meas file. The Signal Manager lists the seven signals that 
opampmc.ms0 contains.

3. Plot the systoffset2 signal.

You can double-click a signal, or select a signal name and click the Plot 
button located at the bottom of the Signal Manager.

4. Click the Measurement Tool icon button at the bottom of the main 
CosmosScope window to open the Measurement Tool.

5. In the Measurement Tool dialog box, click the Measurement button, and 
choose Statistics > Pareto. The Measurement Tool dialog box shows the 
Pareto measurement options.

6. Ensure Graph0 is specified in the Active graph text box and sysoffset2 is 
specified in the Signal graph text box.

7. Click the folder icon to the right of the Parameter Plot File text field. Browse 
to and select the Opampmc.mcs0 parameter file.

8. Click the down arrow to the right of the Parameter Names text field to display 
a list of all the parameters that Opampmc.mcs0 contains.

9. Select all the parameters in the Select List dialog box, and click OK.
CosmosScope™ User Guide 9
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Performing a Pareto Analysis
10. Change the remaining options to match those in the following figure. Ensure 
zero (0) is specified for in Minimum R to Display text field.

11. Click Apply to make the measurement. 

A histogram of the measurement appears in the CosmosScope main 
window. 

12. Take a look at the results.
10 CosmosScope™ User Guide
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Viewing Saber Simulator Results
Zoom the histogram to fit to get the full display and see what parameters 
have the most effect on system offset. You can also open the pareto.txt file 
and see the numerical results (located in column R).

Viewing Saber Simulator Results

In this tutorial, you will use CosmosScope to view analysis results from the 
simulation of a single-stage amplifier design. 

This section covers the following topics:
■ Setting up the Saber Simulator Data
■ Viewing Saber Transient Analysis Waveforms
■ Viewing Saber AC Analysis Waveforms
■ Performing Measurements on a Waveform

Setting up the Saber Simulator Data
Saber Simulator analysis results for a simple transistor amplifier have been 
provided for use with this tutorial. Create a directory and make a copy of the 
example as follows:

1. Create a directory called synopsys_tutorial.

2. Navigate to the new synopsys_tutorial directory.

3. Copy the install_home/examples/Saber/SaberScope/saber_amp 
directory to the synopsys_tutorial directory:

UNIX:

cp -r install_home/examples/Saber/SaberScope/
saber_amp .

install_home is the location where your software has been installed.

Windows:

In Windows Explorer, hold down the Ctrl key and drag the saber_amp folder 
from \examples\Saber\SaberScope\ to the synopsys_tutorial 
directory you just created.
CosmosScope™ User Guide 11
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Viewing Saber Simulator Results
Viewing Saber Transient Analysis Waveforms
The results of a Saber Simulator transient analysis reside in the saber_amp 
directory. You can view the results with the CosmosScope Waveform Analyzer 
as follows:

1. Invoke CosmosScope.

2. Open the Open Plotfiles dialog box: File > Open > Plotfiles... .

3. In the Open Plotfiles dialog box, browse to the 
synopsys_tutorial\saber_amp directory; in the Files of type field, 
select Saber pl (*.ai_pl, *.p1, *.p1*).

4. Click on the single_amp.tr.ai_pl item and click the Open button. The Signal 
Manager and the single_amp.tr.ai_pl Plot File windows are displayed.

5. From the single_amp.tr.ai_pl Plot File window, select signal in by left-clicking 
it. The signal is highlighted.

6. Plot the selected signal on the graph by clicking the Plot button.

7. In the single_amp.tr.ai_pl Plot File window, select the aout signal.

8. Plot the selected signal on the same graph as the in signal by moving the 
cursor to the Graph window and clicking the middle mouse button. When 
using a two-button mouse, place the cursor in the graph region, click the 
right mouse button to bring up the graph pop-up, then select Plot.

These waveforms show the input and the output of a simple transistor 
amplifier.

9. Zoom in to the area between 2u and 4u by moving the cursor to the X-axis 
2u tick mark.

10. Click and hold the left mouse button and drag it over to the 4u tick mark and 
release the button. The same technique can be used to zoom on the Y-axis.

11. If you like, experiment with the Zoom icons .

12. When you have finished viewing the waveforms, click the Clear icon .
12 CosmosScope™ User Guide
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Viewing Saber Simulator Results
Viewing Saber AC Analysis Waveforms
The results of a Saber Simulator AC analysis also reside in the saber_amp 
directory. You can view these results as follows:

1. In the Signal Manager dialog box, click on the Open Plotfiles button. 

2. In the Open Plotfiles dialog box, click on the single_amp.ac.ai_pl selection 
and click the Open button. The single_amp.ac.ai_pl Plot File window is 
displayed.

3. In the single_amp.ac.ai_pl Plot File window, select signal aout and plot it.

4. In this tutorial you do not need the Phase(deg):f(Hz) waveform. To delete it 
from the Graph window, do the following:

• Move the mouse cursor to the aout signal name associated with the 
Phase(deg):f(Hz) plot. The aout signal name and the waveform change 
color.

• Click and hold the right mouse button to open the Signal menu.

• Select the Delete Signal item.

5. Do the following to see how you can plot additional waveforms to the Graph 
window:

• From the single_amp.tr.ai_pl Plot File window, plot the aout and in 
signals. Two new waveforms are added to the graph window.

• Delete the in and aout waveforms when you have finished viewing them.

6. Look at the aout (dBV):f(Hz) (dB in volts versus frequency in Hertz) 
waveform in the Graph window.

From the waveform you can see that the gain is about 10dB from about 2000 
Hz to 300 kHz. The next part of this tutorial uses the Measurement Tool on 
this waveform to get some accurate readings on the gain and the frequency 
response.
CosmosScope™ User Guide 13
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Viewing Saber Simulator Results
Performing Measurements on a Waveform
The Measurement Tool allows you to perform various measurements on a 
waveform. Check the bandwidth and gain of the single-stage amplifier output 
signal (aout) as follows:

1. Use the Close buttons on the Plot File windows and the Signal Manager 
dialog box to close them.

2. In the Tool Bar located at the bottom of 

the CosmosScope window, click the Measurement icon .

The Measurement dialog box appears. 

3. Select the Bandwidth measurement in the Measurement dialog box as 
follows:

a. Move the mouse cursor to the right of the Measurement field and press 
and hold the left mouse button on the down arrow  button.

b. Move the mouse cursor down to the Frequency Domain menu.

c. Select Bandwidth.

To summarize, choose the Measurement > 
Frequency Domain > Bandwidth menu item.
14 CosmosScope™ User Guide
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Viewing Saber Simulator Results
d. Because there is only one signal in the Graph window, aout should 
appear in the Signal field in the Measurement dialog box as shown in 
the following figure.

e. If you want to see values displayed on the graph for Topline and Offset 
that are used in the bandwidth calculation, click the visibility indicator 
buttons to the right of the Reference Levels fields they will turn green to 
indicate they’re activated.

f. Click the Apply button. The bandwidth is displayed on the graph.

4. Select the Gain Margin measurement by doing the following:

a. From the Measurement Tool window, choose Measurement > 
Frequency Domain > Gain Margin.

b. Click the Apply button. The gain margin is displayed on the graph.

c. You can select the measurement labels and move them if the graph 
becomes too cluttered. Position the cursor over the text. Then left-click 
and hold while moving the cursor to a new location.

5. You can get more information about each of the measures you performed or 
control the amount of information displayed in the Graph window by using 
the Measure Results dialog box as follows:

a. In the Graph window, move the mouse cursor to the aout signal name.

Measurement = Bandwidth

Signal = aout

Click these buttons to
display levels on graph.
Click them again to hide
the values.
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Viewing Saber Simulator Results
b. Use the popup menu and choose Signal > Measure Results.... The 
Measure Results dialog box appears.

c. In the Measure Results dialog box, be sure the Bandwidth item in the 
left column is selected as shown in the following figure:

d. Notice in the Measure Results dialog box, in the right column, the 
different values that are available from executing the bandwidth 
measurement.

e. Click on the various visibility indicators to choose which values are 
displayed in the Graph window.

f. When you have finished exploring the Measure Results dialog box, 
close it.

6. To close CosmosScope, choose File > Exit.

Select button

Click these buttons to
display levels on graph.
Click them again to hide
the values.

Visibility
Indicators
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Viewing HSPICE Results

This tutorial explains how to use CosmosScope to view the analysis results 
from the simulation of a single-stage amplifier design. 

This section covers the following topics:
■ Setting up the Design Data
■ Viewing HSPICE Transient Analysis Waveforms
■ Viewing AC Analysis Waveforms
■ Performing Measurements on an HSPICE Waveform

Setting up the Design Data
Analysis-results from a simple transistor amplifier have been created for you 
using the HSPICE transient and AC simulators for use with this tutorial. You will 
create a directory and then make a copy of the example as follows:

1. Create a directory called synopsys_tutorial.

2. Navigate to the new synopsys_tutorial directory.

3. Copy the install_home/examples/CScope/hspice_amp directory to 
the synopsys_tutorial directory:

UNIX:

cp -r install_home/examples/CScope/hspice_amp .

install_home is the location where your software has been installed.

Windows:

In Explorer, hold down the Ctrl key and drag the hspice_amp folder from 
install_home\examples\CScope\ to the synopsys_tutorial 
directory that you just created.

Viewing HSPICE Transient Analysis Waveforms
The results of a simulator transient analysis reside in the hspice_amp directory. 
You can view the results with the CosmosScope Waveform Analyzer as follows:

1. Invoke CosmosScope.
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2. Open the Open Plotfiles dialog box: File > Open > Plotfiles... .

3. In the Open Plotfiles dialog box, browse to the 
synopsys_tutorial\hspice_amp directory; in the Files of type field, 
select HSPICE (*.tr*, *.ac*, *.sw*, *.ft*) item. 

4. Click on the amp.tr0 item and click the Open button. The Signal Manager 
and the amp Plot File windows are displayed.

5. From the amp Plot File window, select signal v(in) by left-clicking it. The 
signal is highlighted.

6. Plot the selected signal on the graph by clicking the Plot button.

7. In the amp Plot File window, select signal v(aout).

8. Plot the selected signal on the same graph as the v(in) signal by moving the 
cursor to the Graph window and clicking the middle mouse button. When 
using a two-button mouse, place the cursor in the graph region, click the 
right mouse button to bring up the graph pop-up, then select Plot.

These waveforms show the input and the output of a simple transistor 
amplifier.

9. Zoom in to the area between 2u and 4u by moving the cursor to the X-axis 
2u tick mark.

10. Click-and-hold the left mouse button and drag it over to the 4u tick mark and 
release the button. The same technique can be used to zoom on the Y-axis.

11. If you like, experiment with the Zoom icons .

12. When you have finished viewing the waveforms, click the Clear icon .

Viewing AC Analysis Waveforms
The results of a simulator AC analysis also reside in the hspice_amp 
directory. You can view these results as follows:

1. In the Signal Manager dialog box, click on the Open Plotfiles button. 

2. In the Open Plotfiles dialog box, in the Files of type field, select the HSPICE 
(*.tr*, *.ac*, *.sw*, *.ft*) item.

3. Click on the a.ac0 selection and click the Open button. The “a” Plot File 
window is displayed.

4. In the Plot File window, select the v(aout) signal and plot it.
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5. In this tutorial you do not need the Phase(deg):Frequency(Hertz) waveform. 
To delete it from the Graph window, do the following:

a. Move the mouse cursor to the v(aout) signal name associated with the 
Phase plot. The v(aout) signal name and the waveform change color.

b. Press and hold the right mouse button to bring up the Signal menu.

c. Select the Delete Signal item.

6. Change the X-axis attributes to display as a logarithmic waveform as 
follows:

a. To bring up the Axis Menu, move the cursor to the X-axis and click-and-
hold the right mouse button.

b. To bring up the Axis Attributes dialog box, select the Attributes menu 
item.

c. In the Scale field, click the Log radio button. The waveform should now 
look similar to a bell curve.

d. Close the Axis Attributes dialog box.

7. Do the following to see how you can plot additional waveforms to the Graph 
window:

a. From the amp Plot File window, plot the v(aout) and v(in) signals. Two 
new waveforms are added to the graph window.

b. When you have finished viewing the v(in) and v(aout) waveforms that 
you just plotted in the previous step, delete them as follows:

First move the cursor to the waveform name on the graph. Then right-
click the mouse button and choose Signal > Delete Signal from the 
pop-up menu that appears. Do this for each signal you want to delete.

8. Look at the vdb(aout) (dBV):Frequency(Hertz) waveform in the Graph 
window.

From the waveform you can see that the gain is about 10dB from about 2000 
Hz to 300 kHz. The next part of this tutorial uses the Measurement Tool on 
this waveform to get some accurate readings on the gain and the frequency 
response.
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Performing Measurements on an HSPICE Waveform
The Measurement Tool within CosmosScope provides a method of performing 
various measurements on a waveform. You check the bandwidth and gain of 
the single-stage amplifier output signal v(aout) as follows:

1. Close the Plot File windows and the Signal Manager window.

2. In the Tool Bar located at the bottom of 

the CosmosScope window, click the Measurement icon .

The Measurement dialog box appears. 

3. Select the Bandwidth measurement in the Measurement dialog box as 
follows:

a. Move the mouse cursor to the right of the Measurement field and press 
and hold the left mouse button on the down arrow  button.

b. Move the mouse cursor down to the Frequency Domain menu.

c. Select Bandwidth.

To summarize, choose the Measurement > 
Frequency Domain > Bandwidth menu item.
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d. Because there is only one signal in the Graph window, v(aout) should 
appear in the Signal field in the Measurement dialog box as shown in 
the following figure.

e. If you want to see values displayed on the graph for Topline and Offset 
that are used in the bandwidth calculation, click the visibility indicator 
buttons to the right of the perspective Reference Levels fields.

f. Click the Apply button. The bandwidth is displayed on the graph.

4. Select the Gain Margin measurement by doing the following:

a. Choose the Measurement > Frequency Domain > Gain Margin menu 
item.

b. Click the Apply button. The gain margin is displayed on the graph.

c. You can select the measurement labels and move them if the graph 
becomes too cluttered. Position the cursor over the text. Then left-click 
and hold while moving the cursor to a new location.

5. You can get more information about each of the measures or control the 
amount of information displayed in the Graph window by using the Measure 
Results dialog box:

a. In the Graph window, move the cursor to the v(aout) signal name.

Measurement = Bandwidth

Signal = v(aout)

Click these buttons to
display levels on graph.
Click them again to hide
the values.
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b. Use the popup menu and choose the Signal Menu > Measure 
Results... item. The Measure Results dialog box appears.

c. In the Measure Results dialog box, be sure the Bandwidth item in the 
left column is selected (see the following figure).

d. Notice in the Measure Results dialog box right column, the different 
values available from executing the bandwidth measurement.

e. Click on the various visibility indicators to choose which values are 
displayed in the Graph window.

f. When you have finished exploring the Measure Results dialog box, 
close it.

6. When you have finished trying out the features of CosmosScope, close the 
application by selecting the File > Exit menu item.

Select button

Click these buttons to
display levels on graph.
Click them again to hide
the values.

Visibility
Indicators
22 CosmosScope™ User Guide
F-2011.09



3

3 Signals

Explains how to convert, pan, and change signals and their associated 
properties. Also explains about how to convert and combine analog and digital 
signals.

This section covers the following topics:
■ Converting Analog Signals to Digital
■ Converting Digital Signals to Analog
■ Converting Frequency Domain Signals to the Steady-State Time Domain
■ Changing Signal Appearance
■ Changing Signal Zoom Level
■ Panning Signals
■ Changing Signal Display Colors
■ Defining Custom Signal Display Colors
■ Moving Signals to Graph Regions
■ Specifying Analog Signal Fill Patterns
■ Combining Digital Signals into a Bus
■ Displaying the Digital Signal Grid
■ Changing Symbol Styles
■ Changing Signal Colors
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Converting Analog Signals to Digital

To convert analog signals to digital:

1. Select one or more analog signals that are currently graphed. You can click 
either the name of the signal or the signal attributes line just below the signal 
name to select a signal.

2. Choose Signal > Convert to Digital (A2D)... from the main menu.

3. Select a single- or multiple-bit conversion, and enter the necessary 
threshold values. You can also enter a value for sample period size.

4. Click Ok to convert the signal(s).

Converting Digital Signals to Analog

This section covers the following topics:
■ Converting Single-Bit Digital Signals to Analog
■ Converting Digital Bus Signals to Analog

Converting Single-Bit Digital Signals to Analog
To convert single-bit digital signals to analog:

1. Select one or more single-bit digital signals that are currently graphed. You 
can click either the name of the signal or the signal attributes line just below 
the signal name to select a signal.

2. Choose Signal > Convert to Analog (D2A)... from the main menu.

3. Enter values for the digital 0 and 1 states (VLow and VHigh, respectively).

4. Enter values for the rising and falling time (TRise and TFall), which specifies 
the rising and falling time when any value changes in the input digital signal.

5. If needed, select Ignore glitches shorter than or Convert to current, 
Resistance, and enter the necessary values.

6. Select an option to convert uknown values. If you select Last known and 
the first state of the digital signal is unknown, (VLow+VHigh)/2 is used.

7. Click Ok to convert the signal(s).
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Converting Digital Bus Signals to Analog
To convert digital bus signals to analog:

1. Select one or more digital bus signals that are currently graphed. You can 
click either the name of the signal or the signal attributes line just below the 
signal name to select a signal.

2. Choose Signal > Convert to Analog (D2A)... from the main menu.

3. Enter the minimum and maximum values for the converted signals (Lower 
bound and Upper bound).

4. Enter values for the rising and falling time (TRise and TFall), which specifies 
the rising and falling time when any value changes in the input digital signal.

5. If needed, select Ignore glitches shorter than or Convert to current, 
Resistance, and enter the necessary values.

6. Click Ok to convert the signal(s).

Converting Frequency Domain Signals to the Steady-
State Time Domain

Select one or more frequency domain signals that are currently graphed, and 
choose Signal > To Time Domain from the main menu.

Changing Signal Appearance

Double-click the signal name, which opens the Signal Attributes dialog box.

Several of the attributes in the Signal Attributes dialog box are also available 
from the Signal menu.
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Changing Signal Zoom Level

Select a signal, and press the z key to zoom in or Shift+z to zoom out. Press 
the f key to zoom in to fit the size of the current window. All signals on a graph 
change at the same zoom level.

You can also change zoom levels using any of the following other methods:
■ Click one of the zoom icon button at the top of the main window
■ Choose Graph > Zoom from the main CosmosScope menu.
■ Click and hold the left mouse button, then drag your mouse to create a frame 

around the area you want to enlarge. Release the mouse button to zoom in.
■ Place the mouse cursor at one end of the range you wish to zoom in on 

either the X or Y axis. Press and hold the left mouse button and move the 
cursor to the other end of the range you wish to zoom in on. Release the 
mouse button to zoom in on the selected axis.

■ Click and hold the right mouse button over one of the axes or over an axis 
name in the legend, and choose Zoom > <zoom level> from the pop-up 
menu that appears.

Panning Signals

To pan a signal, right-click one of the axes and choose Pan > Right/Left/Up/
Down from the pop-up menu that appears.

You can also pan signals using one of the following methods:
■ Click one of the axes, and choose Graph > Pan > Right/Left/Up/Down from 

the main CosmosScope menu.
■ Place the mouse cursor on either the X or Y axis. Press and hold the middle 

mouse button and move the cursor. The axis will pan with the mouse cursor. 
Release the button and the signal will snap to the new axis coordinates.

■ Place the mouse cursor inside of a graph region. Press and hold the middle 
mouse button, and move the mouse so that the axis scales move with it. 
Release the mouse button, and the waveform will snap to the new axis 
coordinates.

■ Right-click the x-axis, and choose Attributes... from the pop-up menu that 
appears. Move the Slider bar in the Range field to pan the view left and right.
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Changing Signal Display Colors

Select one or more signals, choose Signal > Color from the main menu, and 
select one of the available colors.

You can also define custom colors from the Signal tab, which is located in the 
CosmosScope preferences (Edit > Preferences...). See Defining Custom 
Signal Display Colors for more information.

Defining Custom Signal Display Colors

This section covers the following topics:
■ Defining Analog Signal Colors
■ Defining Digital Signal Colors

Defining Analog Signal Colors

Note:   If your screen colors are mapped to Mono, signals are displayed 
as a variety of dashed lines. These dashed lines cannot be 
customized.

To define custom signal display colors for analog signals:

1. Choose Edit > Preferences..., and click the Signal tab.

2. Click the Add button. A new column appears at the end of Map1, Map2, and 
Mono rows.

3. Click the new Map1 color button. The Color Editor appears.

4. Click the Define Custom Colors button.

5. Move the cursor in the colored box to select a color.

6. Move the vertical slide bar to adjust the brightness of the selected color.

7. Click the Add to Custom Colors button to add your defined color to the 
Custom Colors pallette.
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8. Once you are finished defining custom colors, click Ok to close the Color 
Editor.

9. Click the Save button at the bottom of the Signal tab to save your changes.

Defining Digital Signal Colors

Note:   If your screen colors are mapped to Mono, signals are displayed 
as a variety of dashed lines. These dashed lines cannot be 
customized.

To define custom digital signal display colors:

1. Choose Edit > Preferences..., and click the Signal tab.

For digital signals, CosmosScope displays different colors and line styles for 
different logical states. Currently, CosmosScope supports logic_4, 
std_logic, and nanosim_logic type digital signals.

2. Choose a logic type for which you want to define custom colors.

3. Click a button in the Colors row that you want to change. The Color Editor 
appears.

4. Click the Define Custom Colors button.

5. Move the cursor in the colored box to select a color.

6. Move the vertical slide bar to adjust the brightness of the selected color.

7. Click the Add to Custom Colors button to add your defined color to the 
Custom Colors pallette.

8. Once you are finished defining custom colors, click Ok to close the Color 
Editor.

9. Click the Save button at the bottom of the Signal tab to save your changes.

Moving Signals to Graph Regions

Select one or more signals, and choose one of the options available from 
Signal > Move to Stack Region:
28 CosmosScope™ User Guide
F-2011.09



Chapter 3: Signals
Specifying Analog Signal Fill Patterns
■ Digital/Trace moves selected analog or digital signals into the digital/trace 
graph region.

■ New Analog moves selected analog or digital signals into a new analog 
graph region.

■ Analog n (where n is the identifying number of a graph) moves selected 
analog or digital signals into the analog graph region specified by the 
number n.

Specifying Analog Signal Fill Patterns

Select one or more analog signals on a graph, and choose one of the available 
fill patterns from Signal > Bar. The area under the signal curve fills in with the 
pattern you select.

Combining Digital Signals into a Bus

To combine digital signals from the trace graph region into a single digital bus:

1. Select two or more digital signals from the trace graph region.

The first signal you select is considered the least significant bus (LSB), and 
each additional signal you select is considered more significant than the 
previous signal. The last signal you select is assumed to be the most 
significant bus (MSB).

2. Choose Signal > Create Bus from the main menu. The signal is plotted in 
CosmosScope and given the designation Groupnumber.

Displaying the Digital Signal Grid

Select a signal name in a graph window for which you want to display the grid, 
and choose Signal > Display Digital Signal Grid.
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Changing Symbol Styles

Select one or more signal names on a graph, and choose Signal > Symbol. 

Changing Signal Colors

Select one or more signal names on a graph, and choose Signal > Color. 
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Explains how to display, save, and use graphs in CosmosScope. Also explains 
how to annotate and export the graphs.

This section covers the following topics:
■ Displaying Graphs
■ Saving Graphs
■ Opening Outlines
■ Saving Outlines
■ Placing Trace Markers
■ Changing Trace Height Display
■ Annotating Graphs
■ Exporting Images
■ Changing Graph Font Face and Style
■ Changing Graph Zoom Level
■ Displaying the Slider Bar

Displaying Graphs

To graph waveforms on the work surface, use the Signal Manager. See the 
CosmosScope Tools Reference for more information on the Signal Manager.

You can also update a displayed waveform by clicking the Reload button (third 
from left in the icon bar) or update the waveform dynamically.
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To update the waveform dynamically, choose Edit > Preferences... . In the 
Scope Preferences form, select the Display tab. Select the Dynamic Waveform 
Display button and enter the interval, in seconds, desired for dynamically 
updating the displayed waveform.

Saving Graphs

To save a graph:

1. Choose File > Save Graph... from the CosmosScope main menu.

2. Specify the name and location for the graph to be saved, and click Save. 
The Save Graph dialog box opens.

Select one of the following options:

• Save copy of waveforms with graph

This option saves copies all of the related plotfiles in the specified 
directory. These plotfiles are separate from the originals and are not 
overwritten by subsequent analyses.

• Reference the current plot files

This option maintains the connection to the original plotfiles. The graph 
can be automatically updated when reopened if you specify any 
Replace or Append plot actions for an analysis. Make sure you specify 
either absolute or relative paths to the graph plotfiles.

3. Click the Save button.

Opening Outlines

To open a saved outline:

1. Choose Open > Outlines... from the CosmosScope main menu.
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2. Select an outline file, and click the Open button. The Create Graph With 
Outline dialog box appears.

3. Specify any desired waveforms to open in the middle section of the Create 
Graph With Outline dialog box.

You can fill in the waveform entries using one of the following methods:

• Paste waveforms into the list by selecting them in a graph or plotfile 
window, placing the cursor in the text box next to the placeholder, and 
then clicking the middle mouse button. You cannot type in the entry 
boxes.

• Select one or more plotfiles in the Plotfile lists box, which lists all the 
opened plotfiles. CosmosScope searches the selected plotfiles for 
waveform names and fills the entries with corresponding waveforms. 
Selecting the empty line in the Plotfile lists box clears all the entries.
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When multiple plotfiles are selected, clicking the Apply to each 
selected plotfile individually radio button creates an outline for each 
selected plotfile; clicking the Apply once by matching signals in all 
selected plotfile radio button creates an outline only for waveforms that 
are located in multiple plotfiles.

4. Click the Apply button to open a new graph window and plot the waveforms.

Saving Outlines

An outline file contains all of the information displayed in the document window 
except for displayed signals. Any additions made with the Draw tool or 
Measurement tool are included in an outline file.

To save a graph outline:

1. Choose File > Save Outline... from the main CosmosScope menu.

2. Specify the name and location for the graph outline to be saved, and click 
Save. The Graph Outline dialog box opens.

3. Select all desired attributes that you want to include in the graph outline.

Clicking the Dependencies check box maintains the connection to the 
plotfile. The outline can be automatically updated when reopened if you 
specify any Replace or Append plot actions for an analysis.

4. Click the OK button to save the graph outline.

Placing Trace Markers

To place a Trace marker:

1. Click and hold the New Marker Symbol, then drag the marker to the desired 
location.

2. Release the mouse button to place the marker. The logic state of the 
location is displayed in the Marker field.

A Trace graph uses the same pop-up menus available in the Analog graph 
region with the addition of the Trace popup menu. The Trace pop-up menu 
operates only in the Trace graph region.
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Changing Trace Height Display

To change the trace height display:

1. Open the CosmosScope preferences (Edit > Preferences...).

2. Click the XY tab.

3. In the "Digital region options" section located at the top of the XY tab, 
change the analog or digital trace height values as necessary.

Annotating Graphs

Choose Graph > Annotate Info..., and click the box next to the text variable(s) 
you want to add. The information that you add appears on the graph in the 
active graph window, which you can then move to any position on the graph.

Exporting Images

To export an image of the active graph window:

1. Choose File > Export Image....

2. Choose an output image file type.

3. Save the image.

Changing Graph Font Face and Style

Choose Graph > Font... from the main menu, and select the desired font, font 
style, or size.

Changing Graph Zoom Level

See Changing Signal Zoom Level for information on changing zoom levels.
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Displaying the Slider Bar

To display the slider bar on the x-axis, right-click the x-axis, and choose X Axis 
Slider from the pop-up menu that appears.

You can also display the slider bar using one of the following methods:
■ Right-click the x-axis, and choose Attributes... from the pop-up menu that 

appears. Then, click the X axis slider radio button.
■ Click the x-axis, and choose Axis > Attributes... from the CosmosScope 

main menu. Then, click the X axis slider radio button.
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Explains how to compare waveforms and create multi-member parameter files 
and multi-member waveforms.

This section covers the following topics:
■ Comparing Waveforms
■ Creating Multi-Member Parameter Files
■ Merging All or Selected Plotfile Waveforms into Multi-Member Waveforms
■ Creating Multi-Member Waveforms

Comparing Waveforms

To compare waveforms:

1. Choose Graph > Waveform Compare... from the main menu.

2. Select the graph that contains the first signal you want to compare from the 
Graph list1 list. The signals that appear on the graph are listed in the field 
just below the Signal1 field.

3. Select the signal name that you want to compare. The signal name appears 
in the Signal1 field.

If you want to see more information about the signal, move your mouse over 
the signal name. The following information appears in the status bar at the 
bottom of the CosmosScope main window:

• full name of the signal

• graph on which the signal is located

• signal handle
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• waveform handle

• plotfile name

4. Repeat steps 2 and 3 to select a signal for Signal2, which might be from a 
different Graph.

5. If the signals are digital, specify any desired compare options. 

6. Click Apply to generate the result.
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Creating Multi-Member Parameter Files

Before merging any waveforms into multi-member waveforms, you might 
consider defining the list of parameters to use when creating the multi-member 
waveform plotfile instead of using the defaut "run" parameters. See Creating 
Multi-Member Parameter Files for more information.

To create a *.par file:

1. Open a new text file, and enter the desired parameters to use when the 
multi-member waveform is created. Each parameter is entered on its own 
line. For example:

vdd = 1.2
temp = -27
mos = ’ff’

2. Save the text file, and name it using the <plot_filename>.par syntax. The 
<plot_filename> is the same as the multi-member file name you are going 
to create. Save the *.par file in the same directory as the plot files you are 
using to create the multi-member waveform. 

3. Merge the plotfiles into multi-member waveforms, and ensure the default 
"run" parameter is used. The plotfiles are merged using the parameter file 
you created instead of using the "run" parameter.

See Merging All or Selected Plotfile Waveforms into Multi-Member 
Waveforms to continue.

Merging All or Selected Plotfile Waveforms into Multi-
Member Waveforms

Before merging any waveforms into multi-member waveforms, you might 
consider defining the list of parameters to use when creating the multi-member 
waveform plotfile instead of using the defaut "run" parameters. See Creating 
Multi-Member Parameter Files for more information.

To merge all or selected plotfile waveforms into multi-member waveforms:

1. Choose File > Merge Plotfiles... . The Select Plotfiles to Merge dialog box 
appears. If you previously selected a plot file to merge, the last plot file 
selection is automatically selected in the File names: text field.
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2. Select the plotfiles you want to include in the multi-member waveform and 
click the Open button. The Create Multi-Member Waveforms and Plotfile 
dialog box appears with the selected files in the Plotfile List field.

If you want to see a table containing a list of plotfiles vs. the parameters, click 
the Table button. The following Parameter Table dialog box opens:

You can use the Parameter Table to swap values between plotfiles or assign 
a particular set of parameter values to a specific plotfile. Clicking a value in 
the run column opens a pop-up menu that allows you to choose from 
available parameter values for each plotfile. Clicking OK checks that the 
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parameter sets are unique and redisplays the new parameter list in the 
Create Multi-Member Waveform dialog box. Only the parameter sets that 
correspond to a plotfile or waveform are displayed. All other parameter sets 
are removed from the Parameter List. 

3. If you want to merge all waveforms, ensure the All radio button is selected 
next to the Merge Waveforms field, and skip to step Step 6. If you want to 
merge only selected waveforms, continue to the next step.
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4. Click the Selected radio button next to the Merge Waveforms text.

5. Select the desired waveforms to merge.
42 CosmosScope™ User Guide
F-2011.09



Chapter 5: Waveforms
Merging All or Selected Plotfile Waveforms into Multi-Member Waveforms
6. Click the Edit button under the Parameter List window. The Multi-Member 
Parameter Create dialog box appears.

7. Enter the desired values for the following fields:

• Parameter Name -- The name of the parameter. The default is “run”.

• Values -- A list of values the parameters can have.

• Type -- The type of parameter. You can select string, number, or set. The 
default is “string”.

For example:

Parameter Name: run Values: 1 2 3 4 Type: number

8. Click the OK button to save your settings. The Multi-Member Parameter 
Create dialog box closes.

9. Select the Display Merged Waveforms check box to plot all merged 
plotfiles to the graph window. By default, this check box is unchecked, and 
the merged plotfiles are not plotted to the graph window.

10. Click the OK button in the Create Multi-Member Waveforms and Plotfile 
dialog box to merge the waveforms. The multi-member waveform appears 
and you are prompted to save the file.
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Creating Multi-Member Waveforms

To merge waveforms into a single multi-member waveform:

1. Choose Signal > Create Multi-Member... . The Create Multi-Member 
Waveform dialog box appears with the selected waveform(s) in the 
Waveform List field.

2. Click the Add button to add waveforms to the Waveform List, or click the 
Delete button to delete waveforms from the Waveform List.

The Default parameter name drop-down menu is set to run (by default). You 
can choose one of the following default parameter names:

run number Selected by default if the merged signals merged have 
the same name and come from different plotfiles. The 
number is from the extension of the file (for example, the 
*.tr0 and *.tr1 file extensions result in run numbers 0 1).  
If the file extension does not contain a number or a 
duplicate number exists, the run number is assigned 
based on the total number of merged signals.
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If you want to see a table containing a list of waveforms vs. the parameters, 
click the Table button. The following Parameter Table dialog box opens:

You can use the Parameter Table to swap values between waveforms or 
assign a particular set of parameter values to a specific waveform. Clicking 
a value in the run column opens a pop-up menu that allows you to choose 
from available parameter values for each waveform. Clicking OK checks that 
the parameter sets are unique and redisplays the new parameter list in the 
Create Multi-Member Waveform dialog box. Only the parameter sets that 
correspond to a plotfile or waveform are displayed. All other parameter sets 
are removed from the Parameter List. 

signal name Selected by default if different signal names are merged 
from a single plotfile. The name is the name of the signal.

run_signal number 
name

Selected by default if different signal names are merged 
from different plot files. The name is the signal name, 
and the number is either the number stripped from the 
file extension or a count of the total number of merged 
signals.

custom name Displays the parameter name and values defined using 
the Parameter Create dialog box. If you do not change 
the default parameter, custom is assigned to the default 
name.
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3. To modify parameters in the Parameter List window, click the Edit button 
under the Parameter List window. The Multi-Member Parameter Create 
dialog box appears.

4. Enter the desired values for the following fields:

• Parameter Name -- The name of the parameter. The default is “run”.

• Values -- A list of values the parameters can have.

• Type -- The type of parameter. You can select string, number, or set. The 
default is “string”.

For example:

Parameter Name: run Values: 1 2 3 4 Type: number

5. Click the OK button to save your settings. The Multi-Member Parameter 
Create dialog box closes.

6. Click the OK button in the Create Multi-Member Waveform dialog box to 
merge all the selected waveforms from the Waveform List into a single multi-
member waveform. CosmosScope displays the final merged waveform and 
does not prompt you to save the merged waveform.
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