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Note: The downloader does not provide external power:5This pin does not output power. This pin needs to be connected to the power supply of the target board, otherwise it

will not work!4FeetGNDIt is also required to accept.

Note: Do not plug or unplug while power is on20PPlease plug in and out after power off.20POtherwise, the d loader may be d

Chapter 1CCS6.2Software Installation

First we need to installTI DSPSoftware development environmentCCS (Code Composer Studio). If you have used emulator products

from other companies. We recommend usingCCS6.2version, because temporarily Hezhongda'sXDS510PLUSandXDS560PLUSThe emulator

only supportsCCS6.2, the compatibility of higher versions is not very good. In addition, we chooseXDS100 V2The emulator is only applicable

toCCS4.0And above versions of the development environment, XDS100V3The emulator is only suitable forCCS5.2And above versions of the

development environment.

Note: Before installation, turn off anti-virus software and360, PC Manager and other security protection software, otherwise a warning will

appear when clicking the installation program, and forced installation will result in file loss. Double-clickccs_setup_6.2.0.00050.exeThe file appears

as shown below1-2The interface shown:

| baserepo

| binary

| featurerepo
. features

| | artifacts.jar

vy ccs_setup_6.2.0.00050.exe

L | contentyar
|| README_FIRST.txt

|| timestamp.txt
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Fleaze read the following license agreement carefully.

License Agreement »".

Code Composer Studio 6.2 Software License Agreement E|

IMPORTANT - PLEASE READ THE FOLLOWING LICEMSE AGREEMENT CAREFULLY., THISIS A
LEGALLY BINDING AGREEMENT. AFTER ¥YOU READ THIS LICEMSE AGREEMENT, YOU WILL BE
ASKED WHETHER YOU ACCEPT AND AGREE TO THE TERMS OF THIS LICEMSE AGREEMENT. DO
NOT CLICK "I ACCEPT" UMLESS: (1) YOU ARE AUTHORIZED TO ACCEPT AMD AGREE TO THE
TERMS OF THIS LICENSE AGREEMENT OMN BEHALF OF YOURSELF AND YOUR COMPAMY: AMD
(2) YOU INTEMND TO ENTER INTO AMND TO BE BOUND BY THE TEEMS OF THIS LEGALLY
BINDIMG AGREEMENT OM BEHALF OF YOURSELF AND YOUR COMPANY.

Important - Read carefully: This Code Composer Studio 6.2 Software License Agreement
(“Agreement”) is a legal agreement between you (either an individual or entity) and Texas
Instruments Incorporated ("TI"). The "Licensed Materials" subject to this Agreement include the

software programs (in whole or in part] that accompany this Agreement and any "on-line” or v
1| | »

@ [ accept the terms of the license agreement.

) I do not accept the terms of the license agreement.

Texas Instruments

= Back Mext = Finish Cancel

picturel-2

choose"l accept the terms of the license agreement” , clickNext” As shown below1-3



Where should Code Composer Studio vE be installed?

Choose Installation Location »".

To change the main installation folder click the Browse button.

~CCS Install Folder

Texas Instruments

= Back “ Mext = ” Finish | I Cancel

picturel-3

Click "Browse” Select the installation path (note: the path cannot contain Chinese characters), but the default path is recommended.D:\tiClick "

Next” See the figure below1-4As shown:



Processor Support

Select Product Families to be installed.

MSP Ultra Low Power MCUs
C2000 32-bit Real-time MCUs
SimpleLink Wireless MCUs
32-bit ARM MCUs

Sitara 32-bit ARM Processors
Media Processors

Single Core DSPs

Multi Core Processors

F B B

EIEERE
NEEEEEEEE

[

UCD Digital Power Controllers

v Select all

~Description

Install Size: 1767.69 MB.

Texas Instruments

= Back

Mext =

Finish

picturel-4

Select the content to be installed according to your needs. Select "Select All” , then clickNext” See the figure

below1-5Shown




Select Debug Probes

you want to leave out,

Select the debug probes you want installed and deselect the debug probes

~Description

TI ¥DS Debug Probe Support

Ll Blackhawk Debug Probes

MSP430 USB FET
Tiva/Stellaris ICDI Debug Probe

[T Select all

O spectrum Digital Debug Probes and Boards

Install Size: 1938.54 MB.

Texas Instruments

= Back

Finish

MNext = l

| |

Cancel

picturel-5

Still choose the simulation device driver type according to your needs, here selectTI XDS Debug Probe Support, then click “Next”

See the figure below1-6As shown:




_I.'f-,'i Code Composer Studio vb Setup |

App Center

Texas Instruments

There are additional products and features ("add-ons") available from the CCS App Center.
Selected add-ons will be downloaded in the background and installed by the App Center when
you run Code Composer Studio for the first time.

~Description
= O Tools (for App Center background download)

O msp430 GCC
O PrRU Compiler
O eve Compiler
O Linux Development Toals

ERM ) S oftware (for App Center background download)

O GuI Composer

[T Select all Install Size: 1938.54 MB.

Texas Instruments

Mext = [ Finish ] I Cancel

picturel-6
Select according to your needs, unselect all here, and then click "Finish” During the installation process, the following figure will pop up1-7Do not click

the dialog box that displays some installation functions.Cancelbutton, otherwise this feature will not be installed during the installation process.



CCS Installation

Code Composer Studio is being installed on your computer

¥+ Code Composer Studio v6 Setup | = B ¥®

|'\

Unzipping C:f/Users/FY/AppData/Local/Temp/ccs_B[...]serepo/eclipse_core_4.5.1.custom-160121.zip

Starting Install

Installing utilities and miscellaneous

Unzipping
CifUsers/FY/AppDatajLocal/Temp/ccs_634fa081-f124-455{-4fbe-add16d0876ac/com.ti.cestudio.instal
ler.msve,2015.win32_root_14.0.23506

Installing com.ti.ccstudicunstaller.msve.2015.win32..,

com.ti.ccstudiodinstaller.msve. 2013.win32 installed

Unzipping
CfUsers/FY/AppDatajLocal/Temp/jccs_634fa0B81-f12f-455f-dfbe-add16d0876ac/jre_root_1.7.0.80
Unzipping
C:fUsers/FY/AppData/Local/Temp/ccs_634fal81-f12-455f-4fbe-add16d0876ac/downloads/fjre-1.7.0.
80-windows-i5386.zip

Installing Eclipse

Unzipping
CfUsers/FY/AppData/Local/Temp/ccs_634fa0B81-f12f-435f-dfbe-add16d0876ac/baserepo/eclipse_co
re_d.5.1.custom-160121.zip

Texas Instruments

picturel-7

After the installation is complete, click "Finish" as shown in Figure 1-8 below:




-

¥+ Code Composer Studio v6 Setup |ﬂ|

CCS Installation

Code Composer Studio has been successfully installed.

W Launch Code Composer Studio

W Create Desktop Shortcut

W Create Start Menu Shortcut

Texas Instruments

Figure 1-8

Chapter 2CCSConnection to the emulator

becauseXDS100 V3The emulator driver has already done thisCCSV6So when the user installsCCSV6After the version of
the software is installed, the emulator driver has been installed. Next, the user only needs toUSBand PCMachineUSBThe
driver is also automatically recognized and installed. When it prompts that the driver is installed and can be used, the user
can use the emulator to simulate the target board.
Next we willTMS320F28035Take the development board as an example to explain how to use itXDS100 V3
Simulate the target board.DSP, the operation process is the same.

In the device manager, you can see the following:
The computer will automatically install the driver.
The following two drivers are displayed as normal. (You can see it in the device manager) The

old driver shows:



i FE. VURTESE

> SRS

4§ BESTREES

----- E Generic USE Hub

----- § Generic USB Hub

----- E Intel(R]) 8 Series/C220 Series USE EHCI #1 - 8C26
..... ' jes USB EHCI #2 - 8C2D
..... § TIXDS100v3 Channel A
----- § TIXDS100v3 Channel B
..... § Ust 20 EE=

New driver display:

> g IDE ATA/ATAPI 55158

Al;, Texas Instruments Debug Probes
A XDS100v3 Class Auxiliary Port
------ B XDS100w3 Class Debug Port

2.1 Define the workspace directory

The first thing CCSv6 requires is the definition of a workspace, a directory that holds all the elements used in the
development process (projects and links to projects, and possibly source code).

By default, the workspace will be created in C:\Users\<user>\Documents or C:\Documents
and Settings\<user>\My Documents, but you can choose any location. Each execution of CCSv6 will
ask for the workspace directory. If you plan to use one directory for all projects, just check the "Use
this as the default and do not ask again" option, as shown in Figure 2-1-1

| & |

vv Workspace Launcher . )

Select a workspace

Code Composer Studio stores your projects in a folder called a workspace.
Choose a workspace folder to use for this session.

Workspace: C\Users\F¥i\workspace_v6_2 -

[Tl Use this as the default and do not ask again

OK ] I Cancel

Figure 2-1-1

2.2Establish target board configuration environment
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If usedCCSUsers of lower versions are not unfamiliar with this.CCSv6In the version environment, it is also necessary to establish a simulation configuration environment, but the

human-machine interface is different.CCSIn lower versions, useCCS SETUPTo establish, | will not introduce it here. The following mainly introduces how toCCSv6Established in:

In the toolbar, clickFile ->New->Target Configuration File” , as shown below2-2-1As shown:

’!ﬁ CCSEdit_-CodeCompmer-
[File] Edit View Navigate Project Run Scripts Window Help

New Alt+Shift+N » | £ CCS Project
Open File... ™ Project...

' Close Ctrl+W | [¢] Source File
Close All Ctrl+Shift+W | [/ Header File
Save Ctrl+S ?} Class
Save As... ¥ File from Template
Save Al Cri+shiftes | S Folder
Revert %/ Target Configuration File

Tgé DSP/BIOS v5.x Configuration File
Move...
7#| Rename... £2 ™ Other.. C
- we: B
picture2-2-1

Name this configuration "f28035_xds100v3.ccxml"(You can name it yourself), click "Finsh”

As shown below2-2-2As shown:

11



w+ Mew Target Configuration

Target Configuration

Create a new Target Configuration file.

File nami: f28035_xds100v3.coxml

Use shared location

Location: C:/Users/F¥fuser/CCSTargetConfigurations | File System.. | | Workspace...

@ | Fnish || Cancel

picture2-2-2

exist"connectionln the "Debugger Type" column, select "Texas Instruments XDS100v3 USB

Emulator","Deviceln the "(Chip Type)" column, select "TMS320F28035", as shown below2-2-3Shown:

12



¥e CCS Edit - C:IL.Imrs\FﬂuseﬁCCSTargetCnnﬁgurations'\fzE-.DE‘-SIHdleDVS.ccxml - Code Composer Studio

File Edit View Mavigate Project Run Scripts Window Help

D HRIK iRk S BIEICE D

- Getting Started [z *f28035_xdsl00v3.caml 53

[ty | Basic

E General Setup

[ This section describes the general configuration about the target.
Connection

Texas Instruments XD5100v3 USE Debug Probe

Board or Device 2gp2s5

[ Developer's Kit - Dual Motor Control and PFC (F28033)
[[] Developer's Kit - Motor Control and PFC (F28035)

[ _Experimenter's Kit - Piccolo F28035
TMS320F28035

picture2-2-3

If you use the defaultGELfile, then clickSave” As shown in Figure 2-2-4
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I Getting Started {7 *f28035_xds100v3.coxml B3

asic

General Setup Advanced Setup
This section describes the general configuration about the target.

Cannection ’Texas Instruments XDS100v3 USE Debug Probe v] Target Configuratic
Board or Device 28035 &

Save Configuration

[[] Developer's Kit - Dual Motor Control and PFC (F28033)
. 5
[[] Developer's Kit - Motor Contral and PFC (F28035)

[[] Experimenter's Kit - Piccolo F28033
TMS5320F28035

Test Connection

To test a connectior
configuration file co

Test Connection

Alternate Commun

Uart Communicatic

» To enable host side
communication ove
implementation. Ple
tarnet annlicatinon

Figure 2-2-4

So far, this configuration environment has been established.

2.3 Connecting to the target board

Find the "View->Target configurations" button on the toolbar and click it to switch to the configuration interface. Then right-click
the configuration file in the configuration interface and select "Set as Default" to set the newly created configuration file as the
default state. Start debugging, right-click and select "Launch Selected Configuration" of the configured project. Detailed

operations are shown in Figure 2-3-1 below:

14



Quick Access

= m

m

-

¥, Target Configurati...
type filter text

=2 Projects
4 = User Defined

| NewTargetConfiguratio

& | [Eccsed]

o
L

=)

(= ccs5516
i__TJE fmas_xd!p'IM“': |
4, New Target Configuration
Import Target Configuration
¥ Delete Delete
Rename F2
5 Refresh FS
s+ Launch Selected Configuration

< | 1

Click the New button |

Set as Default
Link File To Project b

Properties Alt+Enter

new target configuration file. Click

Figure 2-3-1

After successful startup, click "Run->Connect Target" in the toolbar to connect to the target board, as shown

in Figure 2-3-2 below:

15



\"» CCS Debug - C:

| File Edit View Project Tools |Run| Scripts Window Help
MG @S ~:2:8: { 5[ Connect Target

e
R

Disconnect Target

.. Restore Debug State

1% Debug &2 @ Load

4 vy 28035 _xds100v3.ccxml [Coc
J® Texas Instruments XDS1(

,.P Texas Instruments XDS1( Suspend
@ Terminate

Resume

¥  Disconnect
Figure 2-3-2

The interface shown in Figure 2-3-3 below appears, indicating that the connection is successful. Next, the user can conduct simulation experiments by himself.

File Edit View Project Tools Run Scripts Window Help

-l RA-Riais-ig-BrpnEr e - PS¢ ina

Quick At
15 Debug 2 . ¥ = O  ®=Variables 52 € Expressions }{ii Registers
4 &% f28035_xds100v3.coxml [Code Composer Studio - Device Debugging]
4 B Texas Instruments XDS100v3 USE Debug Probe_0/C28xx (Suspend  Name  Type
= 0x3FFBALl (no symbaols are defined for 0x3FFBAL)
Xﬁ Texas Instruments XD5100v3 USE Debug Probe_0/CLA_O (Disconm
4 m | 3
28035 _xds1... [c]|0x3ffaal 52 ™ = B == Disassembly Enter location here |_ |
Mo source available for "0x3ff8al” p 3ffeal: 2sADeea4 MOV @sp, #exoool
affeas: 561F SETC OB IMODE
A s Disassaembl}r ] affEad: 5616 CLRC AMODE
3ff8as:  561A SETC MBM1MAP
f affEae: 2948 CLRC PAGE®
| \ affea7: JelFeaes MOV DP, #ewd
=T ﬂE‘ ¢ Etl:ﬁ affEao: 2962 CLRC OV
| RIS e 3ffaa:  FFE9 SPM #0
I affaab: Je7FF4B8 LCR ax3ffabe
affead: SeCFaaa2 BF 2, UNC
affaat: 28ADe3E4 MOV [@sP, #BxeEaR
3ffabl: 2BEBD MOV *SP++, #06
affab2: 2BEBD MOV *SP++, #06
affab3: 1EBD MOVL *SP++, ACC
| 3ffaba: aaa7 POP RPC
3ffebs: 5633 ZAPA
3ffebe: 1EAC MOVL (@1, ACC
Figure 2-3-3
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{elp

iib.*?{s---l%@'@'

Connect or disconnect shortcut keys

Chapter 3 CreationCCS6.0project

3.1 Create a project

After the Welcome screen closes, the following workspace will be displayed, and you can now create a new project. Go to the menu "File

-> New -> CCS Project" as shown in Figure 3-1 below:

New Alt+Shift+N » E CCS Project .
Open File... |1 Project...
' —&
Close Ctrl+W | ¢/ Source File
Close All Ctrl+Shift+W | [n] Header File
Save Ctrl+S | G
Save As % File from Template
Save Al Ctrlsshiftss | Folder
- [4, Target Configuration File "
| g8 DSP/BIOS v5.x Configuration File
Move...
o | Recesios. £ ™4 Other... Ctrl+N
#| Refresh F5
Convert Line Delimiters To »

Figure 3-1

@ In "Project Name(Project Name) field, type a name for the new project. If you selectUse default
locationUse default location" option (enabled by default) will create the project in the workspace folder.
Uncheck this option to choose a new location (usingBrowse...(Browse...)" button). Name the project "
led_test"

®1In "Target” Select the chip type to be used from the menu.

@ In" “Connection” Select Debugger.

® Click "Finish(Complete)" to create the project., as shown below3-2As shown:

17



CCS Project

Create a new CCS Project. %_

Target:

Connection:

Texas Instruments XD5100v3 USE Debug Probe

TMS320F28035

5 C28)XX [C2000] % a7

Project name: led_test

Use default location

™~ =

Location: | ChUsers\Fyworkspace vb_2\|ed_test Browse...

Compiler version: | TIw13.12.3.LTS

|| More.

b Advanced settings

« Project templates and examples

type filter text

4 Empty Projects
[& Empty Project

[ Empty Project (with main.c)
[& Empty Assembly-only Project

Creates an empty project fully initialized =
for the selected device. The project will
contain an empty 'main.c’ source-file.

= Back

Cancel

=y
=,
i

—gl

Mext =

picture3-2

® To create files for the project,C/C++ Projects (C/C++Project)" (Path: Toolbar
Window->Show View->OtherNextC/C++->C/C++ Projects) view and selectNew ->
Source File(New->Source File)". In the text box that opens, type a file with a valid

extension (.c. .C. .cpp. .C++. .asm. .s64. .s55ClickFinish(Finish)

@ To add existing source files to the project,C/C++ Projects (C/C++Right-click the project name in

the Projects tab and selectAdd Files to Project(Add files to project)", add the source files

18




You can also select "Link Files to Project(Link File to Project)" to create a file reference, which
keeps the file in its original directory. This is necessary if your source code contains files in a
very specific directory structure.

3.2 Generate Project

Once the project has been created and all files have been added or created, you need to build the project.
Simply go to the menu "Project -> Build Active Project". The "Rebuild Active Project" option rebuilds all
source files and referenced projects. However, if the project is large, this can be a lengthy process.

Note: If build errors are encountered and no executable is created, the console window at the bottom of the screen will

display an error or warning message and the debugging session will not start.

Chapter 4 Project Introduction

4.1 Importing CCS high version projects

In the "C/C++ Projects" (path: Window->Show View->C/C++->C/C++ Projects
under Other in the toolbar), that is, the "CCS Edit" view, click "Project->Import CCS
Projects..." on the toolbar as shown in Figure 4-1-1 below:

19



Edit - Code Composer Studio - -—

File Edit View Navigate Run Scripts Window Help

ﬁ R @‘5 v '0 1 B New CCS Project...
® New Energia Sketch...

It Proj... 53! = 0| Examples...
ERe v
= .+ Build Al Ctrl+B
Build Configurations
Build Working Set
Clean...

Build Automatically
Show Build Settings...

Add Files...

Import CCS Projects...
Import Legacy CCSv3.3 Projects...
Import Energia Sketch...

RelNE

Import Energia Libraries...

Properties

Figure 4-1-1

In the pop-up window, perform the following operations as shown in Figure 4-1-2:

20



m

Select CCS Projects to Import
Select a directory to search for existing CCS Eclipse projects.
— ki n .
@ Select search-directony:  Dixds\IO_test L Browse...
71 Select archive file: | | | Browse... |

Discovered projects:

| W @ I0_test [D:\xds\IO_test] | Select All

Deselect All

XEBElE TiZ Refresh

i

[ Automatically import referenced projects found in same search-directory

Copy projects into workspace

Open the Resource Explorer to browse™yailable example projects...

52 BEBANIRE
- SHETIER
@ . || Finish || Cancel

Figure 4-1-2

After completion, right-click the project and select "Build Project" to compile. After the compilation is completed, the entire import process is

completed.

Chapter 5 Simulation Debugging of CCS6.0

5.1 Simulation Operation of CCS6.2

After the routine is imported, it is time to debug CCS and the development board. Here, the TMS320F28035 chip is taken as an

example for simulation and burning test.

twenty one



After importing the project above, compile directly and you can see that the io_test.out file has been generated.

sm | Bl Console 22 = O

NS Rk
»C \CDT Build Console [I0_test]

tme "Dy ftifcesve/tools/ compiler/c2888 15.12.3.LT5/bin/
cl2ees"” -v28 -ml -mt --cla_support=cla® -g
--diag warning=225 --display_error_number -z
-m"I0_test.map" --stack_size=8x388
--warn_sections
-i"D: ftifcosve/toocls/compiler/c28@8 15.12.3.LT5/1

ihl!

-i"E:/Program/DSP/28835 source/DSP2883x_common/1i
b

-i"D:/tifcesve/tools/compiler/c28@8 15.12.3.LT75/1
nclude” --reread_libs

--xml_link_info="I0_ test linkInfo.xml"
--rom_model -o “I0 test.out"
"./D5P2883x_CodeStartBranch.obj”
"./D5P2883x_DefaultIsr.ochj”
"./D5P2883x_GlobalVariableDefs.obj"

"L /D5P2883x_PieCtrl.cbj™ "./D5P2B@3x_SysCtrl.obj”
"./fD5P28@3x_usDelay.obj™ . /main.obj"
"../D5P2B@3x_Headers_nonBIOS.cmd™ “../F28835.cmd”
-1libc.a

<Linkingz

'Finished building target: IO test.out'

m

*#*%% Build Finished **** n

You can see that it compiled successfully.

pointdebugOr pressF11You can enter the simulation debugging state
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Fle Edit View Navigate Project

[En]Scﬁpts Window Help

SRR DIt

[ Project Explorer 3 ~ =

2% |
4 = 10 test [Active - Debug]
> 4% Binaries
4 )l Includes

b (£ Dsftifccsvb/tools/comp T

> (2 Di/xds/28035_source/C

{8 E:/program/DSP/2803¢
& E:/program/DSP/2803:
> (= Debug
» |S| DSP2803x_CodeStartBranc

enty three

&, Debug F11
Debug History »
Debug Configurations...

TS uintie 1,
6 for(;3>0;3--)
7 for(i=0;i<600;i++);
8}

12 InitSysCtrl();

13 EALLOW;

14 GpioCtrlRegs.GPAMUX1.all = 0x0000e
15 GpioCtrlRegs.GPAMUX2.all = @x0000¢
16 GpioCtrlRegs.GPADIR.all = @OxFFFFF

18 GoioCtrlRees.GPBMUX1.all ex2eeee



File

An RN PR

%5 Debug

= t =

Edit View Project Tools Run Scripts Window Help

Hrig-fRirrezekBErva-DPoe-Seine

#

=TT | 0= Variables &2 64 Expressions

[
=1
==
==
-

4 W¢ 10_test [Code Composer Studio - Device Debugging] MName Tyg

a4 f# Texas Instruments XD5100w3 USB Debug Probe_0/C28xx (Suspended - HW Breakpoint)

= main() at main.c:12 0x3F6359

= _args_main() at args_main.c:31 O0x3F630D3

= c_int00]) at boot2B.inc:248 0x3FG300 (the entry point was reached)

x@‘ Texas Instruments XD5100v3 USE Debug Probe_0/CLA_D (Disconnected : Unknown)
main.c &2 = B == Disassembly &2
¥
1 , . o main():
5 Uintlé 15 » 3f6359: | 767F6172  LCR InitSysCtr]
& for(;3>@53--) ) 13 EALLOW;
7 for(1-0;1<608;1++); T 3f635b: 7622 EALLOH
B} 14 GpioCtrlRegs.GPAMUXL.all = @x@ees
2 . . 3f635c:  761FBLEE  MOWW DP, #Bxlbe
@ void main(void) 3fE35e: @288 MOVE ACC, #8
11 . Y 3f635f:  1E@6 MOVL @exé, ACC
2 InitSysCerl(); 15 GpioCtrlRegs.GPAMUX2.all = exeeee
3 EALLOW; If6360:  1EMB MOVL @exs, ACC
4 GpioCtrlRegs.GPAMUX1.all = ex@sesesss; // All GPIO E 15 GpioCtrlRegs.GPADIR.all = @xFFFFI
5 GpioCtrlRegs.GPAMUX2.31l = exepeesepd; // All GPIO 25361 1091 S LIBE ACC. #1
6 GpioCtrlRegs.GPADIR.all = @xFFFFFFFF; // outputs 3'FE362: 1604 MOVL @Bx; ACC
7 . 18 GpioCtrlRegs.GPBMUXL1.all = @x@e08!
8 GpioCtrlRegs.GPBMUX1.3ll = exeaoeeese; // All GPIO IF6363; 8268 MOVE ACC. £8
g GpioCtrlRegs.GPEDIR.all = BxFFFFFFFF; // outputs 364 1516 MOVL @axia acc
° ) 19 GpioCtrlRegs.GPBDIR.all = BxFFFFI
1 E::Fi” - If6365: 1981 SUEBB ACC, #1
2 while(1) If6366:  1E1A MOVL @exla, ACC
? . 21 EDIS;
4 GpicDataRegs.GPADAT.all =@xFFFFFFFF; 3FE3I67: 7614 EDIS
5 GpicDataRegs.GPBDAT.all =8xFFFFFFFF; 23 ' while(1)
& delay(6@8); - 7 AFATIARAT FFRY SPM #A
4 »
E) Console 2

CDT Build Console [10_test]

##%% Build of configuraticn Debug for project I0 test *=**=

From the above you can see a series of debugging operation buttons

twenty four



- CCS Debug - 10.test/main.c , Code Composer Stucior

File Edit View Project Tools | Run| Scripts Window Help
Hw L] ) %~ @i & Connect Target Ctrl+Al+C h
Disconnect Target Ctrl+Alt+D
4% Debug & Restore Debug State Alt+E
4 %¢ 10 _test [Code Composer Sty @ Load "
4 f* Texas Instruments XDS1LL
= main() at main.c:12 *x e Resume P F&
= _args_main() at args_r Suspend ‘\ %IE‘]‘T Al+F8
= c_intD0() at boot28.ing Terminate Ctrl+F2
ﬁ Texas Instruments XD510 -7 Disconnect
@ Go Main Alt+M
% Reset 2
[£] main.c &2 {g,, Restart i
44 . Step Into F3
5 Uintle i; _
E for(;j>@;i--) i Step Over F&
7 for(i=8;1<6@0;i++ 5 Assembly Step Into Ctrl+Shift+F5
8
g ; i Assembly Step Over Ctrl+Shift+F&
18 void main(void) . Step Return Ff
14{ .
. InitSysCtrl(); Run to Line Ctrl+R
3 EALLOW; Free Run Ctrl+F8
4 GpioCtrlRegs.GPAMUXL. -
5 GpioCtrlRegs.GPAMUX2. e
g GpicCtrlRegs.GPADIR.a Clock N
8 GpioCtrlRegs.GPBMUXL. Advanced 3
] GploCtrlRegs.GPEBDIR.3
8 1, Debug F11
1 EDIS;
2 while{1) Diebug Histary b
3 {
¥
4 GpioDataRegs.GPAD Dmily e
5 GpioDataRegs.GPED Debug Configurations...
6 delay(6@e);
= . Toggle Breakpoint Ctrl+Shift+B
“&  Skip All Breakpoints Ctrl+Alt+B
& Console & .
. i Remove All Breakpoints
ZDT Build Console [10_test] ) .
Breakpoint Types 3
**x* Build of configuration D| & Mew Breakpoint (Code Composer Studio) b
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